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1. Overview

1.1 Introduction

This chapter defines the Account and Profile Manager (Local APM Client) Manual
Validation Procedure and is part of the required set of test procedures to be used in
the certification of products to The Open Brand COE Platform Product Standard®.

2. Test Purpose

2.1 Scope

This Account and Profile Manager validation procedure provides a detailed test of the
Client side of the Account and Profile Manager configuration software against Local
user accounts. This test procedure establishes a multiple-host APM administrative
domain and creates and manipulates Local accounts, groups and profiles within this
domain.

2.2 Description of test items

Functionality that will be tested using the Account and Profile Manager (Local APM
Master) Validation Procedure is as follows:

A. Configure APM

Designate the New APM Master and Configure Authentication
Merge Hosts

Create Local Users with Associated Profiles and Features
Add a Profile to an Existing User

Verify assigned Profiles and Unix permissions

. Augment Local Users With a New UNIX Group

I 0mmoOoOo®

Deassign a Profile from a Local User

—

Verify Deassignment of Profile from Local User
J. Verify Assign Passwords Functionality
K. Delete a Local Account

L. Create a Local User with no Profile
Test Local Account Creation on a Master System

! See http://www.opengroup.org/openbrand/coe/
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M. Create and Test An Account with the Same Login Name as That of a

= < < d

x

Previously Deleted Account
Create and Test a Profile Containing a Subset of the Features in a
Segment
Test Local Profile and Local Account Creation and Modification on a
Master System
Test Local Profile Creation on a Client System

Verify a User with no Profiles Assigned Has no Profiles Available

Add Multiple Users, Use Templates to Predefine Account Parameters,
and Verify Accounts Created on One Merged Host Are Reflected On The
Other

Test Users with Multiple Derivative Profiles
Use Templates to Predefine Profiles

Test interactions of Segments. Test Account Modification on a Master
System

Test Session Manager's Ability to Resume the Previously Active Set of
Profiles

Log in With no Available Profile and Test Account Modification on a
Master System

Test ability to detect duplicate Local user names
Test Ability to Detect Duplicate Profiles
Test Ability to Detect Duplicate UNIX Groups

. Delete a Profile and Verify Local Users Cannot Assume a Profile Already

Assigned to Them After the Profile Has Been Deleted
Reset Test Cell for Additional Testing
Remove Hosts

Log out of the Candidate Platform (kpccp) and the Validation Host
(kpchost)
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2.3 Setup/Equipment Required

The Validation Host (hostname: kpchost) is configured as an APM Client.

The Candidate Platform (hostname: kpccp) is configured as an APM Master of the
Validation Host.

2.4 Required Media

None

2.5 Required Personnel

One (1) tester. The tester must be familiar with POSIX/UNIX application platforms,
but need not be familiar with the Common Operating Environment (COE).

2.6 Known Problems

None

2.7 Change History
June 02, 2003

Initial Release
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3. Test Procedure Submission Form

Test Title: Account and Profile Manager (Local APM Client) Validation Procedure

Candidate Platform:

Tester:

Start Time:

End Time:

Test Site/Organization:

Date:

Estimated Runtime: 8 hours

Actual Runtime:

Overall Test Result (Circle One): PASS / FAIL

Configuration Validated

Hardware Platform:

Network Type:

Local Devices (if any):

System Software:

Printer:




Start of Validation Procedure

4. Test Procedure

Operator Action Expected Result Observed Result
A 4.1 Configure APM
Al On the Candidate Platform (kpccp) Configure APM For Testing
A.l.1 NOTE: Perform the following steps on the The desktop appears. Setup
Candidate Platform (kpccp).
Login as secman.
A.1.2 Select Applications > Application The Application Manager - SecAdm Setup
Manager > DII APPS > SecAdm. window appears.
A.l13 Double-click Edit APM Configuration. The Edit APM Configuration window Circle one: PASS /FAIL
appears.
Al4 Under Local Options, set Log Level to Trace is selected. Circle one: PASS/FAIL
Trace.
A.l1.5 Click Domain Options. The Domain tab is selected. Circle one: PASS / FAIL
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Operator Action

Expected Result

Observed Result

A.1.6 Select Manage Hosts. Manage Hosts is selected. Circle one: PASS /FAIL
Al.7 Click Submit. A Done dialog box appears with the message: Circle one: PASS /FAIL
Operation completed successfully.
A.1.8 Click OK. The Edit APM Configuration window Circle one: PASS /FAIL
disappears.
A2 On the Validation Host (kpchost) Configure APM For Testing
A2.1 NOTE: Perform the following steps on the The desktop appears. Setup
Validation Host (kpchost).
Login as secman.
A22 Select Applications > Application The Application Manager - SecAdm Setup
Manager > DII APPS > SecAdm. window appears.
A23 Double-click Edit APM Configuration. The Edit APM Configuration window Circle one: PASS /FAIL

appears.
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Operator Action Expected Result Observed Result
A24 Under Local Options, set Log Level to Trace is selected. Circle one: PASS / FAIL
Trace.
A2.5 Click Domain Options. The Domain tab is selected. Circle one: PASS / FAIL
A.2.6 Select Manage Hosts. Manage Hosts is selected. Circle one: PASS /FAIL
A2 Click Submit. A Done dialog box appears with the message: Circle one: PASS /FAIL
Operation completed successfully.
A28 Click OK. The Edit APM Configuration window Circle one: PASS /FAIL
disappears.
A29 Log out. The DIT COE LOGIN screen appears. Circle one: PASS /FAIL

© 2003, The Open Group
Chapter 3, Page 9
Revision: 1.0




Operator Action Expected Result Observed Result
B 4.2 Designate the New APM Master and Configure Authentication
B.1 On the Candidate Platform (kpccp) Configure the Validation Host (kpchost) As the APM Master
B.1.1 NOTE: Perform the following steps on the The Edit APM Configuration window Circle one: PASS /FAIL
Candidate Platform (kpccp). appears.
Double-click Edit APM Configuration.
B.1.2 Local Options: SetMaster Host to Dialog box accepts input. Circle one: PASS / FAIL
kpchost.
B.1.3 Local Options: Ensure Enable Enable Authentication is checked. Circle one: PASS / FAIL
Authentication is selected.
B.1.4 Click Submit. A Done dialog box appears with the message: Circle one: PASS /FAIL
Operation completed successfully.
B.1.5 Click OK. The Edit APM Configuration window Circle one: PASS /FAIL
disappears.
B.1.6 Log out. The DIT COE LOGIN screen appears. Circle one: PASS /FAIL
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Operator Action Expected Result Observed Result
B.2 On the Candidate Platform (kpccp) Set the Local APM Authentication Key
B.2.1 NOTE: Perform the following steps on the The desktop appears. Setup
Candidate Platform (kpccp).
Log in as keyman.
B.2.2 Select Applications > Application The Application Manager - APM appears. | Setup
Manager > DII APPS > APM.
B.2.3 Double-click Authentication Manager. The Authentication Manager window Setup
appears.
B.2.4 Enter the Local Auth Key in the text box. Record Asterisks appear in the text box. Circle one: PASS /FAIL
the Local Authentication Key here.
Local Authentication Key:
B.2.5 Click Set Key. A Message box appears stating: Circle one: PASS /FAIL
The local key is set.
B.2.6 Click OK. The Message box disappears. Circle one: PASS /FAIL
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Operator Action

Expected Result

Observed Result

B.2.7 Click Close. The Authentication Manager window Circle one: PASS /FAIL
disappears.
B.2.8 Log out. The DIT COE LOGIN screen appears. Circle one: PASS /FAIL
B.3 On the Validation Host (kpchost) Store An Encrypted Copy Of the Client’s APM Key
B.3.1 NOTE: Perform the following steps on the The desktop appears. Setup
Validation Host (kpchost).
Log in as keyman.
B.3.2 Select Applications > Application The Application Manager - APMwindow | Setup
Manager > DII APPS > APM. appears.
B.3.3 Double-click Authentication Manager. The Authentication Manager window Circle one: PASS /FAIL
appears.
B.3.4 Enter the Master Auth Key in the text box. Record | Asterisks appear in the text box. Circle one: PASS / FAIL

the Master Authentication Key here.

Master Authentication Key:
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Operator Action Expected Result

Observed Result

B.3.5

Click Set Master Key. A Confirm dialog box appears with the following
message:

You will have to re-enter local
auth keys after the master auth
key is changed.

Are you sure you want to
initialize master key?

Circle one: PASS / FAIL

B.3.6

Click Yes. A Message box appears with the following
message:

Master authentication key is
reset.

Circle one: PASS / FAIL

B.3.7

Click OK. The Message box disappears.

Circle one: PASS / FAIL

B.3.8

Click Set Client’s Local Key. The Hosts List window appears.

Circle one: PASS / FAIL

B.3.9

In the Additional Host text box, enter kpccp appears in the text box.
kpccp

Circle one: PASS / FAIL
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Operator Action Expected Result Observed Result
B.3.10 Click Add Host. The Set Key for New Host window Circle one: PASS / FAIL
appears.
B.3.11 Enter the Candidate Platform's APM authentication | Asterisks appear in the text boxes. Circle one: PASS /FAIL
key (from step B.2.4) twice in the text boxes.
B.3.12 Click Submit. The Message window appears, indicating: Circle one: PASS /FAIL
Authentication keys are set.
B.3.13 Click OK. The Message window disappears. Circle one: PASS /FAIL
B.3.14 In the Hosts List window, click Close. The Host List window disappears. Circle one: PASS /FAIL
B.3.15 In the Authentication Manager window, The Authentication Manager window Circle one: PASS / FAIL

click Close.

disappears.
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Operator Action Expected Result Observed Result

B.3.16 Log out of the Validation Host (kpchost). The DIT COE LOGIN screen appears. Setup

C 4.3 Merge Hosts

C1 Merge Hosts From the Candidate Platform (kpccp)

C.1.1 NOTE: Perform the following steps on the The desktop appears. Circle one: PASS /FAIL
Candidate Platform (kpccp).
Log in as secman.

C.1.2 Select Applications > Application The Application Manager - SecAdm Circle one: PASS / FAIL
Manager > DII APPS > SecAdm. window appears.

C.13 In the Application Manager - SecAdm The MergeHost Tool dialog box appears. Circle one: PASS / FAIL
dialog box, double-click Merge Host.

C.l14 Verify that kpchost isinthe Master APM kpchost appears in the text box. Circle one: PASS /FAIL
Server section.

C.1.5 Verify that kpccp isin the New APM Domain |kpccp appears in the text box. Circle one: PASS /FAIL

Host section.
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Operator Action

Expected Result

Observed Result

C.1.6

Click OK.

An Input dialog box appears asking for the
master APM authentication key.

Circle one: PASS / FAIL

C.1.7

Enter the master APM authentication key.

Asterisks appear in the text box.

Circle one: PASS /FAIL

C.1.8

Click OK.

The MergeHost Tool dialog box disappears.
The progress of the merge is tracked in the
MergeHost Status window.

Do not expect conflicts. However, if a conflict is
detected with the SA Default features, click
use master, click Apply and click OK to clear
the conflict.

The MergeHost Warnings window appears.
The MergeHost Confirmation window
appears.

Circle one: PASS / FAIL

C.1.9

Click OK in the MergeHost Confirmation
dialog box to send the commands and finish the
merge.

The MergeHost Status window reads:
Finished.

Circle one: PASS / FAIL

C.1.10

Click OK in the MergeHost Status window.

The MergeHost Status window and
MergeHost Warnings window disappear.

Circle one: PASS / FAIL
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Operator Action

Expected Result

Observed Result

D 4.4 Create Local Users With Associated Profiles and Features
D.1 Create A New Account On the Candidate Platform (kpccp)
D.1.1 NOTE: Perform the following steps on the An Input dialog box appears asking for the Circle one: PASS /FAIL
Candidate Platform (kpccp). master APM authentication key.
In the Application Manager - SecAdm
dialog box, double-click APM Client.
D.1.2 Enter the master APM authentication Key. Asterisks appear in the text box. Circle one: PASS / FAIL
D.1.3 Click OK. The Account and Profile Manager dialog | Circle one: PASS /FAIL
box appears.
D.1.4 Select File > New Account. The Create Account dialog box appears. Circle one: PASS /FAIL
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Operator Action

Expected Result

Observed Result

D.1.5 Enter the following values: Each item is filled in. Circle one: PASS /FAIL
Login: Ltestlm
Password: temp
Password Confirm: temp
Template: secman
Home server: EACH HOST
Manage as: Local
D.1.6 Click Hosts. The Hosts tab is displayed. Circle one: PASS/FAIL
D.1.7 Verify kpccp and kpchost appear in the kpccp and kpchost appear in the Assigned | Circle one: PASS / FAIL
Assigned Hosts panel. Hosts panel.
D.1.8 Click Submit. A Status Summary dialog box appears Circle one: PASS /FAIL
indicating the new user has been added.
D.1.9 Click OK. Control returns to the Account and Profile | Circle one: PASS/FAIL

Manager dialog box.
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Operator Action

Expected Result

Observed Result

D.2 Verify the New Account On the Candidate Platform (kpccp)
D.2.1 NOTE: Perform the following steps on the The Accounts tab is displayed. Circle one: PASS /FAIL
Candidate Platform (kpccp).
Verify that the focus remains on the Accounts
tab.
D.2.2 Verify the entries for Ltest1lm. The parameters listed for user Lt est 1m match Circle one: PASS /FAIL
those below:
Login: Ltestlm
Default Group: admin
Home Server: each host
Profiles: SSO Default
Assigned Groups: admin
Shell: /bin/csh
Hosts: kpccp, kpchost
D.23 Open a Terminal window. A Terminal window appears with a command Circle one: PASS /FAIL
line prompt.
D.2.4 At the command prompt type The command prompt returns. Circle one: PASS /FAIL

cd /h/USERS
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Operator Action Expected Result

Observed Result

D.2.5 At the command prompt type A directory Ltest1m is not listed. Circle one: PASS /FAIL
ls -1la global

D.2.6 At the command prompt type A directory Ltest1lmis listed. Circle one: PASS /FAIL
ls -la local

E 4.5 Add A Profile To An Existing User

E.l Add A Profile To Ltest1lm On the Candidate Platform (kpccp)

E.1.1 NOTE: Perform the following steps on the A Modify Account: Ltestlm dialog box Circle one: PASS /FAIL
Candidate Platform (kpccp). appears.
In the Account and Profile Manager
dialog box, under Accounts, double-click user
Ltestlm.

E.1.2 Click Profiles. The Profiles tab is displayed. Circle one: PASS /FAIL

E.1.3 Double-click SA Default. Profile SA Default moves to the Assigned Circle one: PASS /FAIL

Profiles panel.
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Operator Action

Expected Result

Observed Result

E.1.4 Click Submit. A Status Summary dialog box appears Circle one: PASS /FAIL
indicating user Ltest1m was modified.
E.1.5 Click OK to clear the Status Summary. Control returns to the Account and Profile | Circle one: PASS/FAIL
Manager dialog box.
E.2 Verify the New Profile On the Candidate Platform (kpccp)
E.2.1 NOTE: Perform the following steps on the The Account and Profile Manager dialog | Circle one: PASS /FAIL
Candidate Platform (kpccp). box is refreshed.
In the Account and Profile Manager
dialog box, select View > Refresh Catalog
> Accounts.
E.2.2 Under the Accounts tab, examine the entry for In the Profiles column, user Ltest1lm has Circle one: PASS /FAIL
Ltestlm. SSO Default and SA Default assigned.
E.2.3 Log out of the Candidate Platform (kpccp). The DIT COE LOGIN screen appears. Circle one: PASS /FAIL
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Operator Action Expected Result Observed Result
F 4.6 Verify Assigned Profiles and Unix Permissions
F.1 Login As Ltest1m and Assign Profiles On the Candidate Platform (kpccp)
F.1.1 NOTE: Perform the following steps on the A dialog box appears indicating that the password | Circle one: PASS / FAIL
Candidate Platform (kpccp). needs to be changed.
Log in as user Ltest1m. Use the initial password,
temp.
F.1.2 Click OK. A command line window appears with an Enter | Circle one: PASS /FAIL
login password prompt.
F.1.3 Enter the initial password, temp. The prompt changes to New password. Circle one: PASS /FAIL
NOTE: The mouse cursor must be within the
command line window.
F.1.4 Enter a new password. The prompt changed to Re-enter new Circle one: PASS / FAIL
password.
Record the new password. Password:
F.1.5 Re-enter the new password. The DIT COE LOGIN screen appears. Circle one: PASS /FAIL
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Operator Action Expected Result Observed Result

F.1.6 Login as user Ltest1m with the new password. | The desktop appears. Circle one: PASS / FAIL

F.1.7 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one: PASS /FAIL

F.1.8 Double-click SSO Default. Profile SSO Default moves to the Selected | Circle one: PASS /FAIL
Profiles panel.

F.1.9 Click OK. The Profile Selector Results window Circle one: PASS / FAIL
appears stating that the profile was successfully
assumed.

F.1.10 Click Done. The Profile Selector window and the Circle one: PASS / FAIL
Profile Selector Results window
disappear.

F.1.11 Select Applications > Application The Application Manager - SecAdm Circle one: PASS / FAIL

Manager > DII_APPS > SecAdm.

window appears.
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Operator Action Expected Result Observed Result
F.1.12 Double-click Profile Selector Config. The Profile Selector Configuration Circle one: PASS / FAIL
window appears.
F.1.13 Set Profile Selection Criteria to Profile Selection Criteria issetto Circle one: PASS /FAIL
Multiple. Multiple.
F.1.14 Click OK. The Profile Selector Configuration Circle one: PASS / FAIL
window disappears.
F.1.15 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one: PASS /FAIL
F.1.16 Double-click SA Default. Profile SA Default moves to the Selected Circle one: PASS /FAIL
Profiles panel.
F.1.17 Click OK. The Profile Selector Results window Circle one: PASS / FAIL

appears stating that the profile was successfully
assumed.
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Operator Action

Expected Result

Observed Result

F.1.18 Click Done. The Profile Selector window and the Circle one: PASS / FAIL
Profile Selector Results window
disappear.
F.2 Verify That User Ltest1m Can Launch secman (SecAdm) Icons But Not sysadmin (SysAdm)
Icons On the Candidate Platform (kpccp)
F.2.1 NOTE: Perform the following steps on the The Assign passwords dialog box appears. | Circle one: PASS /FAIL
Candidate Platform (kpccp).
In the Application Manager - SecAdm
window, double-click Assign Passwords.
F22 Click Cancel. The Assign passwords dialog box Circle one: PASS/FAIL
disappears.
F.2.3 Select Applications > Application The Application Manager - SysAdm Circle one: PASS / FAIL
Manager > DII APPS > SysAdm. window appears.
F2.4 Double-click Change Machine ID. An INFORMATIONAL MESSAGE dialog box Circle one: PASS /FAIL

appears with the message:

You do not have permission to
launch /h/AcctGrps/SysAdm/bin/

SAChangeMachineId.
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Operator Action Expected Result Observed Result
F.2.5 Click OK. The INFORMATIONAL MESSAGE dialog box Circle one: PASS/FAIL
disappears.
F.2.6 Log out of the Candidate Platform (kpccp). The DIT COE LOGIN screen appears. Circle one: PASS /FAIL
F.3 Login As Ltest1m and Assign Profiles On the Validation Host (kpchost)
F.3.1 NOTE: Perform the following steps on the A dialog box appears indicating that the password | Circle one: PASS / FAIL
Validation Host (kpchost). needs to be changed.
Log in as user Ltest 1m. Use the initial password,
temp.
F3.2 Click OK. A command line window opens with an Enter Circle one: PASS /FAIL
login password prompt.
F.3.3 Enter the initial password, temp. The prompt changes to New password. Circle one: PASS /FAIL
NOTE: The mouse cursor must be within the
command line window.
F.34 Enter a new password. The prompt changed to Re-enter new Circle one: PASS /FAIL
password.
Record the new password. Password:
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Operator Action Expected Result Observed Result

F.3.5 Re-enter the new password. The DIT COE LOGIN screen appears. Circle one: PASS /FAIL

F.3.6 Log in as user Ltest1lm with the new password. | The desktop appears. Circle one: PASS /FAIL

F.3.7 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one: PASS /FAIL

F.3.8 Double-click SSO Default. Profile SSO Default moves to the Selected |Circle one: PASS/FAIL
Profiles panel.

F.3.9 Click OK. The Profile Selector Results window Circle one: PASS /FAIL
appears stating that the profile was successfully
assumed.

F.3.10 Click Done. The Profile Selector window and the Circle one: PASS /FAIL

Profile Selector Results window
disappear.
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Operator Action Expected Result Observed Result
F.3.11 Select Applications > Application The Application Manager - SecAdm Circle one: PASS / FAIL
Manager > DII APPS > SecAdm. window appears.
F.3.12 Double-click Profile Selector Config. The Profile Selector Configuration Circle one: PASS /FAIL
window appears.
F.3.13 Set Profile Selection Criteria to Profile Selection Criteria issetto Circle one: PASS / FAIL
Multiple. Multiple.
F.3.14 Click OK. The Profile Selector Configuration | Circle one: PASS/FAIL
window disappears.
F.3.15 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one: PASS /FAIL
F.3.16 Double-click SA Default. Profile SA Default moves to the Selected Circle one: PASS /FAIL

Profiles panel.
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Operator Action

Expected Result

Observed Result

F.3.17 Click OK. The Profile Selector Results window Circle one: PASS / FAIL
appears stating that the profile was successfully
assumed.
F.3.18 Click Done. The Profile Selector window and the Circle one: PASS /FAIL
Profile Selector Results window
disappear.
F.4 Verify That User Ltest1m Can Launch secman (SecAdm) Icons But Not sysadmin (SysAdm)
Icons On the Validation Host (kpchost)
F.4.1 NOTE: Perform the following steps on the The Assign passwords dialog box appears. | Circle one: PASS/FAIL
Validation Host (kpchost).
In the Application Manager - SecAdm
window, double-click Assign Passwords.
F.4.2 Click Cancel. The Assign passwords dialog box Circle one: PASS /FAIL
disappears.
F4.3 Select Applications > Application The Application Manager - SysAdm Circle one: PASS /FAIL

Manager > DII APPS > SysAdm.

window appears.
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Operator Action

Expected Result

Observed Result

F.4.4 Double-click Change Machine ID. An INFORMATIONAL MESSAGE dialog box Circle one: PASS /FAIL
appears with the message:
You do not have permission to
launch /h/AcctGrps/SysAdm/bin/
SAChangeMachineId.
F.4.5 Click OK. The INFORMATIONAL MESSAGE dialog box Circle one: PASS/FAIL
disappears.
F.4.6 Log out of the Validation Host (kpchost). The DIT COE LOGIN screen appears. Circle one: PASS /FAIL
G 4.7 Augment Local Users With A New UNIX Group
G.1 Add Unix Group other To User Ltestlm On the Candidate Platform (kpccp)
G.1.1 NOTE: Perform the following steps on the The desktop appears. Setup
Candidate Platform (kpccp).
Login as secman.
G.1.2 Select Applications > Application The Application Manager — SecAdm Setup

Manager > DII_APPS > SecAdm.

window appears.
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Operator Action Expected Result Observed Result

G.1.3 Double-click APM Client. An Input dialog box appears asking for the Circle one: PASS /FAIL
master APM authentication key.

G.14 Enter the master APM authentication Key. Asterisks appear in the text box. Circle one: PASS /FAIL

G.1.5 Click OK. The Account and Profile Manager Circle one: PASS / FAIL
dialog box appears.

G.1.6 Select user Ltest1m. User Ltest1m is highlighted. Circle one: PASS /FAIL

G.1.7 Select Edit > Modify. A Modify Account: Ltestlm dialog box Circle one: PASS /FAIL
appears.

G.1.8 Click Groups. The Groups tab is displayed. Circle one: PASS /FAIL
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Operator Action Expected Result Observed Result
G.1.9 Double-click other. other moves to the Assigned Groups panel. | Circle one: PASS /FAIL
G.1.10 Click Submit. A Status Summary dialog box appears Circle one: PASS /FAIL
indicating user Ltest 1m was modified.
G.1.11 Click OK. Control returns to the Account and Profile | Circle one: PASS/FAIL
Manager dialog box.
G.1.12 Select View > Refresh Catalog > The Account and Profile Manager Circle one: PASS /FAIL
Groups. dialog box is refreshed.
G.1.13 Verify that the focus remains on the Accounts The Accounts tab is displayed. Circle one: PASS /FAIL

tab.
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Expected Result

Observed Result

G.1.14 Verify the entries for Ltest1lm. The parameters listed for user Lt est 1m match Circle one: PASS /FAIL
those below:
Login: Ltestlm
Default Group: admin
Home Server: each host
Profiles: SSO Default,
SA Default
Assigned Groups: admin, other
Shell: /bin/csh
Hosts: kpccp, kpchost
G.1.15 Log out of the Candidate Platform (kpccp). The DIT COE LOGIN screen appears. Setup
G.2 Verify That User Ltest1m Can Launch secman (SecAdm) and sysadmin (SysAdm) Icons On the
Candidate Platform (kpccp)
G.2.1 NOTE: Perform the following steps on the The desktop appears. Circle one: PASS / FAIL
Candidate Platform (kpccp).
Login as user Ltest1m.
G.2.2 Select Applications > Application The Application Manager - SecAdm Circle one: PASS / FAIL

Manager > DII APPS > SecAdm.

window appears.
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G.23 Double-click Assign Passwords. The Assign Passwords dialog box appears. Circle one: PASS /FAIL
G.24 Click Cancel. The Assign Passwords dialog box Circle one: PASS / FAIL
disappears.
G.2.5 Select Applications > Application The Application Manager - SysAdm Circle one: PASS / FAIL
Manager > DII APPS > SysAdm. window appears.
G.2.6 Double-click Change Machine ID. The Change Machine Id dialog box appears. | Circle one: PASS /FAIL
G.2.7 Click Cancel. The Change Machine Id dialog box Circle one: PASS /FAIL
disappears.
G.2.8 Log out of the Candidate Platform (kpccp). The DIT COE LOGIN screen appears. Circle one: PASS /FAIL
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GJ3 Verify That User Ltest1m Can Launch secman (SecAdm) and sysadmin (SysAdm) Icons On the
Validation Host (kpchost)

G.3.1 NOTE: Perform the following steps on the The desktop appears. Circle one: PASS /FAIL
Validation Host (kpchost).
Login as user Ltest1m.

G3.2 Select Applications > Application The Application Manager - SecAdm Circle one: PASS / FAIL
Manager > DII APPS > SecAdm. window appears.

G.33 Double-click Assign Passwords. The Assign passwords dialog box appears. Circle one: PASS / FAIL

G.34 Click Cancel. The Assign passwords dialog box Circle one: PASS /FAIL

disappears.

G35 Select Applications > Application The Application Manager - SysAdm Circle one: PASS /FAIL
Manager > DII APPS > SysAdm. window appears.

G.3.6 Double-click Change Machine ID. The Change Machine Id dialogbox appears. | Circle one: PASS /FAIL
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G.3.7 Click Cancel. The Change Machine Id dialog box Circle one: PASS /FAIL
disappears.
G.3.8 Log out of the Validation Host (kpchost). The DIT COE LOGIN screen appears. Circle one: PASS /FAIL
H 4.8 Deassign A Profile From A Local User
H.1 Deassign Profile SSO Default From User Ltestlm On the Candidate Platform (kpccp)
H.1.1 NOTE: Perform the following steps on the The desktop appears. Setup
Candidate Platform (kpccp).
Login as secman.
H.1.2 Select Applications > Application The Application Manager — SecAdm Setup
Manager > DII APPS > SecAdm. window appears.
H.1.3 Double-click APM Client. An Input dialog box appears asking for the Circle one: PASS / FAIL
master APM authentication key.
H.14 Enter the master APM authentication Key. Asterisks appear in the text box. Circle one: PASS /FAIL
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H.1.5 Click OK. The Account and Profile Manager Circle one: PASS / FAIL
dialog box appears.

H.1.6 Select user Ltest1m. User Ltest1lm entry is highlighted. Circle one: PASS /FAIL

H.1.7 Select Edit > Modify. A Modify Account: Ltestlm dialog box Circle one: PASS /FAIL
appears.

H.1.8 Click profiles. The Profiles tab is displayed. Circle one: PASS /FAIL

H.1.9 Double-click SSO Default. Profile SSO Default moves to the Circle one: PASS /FAIL
Available Profiles panel.

H.1.10 Click Submit. A Status Summary dialog box appears Circle one: PASS /FAIL

indicating user Ltest1m was modified.
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H.1.11 Click OK. Control returns to the Account and Profile | Circle one: PASS/FAIL
Manager dialog box.
H.1.12 Log out of the Candidate Platform (kpccp). The DIT COE LOGIN screen appears. Setup
I 4.9 Verify Deassignment Of Profile From Local User
I.1 Verify Deassignment On the Candidate Platform (kpccp)
L1.1 NOTE: Perform the following steps on the The desktop appears. Circle one: PASS / FAIL
Candidate Platform (kpccp).
Login as user Ltestlm.
[.1.2 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one: PASS /FAIL
[1.3 Verify that SA Default is the only profile listed | SA Default is the only profile listed in the Circle one: PASS /FAIL
inthe Selected Profiles panelandthatno |Selected Profiles panel and no profiles are
profiles are listed in the Available Profiles |listed inthe Available Profiles panel.
panel.
L1.4 Click Cancel. The Profile Selector window disappears. | Circle one: PASS /FAIL
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I.1.5 Select Applications > Application SysAdm is the only folder present in the Circle one: PASS / FAIL
Manager > DII APPS. Application Manager - DII APPS
window.
I.1.6 Log out of the Candidate Platform (kpccp). The DIT COE LOGIN screen appears. Circle one: PASS /FAIL
1.2 Verify Deassignment On the Validation Host (kpchost)
[.2.1 NOTE: Perform the following steps on the The desktop appears. Circle one: PASS / FAIL
Validation Host (kpchost).
Login as user Ltest1m.
[2.2 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one: PASS / FAIL
[.2.3 Verify that SA Default is the only profile listed | SA Default is the only profile listed in the Circle one: PASS /FAIL
inthe Selected Profiles panel and thatno |Selected Profiles panel and no profiles are
profiles are listed in the Available Profiles |listed inthe Available Profiles panel.
panel.
L2.4 Click Cancel. The Profile Selector window disappears. | Circle one: PASS /FAIL
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1.2.5 Select Applications > Application SysAdm and IPENT are the only folders present in | Circle one: PASS /FAIL
Manager > DII APPS. the Application Manager - DII APPS
window.
[.2.6 Log out of the Validation Host (kpchost). The DIT COE LOGIN screen appears. Circle one: PASS /FAIL
J 4.10 Verify Assign Passwords Functionality
NOTE: To enable concurrent password changes, ensure the root passwords are the same on both hosts
J.1 Assign A New Password On the Candidate Platform (kpccp)
J.1.1 NOTE: Perform the following steps on the The desktop appears. Setup
Candidate Platform (kpccp).
Login as secman.
J.1.2 Select Applications > Application The Application Manager — SecAdm Setup
Manager > DII APPS > SecAdm window appears.
J.1.3 Double-click Assign Passwords. The Assign passwords dialog box appears. Circle one: PASS /FAIL
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J.1.4 Select user Ltest1m. User Ltestlm is highlighted. Circle one: PASS /FAIL

J.1.5 Click Submit. The Assign password dialog box appears. Circle one: PASS /FAIL

J.1.6 In the Trusted User Password text box, Asterisks appear in the text box. Circle one: PASS / FAIL
enter the kpccp root password.

J.1.7 In the New Password text box enter password Asterisks appear in the text box. Circle one: PASS / FAIL
temp for Ltestlm.

J.1.8 In the Password Confirm text box enter the Asterisks appear in the text box. Circle one: PASS / FAIL
same new password.

J.1.9 At Hosts, click Select and select kpcep. kpccp is highlighted. Circle one: PASS /FAIL
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Operator Action Expected Result Observed Result
J.1.10 Click Submit. A Status Summary window shows a green Circle one: PASS /FAIL
checkmark and status value of 0.
J.1.11 Click OK. Control returns to the Assign passwords Circle one: PASS /FAIL
dialog box.
J.1.12 Select user Ltest1lm. User Ltestlm is highlighted. Circle one: PASS /FAIL
J.1.13 Click Submit. The Assign password dialog box appears. Circle one: PASS /FAIL
J.1.14 In the Trusted User Password text box, Asterisks appear in the text box. Circle one: PASS /FAIL
enter the kpchost root password.
J.1.15 In the New Password text box enter password Asterisks appear in the text box. Circle one: PASS /FAIL

temp for Ltestlm.
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J.1.16 In the Password Confirm text box enter the Asterisks appear in the text box. Circle one: PASS /FAIL
same new password.

J.1.17 AtHosts, click Select and select kpchost. kpchost is highlighted. Circle one: PASS /FAIL

J.1.18 Click Submit. A Status Summary window shows a green Circle one: PASS /FAIL
checkmark and status value of 0.

J.1.19 Click OK. Control returns to the Assign passwords Circle one: PASS /FAIL
dialog box.

J.1.20 Click Cancel. The Assign passwords dialog box disappears. | Circle one: PASS / FAIL

J.1.21 Log out of the Candidate Platform (kpccp). The DIT COE LOGIN screen appears. Setup
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J.2 Verify the Password Change On the Candidate Platform (kpccp)
J.2.1 NOTE: Perform the following steps on the A dialog box appears indicating that the password | Circle one: PASS / FAIL
Candidate Platform (kpccp). needs to be changed.
Log in as user Ltest1m with the password temp.
J.2.2 Click OK. A command line window appears with an Enter | Circle one: PASS /FAIL
login password prompt.
J2.3 Enter the password temp. The prompt changes to New password. Circle one: PASS /FAIL
NOTE: The mouse cursor must be within the
command line window.
J.2.4 Enter a new password. The prompt changed to Re-enter new Circle one: PASS /FAIL
password.
Record the new password. Password:
J.2.5 Re-enter the new password. The DIT COE LOGIN screen appears. Circle one: PASS /FAIL
J.2.6 Log in as user Ltest1lm with new password. The desktop appears. Circle one: PASS / FAIL
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J.2.7 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one: PASS /FAIL
J.2.8 Verify that SA Default is the only profile listed | SA Default is the only profile listed in the Circle one: PASS /FAIL
inthe Selected Profiles panel and thatno |Selected Profiles panel and no profiles are
profiles are listed in the Available Profiles |listed inthe Available Profiles panel.
panel.
J2.9 Click Cancel. The Profile Selector window disappears. | Circle one: PASS /FAIL
J.2.10 Select Applications > Application SysAdm is the only folder present in the Circle one: PASS / FAIL
Manager > DII APPS. Application Manager - DII APPS
window.
J.2.11 Log out of the Candidate Platform (kpccp). The DIT COE LOGIN screen appears. Circle one: PASS /FAIL
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J.3 Verify the Password Change On the Validation Host (kpchost)
J.3.1 NOTE: Perform the following steps on the A dialog box appears indicating that the password | Circle one: PASS / FAIL
Validation Host (kpchost). needs to be changed.
Log in as user Ltest1m with the password temp.
J.3.2 Click OK. A command line window appears with an Enter | Circle one: PASS /FAIL
login password prompt.
J3.3 Enter the password temp. The prompt changes to New password. Circle one: PASS /FAIL
NOTE: The mouse cursor must be within the
command line window.
J.3.4 Enter a new password. The prompt changed to Re-enter new Circle one: PASS /FAIL
password.
Record the new password. Password:
J.3.5 Re-enter the new password. The DIT COE LOGIN screen appears. Circle one: PASS /FAIL
J.3.6 Log in as user Ltest1lm with new password. The desktop appears. Circle one: PASS / FAIL
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J.3.7 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one: PASS /FAIL
J.3.8 Verify that SA Default is the only profile listed | SA Default is the only profile listed in the Circle one: PASS /FAIL
inthe Selected Profiles panel and thatno |Selected Profiles panel and no profiles are
profiles are listed in the Available Profiles |listed inthe Available Profiles panel.
panel.
J.3.9 Click Cancel. The Profile Selector window disappears. | Circle one: PASS /FAIL
J.3.10 Select Applications > Application SysAdm and IPENT are the only folders present in | Circle one: PASS /FAIL
Manager > DII APPS. the Application Manager - DII APPS
window.
J.3.11 Log out of the Validation Host (kpchost). The DIT COE LOGIN screen appears. Circle one: PASS /FAIL

© 2003, The Open Group
Chapter 3, Page 47

Revision: 1.0




Operator Action Expected Result Observed Result
K 4.11 Delete A Local Account
K.1 Delete An Account On the Candidate Platform (kpccp)
K.1.1 NOTE: Perform the following steps on the The desktop appears. Setup
Candidate Platform (kpccp).
Log in as user secman.
K.1.2 Select Applications > Application The Application Manager - SecAdm Setup
Manager > DII APPS > SecAdm. window appears.
K.1.3 Double-click APM Client. An Input dialog box appears asking for the Circle one: PASS / FAIL
master APM authentication key.
K.1.4 Enter the master APM authentication Key. Asterisks appear in the text box. Circle one: PASS / FAIL
K.1.5 Click OK. The Account and Profile Manager Circle one: PASS / FAIL
dialog box appears.
K.1.6 Select user Ltest1m. User Ltest1m entry is highlighted. Circle one: PASS /FAIL
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K.1.7 Select Edit > Delete. A Confirm window prompts for confirmation. Circle one: PASS /FAIL

K.1.8 Click Yes to confirm deletion. A Status Summary window appears. All Circle one: PASS /FAIL
entries show a green checkmark icon and a
Status value of 0.

K.1.9 Click OK to clear the Status Summary. Control returns to the Account and Profile |Circleone: PASS/FAIL
Manager dialogbox. User Ltestlmis no
longer listed under the Accounts tab.

K.1.10 Open a Terminal window. A Terminal window appears with a command Setup
line prompt.

K.1.11 At the command prompt type The command prompt returns. Setup

cd /h/USERS
K.1.12 At the command prompt type Ltestlmis not present in the global Circle one: PASS /FAIL

ls -1la global

subdirectory.
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K.1.13 At the command prompt type Ltestlmis not present in the local Circle one: PASS /FAIL
1s -la local subdirectory.
K.1.14 Log out of the Candidate Platform (kpccp). The DIT COE LOGIN screen appears. Setup
K.1.15 Attempt to log in as user Ltest1lm. Console login FAILS for user Ltest1m. Circle one: PASS /FAIL
K.2 Verify Account Deletion On the Validation Host (kpchost)
K.2.1 NOTE: Perform the following steps on the The desktop appears. Setup
Validation Host (kpchost).
Log in as user secman.
K.2.2 Open a Terminal window. A Terminal window appears with a command Setup
line prompt.
K.23 At the command prompt type The command prompt returns. Setup

cd /h/USERS
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K.2.4 At the command prompt type Ltestlmis not present in the global Circle one: PASS /FAIL
1s -la global subdirectory.

K.2.5 At the command prompt type Ltestlmis not present in the local Circle one: PASS /FAIL
1s -la local subdirectory.

K.2.6 Log out of the Validation Host (kpchost). The DIT COE LOGIN screen appears. Setup

K.2.7 Attempt to log in as user Ltest1lm. Console login FAILS for user Ltest1m. Circle one: PASS /FAIL

L 4.12 Create A Local User With No Profile - Test Local Account Creation On A Master System

L.1 Create A New Account On the Validation Host (kpchost)

L.1.1 NOTE: Perform the following steps on the The desktop appears. Setup
Validation Host (kpchost).
Log in as user secman.

L.1.2 Select Applications > Application The Application Manager — SecAdm Setup

Manager > DII APPS > SecAdm.

window appears.
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L.13 Double-click APM Client. An Input dialog box appears asking for the Circle one: PASS /FAIL
master APM authentication key.

L.1.4 Enter the master APM authentication Key. Asterisks appear in the text box. Circle one: PASS /FAIL

L.1.5 Click OK. The Account and Profile Manager Circle one: PASS / FAIL
dialog box appears.

L.1.6 Select File > New Account. The Create Account dialog box appears. Circle one: PASS /FAIL

L.1.7 Enter the following values: Each item is filled in. Circle one: PASS /FAIL

Login: noprolm
Password: temp
Password Confirm: temp
Template: secman

Home server: EACH HOST

Manage as: Local
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L.1.8 Click Hosts. The Hosts tab is displayed. Circle one: PASS /FAIL

L.1.9 Verify kpccp and kpchost appear in the kpcep and kpchost appear in the Assigned | Circle one: PASS /FAIL
Assigned Hosts panel. Hosts panel.

L.1.10 Click Profiles. The Profiles tab is displayed. Circle one: PASS /FAIL

L.1.11 Double-click SSO Default inthe Assigned Profile SSO Default moves to the Available | Circle one: PASS/FAIL
Profiles panel. Profiles panel.

L.1.12 Click Submit. A Status Summary dialog box appears Circle one: PASS /FAIL

indicating the new user has been added.
L.1.13 Click OK. Control returns to the Account and Profile | Circle one: PASS/FAIL

Manager dialog box.
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L.1.14 Log out of the Validation Host (kpchost). The DIT COE LOGIN screen appears. Setup
L.2 Verify the No-Profile Account On the Candidate Platform (kpccp)
L.2.1 NOTE: Perform the following steps on the A dialog box appears indicating that the password | Circle one: PASS / FAIL
Candidate Platform (kpccp). needs to be changed.
Log in as user noprolm. Use the initial password,
temp.
L.2.2 Click OK. A command line window appears with an Enter | Circle one: PASS /FAIL
login password prompt.
L.2.3 Enter the initial password, temp. The prompt changes to New password. Circle one: PASS /FAIL
NOTE: The mouse cursor must be within the
command line window.
L.2.4 Enter a new password. The prompt changed to Re-enter new Circle one: PASS /FAIL
password.
Record the new password. Password:
L.2.5 Re-enter the new password. The DIT COE LOGIN screen appears. Circle one: PASS /FAIL
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L.2.6 Log in as user noprolm with new password. The desktop appears. Circle one: PASS / FAIL
L.2.7 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one: PASS /FAIL
L.2.8 Verify that no profiles are listed in the No profiles are listed in the Available Circle one: PASS /FAIL
Available Profiles or Selected Profiles or Selected Profiles panels.
Profiles panels.
L.2.9 Click Cancel. The Profile Selector window Circle one: PASS /FAIL
disappears.
L.2.10 Log out of the Candidate Platform (kpccp). The DIT COE LOGIN screen appears. Circle one: PASS /FAIL
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L.3 Verify the No-Profile Account On the Validation Host (kpchost)
L.3.1 NOTE: Perform the following steps on the A dialog box appears indicating that the password | Circle one: PASS / FAIL
Validation Host (kpchost). needs to be changed.
Log in as user noprolm. Use the initial password,
temp.
L.3.2 Click OK. A command line window appears with an Enter | Circle one: PASS /FAIL
login password prompt.
L33 Enter the initial password, temp. The prompt changes to New password. Circle one: PASS /FAIL
NOTE: The mouse cursor must be within the
command line window.
L.3.4 Enter a new password. The prompt changed to Re-enter new Circle one: PASS / FAIL
password.
Record the new password. Password:
L.3.5 Re-enter the new password. The DIT COE LOGIN screen appears. Circle one: PASS /FAIL
L.3.6 Log in as user noprolm with new password. The desktop appears. Circle one: PASS / FAIL
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L.3.7 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one: PASS /FAIL
L.3.8 Verify that no profiles are listed in the No profiles are listed in the Available Circle one: PASS /FAIL
Available Profiles or Selected Profiles or Selected Profiles panels.
Profiles panels.
L.3.9 Click Cancel. The Profile Selector window disappears. | Circle one: PASS /FAIL
L.3.10 Log out of the Validation Host (kpchost). The DIT COE LOGIN screen appears. Circle one: PASS /FAIL
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4.13 Create and test account

Create and Test An Account with the Same Login Name As That Of A Previously Deleted Account

M Create and Test A Profile Containing A Subset Of the Features In A Segment
Test Local Profile and Local Account Creation and Modification On A Master System
Test Local Profile Creation On A Client System
M.1 Create A New Profile (SSO Test) Incorporating Segment Security Administration and
Assign Several (But Not All Available) Features To the Profile On the Validation Host (kpchost)
M.1.1 NOTE: Perform the following steps on the The desktop appears. Setup
Validation Host (kpchost).
Log in as user secman.
M.1.2 Select Applications > Application The Application Manager - SecAdm Setup
Manager > DII APPS > SecAdm. window appears.
M.1.3 Double-click APM Client. An Input dialog box appears asking for the Circle one: PASS / FAIL
master APM authentication key.
M.1.4 Enter the master APM authentication Key. Asterisks appear in the text box. Circle one: PASS / FAIL
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M.1.5 Click OK. The Account and Profile Manager Circle one: PASS / FAIL
dialog box appears.
M.1.6 Click Profiles. The Profiles tab is displayed. Circle one: PASS /FAIL
M.1.7 Select File > New Profile. The Create Profile dialog box appears. Circle one: PASS /FAIL
M.1.8 Enter the following values: Each item is filled in. Circle one: PASS /FAIL
Profile Name: SSO Test
Profile Template: SSO Default
M.1.9 Click Features. The Features tab is displayed. Circle one: PASS /FAIL
M.1.10 Select SOL. Security Administrationin |SOL Security Administrationis Circle one: PASS /FAIL

the Segments panel.

highlighted. The SOL Security
Administration features appear in the
Features panel.
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M.1.11 Deselect APM Server Start, Audit Log There are no check marks next to APM Server Circle one: PASS /FAIL
File Manager, and Profile Selector |Start, Audit Log File Manager, and
Configinthe Features panel. Profile Selector Config.

M.1.12 Click Hosts. The Host s tab is displayed. Circle one: PASS /FAIL

M.1.13 Verify kpccp and kpchost appear in the kpccp and kpchost appear in the Assigned | Circle one: PASS /FAIL
Assigned Hosts panel. Hosts panel.

M.1.14 Click Submit. A Status Summary dialog box appears Circle one: PASS /FAIL

indicating the new profile has been added.
M.1.15 Click OK. Control returns to the Account and Profile | Circle one: PASS/FAIL

Manager dialog box.
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M.2 Create A New Profile (SA Test) Incorporating Segment System Administration and
Assign Several (But Not All Available) Features To the Profile On the Candidate Platform (kpccp)
M.2.1 NOTE: Perform the following steps on the The desktop appears. Setup
Candidate Platform (kpccp).
Log in as user secman.
M.2.2 Select Applications > Application The Application Manager - SecAdm Circle one: PASS / FAIL
Manager > DII APPS > SecAdm. window appears.
M.2.3 Double-click APM Client. An Input dialog box appears asking for the Circle one: PASS / FAIL
master APM authentication key.
M.2.4 Enter the master APM authentication Key. Asterisks appear in the text box. Circle one: PASS / FAIL
M.2.5 Click OK. The Account and Profile Manager Circle one: PASS / FAIL
dialog box appears.
M.2.6 Click Profiles. The Profiles tab is displayed. Circle one: PASS /FAIL
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M.2.7 Select File > New Profile. The Create Profile dialog box appears. Circle one: PASS /FAIL
M.2.8 Enter the following values: Each item is filled in. Circle one: PASS /FAIL
Profile Name: SA Test
Profile Template: SA Default
M.2.9 Click Features. The Features tab is displayed. Circle one: PASS /FAIL
M.2.10 Select SOL. System Administrationinthe |SOL System Administrationis Circle one: PASS / FAIL
Segments panel. highlighted. The SOL. System
Administration features appear in the
Features panel.
M.2.11 Deselect Adm Tool, Disk Manager, and There are no check marks next to Adm Tool, Circle one: PASS /FAIL
Network Installation Server inthe Disk Manager, and Network
Features panel. Installation Server.
M.2.12 Click Hosts. The Host s tab is displayed. Circle one: PASS /FAIL
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M.2.13 Verify kpccp and kpchost appear in the kpccp and kpchost appear in the Assigned | Circle one: PASS /FAIL
Assigned Hosts panel. Hosts panel.
M.2.14 Click Submit. A Status Summary dialog box appears Circle one: PASS /FAIL
indicating the new profile has been added.
M.2.15 Click OK. Control returns to the Account and Profile | Circle one: PASS/FAIL
Manager dialog box.
M.3 Re-create the Ltest1m Account On the Validation Host (kpchost)
M.3.1 NOTE: Perform the following steps on the The Accounts tab is displayed. Circle one: PASS /FAIL
Validation Host (kpchost).
In the Account and Profile Manager
dialog box, click Accounts.
M.3.2 Select File > New Account. The Create Account dialog box appears. Circle one: PASS /FAIL
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Operator Action

Expected Result

Observed Result

M.3.3 Enter the following values: Each item is filled in. Circle one: PASS / FAIL
Login: Ltestlm
Password: temp
Password Confirm: temp
Template: None
Home server: EACH HOST
Manage as: Local
Default Group: admin
M.34 Click profiles. The Profiles tab is displayed. Circle one: PASS /FAIL
M.3.5 Double-click SSO Test. Profile SSO Test moves to the Assigned Circle one: PASS /FAIL
Profiles panel.
M.3.6 Click Hosts. The Hosts tab is displayed. Circle one: PASS/FAIL
M.3.7 Double-click kpccp and kpchost. kpccp and kpchost move to the Assigned | Circle one: PASS /FAIL

Hosts panel.
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Observed Result

M.3.8 Click Submit. A Status Summary dialog box appears Circle one: PASS /FAIL
indicating the new user has been added.
M.3.9 Click OK. Control returns to the Account and Profile | Circle one: PASS/FAIL
Manager dialog box.
M.3.10 Log out of the Validation Host (kpchost). The DIT COE LOGIN screen appears. Setup
M4 Verify the Parameters Of the New Account On the Candidate Platform (kpccp)
M.4.1 NOTE: Perform the following steps on the The Account and Profile Manager dialog | Circle one: PASS /FAIL
Candidate Platform (kpccp). box is refreshed.
In the Account and Profile Manager
dialog box, select view > Refresh Catalog
> All.
M.4.2 Click Accounts. The Accounts tab is displayed. Circle one: PASS /FAIL
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Expected Result
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M.4.3 Verify the entries for Ltest1m. The parameters listed for user Ltest 1m match Circle one: PASS /FAIL
those below:
Login: Ltestlm
Default Group: admin
Home Server: each host
Profiles: SSO Test
Assigned Groups: admin
Shell: /bin/csh
Hosts: kpccp, kpchost
M.4.4 Open a Terminal window. A Terminal window appears with a command Setup
line prompt.
M.4.5 At the command prompt type The command prompt returns. Setup
cd /h/USERS
M.4.6 At the command prompt type A directory Ltest1lm is not listed. Circle one: PASS /FAIL

ls -la global
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Expected Result
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M.4.7 At the command prompt type A directory Ltest1mis listed. Circle one: PASS /FAIL
ls -la local

M.4.8 Log out of the Candidate Platform (kpccp). The DIT COE LOGIN screen appears. Setup

M.5 Test the Ltest1m Account On the Candidate Platform (kpccp)

M.5.1 NOTE: Perform the following steps on the A dialog box appears indicating that the password | Circle one: PASS / FAIL
Candidate Platform (kpccp). needs to be changed.
Log in as user Ltest 1m. Use the initial password,
temp.

M.5.2 Click OK. A command line window appears with an Enter | Circle one: PASS /FAIL

login password prompt.

M.5.3 Enter the initial password, temp. The prompt changes to New password. Circle one: PASS /FAIL
NOTE: The mouse cursor must be within the
command line window.

M.5.4 Enter a new password. The prompt changed to Re-enter new Circle one: PASS /FAIL

Record the new password.

password.

Password:
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M.5.5 Re-enter the new password. The DIT COE LOGIN screen appears. Circle one: PASS /FAIL
M.5.6 Log in as user Ltest1lm with the new password. | The desktop appears. Circle one: PASS /FAIL
M.5.7 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one: PASS /FAIL
M.5.8 Verify that SSO Test is the only profile listed. Profile SSO Test is the only profile listed. Circle one: PASS /FAIL
M.5.9 Double-click SSO Test. Profile SSO Test moves to the Selected Circle one: PASS /FAIL
Profiles panel.
M.5.10 Click OK. The Profile Selector Results window Circle one: PASS /FAIL

appears stating that the profile was successfully
assumed.
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M.5.11 Click Done. The Profile Selector window and the Circle one: PASS / FAIL
Profile Selector Results window
disappear.
M.5.12 Select Applications > Application The Application Manager — SecAdm Circle one: PASS /FAIL
Manager > DII APPS > SecAdm. window appears.
M.5.13 Verify the icons for APM Server Start, The icons for APM Server Start, Audit Circle one: PASS /FAIL
Audit Log File Manager, and Profile |Log File Manager, and Profile
Selector Config are not displayed. Selector Config are not displayed.
M.5.14 Double-click Assign Passwords. The Assign passwords dialog box appears. Circle one: PASS / FAIL
M.5.15 Click Cancel. The Assign passwords dialog box Circle one: PASS /FAIL
disappears.
M.5.16 Log out of the Candidate Platform (kpccp). The DIT COE LOGIN screen appears. Circle one: PASS /FAIL
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M.6 Test the Ltest1m Account On the Validation Host (kpchost)
M.6.1 NOTE: Perform the following steps on the A dialog box appears indicating that the password | Circle one: PASS / FAIL
Validation Host (kpchost). needs to be changed.
Log in as user Ltest1m. Use the initial password,
temp.
M.6.2 Click OK. A command line window appears with an Enter | Circle one: PASS /FAIL
login password prompt.
M.6.3 Enter the initial password, temp. The prompt changes to New password. Circle one: PASS /FAIL
NOTE: The mouse cursor must be within the
command line window.
M.6.4 Enter a new password. The prompt changed to Re-enter new Circle one: PASS /FAIL
password.
Record the new password. Password:
M.6.5 Re-enter the new password. The DIT COE LOGIN screen appears. Circle one: PASS /FAIL
M.6.6 Log in as user Ltest1m with the new password. | The desktop appears. Circle one: PASS / FAIL
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M.6.7 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one: PASS /FAIL

M.6.8 Verify that SSO Test is the only profile listed. Profile SSO Test is the only profile listed. Circle one: PASS /FAIL

M.6.9 Double-click SSO Test. Profile SSO Test moves to the Selected Circle one: PASS /FAIL
Profiles panel.

M.6.10 Click OK. The Profile Selector Results window Circle one: PASS /FAIL
appears stating that the profile was successfully
assumed.

M.6.11 Click Done. The Profile Selector window and the Circle one: PASS / FAIL
Profile Selector Results window
disappear.

M.6.12 Select Applications > Application The Application Manager - SecAdm Circle one: PASS / FAIL

Manager > DII_APPS > SecAdm.

window appears.
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M.6.13 Verify the icons for APM Server Start, The icons for APM Server Start, Audit Circle one: PASS /FAIL
Audit Log File Manager, and Profile [Log File Manager, and Profile
Selector Config are not displayed. Selector Config are not displayed.
M.6.14 Double-click Assign Passwords. The Assign passwords dialog box appears. Circle one: PASS / FAIL
M.6.15 Click Cancel. The Assign passwords dialog box Circle one: PASS /FAIL
disappears.
M.6.16 | Log out of the Validation Host (kpchost). The DIT COE LOGIN screen appears. Circle one: PASS /FAIL
N 4.14 Verify A User With No Profiles Assigned Has No Profiles Available
N.1 Deassign Profile SSO Test From User Ltest1lm On the Candidate Platform (kpccp)
N.1.1 NOTE: Perform the following steps on the The desktop appears. Setup
Candidate Platform (kpccp).
Log in as user secman.
N.1.2 Select Applications > Application The Application Manager — SecAdm Setup

Manager > DII APPS > SecAdm.

window appears.
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N.1.3 Double-click APM Client. An Input dialog box appears asking for the APM | Circle one: PASS /FAIL
master authentication key.

N.1.4 Enter the APM master authentication Key. Asterisks appear in the text box. Circle one: PASS /FAIL

N.1.5 Click OK. The Account and Profile Manager Circle one: PASS / FAIL
dialog box appears.

N.1.6 Select user Ltest1m. User Ltest1lm entry is highlighted. Circle one: PASS /FAIL

N.1.7 Select Edit > Modify. A Modify Account: Ltestlm dialog box Circle one: PASS /FAIL
appears.

N.1.8 Click Profiles. The Profiles tab is displayed. Circle one: PASS /FAIL
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Expected Result
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N.1.9 Double-click SSO Test. Profile SSO Test moves to the Available Circle one: PASS /FAIL
Profiles panel.
N.1.10 Click Submit. A Status Summary dialog box appears Circle one: PASS /FAIL
indicating user Ltest 1m was modified.
N.1.11 Click OK. Control returns to the Account and Profile | Circle one: PASS/FAIL
Manager dialog box.
N.1.12 Log out of the Candidate Platform (kpccp). The DIT COE LOGIN screen appears. Setup
N.2 Verify No Profiles Are Available On the Candidate Platform (kpccp)
N.2.1 NOTE: Perform the following steps on the The desktop appears. Circle one: PASS /FAIL
Candidate Platform (kpccp).
Login as user Ltest1m.
N.2.2 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one: PASS / FAIL
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N.2.3 Verify that no profiles are listed in the Selected | No profiles are listed in the Selected Circle one: PASS /FAIL
Profiles panel or the Available Profiles panel or the Available
Profiles panel. Profiles panel.
N.24 Click Cancel. The Profile Selector window disappears. | Circle one: PASS /FAIL
N.2.5 Log out of the Candidate Platform (kpccp). The DIT COE LOGIN screen appears. Circle one: PASS / FAIL
N.3 Verify No Profiles Are Available On the Validation Host (kpchost)
N.3.1 NOTE: Perform the following steps on the The desktop appears. Circle one: PASS / FAIL
Validation Host (kpchost).
Login as user Ltest1m.
N.3.2 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one: PASS /FAIL
N.3.3 Verify that no profiles are listed in the Selected | No profiles are listed in the Selected Circle one: PASS /FAIL

Profiles panel or the Available
Profiles panel.

Profiles panel or the Available
Profiles panel.
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N.3.4 Click Cancel. The Profile Selector window disappears. | Circle one: PASS /FAIL
N.3.5 Log out of the Validation Host (kpchost). The DIT COE LOGIN screen appears. Circle one: PASS /FAIL
N.4 Reassign Profile SSO Test To User Ltestlm On the Candidate Platform (kpccp)
N.4.1 NOTE: Perform the following steps on the The desktop appears. Setup
Candidate Platform (kpccp).
Login as secman.
N.4.2 Select Applications > Application The Application Manager - SecAdm Setup
Manager > DII APPS > SecAdm. window appears.
N.4.3 Double-click APM Client. An Input dialog box appears asking for the APM | Circle one: PASS /FAIL
master authentication key.
N.4.4 Enter the APM master authentication Key. Asterisks appear in the text box. Circle one: PASS / FAIL
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N.4.5 Click OK. The Account and Profile Manager Circle one: PASS / FAIL
dialog box appears.

N.4.6 Select user Ltest1m. User Ltest1lm entry is highlighted. Circle one: PASS /FAIL

N.4.7 Select Edit > Modify. A Modify Account: Ltestlm dialog box Circle one: PASS /FAIL
appears.

N.4.8 Click profiles. The Profiles tab is displayed. Circle one: PASS /FAIL

N.4.9 Double-click SSO Test. Profile SSO Test moves to the Assigned Circle one: PASS /FAIL
Profiles panel.

N.4.10 Click Submit. A Status Summary dialog box appears Circle one: PASS /FAIL

indicating user Ltest1m was modified.
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N.4.11 Click OK. Control returns to the Account and Profile | Circle one: PASS/FAIL
Manager dialog box.
4.15 Multi-user account functions
(0)
Add Multiple Users, Use Templates To Predefine Account Parameters, and Verify Accounts Created On One Merged Host Are
Reflected On The Other
0.1 Add A New User On the Candidate Platform (kpccp)
O.1.1 NOTE: Perform the following steps on the The Create Account dialog box appears. Circle one: PASS /FAIL
Candidate Platform (kpccp).
In the Account and Profile Manager
dialog box, select File > New Account.
0.1.2 Click Identification. The Identification tab is displayed. Circle one: PASS /FAIL
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0.1.3 Enter the following values: Each item is filled in. Circle one: PASS /FAIL
Login: Ltest2m
Password: temp
Password Confirm: temp
Template: sysadmin
Home server: EACH HOST
Manage as: Local
0.14 Click Groups. The Groups tab is displayed. Circle one: PASS /FAIL
0.1.5 Verify only group other appears in the Only group other appears in the Assigned Circle one: PASS /FAIL
Assigned Groups panel. Groups panel.
0.1.6 Click Profiles. The Profiles tab is displayed. Circle one: PASS /FAIL
0.1.7 Verify SA Default appears in the Assigned Profile SA Default appears in the Assigned | Circle one: PASS /FAIL

Profiles panel.

Profiles panel.
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O.1.8 Click Hosts. The Hosts tab is displayed. Circle one: PASS /FAIL
0.1.9 Verify kpccp and kpchost appear in the kpcep and kpchost appear in the Assigned | Circle one: PASS /FAIL
Assigned Hosts panel. Hosts panel.
0.1.10 Click Submit. A Status Summary dialog box appears Circle one: PASS /FAIL
indicating the new user has been added.
O.1.11 Click OK. Control returns to the Account and Profile | Circle one: PASS/FAIL
Manager dialog box.
0.2 Add A New User On the Validation Host (kpchost)
0.2.1 NOTE: Perform the following steps on the The desktop appears. Setup
Validation Host (kpchost).
Login as secman.
0.2.2 Select Applications > Application The Application Manager — SecAdm Setup

Manager > DII APPS > SecAdm.

window appears.
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0.23 Double-click APM Client. An Input dialog box appears asking for the APM | Circle one: PASS /FAIL
master authentication key.

0.24 Enter the APM master authentication Key. Asterisks appear in the text box. Circle one: PASS /FAIL

0.2.5 Click OK. The Account and Profile Manager dialog | Circle one: PASS /FAIL
box appears.

0.2.6 Select File > New Account. The Create Account dialog box appears. Circle one: PASS /FAIL

0.2.7 Enter the following values: Each item is filled in. Circle one: PASS /FAIL

Login: Ltest3m
Password: temp
Password Confirm: temp
Template: None

Home server: EACH HOST

Manage as: Local
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0.2.8 Click Groups. The Groups tab is displayed. Circle one: PASS /FAIL
0.2.9 Verify no groups are in the Assigned Groups | No groups are in the Assigned Groups panel. | Circle one: PASS /FAIL
panel.
0.2.10 Click Profiles. The Profiles tab is displayed. Circle one: PASS /FAIL
0.2.11 Double-click SA Test. Profile SA Test moves to the Assigned Circle one: PASS /FAIL
Profiles panel.
0.2.12 Click Hosts. The Host s tab is displayed. Circle one: PASS /FAIL
0.2.13 Double-click kpccp and kpchost. kpccp and kpchost move to the Assigned | Circle one: PASS / FAIL

Hosts panel.
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0.2.14 Click Submit. A Status Summary dialog box appears Circle one: PASS /FAIL
indicating the new user has been added.
0.2.15 Click OK. Control returns to the Account and Profile | Circle one: PASS/FAIL
Manager dialog box.
03 Verify the Two New Users On the Candidate Platform (kpccp)
0.3.1 NOTE: Perform the following steps on the The Account and Profile Manager dialog | Circle one: PASS /FAIL
Candidate Platform (kpccp). box is refreshed.
In the Account and Profile Manager
dialog box, select View > Refresh Catalog
> All.
0.3.2 Click Accounts. The Accounts tab is displayed. Circle one: PASS /FAIL
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033 Verify the entries for Ltest2m and Ltest3m. | The parameters listed for user Ltest2m match Circle one: PASS /FAIL
those below.
Login: Ltest2m
Default Group: other
Home Server: each host
Profiles: SA Default

Assigned Groups: other
Shell: /bin/csh
Hosts: kpccp, kpchost

The parameters listed for user Ltest 3m match
those below.

Login: Ltest3m
Default Group: admin
Home Server: each host
Profiles: SA Test

Assigned Groups: admin
Shell: /bin/csh
Hosts: kpccp, kpchost
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034 Open a Terminal window. A Terminal window appears with a command Setup
line prompt.
0.3.5 At the command prompt type The command prompt returns. Setup
cd /h/USERS
0.3.6 At the command prompt type Directories Ltest2m and Ltest3m are not listed. | Circle one: PASS / FAIL
ls -1la global
0.3.7 At the command prompt type Directories Ltest2m and Ltest3m are listed. Circle one: PASS / FAIL

ls -1la local
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P 4.16 Test Users with Multiple Derivative Profiles
Use Templates To Predefine Profiles
P.1 Create A New Profile SA Multiple Incorporating Segment Security Administration and
Assign Several (Or All Available) Features To the Profile On the Candidate Platform (kpccp)
P.1.1 NOTE: Perform the following steps on the The Profiles tab is displayed. Circle one: PASS /FAIL
Candidate Platform (kpccp).
In the Account and Profile Manager
dialog box, click Profiles.
P.1.2 Select File > New Profile. The Create Profile dialog box appears. Circle one: PASS /FAIL
P.1.3 Enter the following values: Each item is filled in. Circle one: PASS /FAIL
Profile Name: SA Multiple
Profile Template: SA Default
P.14 Click Features. The Features tab is displayed. Circle one: PASS / FAIL
P.1.5 Select SOL. System Administrationinthe |SOL System Administrationis Circle one: PASS /FAIL

Segments panel.

highlighted. The SOL System
Administration features appear in the
Features panel.
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P.1.6 Deselect Disk Manager, Reboot System, | There are no check marks nextto Disk Circle one: PASS / FAIL
and Set System Time inthe Features Manager, Reboot System, and Set
panel. System Time.

P.1.7 Click Hosts. The Hosts tab is displayed. Circle one: PASS /FAIL

P.1.8 Verity kpccp and kpchost appear in the kpccp and kpchost appear in the Assigned | Circle one: PASS /FAIL
Assigned Hosts panel. Hosts panel.

P.1.9 Click Submit. A Status Summary dialog box appears Circle one: PASS /FAIL

indicating the new profile has been added.
P.1.10 Click OK. Control returns to the Account and Profile | Circle one: PASS/FAIL

Manager dialog box.
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Q 4.17 Test Interactions Of Segments.
Test Account Modification On a Master System
Q.1 Assign New Groups To Ltest2m and Ltest3m On the Validation Host (kpchost)
Q.1.1 NOTE: Perform the following steps on the The Account and Profile Manager dialog | Circle one: PASS /FAIL
Validation Host (kpchost). box is refreshed.
In the Account and Profile Manager
dialog box, select View > Refresh Catalog
> All.
Q.1.2 Select user Ltest2m. User Ltest2m entry is highlighted. Circle one: PASS /FAIL
Q.13 Select EAit > Modify. A Modify Account: Ltest2m dialog box Circle one: PASS / FAIL
appears.
Q.14 Click Groups. The Groups tab is displayed. Circle one: PASS / FAIL
Q.15 Double-click admin. admin moves to the Assigned Groups panel. | Circle one: PASS /FAIL
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Q.1.6 Click Profiles. The Profiles tab is displayed. Circle one: PASS /FAIL

Q.1.7 Double-click SA Multiple. Profile SA Multiple moves to the Assigned | Circle one: PASS/FAIL
Profiles panel.

Q.1.8 Click Submit. A Status Summary dialog box appears Circle one: PASS /FAIL
indicating user Ltest2m was modified.

Q.1.9 Click OK. Control returns to the Account and Profile | Circle one: PASS/FAIL
Manager dialog box.

Q.1.10 Select user Ltest3m. User Ltest3m entry is highlighted. Circle one: PASS /FAIL

Q.1.11 Select Edit > Modify. A Modify Account: Ltest3m dialog box Circle one: PASS /FAIL

appears.
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Q.1.12 Click Groups. The Groups tab is displayed. Circle one: PASS /FAIL

Q.1.13 Double-click other. other moves to the Assigned Groups panel. | Circle one: PASS /FAIL

Q.1.14 Click Profiles. The Profiles tab is displayed. Circle one: PASS /FAIL

Q.1.15 Double-click SA Multiple. Profile SA Multiple moves to the Assigned |Circle one: PASS/FAIL
Profiles panel.

Q.1.16 Click Submit. A Status Summary dialog box appears Circle one: PASS /FAIL
indicating user Ltest 3m was modified.

Q.1.17 Click OK. Control returns to the Account and Profile | Circle one: PASS/FAIL

Manager dialog box.

© 2003, The Open Group
Chapter 3, Page 90
Revision: 1.0




Operator Action

Expected Result

Observed Result

Q.2 Verify Modifications On the Candidate Platform (kpccp)
Q.2.1 NOTE: Perform the following steps on the The Account and Profile Manager dialog | Circle one: PASS /FAIL
Candidate Platform (kpccp). box is refreshed.
In the Account and Profile Manager
dialog box, select view > Refresh Catalog
> All.
Q.22 Click Accounts. The Accounts tab is displayed. Circle one: PASS / FAIL
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Q.23 Verify the entries for Ltest2m and Ltest3m. | The parameters listed for user Ltest2m match Circle one: PASS /FAIL
those below:
Login: Ltest2m
Default Group: other
Home Server: each host
Profiles: SA Default,
SA Multiple
Assigned Groups: admin, other
Shell: /bin/csh
Hosts: kpccp, kpchost

The parameters listed for user Lt est3m match
those below.

Login: Ltest3m
Default Group: admin
Home Server: each host
Profiles: SA Test,

SA Multiple
Assigned Groups: admin, other
Shell: /bin/csh
Hosts: kpcep, kpchost
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Q24 Log out of the Candidate Platform (kpccp). The DIT COE LOGIN screen appears. Setup
Q.3 Verify Ltest1m User’s Access To Its Assigned Icon On the Candidate Platform (kpccp)
Q3.1 NOTE: Perform the following steps on the The desktop appears. Circle one: PASS / FAIL
Candidate Platform (kpccp).
Login as user Ltest1m.
Q3.2 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one: PASS / FAIL
Q.33 Double-click SSO Test. Profile SSO Test moves to the Selected Circle one: PASS /FAIL
Profiles panel.
Q34 Click OK. A Profile Selector Results window Circle one: PASS /FAIL
appears stating that the profile was successfully
assumed.
Q3.5 Click Done. The Profile Selector window and the Circle one: PASS /FAIL

Profile Selector Results window
disappear.
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Q3.6 Select Applications > Application The Application Manager - SecAdm Circle one: PASS / FAIL
Manager > DII APPS > SecAdm. window appears.

Q.3.7 Verify the icons for APM Server Start, The icons for APM Server Start, Audit Circle one: PASS /FAIL
Audit Log File Manager, and Profile |Log File Manager, and Profile
Selector Config are not displayed. Selector Config are not displayed.

Q.3.8 Double-click Assign Passwords. The Assign passwords dialog box appears. Circle one: PASS /FAIL

Q.3.9 Click Cancel. The Assign passwords dialog box Circle one: PASS / FAIL

disappears.
Q.3.10 Log out of the Candidate Platform (kpccp). The DIT COE LOGIN screen appears. Circle one: PASS /FAIL
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Q4 Verify Ltest2m User’s Access To Its Assigned Icon On the Candidate Platform (kpccp)
Q4.1 NOTE: Perform the following steps on the A dialog box appears indicating that the password | Circle one: PASS / FAIL
Candidate Platform (kpccp). needs to be changed.
Log in as user Ltest2m. Use the initial password,
temp.
Q4.2 Click OK. A command line window appears with an Enter | Circle one: PASS /FAIL
login password prompt.
Q43 Enter the initial password, temp. The prompt changes to New password. Circle one: PASS /FAIL
NOTE: The mouse cursor must be within the
command line window.
Q4.4 Enter a new password. The prompt changed to Re-enter new Circle one: PASS /FAIL
password.
Record the new password. Password:
Q4.5 Re-enter the new password. The DIT COE LOGIN screen appears. Circle one: PASS /FAIL
Q4.6 Log in as user Ltest2m with the new password. | The desktop appears. Circle one: PASS / FAIL
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Q4.7 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one: PASS /FAIL
Q4.8 Double-click Profiles SA Default and SA Profiles SA Default and SA Multiple move |Circle one: PASS/FAIL
Multiple inthe Available Profiles to the Selected Profiles panel.
panel.
Q.49 Click OK. A Profile Selector Results window Circle one: PASS /FAIL
appears stating that the profiles were successfully
assumed.
Q.4.10 Click Done. The Profile Selector window and the Circle one: PASS /FAIL
Profile Selector Results window
disappear.
Q4.11 Select Applications > Application The Application Manager - SysAdm Circle one: PASS / FAIL

Manager > DII APPS > SysAdm.

window appears with the following icons: . . (go
up), Adm Tool, Change Machine ID,
Create Action, DTterm, Disk
Manager, Edit Local Hosts, Network
Installation Server, Reboot
System, Segment Installer, Set
DNS, Set Routes, Set System Time,
Shutdown System, Text Edit, XTerm.
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Q4.12 Log out of the Candidate Platform (kpccp). The DIT COE LOGIN screen appears. Circle one: PASS /FAIL
Q.5 Verify Ltest3m User’s Access To Its Assigned Icon On the Candidate Platform (kpccp)
Q.51 NOTE: Perform the following steps on the A dialog box appears indicating that the password | Circle one: PASS / FAIL
Candidate Platform (kpccp). needs to be changed.
Log in as user Ltest3m. Use the initial password,
temp.
Q5.2 Click OK. A command line window appears with an Enter | Circle one: PASS /FAIL
login password prompt.
Q.53 Enter the initial password, temp. The prompt changes to New password. Circle one: PASS /FAIL
NOTE: The mouse cursor must be within the
command line window.
Q5.4 Enter a new password. The prompt changed to Re-enter new Circle one: PASS / FAIL
password.
Record the new password. Password:
Q.55 Re-enter the new password. The DIT COE LOGIN screen appears. Circle one: PASS /FAIL
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Operator Action Expected Result Observed Result
Q.5.6 Log in as user Ltest3m with the new password. | The desktop appears. Circle one: PASS / FAIL
Q.5.7 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one: PASS /FAIL
Q.5.8 Double-click Profiles SA Test and SA Profiles SA Test and SA Multiple move to Circle one: PASS /FAIL
Multiple inthe Available Profiles the Selected Profiles panel.
panel.
Q.59 Click OK. A Profile Selector Results window Circle one: PASS /FAIL
appears stating that the profiles were successfully
assumed.
Q.5.10 Click Done. The Profile Selector window and the Circle one: PASS / FAIL

Profile Selector Results window
disappear.
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Operator Action Expected Result

Observed Result

Q.5.11 Select Applications > Application The Application Manager - SysAdm Circle one: PASS / FAIL
Manager > DII APPS > SysAdm. window appears with the following icons: . . (go
up), Adm Tool, Change Machine ID,
Create Action, DTterm, Edit Local
Hosts, Network Installation
Server, Reboot System, Segment
Installer, Set DNS, Set Routes,
Set System Time, Shutdown System,
Text Edit, XTerm.
NOTE: This is the complete list of SysAdm
features except Disk Manager.
Q.5.12 Log out of the Candidate Platform (kpccp). The DIT COE LOGIN screen appears. Circle one: PASS /FAIL
R 4.18 Test Session Manager's Ability To Resume the Previously Active Set Of Profiles
R.1 Verify Available Profiles and Icons For Ltest2m On the Candidate Platform (kpccp)
R.1.1 NOTE: Perform the following steps on the The desktop appears. Circle one: PASS /FAIL
Candidate Platform (kpccp).
Log in as user Ltest2m.
R.1.2 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one: PASS /FAIL
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Operator Action

Expected Result

Observed Result

R.1.3 Verify that no profiles are listed in the No profiles are listed in the Available Circle one: PASS /FAIL
Available Profiles panel and SA Profiles panel and SA Default and SA
Default and SA Multiple are listed in the Multiple are listed in the Selected
Selected Profiles panel. Profiles panel.
R.1.4 Click Cancel. The Profile Selector window disappears. Circle one: PASS /FAIL
R.1.5 Select Applications > Application The Application Manager - SysAdm Circle one: PASS /FAIL
Manager > DII APPS > SysAdm. window appears with the following icons: . . (go
up), Adm Tool, Change Machine ID,
Create Action, DTterm, Disk
Manager, Edit Local Hosts, Network
Installation Server, Reboot
System, Segment Installer, Set
DNS, Set Routes, Set System Time,
Shutdown System, Text Edit, XTerm.
R.1.6 Log out of the Candidate Platform (kpccp). The DIT COE LOGIN screen appears. Circle one: PASS / FAIL
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Expected Result

Observed Result

R.2 Verify Available Profiles and Icons For Ltest3m On the Candidate Platform (kpccp)
R.2.1 NOTE: Perform the following steps on the The desktop appears. Circle one: PASS /FAIL
Candidate Platform (kpccp).
Log in as user Ltest3m.
R.2.2 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one: PASS / FAIL
R.2.3 Verify that no profiles are listed in the No profiles are listed in the Available Circle one: PASS /FAIL
Available Profiles paneland SA Test Profiles panel and SA Test and SA
and SA Multiple are listed in the Selected Multiple are listed in the Selected
Profiles panel. Profiles panel.
R.2.4 Click Cancel. The Profile Selector window disappears. | Circle one: PASS /FAIL
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Expected Result

Observed Result

R.2.5

Select Applications > Application
Manager > DII_APPS > SysAdm.

The Application Manager - SysAdm
window appears with the following icons: . . (go
up), Adm Tool, Change Machine ID,
Create Action, DTterm, Edit Local
Hosts, Network Installation
Server, Reboot System, Segment
Installer, Set DNS, Set Routes,
Set System Time, Shutdown System,
Text Edit, XTerm.

NOTE: This is the complete list of SysAdm
features except Disk Manager.

Circle one: PASS / FAIL

R.2.6

Log out of the Candidate Platform (kpccp).

The DIT COE LOGIN screen appears.

Circle one: PASS / FAIL
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S 4.19 Log In With No Available Profile and Test Account Modification On A Master System
S.1 Deassign Profiles SA Test and SA Multiple From User Ltest3m On the Validation Host
(kpchost)
S.1.1 NOTE: Perform the following steps on the User Ltest3m is highlighted. Circle one: PASS /FAIL
Validation Host (kpchost).
In the Account and Profile Manager
dialog box, select user Ltest3m.
S.1.2 Select EAit > Modify. A Modify Account: Ltest3m dialog box Circle one: PASS/FAIL
appears.
S.1.3 Click Profiles. The Profiles tab is displayed. Circle one: PASS /FAIL
S.1.4 Double-click SA Test and SA Multiple. Profiles SA Test and SA Multiple moveto |Circle one: PASS/FAIL
the Available Profiles panel.
S.1.5 Click Submit. A Status Summary dialog box appears Circle one: PASS /FAIL

indicating user Ltest 3m was modified.
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Expected Result

Observed Result

S.1.6 Click OK. Control returns to the Account and Profile | Circle one: PASS/FAIL
Manager dialog box.
S.1.7 Log out of the Validation Host (kpchost). The DIT COE LOGIN screen appears. Setup
S.2 Verify Ltest3m User No Longer Has Access To Its Previously Assigned Icon On the Candidate
Platform (kpccp)
S.2.1 NOTE: Perform the following steps on the The desktop appears. Circle one: PASS / FAIL
Candidate Platform (kpccp).
Log in as user Ltest3m.
S.2.2 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one: PASS / FAIL
S.23 Verify that no profiles are listed in the Selected | No profiles are listed in the Selected Circle one: PASS /FAIL
Profiles panel or the Available Profiles panel or the Available
Profiles panel. Profiles panel.
S.2.4 Click Cancel. The Profile Selector window disappears. | Circle one: PASS /FAIL
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S.2.5 Select Applications > Application .. (go up) is the only icon displayed. Circle one: PASS / FAIL
Manager > DII APPS.
S.2.6 Log out of the Candidate Platform (kpccp). The DIT COE LOGIN screen appears. Circle one: PASS /FAIL
S.3 Verify Ltest3m User No Longer Has Access To Its Previously Assigned Icon On the Validation
Host (kpchost)
S.3.1 NOTE: Perform the following steps on the A dialog box appears indicating that the password | Circle one: PASS / FAIL
Validation Host (kpchost). needs to be changed.
Log in as user Ltest3m. Use the initial password,
temp.
S.3.2 Click OK. A command line window appears with an Enter | Circle one: PASS /FAIL
login password prompt.
S.3.3 Enter the initial password, temp. The prompt changes to New password. Circle one: PASS /FAIL

NOTE: The mouse cursor must be within the
command line window.
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S.3.4 Enter a new password. The prompt changed to Re-enter new Circle one: PASS /FAIL
password.
Record the new password. Password:
S.3.5 Re-enter the new password. The DIT COE LOGIN screen appears. Circle one: PASS /FAIL
S.3.6 Log in as user Ltest3m with the new password. | The desktop appears. Circle one: PASS /FAIL
S.3.7 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one: PASS /FAIL
S.3.8 Verify that no profiles are listed in the Selected | No profiles are listed in the Selected Circle one: PASS /FAIL
Profiles panel or the Available Profiles panel or the Available
Profiles panel. Profiles panel.
S.3.9 Click Cancel. The Profile Selector window disappears. | Circle one: PASS /FAIL
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S.3.10 Select Applications > Application .. (go up) is the only icon displayed. Circle one: PASS / FAIL
Manager > DII APPS.
S.3.11 Log out of the Validation Host (kpchost). The DIT COE LOGIN screen appears. Circle one: PASS /FAIL
T 4.20 Test Ability To Detect Duplicate Local User Names
T.1 Attempt To Add A User Account That Already Exists On the Candidate Platform (kpccp)
T.1.1 NOTE: Perform the following steps on the The desktop appears. Setup
Candidate Platform (kpccp).
Login as secman.
T.1.2 Select Applications > Application The Application Manager - SecAdm Setup
Manager > DII APPS > SecAdm. window appears.
T.1.3 Double-click APM Client. An Input dialog box appears asking for the APM | Circle one: PASS /FAIL
master authentication key.
T.1.4 Enter the APM master authentication Key. Asterisks appear in the text box. Circle one: PASS / FAIL
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Expected Result

Observed Result

T.1.5 Click OK. The Account and Profile Manager dialog | Circle one: PASS /FAIL
box appears.
T.1.6 Select File > New Account. The Create Account dialog box appears. Circle one: PASS /FAIL
T.1.7 Click Identification. The Identification tab is displayed. Circle one: PASS /FAIL
T.1.8 Enter the following values: Each item is filled in. Circle one: PASS /FAIL
Login: Ltest2m
Password: temp
Password Confirm: temp
Template: sysadmin
Home server: EACH HOST
Manage as: Local
T.1.9 Click Groups. The Groups tab is displayed. Circle one: PASS/FAIL
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T.1.10 Verify only group other appears in the Only group other appears in the Assigned Circle one: PASS /FAIL
Assigned Groups panel. Groups panel.

T.1.11 Click Profiles. The Profiles tab is displayed. Circle one: PASS /FAIL

T.1.12 Verify SA Default appears in the Assigned SA Default appears in the Assigned Circle one: PASS /FAIL
Profiles panel. Profiles panel.

T.1.13 Click Hosts. The Hosts tab is displayed. Circle one: PASS / FAIL

T.1.14 Verify kpccp and kpchost appear in the kpccp and kpchost appear in the Assigned | Circle one: PASS /FAIL
Assigned Hosts panel. Hosts panel.

T.1.15 Click Submit. An Error dialog box appears with the message: | Circle one: PASS / FAIL

Login name already exists.
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T.1.16 Click OK. The Error dialog box disappears. Circle one: PASS /FAIL
T.1.17 Click Cancel. Control returns to the Account and Profile | Circle one: PASS/FAIL
Manager dialog box. Only the original user
Ltest2mis listed under the Accounts tab. No
parameters of that or any other account have
changed.
U 4.21 Test Ability To Detect Duplicate Profiles
U1 Attempt To Create A Duplicate Profile SSO Test On the Candidate Platform (kpccp)
U.1.1 NOTE: Perform the following steps on the The Profiles tab is displayed. Circle one: PASS /FAIL
Candidate Platform (kpccp).
In the Account and Profile Manager
dialog box, click Profiles.
U.1.2 Select File > New Profile. The Create Profile dialog box appears. Circle one: PASS /FAIL
U.1.3 Enter the following values: Each item is filled in. Circle one: PASS /FAIL

Profile Name: SSO Test
Profile Template: SSO Default
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U.1.4 Click Features. The Features tab is displayed. Circle one: PASS /FAIL
U.1.5 Select SOL. Security Administrationin |SOL Security Administrationis Circle one: PASS /FAIL
the Segments panel. highlighted. The SOL Security
Administration features appear in the
Features panel.
U.1.6 Click Select All. All Features are selected. Circle one: PASS /FAIL
U.1.7 Click Hosts. The Hosts tab is displayed. Circle one: PASS /FAIL
U.1.8 Verify kpccp and kpchost appear in the kpcep and kpchost appear in the Assigned | Circle one: PASS /FAIL
Assigned Hosts panel. Hosts panel.
U.1.9 Click Submit. An Error dialog box appears with the message: | Circle one: PASS / FAIL

Profile name already exists.
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U.1.10 Click OK. The Error dialog box disappears. Circle one: PASS /FAIL
U.1.11 Click Cancel. Control returns to the Profiles tab of the Circle one: PASS /FAIL
Account and Profile Manager dialog
box. Only the original Profile SSO Test is listed
under the Profiles tab. No parameters of that or
any other Profile have changed.
U.2 Attempt To Create A Duplicate Profile SSO Test But With No Hosts Selected On the Candidate
Platform (kpccp)
U.2.1 NOTE: Perform the following steps on the The Create Profile dialog box appears. Circle one: PASS /FAIL
Candidate Platform (kpccp).
In the Account and Profile Manager
dialog box, select File > New Profile.
U.2.2 Enter the following values: Each item is filled in. Circle one: PASS /FAIL
Profile Name: SSO Test
Profile Template: SSO Default
U.23 Click Features. The Features tab is displayed. Circle one: PASS /FAIL
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u.24 Select SOL. Security Administrationin |SOL Security Administrationis Circle one: PASS /FAIL
the Segments panel. highlighted. The SOL. Security
Administration features appear in the
Features panel.
uU.2.5 Click Select All. All Features are selected. Circle one: PASS /FAIL
U.2.6 Click Hosts. The Hosts tab is displayed. Circle one: PASS/FAIL
u.2.7 Double-click kpccp and kpchost. kpccp and kpchost move to the Available | Circle one: PASS /FAIL
Hosts panel.
U.2.8 Click Submit. A dialog box appears with the following message: | Circle one: PASS / FAIL
You have not selected any hosts
for this profile! Continue?
uU.2.9 Click Yes. An Error dialog box appears with the message: | Circle one: PASS / FAIL

Profile name already exists.
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Expected Result
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U.2.10 Click OK. Control returns to the Create Profile Circle one: PASS /FAIL
window.
U.2.11 Click Cancel. Control returns to the Profiles tab of the Circle one: PASS /FAIL
Account and Profile Manager dialog
box. Only the original Profile SSO Test is listed
under the Profiles tab. No parameters of that or
any other Profile have changed.
\ 4.22 Test Ability To Detect Duplicate UNIX Groups
\'A Attempt To Create A Duplicate Unix Group admin On the Candidate Platform (kpccp)
V.1.1 NOTE: Perform the following steps on the The Groups tab is displayed. Circle one: PASS /FAIL
Candidate Platform (kpccp).
In the Account and Profile Manager
dialog box, click Groups.
V.1.2 Select File > New Group. The Create Group dialog box appears. Circle one: PASS /FAIL
V.13 Enter the following values: Each item is filled in. Circle one: PASS /FAIL

Group name: admin

Template: admin

Manage as: Local
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V.1.4 Click Hosts. The Hosts tab is displayed. Circle one: PASS / FAIL

V.1.5 Double-click kpccp and kpchost. kpccp and kpchost move to the Available | Circle one: PASS/FAIL
Hosts panel.

V.1.6 Click Submit. A dialog box appears with the following message: | Circle one: PASS / FAIL
You have not selected any hosts
for this group! Continue?

V.1.7 Click Yes. An Error window appears with the message: Circle one: PASS /FAIL
Group name in use.

V.1.8 Click OK. Control returns to the Create Group dialog box. | Circle one: PASS / FAIL

V.1.9 Click Hosts. The Hosts tab is displayed. Circle one: PASS / FAIL
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V.1.10 Double-click kpccp and kpchost. kpccp and kpchost move to the Assigned | Circle one: PASS /FAIL
Hosts panel.
V.1.11 Click Identification. The Identification tab is displayed. Circle one: PASS /FAIL
V.1.12 Select Domain from the Manage As drop-down |Domain is selected. Circle one: PASS /FAIL
list.
V.1.13 Click Submit. An Error window appears with the message: Circle one: PASS / FAIL
Group name in use.
V.1.14 Click OK. Control returns to the Create Group dialog box. | Circle one: PASS / FAIL
V.1.15 Click Cancel. Control returns to the Groups tab of the Circle one: PASS / FAIL

Account and Profile Manager dialog
box. Only the original Group admin is listed under
the Groups tab. No parameters of that or any other
Group have changed.
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V.2 Verify No Duplicate Accounts, Groups, or Profiles Have Been Created On the Validation Host
(kpchost)
V.21 NOTE: Perform the following steps on the The desktop appears. Setup
Validation Host (kpchost).
Login as secman.
V.22 Select Applications > Application The Application Manager — SecAdm Setup
Manager > DII APPS > SecAdm. window appears.
V.23 Double-click APM Client. An Input dialog box appears asking for the APM | Circle one: PASS /FAIL
master authentication key.
V.2.4 Enter the APM master authentication Key. Asterisks appear in the text box. Circle one: PASS / FAIL
V.25 Click OK. The Account and Profile Manager dialog | Circle one: PASS /FAIL
box appears.
V.2.6 Click Accounts. The Accounts tab is displayed. No two user Circle one: PASS /FAIL

Accounts have the same name.
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V.2.7 Click Profiles. The Profiles tab is displayed. No two Profiles | Circle one: PASS / FAIL
have the same name.

V.28 Click Groups. The Groups tab is displayed. No two Groups Circle one: PASS /FAIL
have the same name.

V.2.9 Log out of the Validation Host (kpchost). The DIT COE LOGIN screen appears. Setup

W 4.23 Delete A Profile and Verify Local Users Cannot Assume A Profile Already Assigned To Them After the Profile Has Been Deleted
W.1 Delete the Profile SA Multiple On the Candidate Platform (kpccp)

W.1.1 NOTE: Perform the following steps on the The Profiles tab is displayed. Circle one: PASS /FAIL

Candidate Platform (kpccp).

In the Account and Profile Manager
dialog box, click Profiles.

W.1.2 Select SA Multiple. SA Multiple is highlighted. Circle one: PASS /FAIL
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Expected Result

Observed Result

W.1.3 Select Edit > Delete. A Confirm window prompts for confirmation. Circle one: PASS /FAIL
W.14 Click Yes to confirm deletion. A Status Summary window appears indicating | Circle one: PASS / FAIL
the Profile was successfully deleted.
W.1.5 Click OK. Control returns to the Account and Profile | Circle one: PASS/FAIL
Manager dialog box. The entry for SA
Multiple has been removed from the
Profiles tab.
W.1.6 Log out of the Candidate Platform (kpccp). The DIT COE LOGIN screen appears. Setup
W.2 Verify Available Profiles and Icons For User Ltest2m On the Candidate Platform (kpccp)
W.2.1 NOTE: Perform the following steps on the The desktop appears. Circle one: PASS / FAIL
Candidate Platform (kpccp).
Log in as user Ltest2m.
Ww.22 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one: PASS /FAIL
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W.2.3 Verify SA Default is listed in the Selected SA Default is listed in the Selected Circle one: PASS / FAIL
Profiles panel. Profiles panel.
w24 Click Cancel. The Profile Selector window disappears. | Circle one: PASS /FAIL
W.2.5 Select Applications > Application The Application Manager - SysAdm Circle one: PASS / FAIL
Manager > DII APPS > SysAdm. window appears with the following icons: . . (go
up), Adm Tool, Change Machine ID,
Create Action, DTterm, Disk
Manager, Edit Local Hosts, Network
Installation Server, Reboot
System, Segment Installer, Set
DNS, Set Routes, Set System Time,
Shutdown System, Text Edit, XTerm.
W.2.6 Double-click Edit Local Hosts. The Edit Hosts dialog box appears. Circle one: PASS /FAIL
Ww.2.7 Click Close. The Edit Hosts dialog box disappears. Circle one: PASS /FAIL
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W.2.8 Log out of the Candidate Platform (kpccp). The DIT COE LOGIN screen appears. Circle one: PASS /FAIL
W.3 Verify Available Profiles and Icons For User Ltest2m On the Validation Host (kpchost)
W.3.1 NOTE: Perform the following steps on the A dialog box appears indicating that the password | Circle one: PASS / FAIL
Validation Host (kpchost). needs to be changed.
Log in as user Ltest2m with password temp.
W.3.2 Click OK. A command line window appears with an Enter | Circle one: PASS/FAIL
login password prompt.
W.3.3 Enter the current password. The prompt changes to New password. Circle one: PASS /FAIL
NOTE: The mouse cursor must be within the
command line window.
W.3.4 Enter a new password. The prompt changed to Re-enter new Circle one: PASS / FAIL
password.
Record the new password. Password:
W35 Re-enter the new password. The DIT COE LOGIN screen appears. Circle one: PASS /FAIL
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W.3.6 Log in as user Ltest2m with the new password. The desktop appears. Circle one: PASS / FAIL

W.3.7 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one: PASS /FAIL

W.3.8 Double-click SA Default. Profile SA Default moves to the Selected Circle one: PASS /FAIL
Profiles panel.

W.3.9 Click OK. The Profile Selector Results window Circle one: PASS /FAIL
appears stating that the profile was successfully
assumed.

W.3.10 Click Done. The Profile Selector window and the Circle one: PASS /FAIL

Profile Selector Results window
disappear.
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W.a3.11

Select Applications > Application
Manager > DII_APPS > SysAdm.

The Application Manager - SysAdm
window appears with the following icons: . . (go
up), Adm Tool, Change Machine ID,
Create Action, DTterm, Disk
Manager, Edit Local Hosts, Network
Installation Server, Reboot
System, Segment Installer, Set
DNS, Set Routes, Set System Time,
Shutdown System, Text Edit, XTerm.

Circle one: PASS / FAIL

W.3.12

Double-click Set Routes.

The Default Router Setup dialog box
appears.

Circle one: PASS / FAIL

W.3.13

Click Cancel.

The Default Router Setup dialog box
disappears.

Circle one: PASS / FAIL

W.3.14

Log out of the Validation Host (kpchost).

The DIT COE LOGIN screen appears.

Circle one: PASS / FAIL
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X 4.24 Reset Test Cell For Additional Testing
X.1 Clean Up Files Generated During Test Execution On the Candidate Platform (kpccp)
X.1.1 NOTE: Perform the following steps on the The desktop appears. Setup
Candidate Platform (kpccp).
Login as secman.
X.1.2 Select Applications > Application The Application Manager - SecAdm Setup
Manager > DII APPS > SecAdm. window appears.
X.1.3 Double-click APM Client. An Input dialog box appears asking for the APM | Circle one: PASS /FAIL
master authentication key.
X.1.4 Enter the APM master authentication Key. Asterisks appear in the text box. Circle one: PASS / FAIL
X.1.5 Click OK. The Account and Profile Manager dialog | Circle one: PASS /FAIL
box appears.
X.1.6 Click profiles. The Profiles tab is displayed. Circle one: PASS /FAIL
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X.1.7 Select SA Test. SA Test is highlighted. Circle one: PASS /FAIL

X.1.8 Select Edit > Delete. A Confirm window prompts for confirmation. Circle one: PASS /FAIL

X.1.9 Click Yes. A Status Summary window appears indicating | Circle one: PASS / FAIL
the Profile was successfully deleted.

X.1.10 Click OK. Control returns to the Account and Profile | Circle one: PASS/FAIL
Manager dialog box. The entry for SA Test has
been removed from the Profiles tab.

X.1.11 Select SSO Test. SSO Test is highlighted. Circle one: PASS /FAIL

X.1.12 Select Edit > Delete. A Conf irm window prompts for confirmation. Circle one: PASS /FAIL
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X.1.13 Click Yes. A Status Summary window appears indicating | Circle one: PASS / FAIL
the Profile was successfully deleted.

X.1.14 Click OK. Control returns to the Account and Profile | Circle one: PASS/FAIL
Manager dialog box. The entry for SSO Test
has been removed from the Profiles tab.

X.1.15 Click Accounts. The Accounts tab is displayed. Circle one: PASS /FAIL

X.1.16 Select user Ltest1m. User Ltestlmis highlighted. Circle one: PASS /FAIL

X.1.17 Select Edit > Delete. A Confirm window prompts for confirmation. Circle one: PASS /FAIL

X.1.18 Click Yes. A Status Summary window appears indicating | Circle one: PASS /FAIL

the Account was successfully deleted.
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X.1.19 Click OK. Control returns to the Account and Profile | Circle one: PASS/FAIL
Manager dialog box. The entry for Ltest1m has
been removed from the Accounts tab.

X.1.20 Select user Ltest2m. User Ltest2mis highlighted. Circle one: PASS /FAIL

X.1.21 Select Edit > Delete. A Conf irm window prompts for confirmation. Circle one: PASS /FAIL

X.1.22 Click Yes. A Status Summary window appears indicating | Circle one: PASS / FAIL
the Account was successfully deleted.

X.1.23 Click OK. Control returns to the Account and Profile | Circle one: PASS /FAIL
Manager dialog box. The entry for Ltest2m has
been removed from the Accounts tab.

X.1.24 Select user Ltest3m. User Ltest3mis highlighted. Circle one: PASS /FAIL
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X.1.25 Select Edit > Delete. A Conf irm window prompts for confirmation. Circle one: PASS /FAIL

X.1.26 Click Yes. A Status Summary window appears indicating | Circle one: PASS / FAIL
the Account was successfully deleted.

X.1.27 Click OK. Control returns to the Account and Profile | Circle one: PASS/FAIL
Manager dialog box. The entry for Ltest3m has
been removed from the Accounts tab.

X.1.28 Select user noprolm. User noprolm is highlighted. Circle one: PASS /FAIL

X.1.29 Select Edit > Delete. A Confirm window prompts for confirmation. Circle one: PASS /FAIL

X.1.30 Click Yes. A Status Summary window appears indicating | Circle one: PASS /FAIL

the account was successfully deleted.
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X.1.31 Click OK. Control returns to the Account and Profile | Circle one: PASS/FAIL
Manager dialog box. The entry for noprolm has
been removed from the Accounts tab.
X.1.32 Open a Terminal window. A Terminal window appears with a command Cleanup
line prompt.
X.1.33 At the command prompt type The command prompt returns. Cleanup
cd /h/USERS
X.1.34 At the command prompt type Directories Ltest1lm, Ltest2m, Ltest3m Circle one: PASS /FAIL
1s -la global and noprolm are not listed.
X.1.35 At the command prompt type Directories Ltest1lm, Ltest2m, Ltest3m Circle one: PASS /FAIL
1s -la local and noprolm are not listed.
X.1.36 At the command prompt type The Password prompt appears. Cleanup

su -
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Operator Action Expected Result Observed Result

X.1.37 At the command prompt type the root password. | The command prompt returns. Cleanup

X.1.38 At the command prompt type The command prompt returns. Cleanup
csh

X.1.39 At the command prompt type The command prompt returns. Cleanup
cd /var/dt/appconfig/appmanager

X.1.40 At the command prompt type Ltestlm, Ltest2m, Ltest3m, noprolm | Circle one: PASS/FAIL
15 -1 are not listed.

X.1.41 In the Application Manager - SecAdm The Profile Selector Configuration Circle one: PASS /FAIL
window, double-click Profile Selector window appears.
Config.

X.1.42 Set Profile Selection Criteria to Profile Selection Criteria issetto Circle one: PASS /FAIL

Single.

Single.
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Operator Action

Expected Result

Observed Result

X.1.43 Click OK. The Profile Selector Configuration Circle one: PASS /FAIL
window disappears.
X.2 Verify Accounts and Profiles Have Been Removed From the Validation Host (kpchost)
X.2.1 NOTE: Perform the following steps on the The desktop appears. Cleanup
Validation Host (kpchost).
Login as secman.
X.22 Select Applications > Application The Application Manager — SecAdm Cleanup
Manager > DII APPS > SecAdm. window appears.
X.23 Double-click APM Client. An Input dialog box appears asking for the APM | Circle one: PASS /FAIL
master authentication key.
X.2.4 Enter the APM master authentication Key. Asterisks appear in the text box. Circle one: PASS / FAIL
X.2.5 Click OK. The Account and Profile Manager dialog | Circle one: PASS /FAIL

box appears.
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Operator Action

Expected Result

Observed Result

X.2.6 Click Accounts. The Accounts tab is displayed. Accounts Circle one: PASS /FAIL
Ltestlm, Ltest2m, Ltest3m, and
noprolm are not listed.
X.2.7 Click Profiles. The Profiles tab is displayed. Profiles SA Circle one: PASS /FAIL
Test, SSO Test, and SA Multiple are
not listed.
X.2.8 Open a Terminal window. A Terminal window appears with a command Cleanup
line prompt.
X.2.9 At the command prompt type The command prompt returns. Cleanup
cd /h/USERS
X.2.10 At the command prompt type Directories Ltest1lm, Ltest2m, Ltest3m, |Circleone: PASS/FAIL
1s -la global and noprolm are not listed.
X.2.11 At the command prompt type Directories Ltestlm, Ltest2m, Ltest3m, |Circleone: PASS/FAIL

ls -1la local

and noprolm are not listed.
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Operator Action Expected Result Observed Result

X.2.12 At the command prompt type The command prompt returns. Cleanup
cd /var/dt/appconfig/appmanager

X.2.13 At the command prompt type Ltestlm, Ltest2m, Ltest3m,and Circle one: PASS /FAIL
1s -1 noprolm are not listed.

X.2.14 In the Application Manager - SecAdm The Edit APM Configuration window Circle one: PASS / FAIL
window, double-click Edit APM appears.
Configuration.

X.2.15 Under Local Options, set Log Level to Information is selected. Circle one: PASS /FAIL
Information.

X.2.16 Click Domain Options. The Domain tab is selected. Circle one: PASS /FAIL

X.2.17 Deselect Manage Hosts. Manage Hosts is deselected. Circle one: PASS / FAIL
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Operator Action

Expected Result

Observed Result

X.2.18 Click Submit. A Done dialog box appears with the message: Circle one: PASS /FAIL
Operation completed successfully.

X.2.19 Click OK. The Edit APM Configuration window Circle one: PASS /FAIL
disappears.

X.2.20 Double-click Profile Selector Config. The Profile Selector Configuration Circle one: PASS / FAIL
window appears.

X.2.21 Set Profile Selection Criteria to Profile Selection Criteria issetto Circle one: PASS /FAIL

Single. Single.
X.2.22 Click OK. The Profile Selector Configuration | Circle one: PASS/FAIL

window disappears.
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Operator Action Expected Result Observed Result
Y 4.25 Remove Hosts
Y.1 Remove Merged Hosts From the APM Master (kpchost)
Y.1.1 NOTE: Perform the following steps on the The Remove Hosts dialog box appears. Circle one: PASS /FAIL
Validation Host (kpchost).
In the Application Manager - SecAdm
dialog box, double-click Remove Host.
Y.1.2 In the Keep panel, double-click kpccp. kpccp moves to the Remove panel. Circle one: PASS /FAIL
Y.1.3 Click Submit. An INFORMATIONAL MESSAGE window states: | Circle one: PASS /FAIL
APM Server reloaded successfully.
Y.l1.4 Click OK. A Completed window states: Circle one: PASS /FAIL
Removed: kpccp
Y.1.5 Click OK. The Remove Host dialog box disappears. Circle one: PASS /FAIL
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Operator Action

Expected Result

Observed Result

Y.1.6 Double-click APM Server Stop. An INFORMATIONAL MESSAGE box states: Circle one: PASS / FAIL
APM Server successfully stopped.

Y.1.7 Click OK. The INFORMATIONAL MESSAGE box Circle one: PASS / FAIL
disappears.

Y.1.8 Double-click APM Server Start. A INFORMATIONAL MESSAGE box states: Circle one: PASS /FAIL
APM Server started successfully.

Y.1.9 Click OK. The INFORMATIONAL MESSAGE box Circle one: PASS / FAIL
disappears.

Y.1.10 Log out. The DII COE LOGIN screen appears. Circle one: PASS / FAIL

Y.1.11 Log in as keyman. The desktop appears. Cleanup

Y.1.12 Select Applications > Application The Application Manager - APM window | Cleanup

Manager > DII APPS > APM. appears.
Y.1.13 Double-click Authentication Manager. The Authentication Manager window Cleanup

appears.
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Operator Action Expected Result Observed Result
Y.1.14 Enter the master authentication key in the Key text | Asterisks appear in the text box. Cleanup
box.
Y.1.15 Click Set Client’s Local Key. The Hosts List window appears. Cleanup
Y.1.16 Select kpccep. kpccp is highlighted. Cleanup
Y.1.17 Select Delete Host. A Confirm dialog box appears with the Cleanup
following message:
Delete the local authentication
keys of these hosts?
kpccp
Y.1.18 Click Yes. The dialog box disappears. Cleanup
Y.1.19 Click Close inthe Hosts List window. The Hosts List window disappears. Cleanup
Y.1.20 Click Close inthe Authentication The Authentication Manager window Cleanup

Manager window.

disappears.
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Operator Action Expected Result Observed Result
Y.2 Configure the Local Host As the APM Master On the Candidate Platform (kpccp)
Y.2.1 NOTE: Perform the following steps on the The Edit APM Configuration window Circle one: PASS /FAIL
Candidate Platform (kpccp). appears.
In the Application Manager - SecAdm
window, double-click EAit APM
Configuration.
Y.2.2 In the Master Host text box, enter kpccp. kpccp appears in the text box. Circle one: PASS /FAIL
Y.23 Click Submit. Done window states: Circle one: PASS /FAIL
Operation completed successfully.
Y.24 Click OK. The Edit APM Configuration window Circle one: PASS /FAIL
disappears.
Y.25 Double-click Edit APM Configuration. The Edit APM Configuration window Circle one: PASS /FAIL
appears.
Y.2.6 Under Local Options, set Log Level to Information is selected. Circle one: PASS / FAIL

Information.
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Expected Result

Observed Result

Y.2.7 Click Domain Options. The Domain tab is selected. Circle one: PASS / FAIL
Y.2.8 Deselect Manage Hosts. Manage Hosts is deselected. Circle one: PASS /FAIL
Y29 Click Submit. A Done dialog box appears with the message: Circle one: PASS /FAIL
Operation completed successfully.
Y.2.10 Click OK. The Edit APM Configuration window Circle one: PASS / FAIL
disappears.
Y.2.11 In the Terminal window, type The command prompt returns.
cd /h/COE/Comp/APM/bin
Y.2.12 In the Terminal window, type The command prompt returns.
./APM_BecomeOwnMaster
Y.2.13 In the Terminal window, type The APM Server process is listed. Circle one: PASS /FAIL

ps -eaf | grep “cat [s]
/h/COE/Comp/APM/data/APMServer.pid™
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Y.3 Verify Validation Host (kpchost) Removed From the Candidate Platform (kpccp)
Y.3.1 NOTE: Perform the following steps on the The Account and Profile Manager Circle one: PASS /FAIL
Candidate Platform (kpccp). dialog box is refreshed.
In the Account and Profile Manager
dialog box, select view > Refresh Catalog
> All.
Y32 Select Accounts. The Accounts tab is displayed. In the Hosts Circle one: PASS /FAIL
column, only kpccp appears.
Z . I
4.26 Log Out of the Candidate Platform (kpccp) and the Validation Host (kpchost)

End of Test Validation Procedure

© 2003, The Open Group
Chapter 3, Page 140
Revision: 1.0




