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About This Guide
This manual introduces you to the GNOME graphical desktop environment as imple-
mented in openSUSE®10.3 and shows you how to configure it to meet your personal
needs and preferences. It also introduces you to several programs and services, including
office programs such as OpenOffice.org, Web browsers, file managers, scanning tools,
and image editing tools. It is intended for users who have some experience using a
graphical desktop environment such as Macintosh*, Windows*, or other Linux* desk-
tops.

This guide contains the following sections:

• Part I, “GNOME Desktop” (page 1)

• Part II, “Office and Collaboration” (page 145)

• Part III, “Internet” (page 271)

• Part IV, “Multimedia” (page 293)

• Appendix A,Moving from Windows to Linux (page 369)

1 Audience
This guide is intended for users of the GNOME desktop.

2 Feedback
We want to hear your comments and suggestions about this manual and the other doc-
umentation included with this product. Please use the User Comments feature at the
bottom of each page of the online documentation, or go to http://www.novell
.com/documentation/feedback.html and enter your comments there.

http://www.novell.com/documentation/feedback.html
http://www.novell.com/documentation/feedback.html


3 Documentation Updates
For the latest version of this documentation, see the http://www.novell.com/
documentation/opensuse103Web site.

4 Additional Documentation
We provide HTML and PDF versions of our books in different languages. The following
manuals are available for openSUSE:

Start-Up
Guides you through the installation and basic configuration of your system. For
newcomers, the manual also introduces basic Linux concepts such as the file system,
the user concept and access permissions and gives an overview of the features
openSUSE offers to support mobile computing. Provides help and advice in trou-
bleshooting.

KDE Quick Start
Gives a short introduction to the KDE desktop and some key applications running
on it.

KDE User Guide
Introduces the KDE desktop of openSUSE and a variety of applications shipping
with it. It guides you through using these applications and helps you perform key
tasks. It is intended mainly for end users who want to make efficient use of KDE
in everyday life.

GNOME Quick Start
Gives a short introduction to the GNOME desktop and some key applications
running on it.

GNOME User Guide
Introduces the GNOME desktop of openSUSE and a variety of applications you
will encounter when working with the GNOME desktop. It guides you through
using these applications and helps you perform key tasks. It is intended mainly for
end users who want to make efficient use of applications running on the GNOME
desktop.
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Reference
Gives you a general understanding of openSUSE and covers advanced system ad-
ministration tasks. It is intended mainly for system administrators and home users
with basic system administration knowledge. It provides detailed information about
advanced deployment scenarios, administration of your system, the interaction of
key system components and the set-up of various network and file services open-
SUSE offers.

Novell AppArmor Quick Start
Helps you understand the main concepts behind Novell® AppArmor.

Novell AppArmor Administration Guide
Contains in-depth information about the use of Novell AppArmor in your environ-
ment.

Lessons For Lizards
A community book project for the openSUSE distribution. A snapshot of the
manual written by the open source community is released on an equal footing with
the Novell/SUSE manuals. The lessons are written in a cook book style and cover
more specific or exotic topics than the traditional manuals. For more information,
see http://developer.novell.com/wiki/index.php/Lessons
_for_Lizards.

Find HTML versions of the openSUSEmanuals in your installed system under /usr/
share/doc/manual or in the help centers of your KDE or GNOME desktop. You
can also access the documentation on the Web at http://www.novell.com/
documentation/opensuse103/where you can download PDForHTMLversions
of the manuals. For information where to find the books on the installation media, refer
to the Release Notes of this product, available in your installed system under /usr/
share/doc/release-notes/.

5 Documentation Conventions
The following typographical conventions are used in this manual:

• /etc/passwd: filenames and directory names

• placeholder: replace placeholder with the actual value

• PATH: the environment variable PATH
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• ls, --help: commands, options, and parameters

• user: users or groups

• Alt, Alt + F1: a key to press or a key combination; keys are shown in uppercase as
on a keyboard

• File, File > Save As: menu items, buttons

• Dancing Penguins (Chapter Penguins, ↑Another Manual): This is a reference to a
chapter in another manual.

6 About the Making of This Manual
This book is written in Novdoc, a subset of DocBook (see http://www.docbook
.org). The XML source files were validated by xmllint, processed by xsltproc,
and converted into HTML using a customized version of Norman Walsh's stylesheets.

7 Acknowledgments
With a lot of voluntary commitment, the developers of Linux cooperate on a global
scale to promote the development of Linux. We thank them for their efforts—this dis-
tribution would not exist without them. Furthermore, we thank Frank Zappa and Pawar.
Special thanks, of course, go to Linus Torvalds.

Have a lot of fun!

Your SUSE Team
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Part I. GNOME Desktop





1Getting Started with the
GNOME Desktop
This section describes the conventions, layout, and common tasks of the GNOME
desktop as implemented in openSUSE®10.3.

GNOME is an easy-to-use graphical interface that can be customized to meet your
needs and personal preferences. This section describes the default configuration of
GNOME. If you or your system administrator modified the defaults, some aspect might
be different, such as appearance or keyboard shortcuts.

• Section 1.1, “Logging In and Selecting a Desktop” (page 4)

• Section 1.2, “Logging Out” (page 7)

• Section 1.3, “Desktop Basics” (page 8)

• Section 1.4, “Using the Main Menu” (page 14)

• Section 1.5, “Managing Folders and Files with Nautilus” (page 18)

• Section 1.6, “Accessing Network Resources” (page 23)

• Section 1.7, “Accessing Floppy Disks, CDs, or DVDs” (page 27)

• Section 1.8, “Finding Data on Your Computer or in the File System” (page 28)

• Section 1.9, “Moving Text Between Applications” (page 34)

• Section 1.10, “Printing” (page 34)
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• Section 1.11, “Managing Internet Connections” (page 36)

• Section 1.12, “Exploring the Internet” (page 36)

• Section 1.13, “E-mail and Scheduling” (page 37)

• Section 1.14, “Opening or Creating Documents with OpenOffice.org” (page 38)

• Section 1.15, “Controlling Your Desktop’s Power Management” (page 38)

• Section 1.16, “Creating, Displaying, and Decompressing Archives” (page 46)

• Section 1.17, “Taking Screen Shots” (page 51)

• Section 1.18, “Viewing PDF Files” (page 52)

• Section 1.19, “Controlling Sound” (page 53)

• Section 1.20, “Using the Fingerprint Reader” (page 55)

• Section 1.21, “Obtaining Software Updates” (page 57)

• Section 1.22, “For More Information” (page 57)

1.1 Logging In and Selecting a
Desktop

If more than one user account is configured on your computer, usually all users must
authenticate—unless Auto Login is enabled for a certain user. Auto login lets a user
automatically log in to the desktop environment when the system starts. This feature
can be enabled or disabled during installation or at any time using the YaST User
Management module. For more information, refer to the chapter about user management
in Start-Up, available at http://www.novell.com/documentation/
opensuse103/.

If your computer is running in a network environment and you are not the only person
using the machine, you are usually prompted to enter your username and password
when you start your system. If you did not set up your system and your user account,
check with your system administrator for your username and password.

4 GNOME User Guide
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The programmanaging the login process depends on the desktop environment installed
on your system. For GNOME, it is GDM. If the KDE desktop is also installed on your
system, it might be KDM.

The login screen has the following items:

• Login prompt: Enter your username and password to log in.

• Language menu: Select a language for your session.

• Session menu: Select the desktop to run during your session. If other desktops
are installed, they appear in the list.

• Restart: Select to restart the computer.

• Shut Down: Select to shut down the computer.

1.1.1 What Is a Session?
A session is the period of time from when you log in to when you log out. During a
session, you can use applications, print, browse the Web, and so on.

The login screen offers several login options. For example, you can select the language
of your session so that text that appears in the interface is presented in that language.

After your username and password are authenticated, the Session Manager starts. The
Session Manager lets you save certain settings for each session. It also lets you save
the state of your most recent session and return to that session the next time you log in.

The Session Manager can save and restore the following settings:

• Appearance and behavior settings, such as fonts, colors, and mouse settings.

• Applications that you were running. such as a file manager or an OpenOffice.org
program.
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TIP

You cannot save and restore applications that Session Manager does not
manage. For example, if you start the vi editor from the command line in
a terminal window, Session Manager cannot restore your editing session.

For information on configuring session preferences, see Section 2.4.9, “Managing
Sessions” (page 134).

1.1.2 Switching Desktops
If you installed both the GNOME and the KDE desktops, use the following instructions
to switch desktops.

1 Click Computer > Logout > Log Out.

In KDE, click the main menu button, then click Leave > Logout.

2 On the login screen, click Session.

3 Select the desktop you want (GNOME or KDE), then click Change Session.

4 Type your username, then press Enter.

5 Type your password, then press Enter.

1.1.3 Locking Your Screen
To lock the screen, you can do either of the following:

• Click Computer > Lock Screen.

• If the Lock button is present on a panel, click it.

To add the Lock button to a panel, right-click the panel, then click Add to Panel >
Lock Screen.
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When you lock your screen, the screen saver starts. To lock your screen correctly, you
must have a screen saver enabled. To unlock the screen, move your mouse to display
the locked screen dialog. Enter your username and password, then press Enter.

For information on configuring your screen saver, see Section 2.2.7, “Configuring the
Screen Saver” (page 119).

1.2 Logging Out
When you are finished using the computer, you can log out and leave the system running,
or restart or shut down the computer. If your system provides power management, you
can also suspend your computer, making the next system start much faster than a
complete reboot.

1.2.1 Logging Out or Switching Users
1 Click Computer > Logout.

2 Select one of the following options:

Log out: Logs you out of the current session and returns you to the Login
screen.

Switch User: Suspends your session, allowing another user to log in and use
the computer.

1.2.2 Restarting or Shutting Down the
Computer

1 Click Computer > Shutdown.

2 Select one of the following options:

Shutdown: Logs you out of the current session, then turns off the computer.

Restart: Logs you out of the current session, then restarts the computer.
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Sleep: Puts your computer in a temporary state that conserves power. The
state of your session is preserved, however, including all applications you have
running and all documents you have open.

Hibernate: Suspends your session, using no power until the computer is
restarted. The state of your session is preserved, however, including all applica-
tions you have running and all documents you have open.

1.3 Desktop Basics
Aswith other common desktop products, themain components of the GNOMEdesktop
are icons that link to files, folders, or programs, as well as the panel at the bottom of
the screen (similar to the Task Bar in Windows). Double-click an icon to start its asso-
ciated program. Right-click an icon to access additional menus and options. You can
also right-click any empty space on the desktop to access additional menus for config-
uring or managing the desktop itself.
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Figure 1.1 GNOME Desktop

By default, the desktop features two key icons: your personal Home folder and a trash
can for deleted items. Other icons representing devices on your computer, such as CD
drives, might also be present on the desktop. If you double-click your Home folder, the
Nautilus file manager starts and displays the contents of your home directory. For more
information about using Nautilus, see Section 1.5, “Managing Folders and Files with
Nautilus” (page 18).

Right-clicking an icon displays a menu that offers file operations such as copying,
cutting, or renaming. SelectingProperties from themenu displays a configuration dialog.
The title of an icon, as well as the icon itself, can be changed with Select Custom Icon.
The Emblems tab lets you add graphical descriptive symbols to the icon. The Permissions
tab lets you set access permissions for the selected files. The Notes tab lets you manage
comments. The menu for the trash can also features the Empty Trash option, which
deletes its contents.
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A link is a special type of file that points to another file or folder. When you perform
an action on a link, the action is performed on the file or folder that the link points to.
When you delete a link, you delete only the link file, not the file that the link points to.

To create a link on the desktop to a folder or a file, access the object in File Manager
by right-clicking the object and then clickingMake Link. Drag the link from the File
Manager window and drop it onto the desktop.

• Section 1.3.1, “Default Desktop Icons” (page 10)

• Section 1.3.2, “Desktop Menu” (page 10)

• Section 1.3.3, “Bottom Panel” (page 11)

• Section 1.3.4, “Adding Applets and Applications to the Panel” (page 12)

1.3.1 Default Desktop Icons
To remove an icon from the desktop, simply drag it onto the trash can. You cannot
move the Home icon to the trash.

WARNING

.Be careful with this option—if you move folder or file icons to the trash can,
the actual data is deleted. If the icons only represent links to a file or to a di-
rectory, only the links are deleted.

1.3.2 Desktop Menu
Right-clicking an empty spot on the desktop displays a menu with various options.
Click Create Folder to create a new folder. Create a launcher icon for an application
with Create Launcher. Provide the name of the application and the command for
starting it, then select an icon to represent it. You can also change the desktop back-
ground and align desktop icons.
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Figure 1.2 GNOME Desktop Menu

1.3.3 Bottom Panel
The desktop includes a panel across the bottom of the screen. The bottom panel contains
the Computer menu (similar to the Start menu in Windows*) and the icons of all appli-
cations currently running. You can also add applications and applets to the panel for
easy access. If you click the name of a program in the taskbar, the program's window
is moved to the foreground. If the program is already in the foreground, a mouse click
minimizes it. Clicking a minimized application reopens the respective window.

Figure 1.3 GNOME Bottom Panel

The Show Desktop icon is on the right side of the bottom panel. This icon minimizes
all programwindows and displays the desktop. Or, if all windows are alreadyminimized,
it reopens them.

If you right-click an empty spot in the panel, a menu opens, offering the options listed
in Table 1.1, “Panel Menu Options” (page 11):

Table 1.1 Panel Menu Options

DescriptionOption

Opens a menu of applications and applets that can be added
to the panel.

Add to Panel
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DescriptionOption

Modifies the properties for this panel.Properties

Removes the panel from the desktop. All of the panel settings
are lost.

Delete This Panel

Lets you drag the panel to another side of the screen, or locks
the panel in its current position.

Allow Panel to be
Moved/Lock Panel
Position

Creates a new panel and adds it to the desktop.New Panel

Opens the Help Center.Help

Opens information about the panel application.About Panels

1.3.4 Adding Applets and Applications to
the Panel

You can add applications and applets to the bottom panel for quick access. An applet
is a small program, while an application is usually a more robust stand-alone program.
Adding an applet puts useful utilities where you can easily access them.

The GNOME desktop comes with many applets. You can see a complete list by right-
clicking the bottom panel and selecting Add to Panel.

12 GNOME User Guide



Figure 1.4 Add to Panel Dialog Box

Some useful applets include the following:

Table 1.2 Some Useful Applets

DescriptionApplet

Look up a word in an online dictionary.Dictionary Lookup

Terminate an application. This is especially useful if you
want to terminate an application that is no longer respond-
ing.

Force Quit

Find files, folders, and documents on the computer.Search for Files

Create, display, and manage sticky notes on your desk-
top.

Sticky Notes

Access programs from a menu like the one in previous
versions of GNOME. This is especially useful for people
who are used to earlier versions of GNOME.

Traditional Main Menu
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DescriptionApplet

Increase or decrease the sound volume.Volume Control

Display current weather information for a specified city.Weather Report

Access additional work areas, calledworkspaces, through
virtual desktops. For example, you can open applications

Workspace Switcher

in different workspaces and use them on their own
desktops without the clutter from other applications.

1.4 Using the Main Menu
Click Computer on the far left of the bottom panel to open the main menu. Commonly
used applications appear in the main menu, along with recently used applications. You
can also click Documents to display your recent documents, or click Places to display
your favorite places (such as your home directory or the Desktop). ClickMore Applica-
tions to access additional applications, listed in categories. Use the options on the right
to access Help, install additional software, open the GNOMEControl Center, lock your
screen, log out of the desktop, or check the status of your hard drive and network con-
nections.

Figure 1.5 Main Menu

The main menu contains several elements:

14 GNOME User Guide



• Section 1.4.1, “Search Bar” (page 15)

• Section 1.4.2, “Main Menu Tabs” (page 16)

• Section 1.4.3, “System” (page 17)

• Section 1.4.4, “Status” (page 18)

1.4.1 Search Bar
The search bar helps you find applications and files on your system. Enter your search
terms in the Search field, then press Enter. The results are displayed in the Desktop
Search dialog box.

You can use the results list to open a file, forward it via e-mail, or display it in the file
manager. Simply right-click an item in the results list and select the option you want.
The options available for an item depend on the type of file it is. Clicking a file in the
list displays a preview of the file and information such as the title, path, and date the
file was last modified or accessed.

Use the Search menu to limit your search to files in a specific location, such as your
address book or Web pages, or to display only a specific type of file in your results list.
The Sortmenu lets you sort the items in your results list according to name, relevance,
or the date the file was last modified.
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For more information about using the GNOME desktop’s search function, see Chap-
ter 10, Searching with Beagle (page 249).

1.4.2 Main Menu Tabs
You can determine which icons appear in the main menu by clicking the Applications,
Documents, or Places tabs.

• Section “Favorite Applications” (page 16)

• Section “Recent Applications” (page 17)

• Section “Recent Documents” (page 17)

• Section “Recent Places” (page 17)

Favorite Applications
By default, Favorite Applications shows icons for several commonly used applications.
Use this view to show the applications you use most often.

To add an item to your Favorite Applications:

1 Click Computer >More Applications.

2 Right-click the application you want to add.

3 Select Add to Favorites.

The selected application is added to your Favorite Applications.

To remove an item from your Favorite Applications:

1 Click Computer.

2 Make sure that your Favorite Applications appear in the main menu.

If Favorite Applications does not appear on the main menu, click Applications.

3 Right-click the item you want to remove.
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4 Select Remove from Favorites.

The removed application no longer appears in your Favorite Applications view.

Recent Applications
Recent Applications shows the last two applications you have started. Use this view to
quickly find applications you have used recently.

Recent Documents
Click the Documents tab to display the last several documents you have opened. Use
this view to quickly locate the documents you worked on most recently. ClickMore
Documents to open the File Browser.

Recent Places
Click the Places tab to display the last several places you have opened. Use this view
to quickly locate the places you worked on most recently. ClickMore Places to open
the File Browser.

1.4.3 System
System provides shortcuts to several system applications.

Table 1.3 System Shortcuts

DescriptionApplication

Opens the Help Center, which provides online documentation for
your system.

Help

Allows you to customize and configure your system. For more in-
formation, see Chapter 2, Customizing Your Settings (page 59).

Control Center

Opens the Software Installer, which guides you through the process
of installing new software.

Install Software
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DescriptionApplication

Locks your system so that nobody can access it while you are away.
Enter your password to unlock the system.

Lock Screen

Opens the Log Out dialog, where you can log out or switch users.Log Out

Opens the Shutdown dialog, where you can shut down or restart
your system, or suspend the computer.

Shutdown

1.4.4 Status
Status displays information about your hard drive and network connection, including
the amount of available space on your hard disk and the type of network connection
you are using.

1.5 Managing Folders and Files with
Nautilus

Use the Nautilus File Manager to create and view folders and documents, run scripts,
and create CDs of your data. In addition, the File Manager provides support for Web
and file viewing.

You can open the File Manager in the following ways:

• Click Computer > Nautilus File Browser.

• Double-click your Home directory icon on the desktop.

• Click Computer >More Applications > System > Home Folder or Nautilus File
Browser.
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Figure 1.6 File Manager

The elements of the Nautilus window include the following:

Menu: Lets you perform most tasks in the file manager. You can also open a pop-
up menu from file manager windows by right-clicking in a file manager window. The
items in this menu depend on where you right-click. For example, if you right-click a
file or folder, you can select items related to the file or folder. If you right-click the
background of a view pane, you can select items related to the display of items in the
view pane.

Toolbar: Lets you quickly navigate among files and folders, and provides access to
files and folders.The toolbar contains Back, Forward, Up, Stop, Reload, Home, Com-
puter, and Search buttons.

Location Bar: Lets you locate files, folders, and URI sites.

Side Pane: Lets you navigate or display information about the selected file or folder.
Use the drop-down list to customize what is shown in the pane. The list includes ways
to view information about files, perform actions on files, add emblems to files, view a
history of recently visited sites, and display your files in the Tree system. To close the
side pane, click the X at the top right of the side pane. To display the side pane, click
View > Side Pane.

View Pane: Displays folders and files. Use the options on the Viewmenu to increase
or decrease the size of content in the view pane, and to display items as a list or as icons.

Status Bar: Displays the number of items in a folder and gives the available free
space. When a file is selected, the status bar displays the filename and size.
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1.5.1 File Manager Navigation Shortcuts
Some simple shortcuts for navigating in the File Manager include the following:

Table 1.4 File Manager Navigation Shortcuts

DescriptionShortcut

Opens the parent folder.Backspace or Alt+Up-arrow

Selects an item.Up or Down

Opens an item.Alt+Down or Enter

Opens an item and closes the current folder.Shift+Alt+Down

Opens the parent folder and closes the current
folder.

Shift+Alt+Up

Closes all parent folders.Shift+Ctrl+W

Opens a location by specifying a path or URL.Ctrl+L

Opens your home directory.Alt+Home

For more information, click Help > Contents in the File Manager.

1.5.2 Archiving Folders
If you have files you haven’t recently but want to keep on your computer, you can
compress the files into a tape archive (TAR) format.

1 In the Nautilus view pane, right-click the folder you want to archive, then click
Create Archive.
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2 Accept the default archive filename or provide a new name.

3 Select a file extension from the drop-down list (usetar.gz for themost common
archive form).

4 Specify a location for the archive file, then click Create.

To extract an archived file, right-click the file, then select Extract Here.

1.5.3 Creating a CD/DVD
If your system has a CD or DVD read/write drive, you can use the Nautilus file manager
to burn CDs and DVDs.

1 ClickComputer >More Applications >Multimedia >GNOMECD/DVDCreator,
or insert a blank disc and clickMake Data CD/DVD or Make Audio CD/DVD.

2 Copy the files you want to put on the CD or DVD into the Nautilus CD/DVD
Creator window.
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3 ClickWrite to Disc.

4 Modify information in the Write to Disc dialog box or accept the defaults, then
clickWrite.

The files are burned to the disc. This could take a few minutes, depending on the
amount of data being burned and the speed of your burner.

You can also use the Banshee music player to burn audio and MP3 CDs.

1.5.4 Using Bookmarks
Use the Nautilus Bookmarks feature to mark your favorite folders.

1 Select the folder or item you want to create a bookmark for.

2 Click Bookmarks > Add Bookmark. The bookmark is added to the list, with the
folder name as the bookmark name. When you bookmark a file, it is the folder
that is actually bookmarked.

3 To select an item from your Bookmarks list, click Bookmarks, then click the de-
sired bookmark in the list.

You can also organize your Bookmarks list by clicking Bookmarks > Edit Bookmarks
and making your selections in the dialog box.
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To change the order of your bookmarks, click a bookmark and drag it to the desired
location.

1.5.5 File Manager Preferences
You can change the File Manager preferences by clicking Edit > Preferences. For more
information, see Section 2.2.3, “File Management Preferences” (page 99).

1.6 Accessing Network Resources
This section describes how to access network resources:

• Section 1.6.1, “Connecting to Your Network” (page 23)

• Section 1.6.2, “Accessing Network Shares” (page 24)

• Section 1.6.3, “Sharing Directories From Your Computer” (page 26)

1.6.1 Connecting to Your Network
You can connect to a network with wired and wireless connections. To view your net-
work connection status, click Computer. In the Status area of the main menu, The Net-
work Connections icon shows your network connection status. For example, in the
following figure, the computer is connected to a wired network using an Ethernet con-
nection.
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Figure 1.7 Network Connections Icon in the Main Menu

Click the icon to open the YaST Network Settings module. You an use this module to
configure your network setup method or edit your network card configuration.

1.6.2 Accessing Network Shares
Other network devices, like workstations and servers, can be set up to share some or
all of their resources. Typically, files and folders are marked to let remote users access
them. These are called network shares. If your system is configured to access network
shares, you can use Nautilus File Manager to access them.

To access network shares, double-click your Home directory icon on the desktop, then
click Network Servers in the left pane. The view pane displays the network shares that
you can access. Double-click the network resource that you want to access. You might
be required to authenticate to the resource by providing a username and password.
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Figure 1.8 Network File Browser

To access NFS shares, double-click the UNIX Network icon. A list of UNIX* shares
available to you is displayed.

To access Windows shares, double-click theWindows Network icon. The Windows
shares available to you are displayed.

For more information, see Chapter 8, Accessing Network Resources (page 225).

Adding a Network Place
1 Click Computer > Nautilus File Browser > File > Connect to Server.

2 Select a service type, then specify the required information for your type of ser-
vice.
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3 Specify the name you want displayed for this connection, then click Connect.

An icon for the network place is added to the desktop.

1.6.3 Sharing Directories From Your
Computer

You can make directories on your computer available to other users on your network.

Enabling Sharing
Use YaST to enable sharing on your computer. In order to enable sharing, you must
have root privileges and be a member of a workgroup or domain.

1 Click Computer >More Applications > System > YaST.

2 In YaST, click Network Services >Windows Domain Membership.

3 In the Windows Domain Membership module, click Allow Users to Share Their
Directories.

4 Click Finish.

Sharing a Directory
If directory sharing is enabled on your computer, use the following steps to configure
a directory to be shared.

1 Open the File Manager and browse to the directory you want to share.

2 Right-click the directory you want to share, then click Sharing Options.
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3 Select the Share this folder check box, then type the name you want to use for
this share.

4 If you want other users to be able to copy files to your shared directory, select
the Allow other people to write in this folder check box.

5 (Optional) Type a comment, if desired.

6 Click Create Share.

1.7 Accessing Floppy Disks, CDs, or
DVDs

To access floppy disks, CDs, or DVDs, insert the medium into the appropriate drive.
For many types of removable media, a File Manager window pops up automatically
when the media is inserted or attached to the computer. If File Manager does not open,
double-click the icon for that drive to view the contents.

WARNING

Do not simply remove disks from the drive after using them. Floppy disks, CDs,
and DVDs must always be unmounted from the system first. Close all File
Manager sessions still accessing the medium, then right-click the icon for the
medium and select Eject from the menu. Then safely remove the floppy disk,
CD, or DVD when the tray automatically opens.
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Floppy disks can also be formatted by clickingComputer >More Applications > System
> Floppy Formatter. In the Floppy Formatter dialog, select the density of the floppy
disk and the file system settings: Linux native (ext2), the file system for Linux, or DOS
(FAT) to use the floppy with Windows systems.

1.8 Finding Data on Your Computer
or in the File System

GNOME provides several ways to find data on your computer or in the file system.
With Beagle (also called Desktop Search), you can easily search your personal informa-
tion space (usually your home folder) to find documents, e-mails, Web history, IM/ITC
conversations, source code, images, music files, applications, and much more.

To locate files on your computer, clickComputer, enter your search terms in the Search
field, then press Enter. The results are displayed in the Desktop Search dialog box.

You can use the results lists to open a file, forward it via e-mail, or display it in the file
manager. Simply right-click an item in the results list and select the option you want.
The options available for an item depend on the type of file it is. Clicking a file in the
list displays a preview of the file and information such as the title, path, and date the
file was last modified or accessed.

For more information, see Chapter 10, Searching with Beagle (page 249).
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With Search for Files, you can locate files on your computer or in the file system using
a variety of search criteria, such as file content, date, owner, or file size. Start it by
clicking Computer >More Applications > System > Search for Files.

1.8.1 Searching for Files
Using Search for File on the System menu, you can locate files on your computer or
on a network share using any number of search criteria.

Figure 1.9 Search for Files Dialog

Search for Files uses the find, grep, and locate UNIX commands, and all searches are
case insensitive.

You can also open the Search for Files dialog by entering the following command in a
terminal window:

gnome-search-tool

Performing a Basic Search
1 Click Computer >More Applications > System > Search for Files.

2 Type the search text in the Name contains field.
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The search text can be a filename or partial filename, with or without wildcards,
as shown in the following table:

ResultExampleSearch Text

Searches for all files that contain
“myfile.txt” in the filename.

myfile.txtFull or partial filename

Searches for all files that have a .c
or .h extension.

*.[ch]Partial filename combined
with wildcards (* [ ])

3 In the Look in folder field, type the path to the directory where you want Search
for Files to begin the search.

4 Click Find.

Search for Files searches in the directory that you specify (and any subdirectories of
the directory) and displays the results of the search in the Search Results list. If Search
for Files does not find any files that match the search criteria, the application displays
the message No files found in the Search results list.

Adding Search Options
Use Show more options to search by file content, dates, owner, or file size.

1 Click Computer >More Applications > System > Search for Files.

2 Type the search text in the Name contains field.

3 In the Look in folder field, type the path to the directory where you want Search
for Files to begin the search.

4 Click Select more options, then click Available options

5 Select a search option that you want to apply, then click Add.

The following options are available:
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DescriptionOption

Searches for a file by filename. Type a full file-
name or a partial filename with wildcards in the

Contains the text

field provided. Use an asterisk (*) to indicate a
sequence of characters. Use a question mark (?)
to indicate a single character. The search is case
sensitive.

Searches for files that were modified within the
period specified (in days).

Date modified less than

Searches for files that were modified before the
period specified (in days).

Date modified more than

Searches for files that are equal to or larger than
the size specified (in kilobytes).

Size at least

Searches for files that are smaller than or equal
to the size specified (in kilobytes).

Size at most

Searches for empty files.File is empty

Searches for files that are owned by the user
specified. Type the name of the user in the text
box provided.

Owned by user

Searches for files that are owned by the group
specified. Type the name of the group in the text
box provided.

Owned by group

Searches for files that are owned by a user or
group that is unknown to the system.

Owner is unrecognized

Searches for filenames that do not contain the
string that you enter. Enter a full filename or a

Name does not contain

partial filenamewith wildcards in the field provid-
ed. Use an asterisk (*) to indicate a sequence of
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DescriptionOption

characters. Use a question mark (?) to indicate a
single character. The search is case sensitive.

Searches for files that contain the specified regular
expression in their directory path or filename.

Name matches regular ex-
pression

Type the regular expression in the text box provid-
ed.

Regular expressions are special text strings used
to describe a search pattern. For more information,
see Regular-Expressions.info [http://www
.regular-expressions.info].

Includes hidden and backup files in the search.Show hidden and backup
files

Follows symbolic links when searching for files.Follow symbolic links

Searches in directories that are not in the same
file system as the start directory.

Include other filesystems

6 Specify the required search information for the search option.

7 Repeat Step 5 (page 30) and Step 6 (page 32) for each search option you want
to apply.

To remove a search option from the current search, click the Remove button next
to the option.

8 Click Find.

Using the Search Results List
You can use the Search Results list to open or delete a file found during a search, or
you can save the search results to a file.
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Figure 1.10 Search Results List

To open a file displayed in the Search Results list, right-click the file, then click Open
or double-click the file. To open the folder that contains a file displayed in the Search
Results list, right-click the file, then click Open Folder.

To delete a file displayed in the Search Results list, right-click the file, then clickMove
to Trash.

To save the results of the last search that Search for Files performed, right-click anywhere
in the Search results list, then click Save Results As. Type a name for the file that the
results are saved to, then click Save.

Disabling Quick Searches
By default, Search for Files tries to speed up some searches by using the locate
command.locate provides a secure way to index and quickly search for files. Because
locate relies on a file index, the Search Results list might not be up to date. To disable
quick searches, run the following command in a terminal window:

# gconftool-2 --type=bool --set
/apps/gnome-search-tool/disable_quick_search 1
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1.9 Moving Text Between Applications
To copy text between applications, select the text, then move the mouse cursor to the
position where you want the text copied. Click the center button on the mouse or the
scroll wheel to copy the text.

When copying information between programs, you must keep the source program open
and paste the text before closing it. When a program closes, any content from that ap-
plication that is on the clipboard is lost.

1.10 Printing
Before you can install a printer, you need to know the root password and have your
printer information ready. Depending on how you connect to the printer, you might also
need the printer URI, TCP/IP address or host, and the driver for the printer. A number
of common printer drivers ship with openSUSE. If you cannot find a driver for the
printer, check the printer manufacturer's Web site.

You can also use YaST to configure your printers, as described in Start-Up, available
at http://www.novell.com/documentation/opensuse103/.

1.10.1 Installing a Local Printer
1 Connect the printer cable to your computer and connect the printer's power supply.

The printer dialog should open. If it doesn’t, click Computer > Control Center
> Add Printer > New Printer to open it.

2 Enter the root password.

3 Click Local Printer.

4 If the printer was autodetected, select the printer from the list. If the printer was
not autodetected, click Use another printer by specifying a port and then select
the correct printer port.

5 Click Forward.

34 GNOME User Guide

http://www.novell.com/documentation/opensuse103/


6 Select the printer driver for this printer, then click Apply.

You can also install a printer driver from a disk, or visit the printer manufacturer's
Web site to download the latest driver.

7 Specify desired options (such as a description or location) for the printer in the
Properties dialog box, then click Close.

The installed printer appears in the Printers dialog box. You can now print to the
printer from any application.

1.10.2 Monitoring Print Jobs in GNOME
• Section “Modifying Printer Settings” (page 35)

• Section “Canceling Print Jobs” (page 35)

• Section “Deleting a Printer” (page 36)

Modifying Printer Settings
1 Click Computer > Control Center > Printers.

2 Right-click the printer you want to modify, then click Properties.

3 Modify the properties, then click Close.

Canceling Print Jobs
1 Click Computer > Control Center > Printer.

2 Double-click the printer you sent the job to.

3 Right-click the print job, then click Cancel.

If the print job does not appear in the list, then the print job might have been
printed already.
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Deleting a Printer
1 Click Computer > Control Center > Printer.

2 Click Edit > Become Administrator.

3 Type the root password, then click Continue.

4 Right-click the printer you want to delete, then click Remove.

1.11 Managing Internet Connections
To surf the Internet or send and receive e-mail messages, you must have configured an
Internet connection with YaST. Depending on your environment, in YaST select whether
to use NetworkManager. In GNOME, you can then establish Internet connections with
NetworkManager as described in Start-Up, available athttp://www.novell.com/
documentation/opensuse103/ orwith ifup [http://www.annodex.net/
cgi-bin/man/man2html?ifup].

For a list of criteria to help you to decide whether to use NetworkManager, refer to the
NetworkManager chapter and the mobile computing chapter in Start-Up, available at
http://www.novell.com/documentation/opensuse103/.

1.12 Exploring the Internet
The GNOME desktop includes Firefox, a Mozilla*-based Web browser. You can start
it by clicking Computer > Firefox.

You can type an address into the location bar at the top or click links in a page to move
to different pages, just like in any other Web browser.

For more information, see Chapter 12, Browsing with Firefox (page 273).
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1.13 E-mail and Scheduling
For reading and managing your mail and events, openSUSE offers you Novell® Evo-
lution™, a groupware program that makes it easy to store, organize, and retrieve your
personal information.

Evolution seamlessly combines e-mail, a calendar, an address book, and a task list in
one easy-to-use application. With its extensive support for communications and data
interchange standards, Evolution can work with existing corporate networks and appli-
cations, including Microsoft* Exchange.

To start Evolution, click Computer >More Applications >Office > Evolution Mail and
Calendar.

The first time you start Evolution, it prompts you with a few questions as it sets up a
mail account and helps you import mail from your old mail client. Then it shows you
how many new messages you have and lists upcoming appointments and tasks, as well
as the current weather and news from news feeds. The calendar, address book, and mail
tools are available in the shortcut bar on the left.

Press Ctrl+N to open a new item for whatever part of Evolution you're working in. In
mail, this creates a new message. If you're in the address book, Ctrl+N creates a new
contact card, and in the calendar, Ctrl+N creates a new appointment.

For more information, see Chapter 4, Evolution: E-Mail and Calendaring (page 183).
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1.14 Opening or Creating Documents
with OpenOffice.org

For creating and editing documents, OpenOffice.org is installed with the GNOME
desktop. OpenOffice.org is a complete set of office tools that can both read and save
Microsoft Office file formats. OpenOffice.org has a word processor, a spreadsheet, a
database, a drawing tool, and a presentation program.

To get started, click Computer > OpenOffice.org Writer or select an OpenOffice.org
module by clicking Computer >More Applications > Office, then select the module
you want to open.

A number of sample documents and templates are included with OpenOffice.org. You
can access the templates by clickingFile >New > Templates andDocuments. In addition,
you can use wizards, which guide you through the creation of letters and other typical
documents.

For a more information, see Chapter 3, The OpenOffice.org Office Suite (page 147) or
view the help in any OpenOffice.org program.

1.15 Controlling Your Desktop’s
Power Management

GNOME Power Manager is a session daemon for the GNOME desktop that manages
the power settings for your laptop or desktop computer.

GNOME Power Manager is usually started automatically when GNOME starts, but
you can manually start GNOME Power Manager by using the following command:

gnome-power-manager --verbose --no-daemon

• Section 1.15.1, “GNOME Power Manager Notification Messages” (page 39)

• Section 1.15.2, “Viewing Power Statistics” (page 41)

• Section 1.15.3, “Modifying Power Management Preferences” (page 42)
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• Section 1.15.4, “Session and System Idle Times” (page 45)

1.15.1 GNOME Power Manager Notification
Messages

The GNOME Power Manager displays the following notifications under the specified
conditions:

• Section “AC Adapter Unplugged” (page 39)

• Section “Fully Charged” (page 39)

• Section “Power Low” (page 40)

• Section “Power Critical” (page 40)

• Section “Suspend Failure” (page 40)

AC Adapter Unplugged
Figure 1.11 GNOME Power Manager Notification When AC Adapter is Removed

You can disable this notification by changing the GConf key /apps/
gnome-power-manager/notify_ac_adapter.

Fully Charged
Figure 1.12 GNOME Power Manager Notification When Laptop Primary Battery

is Fully Charged
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You can disable this notification by changing the GConf key /apps/
gnome-power-manager/notify_fully_charged.

You will receive a repeat notification only if your battery percentage charge drops below
95% and then is again fully charged. This prevents some machines from showing un-
wanted repeat notifications if the battery is incorrectly reporting the charged status.

Power Low
When the battery is low, you will receive the following notification. You should con-
sider switching to AC power as soon as possible.

Figure 1.13 GNOME Power Manager Notification When Battery Power is Low

Power Critical
When the computer has run out of power, it will show this notification explaining what
action is required. You can change the critical low action using the preferences tool
(see Section 1.15.3, “Modifying Power Management Preferences” (page 42) for more
information).

Figure 1.14 GNOME Power Manager Notification When the System Power is
Critically Low

Suspend Failure
When a suspend failure occurs, you might receive this following warning. The most
common reason for this notification is that the current user does not have permission
to suspend or hibernate the computer.
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Figure 1.15 GNOME Power Manager Notification When Suspend Failure Occurs

1.15.2 Viewing Power Statistics
The statistics program lets you view the power consumption of your laptop hardware
in graphic form.

Figure 1.16 Power History Going From Battery Power to AC

To access the statistics graphs, click Computer >More Applications > System > Power
Statistics.

You might not see some options or graphs if your computer does not have the required
hardware. Youmight also see other hardware not shown here (for example UPS devices),
but these are treated the same way as other devices.

• Section “Change History” (page 42)
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• Section “Power History” (page 42)

• Section “Estimated Time History” (page 42)

Change History
This graph shows the percentage charge available for the composite primary battery.
If you have a main laptop battery and an auxiliary battery, only the averaged value will
be shown. A legend is not shown with this graph.

Power History
This graph shows the power history charge used by the composite primary battery. The
line represents the amount of power that is either being used to charge the batteries in
the system, or the power being used by the system from the batteries. You should see
the line go up when processor intensive tasks are performed, and go down when the
system is at idle (or when the screen is dimmed). A legend is shown with this graph
when data events have been received.

You will not receive rate data from your computer if it is not charging or discharging,
or if the computer is suspended. This is due to hardware limitations where the rate is
only sent from the battery management chip, rather than the power management chip
on the motherboard.

Estimated Time History
This graph shows the estimated charge history for the composite primary battery. The
line represents the amount of time required until charged, or the amount of time until
discharge. This line should go proportionally up when the power decreases and down
when the rate increases. A legend is shown with this graph when data events have been
received.

1.15.3 Modifying Power Management
Preferences

The Power Management Preferences dialog box lets you control the LCD brightness
when your system is on AC or battery power, the idle time for the screen power-down
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and suspend action, the actions to perform when the laptop lid is closed, and the notifi-
cation area icon policy.

To access Power Management Preferences, click Computer >More Applications >
System > Power Management.

• Section “On AC Power Preferences” (page 43)

• Section “On Battery Power Preferences” (page 44)

• Section “General Preferences” (page 44)

On AC Power Preferences
Use the options on the On AC Power dialog box to automatically put your computer
to sleep when it has been inactive for a specified amount of time.When your computer
is asleep, it is turned on but in a low power mode. It takes less time for a computer to
wake up from sleep than it does for the computer to start up after being turned off.

You can also set only the display to sleep. If your computer is in the middle of a task
(for example, burning a DVD) that you want to finish while you are away, set only the
display to sleep.

Figure 1.17 GNOME Power Manager On AC Power Preferences
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On Battery Power Preferences
Use the options on the On Batter Power dialog box to automatically put your computer
to sleep when it has been inactive for a specified amount of time, to specify what happens
when you laptop lid closed, and what happens when battery power is critically low.

When your computer is asleep, it is turned on but in a low power mode. It takes less
time for a computer to wake up from sleep than it does for the computer to start up after
being turned off.

You can also set only the display to sleep. If your computer is in the middle of a task
(for example, burning a DVD) that you want to finish while you are away, set only the
display to sleep.

Figure 1.18 GNOME Power Manager On Battery Power Preferences

General Preferences
Use the options on the General Power Management Preference dialog box to configure
miscellaneous options related to GNOMEPowerManager’s behavior, such as the actions
to perform when the power or suspend buttons are pressed, if an icon is displayed in
the Notification area, and if sound is used to notify you in the event on an error.
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Figure 1.19 GNOME Power Manager General Preferences

1.15.4 Session and System Idle Times
gnome-screensaver is a session daemon that monitors user input (if the mouse
has or has not been moved, and if the keyboard has or has not been pressed), then starts
a timeout. When the value of this timeout reaches the value set in Screensaver Prefer-
ences (using the Regard this computer as idle after option), then the login is marked
as “session idle.” At this point, GNOME Power Manager performs the session idle ac-
tions, such as enabling low-power mode, and lowering the laptop panel brightness.
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Figure 1.20 Changing the Session Idle Timeout in Screensaver Preferences

As soon as the session is marked idle, GNOME Power Manager starts it's own system
timer. When the timeout set in GNOME Power Manager Preferences is reached, and
the CPU load is idle, then the idle action is performed (such as turning off the screen,
suspending, or hibernating the computer).

To make this clearer, the sliders in GNOME Power Manager Preferences are set to start
at the value of the session-timeout + 1 minute, as GNOME PowerManager Preferences
cannot logically trigger before the session is marked as idle. If you adjust the value of
the session idle timeout in Screensaver Preferences, the start time of the sliders in
GNOME Power Manager Preferences will change accordingly.

For more information, see Section 2.2.7, “Configuring the Screen Saver” (page 119).

1.16 Creating, Displaying, and
Decompressing Archives

You can use the Archive Manager application (also known as File Roller) to create,
view, modify, or unpack an archive. An archive is a file that acts as a container for
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other files. An archive can contain many files, folders, and subfolders, usually in com-
pressed form. Archive Manager application supports common formats, such as zip,
tar.gz, tar.bz2, lzh, and rar. You can use Archive Manager to create, open,
and extract a compressed non-archive file.

To start ArchiveManager, clickComputer >More Applications >Utilities > File Roller.
If you already have a compressed file, double-click the filename in the Nautilus file
manager to view the contents of the archive in Archive Manager.

Figure 1.21 Archive Manager

• Section 1.16.1, “Opening an Archive” (page 47)

• Section 1.16.2, “Creating Archives” (page 48)

• Section 1.16.3, “Extracting Files From an Archive” (page 49)

1.16.1 Opening an Archive
1 In Archive Manager, click Archive > Open.

2 Select the archive you want to open.

3 Click Open.

Archive Manager automatically determines the archive type, and displays the
following:
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• The archive name in the window titlebar.

• The archive contents in the display area.

• The total number of files in the archive, and the size of the archive when
uncompressed, in the statusbar.

To open another archive, click Archive > Open again. Archive Manager opens
each archive in a new window. To open another archive in the same window,
you must first click Archive > Close to close the current archive, then click
Archive > Open.

If you try to open an archive that was created in a format that Archive Manager
does not recognize, the application displays an error message.

1.16.2 Creating Archives
1 In Archive Manager, click Archive > New.

2 Specify the name and location of the new archive.

3 Select an archive type from the Archive type drop-down list.

4 Click New.

Archive Manager creates an empty archive, but does not yet write the archive to
disk. ArchiveManager writes a new archive to disk only when the archive contains
at least one file. If you create a new archive and quit Archive Manager before
you add any files to the archive, Archive Manager deletes the archive.

5 Add files and folders to the new archive:

5a Click Edit > Add Files or Edit > Add a Folder, then select the files or folders
you want to add.

You cannot add folders to the archive with the Add Files dialog box. Use
the Add a Folder dialog box.

5b Click Add.
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Archive Manager adds the files to the current folder in the archive.

You can also add files to an archive in a file manager window without opening Archive
Manager. See Section 1.5.2, “Archiving Folders” (page 20) for more information.

1.16.3 Extracting Files From an Archive
1 In Archive Manager, select the files that you want to extract.

2 Click Archive > Extract.

3 Specify the folder where Archive Manager will extracts the files.

4 Choose from the following extract options:

DescriptionOption

Extracts all files from the archive.All files

Extracts the selected files from the archive.Selected files

Extracts from the archive all files that match the
specified pattern.

Files

Reconstructs the folder structure when extracting
the specified files.

Re-create folders

For example, you specify /tmp in the Filename
text box and choose to extract all files. The archive
contains a subfolder called doc. If you select the
Re-create folders option, ArchiveManager extracts
the contents of the subfolder to /tmp/doc. If you
do not select the Re-create folders option, Archive
Manager does not create any subfolders. Instead,
Archive Manager extracts all files from the
archive, including files from subfolders, to /tmp.
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DescriptionOption

Overwrites any files in the destination folder that
have the same name as the specified files.

Overwrite existing files

If you do not select this option, Archive Manager
does not extract the specified file if an existing file
with the same name already exists in the destina-
tion folder.

Extracts the specified file only if the destination
folder does not contain the specified file, or if the

Do not extract older files

destination folder contains an older version of the
specified file. ArchiveManager uses the modifica-
tion date to determine which file is the most recent.
If the version of the file in the archive is older,
Archive Manager does not extract the specified
file to the destination folder.

This option is only available if theOverwrite exist-
ing files option is selected.

This option is available only if the archive type
supports encryption. Currently, only .zip and
.arj archives support encryption.

Password

If the archive contains encrypted files, enter the
required password in thePassword field to decrypt
the specified files during the extraction process.
The required password is the encryption password
that was specified when the archive was created.

Displays the contents of the destination folder in
a file manager window after the extraction of the
specified files is completed.

Open destination folder
after extraction

5 Click Extract.
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If all of the files in the archive are protected by a password, and you have not
specified the password, Archive Manager displays an error dialog.

If some but not all of the files in the archive are protected by a password, and
you have not specified the password, Archive Manager does not display an error
dialog. However, ArchiveManager extracts only the unprotected files to the new
archive.

To extract an archived file in a file manager window without opening Archive
Manager, right-click the file, then select Extract Here.

The Extract operation extracts a copy of the specified files from the archive. The
extracted files have the same permissions and modification date as the original
files that were added to the archive.

The Extract operation does not change the contents of the archive.

1.17 Taking Screen Shots
You can take a snapshot of your screen or an individual application window using any
of the following methods:

• From any panel

You can add the Take Screenshot button to any panel. For information on how to
do this, see Section 1.3.4, “Adding Applets and Applications to the Panel” (page 12).
After you have added the button, click the Take Screenshot button to take a snapshot
of the entire desktop.

• Use shortcut keys

Press the Print Screen button to take a screen shot of the entire desktop. Press
Alt+Print Screen to take a screen shot of the currently active window or dialog box.

• From the Application Browser

Click Computer >More Applications > System > Take Screenshot.

• From a terminal
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You can use the gnome-panel-screenshot command to take a screen shot.
This command takes a screen shot of the entire screen, then displays the Save
Screenshot dialog box, which you can use to save the screen shot.

You can use the following options with the gnome-panel-screenshot
command:

--window: Takes a screen shot of the currently active window.

--delay=seconds: Takes a screen shot after the specified number of seconds,
then displays the Save Screenshot dialog box.

When you take a screen shot, the Save Screenshot dialog box opens. To save the screen
shot as an image file, enter the filename for the screen shot and choose a location from
the drop-down list.

Figure 1.22 Save Screenshot Dialog Box

You can also use The GIMP to take screen shots. In The GIMP, click File > Acquire
> Screen Shot, select a Single Window or the Whole Screen, then click Grab.

1.18 Viewing PDF Files
Documents that need to be shared or printed across platforms can be saved as PDF
(Portable Document Format) files. openSUSE ships with the Evince PDF Viewer.
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Figure 1.23 Evince PDF Viewer

To open Evince, double-click a PDF file in a file manger window (or Web site), or
press Alt + F2, type evince, then press Enter.

To view a PDF file in Evince, click File > Open, locate the desired PDF file, then click
Open.

Use the navigation icons at the top of the window to navigate through the document.
If your PDF document provides bookmarks, you can access them in the left panel of
the viewer.

1.19 Controlling Sound
YaST automatically identifies and configures the sound cards in your computer. You
can also use the YaST Hardware module to configure your sound card manually. When
your sound card has been configured, you can control the volume and balance of the
sound with the GNOME Volume Control mixer.
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If the mixer icon (a loudspeaker symbol) is not visible in the panel on your desktop,
press Alt+F2 and enter gnome-volume-control, or clickComputer >More Appli-
cations >Multimedia > Volume Control.

Figure 1.24 GNOME Volume Control Dialog Box

The GNOME Volume Control dialog box contains the following elements:

Menubar: The items on the menubar contain all of the commands that you need to
work with the GNOME Volume Control.

Display area: The display area contains the channel faders and associated options
for several mixers, which enable you to control the volume on those mixers.

NOTE

GNOME Volume Control populates the display area dynamically, based on the
functionality supported by your sound card. The mixers displayed in your
GNOME Volume Control window might be different to those shown in Fig-
ure 1.24, “GNOME Volume Control Dialog Box” (page 54).

To increase the volume, slide the fader up. To decrease the volume, slide the fader
down. To lock the left and right mixer channels together, select the Lock option for that
mixer.When you lock the mixer channels, GNOMEVolume Control synchronizes both
faders. To silence a mixer, select theMute option for that mixer. When you adjust the
fader of a muted channel, GNOME Volume Control deselects the Mute option for that
mixer.
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Any mixer that has a Rec option can be a recording source. To specify the current
recording source, select the Rec option for that mixer.

1.20 Using the Fingerprint Reader
With the ThinkFinger driver, openSUSE® supports the fingerprint reader by UPEK/SGS
ThomsonMicroelectronics included with some IBM and Lenovo ThinkPads. The same
fingerprint reader can also be found in other laptops and either as a stand-alone device
or built into someUSB keyboards. For more details, refer to http://thinkfinger
.svn.sourceforge.net/viewvc/*checkout*/thinkfinger/README
.in. After registering their fingerprint, users can log in to the system either by swiping
a finger on the fingerprint reader or by typing in a password.

If the hardware check detects the fingerprint reader integrated with your laptop (or
connected to your system), the packageslibthinkfinger andpam_thinkfinger
are automatically installed. Use the command line tool tf-tool to register or verify
a fingerprint for various users. root permission is required for this. The PAMmodule
pam_thinkfinger supports user authentication by fingerprint for the following
applications and actions (although you might not be prompted to swipe your finger in
all cases):

• Logging in to GDM or a login shell

• Unlocking your screen on the GNOME desktop

• Starting YaST and the YaST modules in the GNOME control center

• Starting an application with root permission: sudo or gnomesu

• Changing to a different user identity with su or su - username

1.20.1 Registering a Fingerprint
Fingerprints can either be registered with YaST or from the command line. This section
contains instructions on registering fingerprints from the command line. Currently,
only one fingerprint per user can be registered.

For more detailed information about configuring and using fingerprint authentication,
see Using_Fingerprint_Authentication [http://en.opensuse.org/].
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1 Open a shell and log in as root.

2 Run tf-tool --help to view the available options.

3 To register a fingerprint for a certain user, enter

tf-tool --add-user login

tf-tool prompts the user to swipe a finger until three readable fingerprints
have been gathered. The user's fingerprint data is then stored to /etc/pam
_thinkfinger/login.bir.

4 If you want to use fingerprint authentication for starting YaST or the YaST
modules in the GNOME control center, register a fingerprint for root, too.

5 To verify an existing fingerprint for a certain user, enter

tf-tool --verify-user login

6 Let the user swipe a finger. tf-tool compares the fingerprint to the print stored
for this user and provides a message if the fingerprints match.

As soon as the user's fingerprint has been successfully registered, the user can choose
to authenticate with either fingerprint or password.

To remove a user's fingerprint, delete the appropriate fingerprint file for this user:
/etc/pam_thinkfinger/login.bir.

With tf-tool --acquire you can do a test run with tf-tool. The fingerprint
is stored as /tmp/test.bir and can be verified with tf-tool --verify.

1.20.2 For More Information
• Find the project home page at http://thinkfinger.sourceforge.net/

• For more technical details, refer to /usr/share/doc/packages/
libthinkfinger/README in your installed system.

• There are also man pages available for pam_thinkfinger and tf-tool.
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1.21 Obtaining Software Updates
When you connect to the Internet, the openSUSEUpdater automatically checks whether
software updates for you system are available. An openSUSE Updater applet in the
system tray of you panel informs you about the availability of updates and lets you
easily install them with just a few clicks. The applet icon changes color and appearance
depending on the availability of updates for your system.

For detailed information on how to install software updates with openSUSE Updater
and how to configure openSUSE Updater, refer to the chapter about installing and re-
moving software in Start-Up, available at http://www.novell.com/
documentation/opensuse103/.

1.22 For More Information
Along with the applications described in this chapter for getting started, GNOME can
run a lot of other applications. Find detailed information about many important applica-
tions in the other parts of this manual.

To learn more about GNOME and GNOME applications, see http://www.gnome
.org and http://gnomefiles.org/ [http://gnomefiles.org].

To report bugs or add feature requests, go to http://bugzilla.gnome.org/ [http://
bugzilla.gnome.org].
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2Customizing Your Settings
You can change the way the GNOME desktop looks and behaves to suit your own
personal tastes and needs. Some of the settings you might want to change include:

• Keyboard and mouse configuration (see Section 2.1.4, “Modifying Keyboard
Preferences” (page 62) and Section 2.1.6, “Configuring the Mouse” (page 69))

• Desktop background (see Section “Changing the Desktop Background” (page 79))

• Screen saver (see Section 2.2.7, “Configuring the Screen Saver” (page 119))

• Password (see Section 2.3.3, “Changing Your Password” (page 125))

• Sounds (see Section 2.4.10, “Setting Sound Preferences” (page 138))

These settings and others can be changed in the Control Center. To access the Control
Center, click Computer > Control Center. The Control Center is divided into the fol-
lowing four categories:

• Section 2.1, “Hardware” (page 60)

• Section 2.2, “Look and Feel” (page 74)

• Section 2.3, “Personal” (page 121)

• Section 2.4, “System” (page 126)
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Figure 2.1 GNOME Control Center

Some settings require that you use the YaSTControl Center. These administrator settings
includes most of the hardware, the graphical user interface, Internet access, security
settings, user administration, software installation, and system updates and information.
You need the root password to access the YaST Control Center.

For information on configuring administrator settings, refer to the Installation and Setup
part of Start-Up, available at http://www.novell.com/documentation/
opensuse103/.

2.1 Hardware
Hardware settings include the following:

• Section 2.1.1, “Configuring Bluetooth Services” (page 61)

• Section 2.1.2, “Configuring Your DSL Connection” (page 61)
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• Section 2.1.3, “Configuring Your Graphics Card and Monitor” (page 62)

• Section 2.1.4, “Modifying Keyboard Preferences” (page 62)

• Section 2.1.5, “Configuring a Modem” (page 68)

• Section 2.1.6, “Configuring the Mouse” (page 69)

• Section 2.1.7, “Configuring a Network Card” (page 71)

• Section 2.1.8, “Installing and Configuring Printers” (page 71)

• Section 2.1.9, “Configuring Removable Drives and Media” (page 72)

• Section 2.1.10, “Configuring a Scanner” (page 73)

• Section 2.1.11, “Specifying Screen Resolution Settings” (page 73)

• Section 2.1.12, “Configuring a Touchpad” (page 74)

2.1.1 Configuring Bluetooth Services
Bluetooth services enable you to connect wireless devices such as mobile phones and
personal data assistants (PDAs) to your computer. Bluetooth wireless support includes
automatic recognition of Bluetooth-enabled devices via the YaST central configuration
and administration tool. Click Computer > Control Center > Hardware > Bluetooth,
then set the configuration options that are appropriate for your device.

NOTE

Root privileges are required for configuring Bluetooth services.

2.1.2 Configuring Your DSL Connection
If you connect to a network over a DSL Connection, use this option to configure your
connection. The DSL connection is configured in YaST.
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NOTE

Root privileges are required for configuring your DSL Connection.

1 Click Computer > Control Center > Hardware > DSL.

2 Enter the root password.

YaST opens.

3 Follow the instructions in YaST to configure DSL.

2.1.3 Configuring Your Graphics Card and
Monitor

Your graphics card was configured for your monitor during installation. If you ever
need to change these settings, clickComputer >Control Center >Hardware >Graphics
Card and Monitor, then set the appropriate options for your monitor.

NOTE

Graphics card configuration is done in YaST2 and requires root privileges.

2.1.4 Modifying Keyboard Preferences
Use the Keyboard Preferences tool to modify the autorepeat preferences for your key-
board and to configure typing break settings.

Click Computer > Control Center > Hardware > Keyboard.

You can set the following preferences:

• Keyboard

• Layouts

• Layout Options
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• Typing Break

Configuring Keyboard Preferences
Use the Keyboard tabbed page to set general keyboard preferences.

Figure 2.2 Keyboard Preferences Dialog—Keyboard Page

You can modify any of the following keyboard preferences:

Table 2.1 Keyboard Preferences

DescriptionOption

Enables keyboard repeat. The action associated with
a key is performed repeatedly when you press and

Key Presses Repeat When
Key is Held Down

hold that key. For example, if you press and hold a
character key, the character is typed repeatedly.

Use theDelay option to select the delay from the time
you press a key to the time that the action repeats.

Use the Speed option to set the speed at which the
action is repeated.

Customizing Your Settings 63



DescriptionOption

Lets the cursor blink in fields and text boxes.Cursor Blinks in Text Boxes
and Fields

Use the slider to specify the speed at which the cursor
blinks.

The test area is an interactive interface that lets you
see how the keyboard settings affect the display as

Type to Test Settings

you type. Type text in the test area to test the effect
of your settings.

Click the Accessibility button to start the Keyboard accessibility preference tool.

Configuring Keyboard Layout Preferences
Use the Layouts tabbed page to set your keyboard layout.

Figure 2.3 Keyboard Preferences Dialog—Layouts Page

Select your keyboard model from the drop-down list, then use the navigational buttons
to add or remove the selected layout to or from the list of available layouts.
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You can select different layouts to suit different locales.

Click the Accessibility button to start the Keyboard accessibility preference tool.

Configuring Keyboard Layout Options
Use the Layout Options tabbed page to set your keyboard layout options. These options
determine the behavior of certain keys and other keyboard settings.

Figure 2.4 Keyboard Preferences Dialog—Layout Options Page

Select an option to open a submenu for that option, then select the desired settings. For
most users, there is no need to change these settings.

Table 2.2 Keyboard Layout Options

DescriptionLayout Option

If supported by your keyboard, add the Euro sign
as the third-level character on the E, 5, or 2 key.

Adding the EuroSign to certain
keys

Assign the behavior of the Unix Super, Meta, and
Hyper modifier keys to the Alt andWindows keys.

Alt/Win key behavior
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DescriptionLayout Option

Choose from a number of that specify the behavior
of the Caps Lock key.

CapsLock key behavior

Specifies the key to be used as the Compose key.
Use the Compose key to combine two keystrokes

Compose key position

to make one character, such as an accented charac-
ter that is not on your keyboard layout.

Specify the key that acts as the Ctrl key. This is
useful on older keyboards that do not have a Ctrl
key.

Ctrl key position

Specify whether to use the Kana lock key and the
NICOLA-F style backspace.

Japanese keyboard options

Specify the keys used to switch keyboard layouts.Layout switching

Specify whether shift works with the Num Lock
key on a numerical keypad as it does onWindows.

Miscellaneous compatibility op-
tions

If not selected, use shift with the numerical keypad
to obtain the reverse of the current behavior. For
example, when Num Lock is off, the 8 key acts as
an up arrow. Press Shift+8 to type the number 8.

Also, specify whether certain keyboard shutcuts
are processed by the X windowing system rather
than by GNOME.

Specify the layout of the numeric keypad. Most
people should use the default, but some keypads
require a non-standard layout.

Numeric keypad layout selection

If a third-level chooser is specified, you can obtain
a third character from certain keys in the sameway

Third level choosers

that using Shift with a key produces a different
key than pressing that key without shift. For exam-
ple, if you add the Euro sign to the E key and set
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DescriptionLayout Option

the left Windows key as the third-level chooser,
then pressing Left-Windows+E produces the Euro
sign.

Specify that one of the keyboard lights indicates
when you are using an alternative keyboard layout.

Use keyboard LED to show alter-
native group

That light will no longer indicate its standard
function.

Configure how and at what level a non-breakable
space is entered using the spacebar.

Using space key to input non-
breakable space character

Click the Accessibility button to start the Keyboard accessibility preference tool. See
Section 2.3.1, “Configuring Keyboard Accessibility Settings” (page 121) for more infor-
mation.

Configuring Typing Break Preferences
Use the Typing Break tabbed page to set typing break preferences.

Figure 2.5 Keyboard Preferences Dialog—Typing Break Page
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You can modify any of the following typing break preferences:

Table 2.3 Typing Break Preferences

DescriptionOption

Locks the screen when you are due a typing break.Lock Screen to Enforce Typing
Break

Lets you specify how long you can work before a
typing break occurs.

Work Interval Lasts

Lets you specify the length of your typing breaks.Break Interval Lasts

Lets you postpone typing breaks.Allow Postponing of Breaks

Click the Accessibility button to start the Keyboard accessibility preference tool. See
Section 2.3.1, “Configuring Keyboard Accessibility Settings” (page 121) for more infor-
mation.

2.1.5 Configuring a Modem
If you connect to a network over a modem, use this option to configure your modem.
The modem is configured in YaST.

NOTE

Root privileges are required for configuring your modem.

1 Click Computer > Control Center > Hardware >Modem.

2 Enter the root password.

YaST opens.

3 Follow the instructions in YaST to configure the modem.
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2.1.6 Configuring the Mouse
Use the Mouse Preference tool to configure your mouse for right-hand use or for left-
hand use. You can also specify the speed and sensitivity of mouse movement.

Click Computer > Control Center > Hardware >Mouse.

You can customize the settings for the Mouse Preference tool in the following areas:

• Buttons

• Motion

Configuring Button Preferences
Use the Buttons tabbed page to specify whether the mouse buttons are configured for
left-hand use. You can also specify the delay between clicks for a double-click.

Figure 2.6 Mouse Preferences Dialog—Buttons Page

The following table lists the mouse button preferences you can modify.
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Table 2.4 Mouse Button Preferences

DescriptionOption

Configures your mouse for left-hand use, swapping the functions
of the left mouse button.

Left-handed
Mouse

Use the slider to specify the amount of time that can pass between
clicks when you double-click. If the interval between the first

Double-Click
Timeout

and second clicks exceeds the time that is specified here, the ac-
tion is not interpreted as a double-click.

Configuring Motion Preferences
Use the Motion tabbed page to set your preferences for mouse movement.

Figure 2.7 Mouse Preferences Dialog—Motion Page

The following table lists the mouse motion preferences you can modify.

Table 2.5 Mouse Motion Preferences

DescriptionOption

Use the slider to specify the speed at which your mouse pointer
moves on your screen when you move your mouse.

Acceleration
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DescriptionOption

Use the slider to specify how sensitive your mouse pointer is to
movements of your mouse.

Sensitivity

Use the slider to specify the distance that you must move an item
before the move action is interpreted as a drag and drop action.

Threshold

2.1.7 Configuring a Network Card
If you connect to a network over a network card, use this option to configure your
connection. The network card is configured in YaST.

NOTE

Root privileges are required for configuring your network card.

1 Click Computer > Control Center > Hardware > Network Card.

2 Enter the root password.

YaST opens.

3 Follow the instructions in YaST to configure the network card.

2.1.8 Installing and Configuring Printers
Use the Printers module to install and configure printers.

To start the Printers module, click Computer > Control Center > Hardware > Printers.
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Figure 2.8 Printers Dialog

2.1.9 Configuring Removable Drives and
Media

You can use a wide variety of removable drives and media, including storage devices,
cameras, scanners, and more. The configurations for many of these devices are set up
automatically during installation. To change the configuration for a drive or other re-
movable device, click Computer > Control Center > Hardware > Removable Drives
and Media.

Some of the possible configuration settings include:

• What happens when a blank CD is inserted in the CD drive

• What happens when an audio CD is inserted in the drive

• Whether images are automatically imported from a digital camera when it is attached
to the computer

• Whether removable storage devices are mounted when they are plugged in to the
computer

• Whether PDAs are automatically synced when attached to the computer

In general, you do not need to change the settings that are already configured unless
you want to change the behavior when a device is connected or if you want to connect
a new device that is not yet configured. If you attach a device for the first time and it
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behaves in an unexpected or undesired way, check the Removable Drives and Media
settings.

2.1.10 Configuring a Scanner
The Scanner configuration enables you to attach and configure a scanner, or to remove
an already-attached scanner.

NOTE

Scanner configuration is done in YaST2 and requires root privileges.

To open YaST2 and configure a scanner, click Computer > Control Center >Hardware
> Scanner. Refer to the instructions on the Scanner Configuration screen for information
about the available options.

2.1.11 Specifying Screen Resolution Settings
Use this module to specify the resolution settings for your screen, including Resolution
and Refresh Rate.

Click Computer > Control Center > Hardware > Screen Resolution.

Figure 2.9 Screen Resolution Preferences Dialog
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The following table lists the screen resolution preferences you can modify.

Table 2.6 Screen Resolution Preferences

DescriptionOption

Select the resolution (in pixels) to use for the
screen.

Resolution

Select the refresh rate to use for the screen.Refresh Rate

Select the rotation mode for your screen if you use
a nonstandard monitor.

Rotation

Makes the screen resolution settings the default
settings only for the computer that you are logged
in to.

Make Default for This Computer
Only

If you cannot find a setting you want, you might need to use the Administrator Settings
to reconfigure your graphics card and monitor settings. See Setting Up Graphics Card
and Monitor [http://www.novell.com/documentation/opensuse103/
opensuse103_startup/data/cha_y2_hw_graph.html] in the openSUSE
103 Start-Up Guide for more information.

2.1.12 Configuring a Touchpad
Use this module to configure the behavior of a touchpad. This module is only available
on computers containing touchpads, such as laptops. In most cases, the default behavior
should remain unchanged. Click Computer > Control Center > Hardware > Touchpad
to start the Touchpad module.

2.2 Look and Feel
Look and Feel settings include the following:

• Section 2.2.1, “Customizing the Desktop Appearance” (page 75)
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• Section 2.2.2, “Configuring Desktop Effects” (page 84)

• Section 2.2.3, “File Management Preferences” (page 99)

• Section 2.2.4, “Locking Desktop Functions” (page 107)

• Section 2.2.5, “Customizing the Main Menu” (page 112)

• Section 2.2.6, “Improving Access for the Visually Impaired” (page 118)

• Section 2.2.7, “Configuring the Screen Saver” (page 119)

• Section 2.2.8, “Customizing Window Behavior” (page 120)

2.2.1 Customizing the Desktop Appearance
Use the Appearance module to customize the look of the desktop. With this module
you can change the desktop theme, fonts, and background, as well as changing the look
of menus and the main toolbar.

• Section “Choosing a Theme” (page 75)

• Section “Changing the Desktop Background” (page 79)

• Section “Configuring Fonts” (page 81)

• Section “Configuring Menus and Toolbars” (page 83)

Choosing a Theme
A theme is a group of coordinated settings that specifies the visual appearance of a part
of the desktop. You can choose themes to change the appearance of the desktop. Use
the Theme Preferences tool to select from a list of preinstalled themes. The list of
available themes includes several themes for users with accessibility requirements.

To choose a theme, click Computer > Control Center > Look and Feel > Appearance,
then click the Theme tab.

The color settings for the desktop and applications are controlled using themes. You
can choose from a variety of preinstalled themes. Selecting a style from the list overview

Customizing Your Settings 75



applies it automatically. Customize opens another dialog where you can customize the
style of single desktop elements, like window content, window borders, pointers, and
icons. Making changes and leaving the dialog by clicking Close switches the theme to
Custom Theme. Click Save As to save your modified theme under a custom name. The
Internet and other sources provide many additional themes for GNOME as .tar.gz
files. Install these with the Install theme.

• Section “Creating a Custom Theme” (page 76)

• Section “Installing a New Theme” (page 78)

• Section “Deleting a Theme” (page 78)

Creating a Custom Theme

The themes that are listed in the Theme Preferences tool are different combinations of
controls options, window frame options, and icon options. You can create a custom
theme that uses different combinations of options.

1 Click Computer > Control Center > Look and Feel > Appearance, then click the
Theme tab.

2 Select a theme from the list of themes, then click Customize.

The following settings can be customized:

• Controls

The controls setting for a theme determines the visual appearance of windows,
panels, and applets. It also determines the visual appearance of the GNOME-
compliant interface items that appear on windows, panels, and applets, such
as menus, icons, and buttons. Some of the controls setting options that are
available are designed for special accessibility needs. You can select an option
for the controls setting in the Controls tabbed page of the Theme Details
tool.

• Colors

The color settings determine the colors of various screen elements. Set the
colors to provide an appearance that most appeals to you.
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• Window Border

The window border setting for a theme determines the appearance of the
frames around windows only. You can select an option for the window frame
setting in the Window Border tabbed page of the Theme Details tool.

• Icons

The icon setting for a theme determines the appearance of the icons on panels
and the desktop background. You can select an option for the icon setting in
the Icons tabbed page of the Theme Details tool.

• Pointer

You can set the appearance and size of your mouse pointer so it is appealing
and easy to see with your chosen theme.

3 Select the controls option that you want to use in the custom theme from the list
in the Controls tab.

4 Click the Colors tab, then select the colors you want to use for the available in-
terface elements.

5 Click theWindow Border tab, then select the window frame option that you want
to use in the custom theme.

6 Click the Icons tab, then select the icons option that you want to use in the custom
theme.

7 Click the Pointer tab, then select the desired mouse pointer.

The following table lists the mouse pointer preferences you can modify.

Table 2.7 Pointer Options

DescriptionOption

Displays the available cursor themes.Cursor Theme
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DescriptionOption

Enables a mouse pointer animation when
you press and release Ctrl. This feature can
help you locate the mouse pointer.

Highlight the PointerWhen You
Press Ctrl

8 Click Close > Save As.

The Save Theme to Disk dialog is displayed.

9 Type a name and a short description for the custom theme in the dialog, then
click Save.

The custom theme now appears in your list of available themes.

Installing a New Theme

You can add a theme to the list of available themes. The new theme must be an archive
file that is tarred and zipped (a .tar.gz file).

1 Click Computer > Control Center > Look and Feel > Appearance, then click the
Theme tab.

2 Click Install.

3 Browse to the location of the theme archive file, select the archive, then click
Open.

4 Click Apply New Theme to apply the theme.

or

Click Keep Current Theme to continue using the currently applied theme.

Deleting a Theme

You can delete controls options, window frame options, or icons options.
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1 Click Computer > Control Center > Look and Feel > Appearance, then click the
Theme tab.

2 Select the theme you want to delete.

3 Click Delete.

Changing the Desktop Background
The desktop background is the image or color that is applied to your desktop. You can
customize the desktop background in the following ways:

• Select an image for the desktop background. The image is superimposed on the
desktop background color. The desktop background color is visible if you select a
transparent image or if the image does not cover the entire desktop.

• Select a color for the desktop background. You can select a solid color or create a
gradient effect with two colors. A gradient effect is a visual effect where one color
blends gradually into another color.

To change the desktop preferences:

1 Click Computer > Control Center > Look and Feel > Appearance, then click the
Background tab.

2 Set the background preferences the way that you want them.

The following settings can be changed:

Table 2.8 Background Preferences

DescriptionOption

Displays an image of your choice on the desktop.Desktop Wallpa-
per

Determines what processing steps should be applied to the
selected image to adapt it optimally to the current screen

Style

resolution. To specify how to display the image, select one
of the following options from the Style drop-down list:
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DescriptionOption

• Centered: Displays the image in the middle of the
desktop.

• Fill Screen: Enlarges the image to cover the desktop
and maintains the relative dimensions of the image.

• Scaled: Enlarges the image until the image meets
the screen edges andmaintains the relative dimensions
of the image.

• Tiled: Repeats the image over the entire screen.

Opens a dialog where you can select an image file to use
as the background picture.

Add Wallpaper

Removes a Desktop Wallpaper after you select it and then
click Remove.

Remove

Lets you specify a color scheme using the options in the
Desktop Color drop-down list and the color selector but-

Desktop Colors

tons. You can specify a color scheme using any of the
following options:

• Solid Color specifies a single color for the desktop
background.

To select a color, click Color. In the Pick a Color dia-
log, select a color and then click OK

• Horizontal Gradient creates a gradient effect from the
left screen edge to the right screen edge.

Click Left Color to display the Pick a Color dialog,
then select the color that you want to appear at the left
edge.
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DescriptionOption

Click Right Color, then select the color that you want
to appear at the right edge.

• Vertical Gradient creates a gradient effect from the
top screen edge to the bottom screen edge.

Click Top Color to display the Pick a Color dialog,
then select the color that you want to appear at the top
edge.

ClickBottomColor, then select the color that you want
to appear at the bottom edge.

3 When you are satisfied with your choices, click Close.

Your desktop immediately changes to show the new settings.

Configuring Fonts
You can select the fonts to use in your applications, windows, terminals, and desktop.
To set the Font preferences, click Computer > Control Center > Look and Feel > Ap-
pearance, then click the Fonts tab.
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Figure 2.10 Font Preferences Dialog

The upper part of the dialog shows the fonts selected for applications, documents, the
desktop, window titles, and a fixed-width font for terminals. Click one of the buttons
to open a selection dialog where you can set the font family, style, and size.

To specify how to render fonts on your screen, select one of the following options:

• Monochrome: Renders fonts in black and white only. The edges of characters
might appear jagged in some cases because the characters are not antialiased. An-
tialiasing is an effect that is applied to the edges of characters to make the characters
look smoother.

• Best Shapes: Antialiases fonts where possible. Use this option for standard
Cathode Ray Tube (CRT) monitors.

• Best Contrast: Adjusts fonts to give the sharpest possible contrast and antialiases
fonts so that characters have smooth edges. This option might enhance the accessi-
bility of the GNOME desktop to users with visual impairments.

• Subpixel Smoothing (LCDs): Uses techniques that exploit the shape of individ-
ual Liquid Crystal Display (LCD) pixels to render fonts smoothly. Use this option
for LCD or flat-screen displays.

Click Details to specify further details of how to render fonts on your screen:
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• Resolution (Dots Per Inch): Use the spin box to specify the resolution to use
when your screen renders fonts.

• Smoothing: Select one of the options to specify how to antialias fonts.

• Hinting: Select one of the options to specify how to apply hinting to improves
the quality of fonts at small sizes and at low screen resolutions.

• Subpixel Order: Select one of the options to specify the subpixel color order
for your fonts. Use this option for LCD or flat-screen displays.

Configuring Menus and Toolbars
You can configure the appearance and behavior of menus and toolbars. ClickComputer
> Control Center > Look and Feel > Appearance, then click the Interface tab.

Showing Icons in Menus

If you want icons to appear in menus, select Show icons in menus. Not all menu items
have icons.

Defining New Keyboard Shortcuts

If you want to be able to define new keyboard shortcuts for menu items, select Editable
menu shortcut keys. When this option is enabled, you can change an application shortcut
key by placing the mouse pointer over the menu item you want to change, then pressing
the new key combination. To remove a shortcut key combination, place the mouse
pointer over the menu item, then press Backspace or Delete.

IMPORTANT

If you assign a new keyboard combination, you are not warned if you select a
combination that was previously assigned to something else. The previous as-
signment is removed and replaced by the new one. There is no automatic way
to restore the original, default keyboard shortcut for a command. You must
manually reassign the keyboard shortcut.
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This feature does not maintain shortcuts that are normally assigned to all ap-
plications, such as Ctrl+C for copy. This might lead to inconsistencies in your
GNOME applications.

Configuring Placement of Toolbar Button Labels

Select one of the following options to specify how toolbar button labels display in your
GNOME-compliant applications:

Text below icons: Displays icon labels below the icons for each button.

Text beside icons: Displays icons on the toolbar, with text beside the most important
icons.

Icons only: Displays icons only, without any text labels.

Text only: Displays text labels on each button, without icons.

A preview of the selected option appears in theMenu and Toolbar Preferences dialog.

2.2.2 Configuring Desktop Effects
Xgl is an Xserver architecture that lets you turn your desktop into a rotating 3-D cube,
tile windows so they don’t overlap, and switch tasks while viewing live thumbnails.
You can enable translucent or transparent windows, zoom in and out of the desktop
screen, and use other window effects such as shadows, fading, and transformations.
You can also configure windows to snap to other windows and screen edges when they
are moved.
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Figure 2.11 3-D Desktop

Enabling Desktop Effects
To enable Xgl, you need a graphics adapter capable of providing 3-D support, and you
also need the graphics driver that Linux uses to operate the graphics adapter. This
driver must be able to handle OpenGL (or 3-D) requests from the Linux kernel. For a
list of supported adapters, see the/etc/X11/xgl-hardware-list file that is in-
cluded with the openSUSE installation. This file tells you which graphics cards are
known to work with Xgl, which cards do not work with Xgl, and which cards might
work with Xgl but are not supported because they are either too slow or contain too
many known defects.

Your screen resolution must be within the 1024x768 to 1920x2000 range, and your
color depth must be set at 24-bit. 3-D acceleration must also be enabled. Use SaX2 to
change your graphics card and monitor properties if necessary.

To enable desktop effects:

1 Click Computer > Control Center.
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2 Click Desktop Effects in the Look and Feel group.

The Desktop Effects tool analyzes your system and tries to determine whether
or not you can run Xgl. If it finds anything wrong, it advises you on what actions
you can take. For example, youmight be advised to change your screen resolution
or color depth, or to activate 3-D acceleration. Follow the on-screen prompts to
configure your system for Xgl.

3 After your system is configured for Xgl, click Enable Desktop Effects.

4 Type the root password, then click Continue.

5 Click Log Out to log out of your session, then type your username and password
to log back in.

The default desktop effects are now enabled. For example, windows “wobble”
when they first appear and when you move them, they fade away when you close
them, and dragging a window to the far right of the screen rotates the desktop
cube. To change any of these effects, see Section “Modifying Desktop Effects”
(page 87).

You can also enable Xgl by running the following command as root:
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gnome-xgl-switch --enable-xgl

To disable Xgl, click Disable Desktop Effects in the Desktop Effects Settings dialog
box, or run the following command as root:

gnome-xgl-switch --disable-xgl

Modifying Desktop Effects
Use the Desktop Effects Settings tool to enable or disable specific desktop effects, or
to change the keystrokes or mouse actions used to control those effects.

1 Click Computer > Control Center.

2 Click Desktop Effects in the Look and Feel group.

3 Choose from the following options:

• Section “Window Effects” (page 87)

• Section “Desktop Cube” (page 89)

• Section “Other Features” (page 91)

4 When you finish making changes, click Close.

You can also use gconf-editor to change Xgl settings.

1 Click Computer >More Applications > System >GNOME Configuration Editor
or press Alt+F2 and enter gconf-editor.

2 Navigate to the apps/compiz/general and apps/compiz/plugins
registry folders and make the changes you want.

3 Click File > Quit to close the Configuration Editor.

Window Effects

Use the options on this tabbed page to specify what happens when you move windows,
how window transitions appear, and to change window opacity.
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Figure 2.12 Window Effects Tabbed Page

Moving Windows
By default, windows appear transparent when youmove them. If you want window
edges to stick (snap) to other windows and workspace edges when you hold down
the Shift key while moving the window, both theWindows wobble while they’re
being moved andWindow edges stick to other windows when you hold down “Shift”
options must be selected.

You can also choose to make windows appear distorted (wobbly) as you move or
resize them, giving the impression that the window is more fluid than rigid.

Window Transitions
These options let you add a fade-in and fade-out effect to windows and menus
when you open and close them. Windows will also shrink smoothly onto the task
bar when they are minimized and will grow smoothly back to their normal size
when they are reopened.

Translucent Windows
This option lets you use the scroll wheel to change how transparent a window ap-
pears on-screen. Select Use scroll wheel plus these modifiers to change window
opacity, then select the button or combination of buttons you want to use. Select a
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window, hold down the button or buttons you selected, then scroll the mouse wheel
up or down to change the transparency of the window.

Figure 2.13 Translucent Window

Desktop Cube

Use the options on this tabbed page to specify how many sides your desktop cube has,
which keystroke and mouse button combination you can use to drag the cube, and to
configure edge flipping.
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Figure 2.14 Desktop Cube Tabbed Page

Desktop Cube
By default, this option gives you four desktops on the faces of a virtual cube that
you can rotate to access each desktop. This provides extra space in which to arrange
open applications and windows. For example, you can put an editor on one desktop,
some shells on another, and your e-mail application and Web browser on the third
desktop. Using Ctrl+Alt+Left arrow and Ctrl+Alt+Right arrow, you can rotate the
cube to access the programs running in the selected desktop and avoid windows
piled on top of each other on one desktop.

Dragging a window to the edge of the screen rotates the cube and places the window
on the new desktop. To rotate the cube manually in 3-D, press Ctrl+Alt, left-click
the desktop, then drag themouse pointer. Ctrl+Alt+Shift+Left-arrow or Right-arrow
lets you rotate the cube while taking the currently selected window with you.

Use the options underDrag the cube with the mouse by using to change the default
keystrokes used to rotate the cube.

For information on how to add an image behind your cube, see Section “Displaying
a Skydome Image Behind the Cube ” (page 97).
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Edge Flipping
When edge flipping is enabled, the desktop cube rotates to the next face when you
bump the mouse pointer to the edge of the screen. You can choose to always enable
edge flipping or to enable edge flipping only when you drag a window or icon to
the edge of the desktop.

Use the slider bar at the bottom of the tabbed window to specify how long (in mi-
croseconds) it takes to rotate the cube after you bump the edge of the desktop with
a window or the mouse pointer.

Other Features

Use the options on this tabbed page to configure window tiling, zooming, and water
effects.

Figure 2.15 Other Features Tabbed Page

Window Picker
This option lets you tile (or scale) the windows on your desktop so that you can
see what windows you have open and select a specific one. This also provides you
with a snapshot of all applications open on your desktop. Pressing Ctrl+Alt+Up-
arrow shrinks all windows and rearranges them on the screen so that they do not
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overlap. Selecting a window with the mouse causes all windows to return to their
original size and position, with the selected window on top.

To change the keystrokes used to tile windows, click the box to the right of Acti-
vate/deactivate when I type untilNew accelerator appears. Then press the keystrokes
you want to use. The new keystrokes appear in the box.

You can also choose to tile windows by moving the mouse pointer to the top left
(default), top right, bottom left, or bottom right of the screen.

Figure 2.16 Application Tiling

Zoom
These options give you the ability to zoom in and out of areas on your screen, which
significantly improves desktop accessibility for visually impaired users or for
anyone who wants to see a part of the screen displayed in a larger size.

By default, pressing the Super key (the Windows key)+Button 3 zooms in on part
of the desktop. If you have a two-button mouse, press the Super key, then press
the left and right buttons simultaneously. You can move the mouse while holding
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those buttons down to see other parts of the screen. You can also press the Super
key and use the scroll wheel on the mouse to manually zoom in and out of the
desktop.

You can choose to deactivate any of these options, or to change the zoom keystrokes.

Water Effect
This option creates a ripple effect on your screen when you hold down the specified
key or key combination (Ctrl+Alt+Super by default) and move the mouse pointer.
You can also enable or disable a rain effect when you press Shift+F9. To change
the keystrokes used to enable and disable the rain effect, click the box to the right
of Activate/deactivate rain when I type until New accelerator appears. Then press
the keystrokes you want to use. These new keystrokes will appear in the box.

Use the slider bar at the bottom of the tabbed window to specify the intensity of
the rain effect.

Figure 2.17 Water Effect
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Xgl Shortcuts
Table 2.9, “Desktop Effects Shortcuts” (page 94) contains a list of the default keystrokes
and mouse movements you can use to perform desktop effects. To change any of these
shortcuts, see Section “Modifying Desktop Effects” (page 87).

Table 2.9 Desktop Effects Shortcuts

ShortcutEffect

Shift+F9Activate or deactivate rain effect

Ctrl+Alt+Super key (Windows key) and
move the mouse pointer

Create ripples with the mouse pointer

Ctrl+Alt+Down-arrow (use the Left- and
Right- arrows to scroll)

Panoramic view of all desktop cubes

Ctrl+Alt+Left-arrow or Right-arrow or
drag a window to the edge of the screen

Rotate desktop cube

Ctrl+Alt+left-click the desktop and drag
the mouse pointer

Rotate desktop cube manually

Ctrl+Alt+Shift+Left-arrow or Right-ar-
row

Rotate desktop cube while keeping the
current active window with you

Alt+TabSwitch windows (thumbnail view)

Ctrl+Alt+Up-arrow or move the mouse
pointer to the top-left corner of the screen

Tile windows

Left-click the window and dragWobbly window

Super key (Windows key)+Button 3Zoom once

Super key (Windows key)+scroll wheel
up

Zoom in manually
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ShortcutEffect

Super key (Windows key)+scroll wheel
down

Zoom out manually

More Desktop Effects
You can also do these things with Xgl:

• Section “Switching Tasks” (page 95)

• Section “Unfolding the Cube ” (page 96) ???

• Section “Displaying a Skydome Image Behind the Cube ” (page 97)

Switching Tasks

Press Alt+Tab to display a thumbnail view of all windows open on your desktop.While
holding the the Alt key down, press Tab to cycle through the list of windows. The cur-
rently highlighted windowwill appear in focus. Release the keys to access that window.
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Figure 2.18 Thumbnail View

Unfolding the Cube

Press Ctrl+Alt+Down-arrow to unfold the desktop cube, opening a panoramic view of
all your desktops. Your desktop cube is laid out like a filmstrip on your screen. You
can use the Left-arrow and Right-arrow to select a different screen. This is similar to
the switcher feature (Alt+Tab), but lets you view a thumbnail of your entire desktop
instead of only your active windows.
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Figure 2.19 Panoramic View of All Desktop Cubes

Displaying a Skydome Image Behind the Cube

You can add background wallpaper (also known as a skydome image) that is visible
when you rotate or unfold the desktop cube.

1 ClickComputer >More Applications > System >GNOMEConfiguration Editor,
or press Alt+F2 and enter gconf-editor.

2 Navigate to the apps/compiz/plugins/cube/screen0/options
registry folder.

3 Scroll down the list on the right side of the Configuration Editor and select sky-
dome.

4 Double-click skydome_image, then specify the path to the skydome image you
want to display behind the cube.
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Skydome imagesmust be in.png format. The suggested image sizes for skydome
images are 1024 x 1024, 1024 x 2048, 1024 x 4096, 2048 x 1024, 2048 x 2048,
2048 x 4096, 4096 x 1024, 4096 x 2048, and 4096 x 4096.

5 (Optional) Select skydome_animated to make it look like you are moving around
the cube when you use your mouse to rotate the cube.

6 Click OK.

7 Click File > Quit to close the Configuration Editor.

Figure 2.20 Skydome Image

98 GNOME User Guide



2.2.3 File Management Preferences
You can change the File Manager preferences in the Control Center by clicking Com-
puter > Control Center > Look and Feel > File Management, or from Nautilus by
clicking Edit > Preferences. The configurable preferences are organized on five tabs:

• Section “Views” (page 99)

• Section “Behavior” (page 101)

• Section “Display” (page 103)

• Section “List Columns” (page 105)

• Section “Preview” (page 105)

Views
To configure the appearance of the File Manager, click Computer > Control Center >
Look and Feel > File Management (or Edit > Preferences from Nautilus), then click
the Views tab.
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Figure 2.21 File Manager Views Dialog Box

Select from the following options:

Table 2.10 File Manager Views Options

DescriptionOptionSection

Determines whether new folders are dis-
played as icons or as a list.

View new folders usingDefault
View

Sets the order in which items are listed.
Items can be listed by name, size, type,
modification date, or emblems.

Arrange items

Places this folder at the top of the list, if
this check box is selected (the default).

Sort folder before files

Shows hidden files and backup files in
your directories. If this check box is not

Show hidden and backup
files
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DescriptionOptionSection

selected (the default), hidden and backup
files do not appear.

Sets the size of items that appear in the
File Manager.

Default zoom levelIcon View
Defaults

Displays items closer together.Use compact layout

Displays icon captions next to the icons,
rather than beneath them.

Text beside icons

Determines the size of items that appear
in the list view.

Default zoom levelList View
Defaults

When selected, displays folders in the tree
in the side pane.

Show only foldersTree View
Defaults

Behavior
To configure the behavior of the File Manager, click Computer > Control Center >
Look and Feel > File Management (or Edit > Preferences from Nautilus), then click
the Behavior tab.
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Figure 2.22 File Manager Behavior Dialog Box

Select from the following options:

Table 2.11 File Manager Behavior Options

DescriptionOption

Performs the default action for an item
when you click the item. If this option is

Single click to activate items

selected and you point to an item, the title
of the item is underlined.

Performs the default action for an item
when you double-click the item.

Double click to activate items

Opens the File Manager in Browser mode
whenever you open it.

Always open in browser windows
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DescriptionOption

Runs an executable file when you open the
file. An executable file is a text file than
can execute (that is, a shell script).

Run executable text files when they are
opened

Displays the contents of an executable file
when you open the file.

View executable text files when they are
opened

Displays a dialog when you click an exe-
cutable file. The dialog asks whether you
want to execute the file or display the file.

Ask each time

Displays a confirmation message before
the Trash is emptied or before files are
deleted.

Ask before emptying the Trash or delet-
ing files

Adds aDeletemenu item to the Editmenu
and the pop-up menu that is displayed

Include a Delete command that bypasses
Trash

when you right-click a file, folder, or
desktop object. When you select an item
and click Delete, the item is immediately
deleted from your file system.

Display
To configure the way icon captions and dates appear in the File Manager, click Com-
puter > Control Center > Look and Feel > File Management (or Edit > Preferences
from Nautilus), then click the Display tab.
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Figure 2.23 File Manager Display Dialog Box

Select from the following options:

Table 2.12 File Manager Display Options

DescriptionOption

Sets the order of information to appear
beneath icon names. You can set three

Icon Captions

information types, in the order that they
appear.

Configures the date format.Date
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List Columns
To configure the columns that appear in the File Manager, as well as the order in which
they appear, click Computer > Control Center > Look and Feel > File Management (or
Edit > Preferences from Nautilus), then click the List Columns tab.

Select the columns that you want to appear. To change the order, clickMove Up or
Move Down.

Figure 2.24 File Manager List Columns Dialog Box

Preview
To configure how file previews appear in the File Manager and whether folders show
the number of items they contain, click Computer > Control Center > Look and Feel
> File Management (or Edit > Preferences from Nautilus), then click the Preview tab:
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Figure 2.25 File Manager Preview Dialog Box

Select from the following options:

Table 2.13 File Manager Preview Options

DescriptionOption

Specifies when to preview the content of
text files in the icons that represent the
files.

Show text in icons

Specifies when to show thumbnails of
image files in the icons that represent the
files.

Show thumbnails

Specifies the maximum file size for files
represented by thumbnails.

Only for files smaller than

Specifies when to preview sound files.Preview sound files
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DescriptionOption

Specifies when to show the number of
files contained in folders. In the Icon

Count number of items

view, you might need to increase your
zoom level to see the number.

2.2.4 Locking Desktop Functions
The Lockdown Editor lets you disable (lockdown) certain desktop functions. This is
useful if you want to restrict the actions that users can perform on a computer. For ex-
ample, you might want to prevent command line operations on a computer that is for
public use at a trade show.

To start the Lockdown Editor, click Computer > Control Center > Look and Feel >
Lockdown Editor.

Youwill see a windowwith a list of options on the left. Each option represents a different
category of desktop settings that can be disabled.

• Section “General” (page 108)

• Section “Panel” (page 109)

• Section “Epiphany Web Browser” (page 110)

• Section “GNOME Screensaver” (page 111)

When the Lockdown Editor starts, it tries to connect to the GConf mandatory configu-
ration source (xml:merged:$prefix/etc/gconf/gconf.xml.mandatory).
If you have access to this configuration source, a lock icon is displayed next to the
checkbox for each setting. Click the lock to specify if the setting is mandatory. If the
setting is mandatory, regular users will not be able to change or override the setting. If
you don’t have access to the mandatory configuration source, the lock icon does not
appear. In this case, all disabled settings are stored in the user's default configuration
source and can be modified later using other tools such as gconf-editor or gconftool-2.
For more information about GConf and mandatory configuration sources, see “GConf
Configuration Sources” [http://www.gnome.org/learn/admin-guide/
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latest/gconf-24.html#gconf-26] in the GNOME Desktop System Adminis-
tration Guide.

General
Use the options in the General category to disable printing, access to the command line,
and saving to disk.

Figure 2.26 General Lockdown Editor Settings

Disable command line
Prevents the user from accessing the terminal or specifying a command line to be
executed. This options also disables access to the panel's Run Application dialog
box.

Disable printing
Prevents the user from printing. This option disables access to the Print dialogs
boxes in all applications.
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Disable print setup
Prevents the user from modifying print settings. This option disables access to the
Print Setup dialog boxes in all applications.

Disable save to disk
Prevents the user from saving files to disk. This option disables access to the Save
as dialog boxes in all applications.

Panel
Use the options in the Panel category to lock down the panel, disable the panel applets
you specify, and disable the force quit, lock screen, and log out options.

Figure 2.27 Panel Lockdown Editor Settings

Lock down the panels
If this option is selected, the panel will not allow any changes to be made to the
configuration of the panel. Individual applets might need to be locked down sepa-
rately, however. The panel must be restarted for this to take effect.
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Disable force quit
If this option is selected, the panel will not allow a user to force an application to
quit (by removing access to the force quit button).

Disable lock screen
If this option is selected, the panel will not allow a user to lock their screen (by re-
moving access to the lock screen menu entries).

Disable log out
If this option is selected, the panel will not allow a user to log out (by removing
access to the log out menu entries).

Disable Applets
.Disables the applets selected in the list.

Epiphany Web Browser
Use the options in the Epiphany Web Browser category to control access to features in
Epiphany.

Figure 2.28 Epiphany Web Browser Lockdown Editor Settings
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Disable quit
Prevents the user from closing Epiphany.

Disable arbitrary URL
Prevents the user from typing a URL in Epiphany.

Disable bookmark editing
Prevents the user from adding or editing bookmarks.

Disable history
Disables all historical information by disabling back and forward navigation, not
allowing the history dialog box, and hiding the most used bookmarks list.

Disable javascript chrome
Disables JavaScript's control over window chrome.

Disable toolbar editing
Prevents the user from editing toolbars.

Force fullscreen mode
Locks Epiphany in fullscreen mode.

Hide menubar
Hides the menubar by default. The menubar can still be accessed using F10.

Disable unsafe protocols
Disables loading of content from the unsafe protocols you specify. Safe protocols
are http and https.

GNOME Screensaver
Use the options in the GNOME Screensaver category to lock the screen when the
screensaver goes active, enable or disable the log out after a delay option in the unlock
dialog box, and to enable or disable the switch user option in the unlock dialog box.
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Figure 2.29 GNOME Screensaver Editor Settings

Lock on activation
Select this option to lock the screen when the screensaver goes active.

Allow log out
Select this option to offer an option in the unlock dialog box to log out after a delay.

Allow user switching
Select this option to offer an option in the unlock dialog box to switch to a different
user.account.

2.2.5 Customizing the Main Menu
Use the Main Menu application to customize the GNOME Main menu. To start this
application, click Computer > Control Center > Look and Feel >Main Menu.
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NOTE

Changes you make to the Main menu are not overwritten during a subsequent
system update. Changes are applied after the latest menu view is generated.

This section contains the following information:

• Section “Editing the Main Menu” (page 113)

Editing the Main Menu
This section describes the following ways you can edit the Main menu:

• Section “Finding Menu Items” (page 114)

• Section “Rearranging Menu Items” (page 115)

• Section “Creating New Separators” (page 115)

• Section “Showing or Hiding Menu Items” (page 115)

• Section “Deleting Items from the Main Menu” (page 116)

• Section “Renaming Menu Items” (page 116)

• Section “Changing an Item’s Generic Name” (page 117)

• Section “Adding New Items to the Main Menu” (page 117)

IMPORTANT

The first time you use Main Menu, changes to the menu do not take effect
until you log out and log back in. After the first time, changes appear immedi-
ately when you make them.

NOTE

Some features, such as the ability to nest groups and insert separators, apply
only if you use older versions of the GNOME menu.
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Finding Menu Items

TheMain Menu window is arranged with the Main menu submenus in theMenus list
on the left and the items in the selected menu in the Items list on the right. Groups in a
submenu are nested below that submenu. To find an item, click the arrow next to a
submenu in theMenus list, select the group containing that item, then locate the item
in the Items list.

Figure 2.30 Main Menu Editor

For example, to locate the Sound Recorder application:

1 Click Computer > Control Center > Look and Feel >Main Menu.

2 Click the arrow next to theMultimedia submenu in theMenus list, then select
the Recording group.

3 Locate Sound Recorder in the Items list.
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Rearranging Menu Items

You can change the order in which items appear in the Main menu. For example, you
might want to place your frequently used applications at the top of the menu or at the
top of their groups to make them easier to find.

To move an item, click it and drag it to a new location in the menu. You can move the
item to a new location in the same menu, or drop it on an item in theMenus list to move
it to a new menu or group. You can also use theMove Up andMove Down buttons to
change an item’s location in the menu.

Creating New Separators

Separators serve as visual cues to make it easier to find items in menus.

NOTE

Separators are not used in the current version of the GNOME menu. Adding a
separator will have no effect. However, if you install and use an older version
of the GNOME menu, you can use separators.

To create a separator:

1 Click Computer > Control Center > Look and Feel >Main Menu.

2 Select the item above the space where you want the separator to appear.

For help locating an item, see Section “Finding Menu Items” (page 114).

3 Click New Separator.

The new separator appears beneath the selected item in the Items list. You can drag the
separator to a new location like you would any other menu item. To delete a separator,
see Section “Deleting Items from the Main Menu” (page 116).

Showing or Hiding Menu Items

To show or hide an item:

1 Click Computer > Control Center > Look and Feel >Main Menu.
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2 Locate the item in the Items list

3 Select the box next to the item to show the item.

or

Deselect the box next to the item to hide the item.

4 Click Close.

When you hide an item, it remains in the Items list and can be shown at another time
if you decide you want it to appear in the menu. To delete an item from the Items list,
see Section “Deleting Items from the Main Menu” (page 116).

Deleting Items from the Main Menu

There are two ways to remove an item from the Main menu:

• To remove an item but retain it in the Items list so you can easily add it to the menu,
hide the item as explained in Section “Showing or HidingMenu Items” (page 115).

• To delete an item from the Items list so it can no longer be shown, right-click the
item and click Delete.

NOTE

Separators can not be hidden. They can only be added or deleted.

If you want to show a deleted item, you must add it like you would a new application.
See Section “Adding New Items to the Main Menu” (page 117) for information about
adding an application.

Renaming Menu Items

1 Click Computer > Control Center > Look and Feel >Main Menu.

2 Locate the menu item whose name you want to change, as explained in Section
“Finding Menu Items” (page 114).

3 Right-click the item, then click Properties.
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4 Replace the current name with the name you want to give the item, then click
Close.

The old name is replaced by the new one in the menu.

Changing an Item’s Generic Name

A short descriptive name appears beneath the name of each item in the Main menu.
This is known as the generic name. To change the generic name:

1 Click Computer > Control Center > Look and Feel >Main Menu.

2 Locate the menu item whose generic name you want to change, as explained in
Section “Finding Menu Items” (page 114).

3 Right-click the item, then click Properties.

4 Replace the current generic name with the generic name you want to give the
item, then click Close.

The old generic name is replaced by the new one in the menu.

Adding New Items to the Main Menu

You can add a new item to the Main menu. This is especially helpful when you install
an application, but it is also useful if you have other applications that do not currently
appear on the menu. You can also add a directory, a link, or another type of item to the
menu.

To add an application to the Main menu:

1 Click Computer > Control Center > Look and Feel >Main Menu.

2 In theMenus list, click the arrow next to the menu containing the group where
you want to add the application, then select the group.

The contents of that group appear in the Items list.

3 Click New Item.

4 Type a name and generic name for the item.
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5 Click Browse and browse to the item.

6 Select the item.

7 Click the Type list, then select the type of item.

For example, if you are adding a directory, click the list and select Directory. If
you are adding an application, leave the default item type, Application, as is.

8 (Optional) To assign an icon to the new item, click No Icon, then select an icon
for the item.

If you do not select an icon, the item appears in the menu without an icon.

9 Click Close.

After the item is added to the menu, you can move it to the place where you want it to
appear in the menu, as described in Section “Rearranging Menu Items” (page 115).

2.2.6 Improving Access for the Visually
Impaired

The Orca screen reader assists visually impaired users so they can read the information
on the screen, either bymagnifying the screen, reading screen output aloud, or outputting
information from the screen in Braille to a screen reader. To configure Orca, click
Computer > Control Center > Look and Feel > Orca Screen Reader.

The first time you run this module, a terminal opens so you can set up the Orca screen
reader. This setup consists of a series of yes/no questions. Answer the questions as ap-
propriate for your setup. After the setup is complete, you must log out and log back in
for your setup to take effect.

After the initial setup, to change the preferences you set during setup or to set additional
options, click Computer > Control Center > Look and Feel > Orca Screen Reader.
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2.2.7 Configuring the Screen Saver
A screen saver is a program that blanks the screen or displays graphics when the com-
puter is not used for a specified amount of time. Originally, screen savers protected
monitors from having images burned into them. Now they are used primarily for enter-
tainment or security.

To configure a screen saver, click Computer > Control Center > Look and Feel >
Screensaver.

Figure 2.31 Screensaver Preferences Dialog

You can select from Random (random selection of screen savers from a custom-defined
list), Blank Screen, or a selection of installed screen savers.

Select a screen saver from the list to choose it. The currently selected screen saver is
displayed in the small preview window. Specify the amount of time that the screen is
to be idle before the screen saver is activated, and whether the screen is locked when
the screen saver is activated.
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2.2.8 Customizing Window Behavior
Use the Window Preferences tool to customize window behavior for the desktop. You
can determine how a window reacts to contact with the mouse pointer or to double-
clicks on its titlebar, and you can define which key to hold for moving an application
window.

To customize window behavior, click Computer > Control Center > Look and Feel >
Windows.

Figure 2.32 Window Preferences Dialog

When several application windows populate the desktop, the active one by default is
the one last clicked. Change this behavior by activating Select WindowsWhen theMouse
Moves over Them. If desired, activateRaise SelectedWindow after an Interval and adjust
the latency time with the slider. This raises a windows a short time after the window
receives focus.

Application windows can be shaded (rolled up) by double-clicking the title bar, leaving
only the title bar visible. This saves space on the desktop and is the default behavior.
It is also possible to set windows to maximize when the title bar is double-clicked.

Using the radio buttons, select a modifier key to press for moving a window (Ctrl, Alt,
Hyper, or the Windows logo key).
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2.3 Personal
Personal settings include the following:

• Section 2.3.1, “Configuring Keyboard Accessibility Settings” (page 121)

• Section 2.3.2, “Configuring Assistive Technology Support” (page 124)

• Section 2.3.3, “Changing Your Password” (page 125)

• Section 2.3.4, “Customizing Keyboard Shortcuts” (page 125)

2.3.1 Configuring Keyboard Accessibility
Settings

GNOME provides keyboard settings designed to help users with motion impairments
use the GNOME desktop. Some of the available settings include:

• How long a key is pressed and held before being recognized as valid input

• Whether the keyboard can be used as a mouse

• Whether key combinations that use Alt, Control, and Shift can be duplicated with
“sticky keys”

To configure keyboard accessibility settings, click Computer > Control Center > Per-
sonal > Accessibility.

The module consists of the three tabs: Basic, Filters, andMouse Keys. Before modifying
settings, activate Enable Keyboard Accessibility Features.
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Figure 2.33 Keyboard Accessibility Preferences Dialog

Features (Basic Tab)
The keyboard accessibility functions can be deactivated automatically after a certain
time. Set an appropriate time limit (measured in seconds) with the slider. The system
can additionally provide audible feedback when the keyboard accessibility functions
are activated and deactivated.

Enable Sticky Keys (Basic Tab)
Some keyboard shortcuts require that one key (a modifier key) is kept pressed constantly
(this applies to Alt, Ctrl, and Shift) while the rest of the shortcut is typed. When sticky
keys are used, the system regards those keys as staying pressed after being pressed
once. For an audible feedback generated each time a modifier key is pressed, activate
Beepwhen the modifier is pressed. IfDisable If Two Keys Pressed Together is selected,
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the keys do not “stick” anymore when two keys are pressed simultaneously. The system
then assumes that the keyboard shortcut has been completely entered.

Enable Repeat Keys (Basic Tab)
ActivateRepeat Keys to make settings with sliders forDelay and Speed. This determines
how long a key must be pressed for the automatic keyboard repeat function to be acti-
vated and at what speed the characters are then typed.

Test the effect of the settings in the field at the bottom of the dialog. Select parameters
that reflect your normal typing habits.

Enable Slow Keys (Filters Tab)
To prevent accidental typing, set a minimum time limit that a key must be pressed and
held before it is recognized as valid input by the system. Also determine whether audible
feedback should be provided for keypress events, accepted keypresses, and the rejection
of a keypress.

Enable Bounce Keys (Filters Tab)
To prevent double typing, set a minimum time limit for accepting two subsequent
keypress events of the same key as the input of two individual characters. If desired,
activate audible feedback upon rejection of a keypress event.

Toggle Keys (Filters Tab)
You can request audible feedback from the system when a keycap modifier key is
pressed.

Mouse Keys Tab
Activates the keyboard mouse; the mouse pointer is controlled with the arrow keys of
the number pad. Use the sliders to set the maximum speed of the mouse pointer, the
acceleration time until the maximum speed is reached, and the latency between the
pressing of a key and the cursor movement.
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2.3.2 Configuring Assistive Technology
Support

To configure assistive technology options, clickComputer >Control Center > Personal
> Assistive Technology Preferences. To enable the technologies, first select Enable
Assistive Technologies and then select the technologies you want to enable every time
you log in.

Figure 2.34 Assistive Technology Preferences Dialog

The gok package must be installed in order to get on-screen keyboard support, and the
gnopernicus and gnome-mag packages must be installed in order to get screenreading
and magnifying capabilities.

If these packages are not installed on your system (they are installed by default during
installation), install them with the following procedure:

1 Click Computer >More Applications > System > YaST.

2 Type the root password, then click OK.

3 Click Software > Software Management.

4 Select Selection from the Filter drop-down menu, then select Accessibility from
the Selection list.

5 Select gok, gnopernicus, and gnome-mag from the Available Software list

6 Click Accept.
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7 Insert the CD you are prompted for, then click OK.

8 Click Cancel > Close after the package installation is complete.

2.3.3 Changing Your Password
For security reasons, it is a good idea to change your password from time to time. To
change your password:

1 Click Computer > Control Center > Personal > Change Password.

2 Type your old (current) password.

3 Type your new password.

4 Confirm your new password by typing it again, then click OK.

2.3.4 Customizing Keyboard Shortcuts
A keyboard shortcut is a key or combination of keys that provides an alternative to
standard ways of performing an action. You can customize the keyboard shortcuts for
a number of actions.

To open the Keyboard Shortcuts tool, click Computer > Control Center > Personal >
Shortcuts.
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Figure 2.35 Keyboard Shortcuts Dialog

To change the shortcut keys for an action, select the action and then press the keys you
want to associate with the action. To disable the shortcut keys for an action, click the
shortcut for the action, then press Backspace.

2.4 System
System settings include the following:

• Section 2.4.1, “Configuring Date and Time” (page 127)

• Section 2.4.2, “Configuring Streaming Audio and Video” (page 127)

• Section 2.4.3, “Configuring Language Settings” (page 127)

• Section 2.4.4, “Configuring Network Proxies” (page 128)

• Section 2.4.5, “Configuring Power Management” (page 130)

• Section 2.4.6, “Setting Preferred Applications” (page 132)

• Section 2.4.7, “Setting Session Sharing Preferences” (page 132)

• Section 2.4.8, “Configuring Beagle Search Settings” (page 134)
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• Section 2.4.9, “Managing Sessions” (page 134)

• Section 2.4.10, “Setting Sound Preferences” (page 138)

• Section 2.4.11, “Managing Users and Groups” (page 141)

• Section 2.4.12, “Configuring Administrative Settings with YaST” (page 142)

2.4.1 Configuring Date and Time
To change your date and time configuration, for example to change your time zone or
the way the date and time are displayed, click Computer > Control Center > System >
Date and Time. This opens the YaST Date and Time module, which requires root
privileges. Enter the root password and follow the instructions on the YaST pages.

2.4.2 Configuring Streaming Audio and
Video

The GStreamer Properties application lets you set which audio and video plug-ins you
want to use for streaming multimedia. To open this application, click Computer >
Control Center > System > GStreamer Properties.

In most cases, you should use the default selections. However, if you want to select
other plug-ins, select the plug-in you want from the menus. The Audio tab lists the plug-
ins for audio input and output. The Video tab lists the video plug-ins.

Click Close when you are finished. The system is immediately configured to use the
selected plug-ins.

2.4.3 Configuring Language Settings
openSUSE can be configured to use any of many languages. The language setting de-
termines the language of dialogs and menus, and can also determine the keyboard and
clock layout.

You can set the following language settings:
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• Primary language

• Whether the keyboard language setting should depend on the primary language

• Whether the time zone should depend on the primary language

• Secondary languages

NOTE

You must have administrator (root) privileges to configure language settings.

To configure your language settings:

1 Click Computer > Control Center > System > Language.

2 (Conditional) If you are not logged in as root or a user with administrator privi-
leges, enter the root password.

If you do not know the root password, contact your system administrator. You
cannot continue without the root password.

3 Specify the primary language, whether you want to adapt the keyboard layout
or time zone to the primary language, and any secondary languages you need to
support on the computer.

4 Click Accept.

The language configuration settings are written to several configuration files.
This process can take a few minutes. The new settings take effect immediately
after they are written to the configuration files.

2.4.4 Configuring Network Proxies
The Network Proxy Configuration tool lets you configure how your system connects
to the Internet. You can configure the desktop to connect to a proxy server and specify
the details of the server. A proxy server is a server that intercepts requests to another
server and fulfills the request itself, if it can. You can specify the Domain Name Service
(DNS) name or the Internet Protocol (IP) address of the proxy server. A DNS name is
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a unique alphabetic identifier for a computer on a network. An IP address is a unique
numeric identifier for a computer on a network.

Click Computer > Control Center > System > Network Proxies.

Figure 2.36 Network Proxy Configuration Dialog

The following table lists the Internet connection options that you can modify.

Table 2.14 Internet Connection Options

DescriptionOption

Connects directly to the Internet, without a proxy
server.

Direct Internet connection

Connects to the Internet through a proxy server and
lets you configure the proxy server manually.

Manual proxy configuration

The DNS name or IP address of the proxy server to
use when you request a HTTP service. Specify the

HTTP proxy

port number of the HTTP service on the proxy server
in the Port box.
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DescriptionOption

The DNS name or IP address of the proxy server to
use when you request a Secure HTTP service. Spec-

Secure HTTP proxy

ify the port number of the Secure HTTP service on
the proxy server in the Port box.

The DNS name or IP address of the proxy server to
use when you request an FTP service. Specify the

FTP proxy

port number of the FTP service on the proxy server
in the Port box.

The DNS name or IP address of the Socks host to
use. Specify the port number for the Socks protocol
on the proxy server in the Port spin box.

Socks host

Connects to the Internet through a proxy server and
lets you configure the proxy server automatically.

Automatic proxy configura-
tion

The URL that contains the information required to
configure the proxy server automatically.

Autoconfiguration URL

2.4.5 Configuring Power Management
The Power Management module lets you manage your system’s power-saving options.
It is especially useful for extending the life of a laptop’s battery charge. However,
several options also help to save electricity when you are using a computer that is
plugged in to an electricity source.

Click Computer > Control Center > System > Power Management.

Specifying Sleep Mode Times
Sleep mode shuts down the computer when it is unused for a specified amount of time.
Whether you are using battery or AC power, you can specify the amount of time that
the computer remains unused before it is put to sleep.You can also put the computer’s
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display to sleep without shutting down the computer, saving the power required by the
display.

Sleep mode is especially important when the computer is operating under battery
power. Both the screen and the computer draw power from the battery, so you can save
a significant amount of battery power by shutting down one or both. It is common to
put the display to sleep after a shorter period of time. Then, if the computer remains
unused for an additional amount of time, it is also put to sleep.

To specify your computer’s sleep settings:

1 Click Computer > Control Center > System > Power Management.

2 Click the tab for the type of power you are using.

If your computer uses AC power, click On AC Power.

If your computer runs on battery power, click On Battery Power.

If your computer operates on both AC and battery power, you can configure the
settings on both tabs. The settings you choose are in effect no matter which
power source you use.

3 Use the sliders to set the amount of inactive time that passes before the display
and computer go into sleep mode.

When the display is in sleep mode, the computer continues to run. When the
computer is in sleep mode, power to the display and hard disk is shut off and the
computer uses only the power needed to maintain the contents of RAM.

4 Click Close.

The options you selected go into effect immediately.

Setting General Power Options
To set general power options, click Computer > Control Center > System > Power
Management, then click the General tab. On this tab, you can choose:

• The sleep type to use when the computer is inactive
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• How and when the Power icon displays

2.4.6 Setting Preferred Applications
The Preferred Applications module allows you to specify which applications to use for
various common tasks:

To change any of these settings:

1 Click Computer > Control Center > System > Preferred Applications.

2 Click the tab for the type of application you want to set.

3 Select one of the available applications from the Choose menu or enter the
command used to start the application.

4 Click Close.

The changes take effect immediately.

2.4.7 Setting Session Sharing Preferences
The Remote Desktop Preference dialog box lets you share a GNOME desktop session
between multiple users and set session-sharing preferences. These preferences can have
a direct impact on the security of your system.

1 Click Computer > Control Center > System > Remote Desktop.
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2 Choose from the following options:

DescriptionOption

Lets remote users view your session. All
keyboard, pointer, and clipboard events
from the remote user are ignored.

Allow other users to view your
desktop

Lets other users access and control your
session from a remote location.

Allow other users to control your
desktop

Click the highlighted text to system ad-
dress by e-mail to a remote user.

Users can view your desktop using
this command

Select the following security considera-
tions when a remote user tries to view or
control your session:

When a user tries to view or con-
trol your desktop

Ask you for confirmation: Select this
option if you want remote users to ask you
for confirmation when they want to share
your session. This option lets you be aware
of other users who connect to your session.
You can also decide what time is suitable
for the remote user to connect to your
session.

Customizing Your Settings 133



DescriptionOption

Require the user to enter this pass-
word: Select this option to authenticate
the remote user if authentication is used.
This option provides an extra level of se-
curity.

Type the password that the remote user
must enter to view or control your session.

Password

3 Click Close.

2.4.8 Configuring Beagle Search Settings
Beagle is the search engine used on the GNOME desktop. By default, Beagle is config-
ured to start automatically and index your home directory. If you want to change these
settings, specify the number of results displayed after a search or change the Beagle
privacy settings, click Computer > Control Center > System > Search Settings.

For more information, see Section 10.4, “Setting Search Preferences” (page 254) and
Section 10.6, “Preventing Files and Directories from Being Indexed” (page 256).

2.4.9 Managing Sessions
This module lets you manage your sessions. A session occurs between the time that
you log in to the desktop environment and the time that you log out. You can set session
preferences and specify which applications to start when you begin a session. You can
configure sessions to save the state of applications and then restore the state when you
start another session.

You can also use this preference tool to manage multiple sessions. For example, you
might have a mobile session which starts applications you use most frequently when
traveling, a demo session that starts applications used to present a demonstration or
slide show to a customer, and a work session that uses a different set of applications
when you are working in the office.
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Click Computer > Control Center > System > Sessions.

This module consists of three tabbed pages:

• Startup Programs: Lets you specify non-session-managed startup applications,
which start automatically when you start a session.

• Current Session: Lets you specify startup order values and select restart styles
for the session-managed applications in your current session.

• Session Options: Lets you remember running applications when logging out so
they open the next time you log in.

Configuring Startup Applications
Use the Startup Programs tabbed page to specify non-session-managed startup applica-
tions.

Figure 2.37 Sessions Dialog—Startup Programs Page

Startup applications are applications that start automatically when you begin a session.
You specify the commands that run these applications and the commands execute auto-
matically when you log in.

You can also start session-managed applications automatically. For more information,
see Section “Remembering Running Applications when Logging Out” (page 138).
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To add a startup application, click Add. The Add Startup Program dialog is displayed.
Specify the command to start the application in the Startup Command field. If you
specify more than one startup application, use theOrder box to specify the startup order
of the each application.

To edit a startup application, select the startup application and then click Edit. The Edit
Startup Program dialog is displayed. Modify the command and the startup order for the
startup application.

To delete a startup application, select the startup application and then click Remove.

Deselect the checkbox in the Enabled column to disable the application but leave it in
the list. Disabled applications do not start at startup but can easily be enabled to do so.

Setting Session Properties
Use the Current Session tabbed page to specify startup order values and to choose restart
styles for the session-managed applications in your current session.

Figure 2.38 Sessions Dialog—Current Session Page

The following table lists the session properties that you can configure.
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Table 2.15 Session Properties for Session-Managed Applications

DescriptionOption

Specifies the order in which the session manager starts session-managed
startup applications. The session manager starts applications with lower
order values first. The default value is 50.

Order

To set the startup order of an application, select the application in the table.
Use the Order box to specify the startup order value.

Determines the restart style of an application. To select a restart style for
an application, select the application in the table and then select one of
the following styles:

Style

• Normal: Starts automatically when you start a session. Use the
kill command to terminate applications with this restart style during
a session.

• Restart: Restarts automatically when you close or terminate the
application. Select this style for an application if it must run continu-
ously during your session. To terminate an application with this restart
style, select the application in the table and then click Remove.

• Trash: Does not start when you start a session.

• Settings: Starts automaticallywhen you start a session. Applications
with this style usually have a low startup order and store your confi-
guration settings for GNOME and session-managed applications.

Deletes the selected application from the list. The application is removed
from the session manager and closed. Applications that you delete are not
started the next time you start a session.

Remove

Applies changes made to the startup order and the restart style.Apply
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Remembering Running Applications when Logging
Out
Use the Session Options tab to automatically save the current state of your session. The
session manager saves the session-managed applications that are open and the settings
associated with the session-managed applications. The next time you start a session,
the applications start automatically with the saved settings.

2.4.10 Setting Sound Preferences
The Sound Preferences tool lets you control when the sound server starts. You can also
specify which sounds to play when particular events occur.

Click Computer > Control Center > System > Sound to open the Sound Preferences
tool.

Setting Sound Devices
Use the Devices tab to configure the application to use for various types of sounds.
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Figure 2.39 Sound Preferences Dialog—Devices Page

Click the drop-down list for each type of sound and select the application to use. In
most cases, Autodetect is the best choice, unless you want to use a specific application.

Setting General Sound Preferences
Use the Sounds tab to specify when to launch the sound server. You can also enable
sound event functions.
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Figure 2.40 Sound Preferences Dialog—General Page

Click Enable software sound mixing (ESD) to start the sound server when you start a
session. When the sound server is active, the desktop can play sounds.

Click Play system sounds to play sounds when particular events occur in the desktop.

Finally, select the sound to play at each of the specified events.

Setting System Beep Preferences
Some applications play a beep sound to indicate a keyboard input error. Use the System
Beep tab to set preferences for the system beep.
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Figure 2.41 Sound Preferences Dialog—System Beep Page

2.4.11 Managing Users and Groups
Use the User Management tool to manage users and groups, including user and group
names, group membership, password and password encryption, and other options.

ClickComputer >Control Center > System >UserManagement. TheUserManagement
tool opens the User and Group Administration module in YaST.

NOTE

Root privileges are required to manage users and groups.

Follow the directions in YaST for information on changing settings.
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2.4.12 Configuring Administrative Settings
with YaST

Use the YaSTControl Center to change the installation and configuration of your whole
system. Administrator (or root) permission is required to open YaST.

To open YaST, click Computer >More Applications > System > YaST, then enter the
root password. If you do not know the root password, ask your system administrator.

YaST contains various modules you can use to adjust your system settings. These
modules are divided into the following categories:

Hardware: Contains modules for configuring hardware components such as your
monitor, keyboard, mouse, printer, and scanner.
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Miscellaneous: The YaST Control Center has several modules that cannot easily be
classified into the first six module groups. The modules in this category can be used
for things such as viewing log files and installing drivers from a vendor CD.

NetworkDevices: Includesmodules for configuring network devices such as network
cards, ISDN, DSL, or modem.

Network Services: Containsmodules for network services and for configuring clients
such as LDAP and NFS.

Novell AppArmor: Use the modules of this category to configure the Novell®
AppArmor™ access control system. This option is available only if theNovell AppArmor
pattern is installed.

Security and Users: Use these modules to configure security details such as firewall
options, and to create and manage users and groups.

Software: Use the modules of this category to set options for installation and updates,
and to install or remove software packages.

System: Use these modules to change system settings such as the date, time, or lan-
guage, and to perform tasks such as backing up or restoring files.

For information about using YaST, see the Installation and Setup part in Start-Up,
available at http://www.novell.com/documentation/opensuse103/.
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Part II. Office and Collaboration





3The OpenOffice.org Office
Suite
OpenOffice.org is a powerful open-source office suite that provides tools for all types
of office tasks, such as writing texts, working with spreadsheets, or creating graphics
and presentations. With OpenOffice.org, you can use the same data across different
computing platforms. You can also open and edit files in other formats, including Mi-
crosoft Office, then save them back to this format, if needed. This chapter covers infor-
mation about the Novell® edition of OpenOffice.org and some of the key features you
should be aware of when getting started with the suite.

• Section 3.1, “Understanding OpenOffice.org” (page 148)

• Section 3.2, “Word Processing with Writer” (page 160)

• Section 3.3, “Using Spreadsheets with Calc” (page 170)

• Section 3.4, “Using Presentations with Impress” (page 172)

• Section 3.5, “Using Databases with Base” (page 175)

• Section 3.6, “Creating Graphics with Draw” (page 179)

• Section 3.7, “Creating Mathematical Formulas with Math” (page 180)

• Section 3.8, “Finding Help and Information About OpenOffice.org” (page 180)

OpenOffice.org consists of several application modules (subprograms), which are de-
signed to interact with each other. They are listed in Table 3.1, “The OpenOffice.org
Application Modules” (page 148). A full description of each module is available in the
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online help, described in Section 3.8, “Finding Help and Information About OpenOf-
fice.org” (page 180).

Table 3.1 The OpenOffice.org Application Modules

PurposeModule

Word processor application moduleWriter

Spreadsheet application moduleCalc

Presentation application moduleImpress

Database application moduleBase

Application module for drawing vector graphicsDraw

Application module for generating mathematical formulasMath

The appearance of the application varies depending on the desktop or windowmanager
you use. Regardless of the appearance, the basic layout and functions are the same.

3.1 Understanding OpenOffice.org
This section contains information that applies to all of the application modules in
OpenOffice.org. Module-specific information can be found in the sections relating to
each module.

• Section 3.1.1, “Advantages of the Novell Edition of OpenOffice.org” (page 149)

• Section 3.1.2, “Using the Standard Edition of OpenOffice.org” (page 151)

• Section 3.1.3, “Compatibility with Other Office Applications” (page 151)

• Section 3.1.4, “Starting OpenOffice.org” (page 153)

• Section 3.1.5, “Improving OpenOffice.org Load Time” (page 154)

• Section 3.1.6, “Customizing OpenOffice.org” (page 154)
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• Section 3.1.7, “Finding Templates” (page 159)

3.1.1 Advantages of the Novell Edition of
OpenOffice.org

openSUSE® includes the Novell edition of OpenOffice.org. The Novell edition includes
several enhancements that are not yet included in the standard edition.

Calc Enhancements
The Novell edition of OpenOffice.org Calc includes the following enhancements that
are not found in the standard edition:

• Improved Excel compatibility for certain functions (for example, AD-
DRESS/OFFSE)

• Improved ergonomics, such as fixes for the standard editions missing keybindings
and the “merge and center” problem

• Support for R1C1-style addresses

• Interoperation between OpenOffice.org Data Pilots and Microsoft* Pivot Tables*

• The ability to edit Data Pilots after they are created

• Addition of the GETPIVOTDATA function to help manipulate information from
Pivot Tables

• Inclusion of a subset of Excel VBA macros that can be loaded and run in OpenOf-
fice.org as if they were native macros, allowing a number of small accounting and
management tools to be migrated to OpenOffice.org without having to rewrite them
to target StarBasic

• A simple linear solver that allows simple numerical analysis
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Writer Enhancements
The Novell edition of OpenOffice.orgWriter includes the following enhancements that
are not found in the standard edition:

• The Navigator provides a tree view of the document structure, providing improved
document navigation

• Improved change-tracking interoperability

• Better HTML export

• Improved printing of fonts

Font Improvements
The Novell edition of OpenOffice.org includes several font enhancements, including:

• Aliased (bitmap) fonts are not allowed, preventing poor display of fonts when a
document is projected

• Inclusion of a set of fonts licensed from AGFA, which are metrically compatible
with some key, default Microsoft fonts and are transparently mapped to the corre-
sponding Microsoft fonts when documents are exported or imported

• An improved OpenSymbol font, which provides better support of bullets, displaying
attractive bullets rather than “missing glyph” square boxes that sometimes appear

OpenClipart
The Linux version of the Novell edition of OpenOffice.org includes a large selection
of free clipart from the OpenCliparthttp://openclipart.org project. To access
this clipart, click Tools > Gallery.

Multimedia
The Novell edition includes native platform multimedia support with gstreamer on
Linux.
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Performance Improvements
The Novell edition of OpenOffice.org on Linux starts faster than the standard edition
due to several enhancements. This is true even on lower-memory systems.

GroupWise Integration
The Novell edition of OpenOffice.org includes basic integration with GroupWise, al-
lowing documents to be placed in and loaded from the GroupWise Document Manage-
ment System.

3.1.2 Using the Standard Edition of
OpenOffice.org

You can use the standard edition of OpenOffice.org rather than the Novell edition. If
you install the latest version of OpenOffice.org, all of your Novell Edition files remain
compatible. However, the standard edition does not contain the enhancements made in
the Novell edition.

3.1.3 Compatibility with Other Office
Applications

OpenOffice.org can work with documents, spreadsheets, presentations, and databases
in many other formats, includingMicrosoft Office. They can be seamlessly opened like
other files and saved back to the original format. Because the Microsoft formats are
proprietary and the specifications are not available to other applications, there are occa-
sionally formatting issues. If you have problems with your documents, consider opening
them in the original application and resaving in an open format such as RTF for text
documents or CSV for spreadsheets.

TIP

For good information about migrating from other office suites to OpenOf-
fice.org, refer to the OpenOffice.org Migration Guide [http://
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documentation.openoffice.org/manuals/oooauthors2/
0600MG-MigrationGuide.pdf].

Converting Documents to the OpenOffice.org Format
OpenOffice.org can read, edit, and save documents in a number of formats. It is not
necessary to convert files from those formats to the OpenOffice.org format to use those
files. However, if you want to convert the files, you can do so. To convert a number of
documents, such as when first switching to OpenOffice.org, do the following:

1 Select File >Wizards > Document Converter.

2 Choose the file format from which to convert.

There are several StarOffice and Microsoft Office formats available.

3 Click Next.

4 Specify where OpenOffice.org should look for templates and documents to
convert and in which directory the converted files should be placed.

IMPORTANT

Documents retrieved from a Windows partition are usually in a subdirec-
tory of /windows.

5 Make sure that all other settings are appropriate, then click Next.

6 Review the summary of the actions to perform, then start the conversion by
clicking Convert.

The amount of time needed for the conversion depends on the number of files
and their complexity. For most documents, conversion does not take very long.

Sharing Files with Users of Other Office Suites
OpenOffice.org is available for a number of operating systems. This makes it an excellent
tool when a group of users frequently need to share files and do not use the same system
on their computers.
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When sharing documents with others, you have several options.

If the recipient needs to be able to edit the file: Save the document in the format
the other user needs. For example, to save as a Microsoft Word file, click File > Save
As, then select the Microsoft Word file type for the version of Word the other user
needs.

If the recipient only needs to read the document: Export the document to a PDF
file with File > Export as PDF. PDF files can be read on any platform using a viewer
like Adobe Acrobat Reader.

If you want to share a document for editing: Use one of the standard document
formats. The default formats comply with the OASIS standard XML format, making
them compatible with a number of applications. TXT and RTF formats, although limited
in formatting, might be a good option for text documents. CSV is useful for spreadsheets.
OpenOffice.org might also offer your recipient's preferred format, especiallyMicrosoft
formats.

If you want to e-mail a document as a PDF: Click File > Send > E-mail as PDF.
Your default e-mail program opens with the file attached.

If you want to e-mail a document to a Microsoft Word user: Click File > Send
> E-mail as Microsoft Word. Your default e-mail program opens with the file attached.

Send a document as the body of an e-mail: Click File > Send > Document as E-
mail. Your default e-mail program opens with the contents of the document as the e-
mail body.

3.1.4 Starting OpenOffice.org
Start the application in one of the following ways:

• Click Computer > OpenOffice.org Writer.

This opens Writer. To open a different module, click File > New from the newly
opened Writer document, then choose the module you want to open.

• Click Computer >More Applications > Office, then click the name of the
OpenOffice.org module you want to start.
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SomeOpenOffice.org modules can be found in other sections of theMore Applica-
tions window. For example, the Writer/Web module is listed under Internet and
the Draw module is under Graphics.

• In a terminal window, enter ooffice. The OpenOffice.org window opens. Click
File > New, then choose the module you want to open.

If any OpenOffice.org application is open, you can open any of the other applications
by clicking File > New > Name of Application.

3.1.5 Improving OpenOffice.org Load Time
To speed up the load time of OpenOffice.org by preloading the application at system
startup:

1 Click Tools > Options >Memory.

2 Select Enable systray Quickstarter.

The next time you restart your system, OpenOffice.org will preload. When you open
an OpenOffice.org application module, it will open faster.

3.1.6 Customizing OpenOffice.org
You can customize OpenOffice.org to best suit your needs and working style. Toolbars,
menus, and keyboard shortcuts can all be reconfigured to help you more quickly access
the features you use the most. You can also assign macros to application events if you
want specific actions to occur when those events take place. For example, if you always
work with a specific spreadsheet, you can create a macro that opens the spreadsheet
and assign the macro to the Start Application event.

This section contains simple, generic instructions for customizing your environment.
The changes you make are effective immediately, so you can see if the changes are
what you wanted and go back and modify them if they weren’t. See the OpenOffice.org
help files for detailed instructions.
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Customizing Toolbars
Use the Customize dialog to modify OpenOffice.org toolbars.

1 Click the arrow icon at the end of any toolbar, then click Customize Toolbar.

or

Click Tools > Customize > Toolbars.

2 Select the toolbar you want to customize.

The toolbar you clicked should already be selected. You can change the toolbar
you want to customize by selecting the desired toolbar from the Toolbar menu.

3 Select the check boxes next to the commands you want to appear on the toolbar,
and deselect the check boxes next to the commands you don’t want to appear.

4 Select whether to save your customized toolbar in the OpenOffice.org module
you are using or in the document.

• OpenOffice.org module

The customized toolbar is used whenever you open that module.

• Document filename

The customized toolbar is used whenever you open that document.

5 Repeat to customize additional toolbars.

6 Click OK.

You can quickly choose the buttons that appear on a particular toolbar.

1 Click the arrow icon at the end of the toolbar you want to change.

2 Click Visible Buttons to display a list of buttons.

3 Select the buttons in the list to enable (check) or disable (uncheck) them.
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Customizing Menus
You can add or delete items from current menus, reorganize menus, and even create
new menus.

1 Click Tools > Customize >Menus.

2 Select the menu you want to change, or click New to create a new menu.

Click Help for more information about the options in the Customize dialog.

3 Modify, add, or delete menu items as desired.

4 Click OK.

Customizing Keyboard Shortcuts
You can reassign currently assigned keyboard shortcuts and assign new shortcuts to
frequently used functions.

1 Click Tools > Customize > Keyboard.

2 Select the keys you want to assign to a function, or select the function and assign
the keys or key combinations.

Click Help for more information about the options in the Customize dialog.

3 Modify, add, or delete keyboard shortcuts as desired.

4 Click OK.

Customizing Events
OpenOffice.org also provides ways to assign macros to events such as application
startup or the saving of a document. The assigned macro runs automatically whenever
the selected event occurs.

1 Click Tools > Customize > Events.
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2 Select the event you want to change.

Click Help for more information about the options in the Customize dialog box.

3 Assign or remove macros for the selected event.

4 Click OK.

Changing the Global Settings
Global settings can be changed in any OpenOffice.org application by clicking Tools >
Options on the menu bar. This opens the window shown in the figure below. A tree
structure is used to display categories of settings.

Figure 3.1 The Options Window

The following table lists the settings categories along with a brief description of each
category:

NOTE

The settings categories that appear depend on the module you are working in.
For example, if you are in Writer, the OpenOffice.org Writer category appears
in the list, but the OpenOffice.org Calc category does not. The OpenOffice.org
Base category appears in both Calc and Writer. The Application column in the
table shows where each setting category is available.
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Table 3.2 Global Setting Categories

ApplicationDescriptionSettings
Category

AllVarious basic settings, including your user data (such
as your address and e-mail), important paths, and
settings for printers and external programs.

OpenOf-
fice.org

AllIncludes the settings related to the opening and saving
of several file types. There is a dialog for general

Load/Save

settings and several special dialogs to define how
external formats should be handled.

AllCovers the various settings related to languages and
writing aids, such as your locale and spell checker

Language
Settings

settings. This is also the place to enable support for
Asian languages.

WriterConfigures the global word processing options, such
as the basic fonts and layout that Writer should use.

OpenOf-
fice.org
Writer

WriterChanges the settings related to the HTML authoring
features of OpenOffice.org.

OpenOf-
fice.org
Writer/Web

CalcChanges the settings for Calc, such as those related
to sort lists and grids.

OpenOf-
fice.org
Calc

ImpressChanges the settings that should apply to all presen-
tations. For example, you can specify the measure-
ment unit for the grid used to arrange elements.

OpenOf-
fice.org Im-
press

DrawIncludes the settings related to the vector drawing
module, such as the drawing scale, grid properties,
and some print options.

OpenOf-
fice.org
Draw
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ApplicationDescriptionSettings
Category

MathProvides a single dialog to set special print options
for formulas.

OpenOf-
fice.org
Math

BaseProvides dialogs to set and edit connections and
registered databases.

OpenOf-
fice.org
Base

AllDefines the default colors used for newly created
charts.

Charts

AllIncludes the dialogs to configure any proxies and to
change settings related to search engines.

Internet

IMPORTANT

All settings listed in the table are applied globally for the specified applications.
They are used as defaults for every new document you create.

3.1.7 Finding Templates
Templates greatly enhance the use of OpenOffice.org by simplifying formatting tasks
for a variety of different types of documents. OpenOffice.org comes with a few tem-
plates, and you can find additional templates on the Internet. You can also create your
own. Creating templates is beyond the scope of this guide, but detailed instructions are
found in the OpenOffice.org help system and in other documents and tutorials available
online.

In addition to templates, you can find other extras and add-ins online. The following
table lists a few of the prominent places where you can find templates and other extras.
(BecauseWeb sites often close or their content changes, the information in the following
table might not be current when you read it.)
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Table 3.3 Where to Find OpenOffice.org Templates and Extras

What You Can FindLocation

Templates for Calc spreadsheets, CD
cases, seed packets, fax cover sheets, and
more

OpenOffice.org documentation Web site
[http://documentation
.openoffice.org/Samples
_Templates/User/template_2
_x/index.html]

Templates for many types of labelsWorldlabel.com [http://www
.worldlabel.com/Pages/
openoffice-template.htm]

For more information about templates, see Section 3.2.4, “Using Templates to Format
Documents” (page 165) and Section 3.3.2, “Using Templates in Calc” (page 171).

3.2 Word Processing with Writer
OpenOffice.org Writer is a full-featured word processor with page and text formatting
capabilities. Its interface is similar to interfaces for other major word processors, and
it includes some features that are usually found only in expensive desktop publishing
applications.

This section highlights a few key features of Writer. For more information about these
features and for complete instructions for usingWriter, look at the OpenOffice.org help
or any of the sources listed in Section 3.8, “Finding Help and Information About
OpenOffice.org” (page 180).

NOTE

Much of the information in this section can also be applied to other OpenOf-
fice.org modules. For example, other modules use styles similarly to how they
are used in Writer.

• Section 3.2.1, “Creating a New Document” (page 161)

• Section 3.2.2, “Sharing Documents with Other Word Processors” (page 162)
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• Section 3.2.3, “Formatting with Styles” (page 162)

• Section 3.2.4, “Using Templates to Format Documents” (page 165)

• Section 3.2.5, “Working with Large Documents” (page 167)

• Section 3.2.6, “Using Writer as an HTML Editor” (page 169)

3.2.1 Creating a New Document
There are two ways to create a new document:

To create a document from scratch, click File > New > Text Document.

To use a standard format and predefined elements for your own documents, try a wizard.
Wizards are small utilities that let you make some basic decisions then produce a ready-
made document from a template. For example, to create a business letter, click File >
Wizards > Letter. Using the wizard's dialogs, easily create a basic document using a
standard format. A sample wizard dialog is shown in Figure 3.2, “An OpenOffice.org
Wizard” (page 161).

Figure 3.2 An OpenOffice.org Wizard

Enter text in the document window as desired. Use the Formatting toolbar or the Format
menu to adjust the appearance of the document. Use theFilemenu or the relevant buttons
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in the toolbar to print and save your document. With the options under Insert, add extra
items to your document, such as a table, picture, or chart.

3.2.2 Sharing Documents with Other Word
Processors

You can use Writer to edit documents created in a variety of other word processors.
For example, you can import a Microsoft Word document, edit it, and save it again as
aWord document. MostWord documents can be imported into OpenOffice.org without
any problem. Formatting, fonts, and all other aspects of the document remain intact.
However, some very complex documents—such as documents containing complicated
tables, Word macros, or unusual fonts or formatting—might require some editing after
being imported. OpenOffice.org can also save inmany popular word processing formats.
Likewise, documents created in OpenOffice.org and saved asWord files can be opened
in Microsoft Word without any trouble.

So, if you use OpenOffice.org in an environment where you frequently share documents
with Word users, you should have little or no trouble exchanging document files. Just
open the files, edit them, and save them as Word files.

3.2.3 Formatting with Styles
OpenOffice.org uses styles for applying consistent formatting to various elements in a
document. The following types of styles are available:

Table 3.4 About the Types of Styles

What it DoesType of Style

Applies standardized formatting to the various types of
paragraphs in your document. For example, apply a paragraph

Paragraph

style to a first-level heading to set the font and font size,
spacing above and below the heading, location of the heading,
and other formatting specifications.

Applies standardized formatting for types of text. For exam-
ple, if you want emphasized text to appear in italics, you can

Character
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What it DoesType of Style

create an emphasis style that italicizes selected text when
you apply the style to it.

Applies standardized formatting to frames. For example, if
your document uses sidebars, you can create frames with

Frame

specified graphics, borders, location, and other formatting
so that all of your sidebars have a consistent appearance.

Applies standardized formatting to a specified type of page.
For example, if every page of your document contains a

Page

header and footer except for the first page, you can use a first
page style that disables headers and footers. You can also
use different page styles for left and right pages so that you
have bigger margins on the insides of pages and your page
numbers appear on an outside corner.

Applies standardized formatting to specified list types. For
example, you can define a checklist with square check boxes

List

and a bullet list with round bullets, then easily apply the
correct style when creating your lists.

Opening the Styles and Formatting Window
The Styles and Formatting window (called the Stylist in earlier versions of OpenOf-
fice.org), is a versatile formatting tool for applying styles to text, paragraphs, pages,
frames, and lists. To open this window, click Format > Styles and Formatting.
OpenOffice.org comes with several predefined styles. You can use these styles as they
are, modify them, or create new styles.

TIP

By default, the Styles and Formatting window is a floating window; that is, it
opens in its own window that you can place anywhere on the screen. If you
use styles extensively, you might find it helpful to dock the window so that it
is always present in the same part of the Writer interface. To dock the Styles
and Formatting window, press Control while you double-click on a gray area
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in the window. This tip applies to some other windows in OpenOffice.org as
well, including the Navigator.

Applying a Style
To apply a style, select the element you want to apply the style to, and then double-
click the style in the Styles and Formatting window. For example, to apply a style to a
paragraph, place the cursor anywhere in that paragraph and double-click the desired
paragraph style.

Using Styles Versus Using Formatting Buttons and
Menu Options
Using styles rather than the Format menu options and buttons helps give your pages,
paragraphs, texts, and lists a more consistent look and makes it easier to change your
formatting. For example, if you emphasize text by selecting it and clicking the Bold
button, then later decide you want emphasized text to be italicized, you need to find all
of your bolded text and manually change it to italics. If you use a character style, you
only need to change the style from bold to italics and all text that has been formatted
with that style automatically changes from bold to italics.

Text formatted with a menu option or button overrides any styles you have applied. If
you use the Bold button to format some text and an emphasis style to format other text,
then changing the style does not change the text that you formatted with the button,
even if you later apply the style to the text you bolded with the button. You must man-
ually unbold the text and then apply the style.

Likewise, if you manually format your paragraphs using Format > Paragraph, it is
easy to end up with inconsistent paragraph formatting. This is especially true if you
copy and paste paragraphs from other documents with different formatting. However,
if you apply paragraph styles, formatting remains consistent. If you change a style, the
change is automatically applied to all paragraphs formatted with that style.

Changing a Style
With styles, you can change formatting throughout a document by changing a style,
rather than applying the change separately everywhere you want to apply the new for-
matting.
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1 In the Styles and Formatting window, right-click the style you want to change.

2 ClickModify.

3 Change the settings for the selected style.

For information about the available settings, refer to the OpenOffice.org online
help.

4 Click OK.

Creating a Style
OpenOffice.org comes with a collection of styles to suit many users’ needs. However,
most users eventually need a style that does not yet exist. To create a new style:

1 Right-click in any empty space in the Styles and Formatting window.

Make sure you are in the list of styles for the type of style you want to create.
For example, if you are creating a character style, make sure you are in the
character style list.

2 Click New.

3 Click OK.

4 Name your style and choose the settings you want applied with that style.

For details about the style options available in any tab, click that tab and then
click Help.

3.2.4 Using Templates to Format Documents
Most word processor users create more than one kind of document. For example, you
might write letters, memos, and reports, all of which look different and require different
styles. If you create a template for each of your document types, the styles you need
for each document are always readily available.
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Creating a template requires a little bit of up-front planning. You need to determine
how you want the document to look so you can create the styles you need in that tem-
plate. You can always change your template, but a little planning can save you a lot of
time later.

NOTE

You can convert Microsoft Word templates like you would any other Word
document. See Section “Converting Documents to the OpenOffice.org Format”
(page 152) for information.

A detailed explanation of templates is beyond the scope of this section. However, more
information is found in the help system, and detailed how-tos are found at the
OpenOffice.org Documentation page [http://documentation.openoffice
.org/HOW_TO/index.html].

Creating a Template
A template is a text document containing only the styles and content that you want to
appear in every document, such as your address information and letterhead on a letter.
When a document is created or opened with the template, the styles are automatically
applied to that document.

To create a template:

1 Click File > New > Text Document.

2 Create the styles and content that you want to use in any document that uses this
template.

3 Click File > Templates > Save.

4 Specify a name for the template.

5 In the Categories box, click the category you want to place the template in.

The category is the folder where the template is stored.

6 Click OK.
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3.2.5 Working with Large Documents
You can useWriter to work on large documents. Large documents can be either a single
file or a collection of files assembled into a single document.

Navigating in Large Documents
The Navigator tool displays information about the contents of a document. It also lets
you quickly jump to different elements. For example, you can use the Navigator to get
a quick overview of all images included in the document.

To open the Navigator, click Edit > Navigator. The elements listed in the Navigator
vary according to the document loaded in Writer.

Figure 3.3 Navigator Tool in Writer

Click an item in the Navigator to jump to that item in the document.

Using a Master Document to Create a Single
Document from Multiple Files
If you are working with a very large document, such as a book, you might find it easier
to manage the book with a master document, rather than keeping the book in a single
file. A master document enables you to quickly apply formatting changes to a large
document or to jump to each subdocument for editing.
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A master document is a Writer document that serves as a container for multiple Writer
files. You can maintain chapters or other subdocuments as individual files collected in
the master document. Master documents are also useful if multiple people are working
on a document. You can separate each person’s portion of the document into subdocu-
ments collected in a master document, allowing multiple writers to work on their sub-
documents at the same time without fear of overwriting other people’s work.

NOTE

If you are coming to OpenOffice.org from Microsoft Word, you might be ner-
vous about using master documents because the master document feature in
Word has a reputation for corrupting documents. This problem does not exist
in OpenOffice.org Writer, so you can safely use master documents to manage
your projects.

To create a master document:

1 Click New >Master Document.

or

Open an existing document and click File > Send > Create Master Document.

2 Insert subdocuments.

3 Click File > Save.

The OpenOffice.org help files contain more complete information about working with
master documents. Look for the topic entitled “Using Master Documents and Subdoc-
uments.”

TIP

The styles from all of your subdocuments are imported into the master docu-
ment. To ensure that formatting is consistent throughout your master document,
you should use the same template for each subdocument. Doing so is not
mandatory; however, if subdocuments are formatted differently, you might
need to do some reformatting to successfully bring subdocuments into the
master document without creating inconsistencies. For example, if two docu-
ments imported into your master document include different styles with the

168 GNOME User Guide



same name, the master document will use the formatting specified for that
style in the first document you import.

3.2.6 Using Writer as an HTML Editor
In addition to being a full-featured word processor, Writer also functions as an HTML
editor. Writer includes HTML tags that can be applied as you would any other style in
a Writer document. You can view the document as it will appear online, or you can
directly edit the HTML code.

Creating an HTML Document
1 Click File > New > HTML Document.

2 Click the arrow at the bottom of the Formatting and Styles window.

3 Select HTML Styles.

4 Create your HTML document, using the styles to tag your text.

5 Click File > Save As.

6 Select the location where you want to save your file, name the file, and select
HTML Document (.html) from the Filter list.

7 Click OK.

If you prefer to edit HTML code directly, or if you want to see the HTML code created
when you edited the HTML file as a Writer document, click View > HTML Source. In
HTML Source mode, the Formatting and Styles list is not available.

NOTE

The first time you switch to HTML Source mode, you are prompted to save the
file as HTML, if you have not already done so.
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3.3 Using Spreadsheets with Calc
Calc is the OpenOffice.org spreadsheet application. Create a new spreadsheet with File
>New > Spreadsheet or open one with File >Open. Calc can read and save inMicrosoft
Excel's format, so it is easy to exchange spreadsheets with Excel users.

NOTE

Calc can process many VBA macros in Excel documents; however, support for
VBA macros is not complete. When opening an Excel spreadsheet that makes
heavy use of macros, you might discover that some do not work.

In the spreadsheet cells, enter fixed data or formulas. A formula can manipulate data
from other cells to generate a value for the cell in which it is inserted. You can also
create charts from cell values.

• Section 3.3.1, “Using Formatting and Styles in Calc” (page 170)

• Section 3.3.2, “Using Templates in Calc” (page 171)

3.3.1 Using Formatting and Styles in Calc
Calc comes with a few built-in cell and page styles to improve the appearance of your
spreadsheets and reports. Although these built-in styles are adequate for many uses,
you will probably find it useful to create styles for your own frequently used formatting
preferences.

Creating a Style
1 Click Format > Styles and Formatting.

2 In the Formatting and Styles window, click either the Cell Styles or the Page
Styles icon.

3 Right-click in the Formatting and Styles window, then click New.

4 Specify a name for your style and use the various tabs to set the desired formatting
options.
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5 Click OK.

Modifying a Style
1 Click Format > Styles and Formatting.

2 In the Formatting and Styles window, click either the Cell Styles or the Page
Styles icon.

3 Right-click the name of the style you want to change, then clickModify.

4 Change the desired formatting options.

5 Click OK.

3.3.2 Using Templates in Calc
If you use different styles for different types of spreadsheets, you can use templates to
save your styles for each spreadsheet type. Then, when you create a particular type of
spreadsheet, use the applicable template and the styles you need for that template are
available in the Formatting and Styles window.

A detailed explanation of templates is beyond the scope of this section. However, more
information is found in the help system and detailed how-tos are found at the OpenOf-
fice.org Documentation page [http://documentation.openoffice.org/
HOW_TO/index.html].

Creating a Template
ACalc template is a spreadsheet that contains styles and content that you want to appear
in every spreadsheet created with that template, such as headings or other cell styles.
When a spreadsheet is created or opened with the template, the styles are automatically
applied to that spreadsheet.

To create a template:

1 Click File > New > Spreadsheet.
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2 Create the styles and content that you want to use in any spreadsheet that uses
this template.

3 Click File > Templates > Save.

4 Specify a name for the template.

5 In the Categories box, click the category you want to place the template in.

The category is the folder where the template is stored.

6 Click OK.

3.4 Using Presentations with Impress
Use OpenOffice.org Impress to create presentations for screen display or printing, such
as slide shows or transparencies. If you have used other presentation software, you can
move comfortably to Impress, which works very similarly to other presentation software.

Impress can open and save Microsoft Powerpoint presentations, which means you can
exchange presentations with Powerpoint users, as long as you save your presentations
in Powerpoint format.

• Section 3.4.1, “Creating a Presentation” (page 172)

• Section 3.4.2, “Using Master Pages” (page 173)

3.4.1 Creating a Presentation
1 Click File > New > Presentation.

2 Select the option to use for creating the presentation.

There are two ways to create a presentation:

• Create an empty presentation
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Opens Impress with a blank slide. Use this option to create a new presentation
from scratch, without any preformatted slides.

• Create a presentation from a template

Opens Impress with your choice of template. Use this option to create a new
presentationwith a predesignedOpenOffice.org template or a template you’ve
created or installed yourself, such as your company’s presentation template.
Impress uses styles and templates the same way other OpenOffice.org mod-
ules do. See Section 3.2.4, “Using Templates to Format Documents”
(page 165) for more information about templates.

You can also choose to open an existing presentation.

3 Select a slide design and an output medium, then click Next.

The slide design provides a variety of backgrounds and ready-made presentations,
or you can select Original to create your own.

The output medium is the form the final presentation will take, such an overhead
sheet, paper, or a screen slide show, among other choices.

Select Preview for a thumbnail showing your choices.

4 Select the type and speed of slide transitions and the presentation type (the timing
of the presentation), then click Create.

There are several slide transition choices, available from the drop-down.

You can choose either the default presentation type or Automatic. If you select
Automatic, specify the amount of time each page displays and the length of the
pause between presentations.

The presentation opens, ready for editing.

3.4.2 Using Master Pages
Master pages give your presentation a consistent look by defining the way each slide
looks, what fonts are used, and other graphical elements. Impress uses two types of
master pages:
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• Slide master

Contains elements that appear on all slides. For example, you might want your
company logo to appear in the same place on every slide. The slide master also
determines the text formatting style for the heading and outline of every slide that
uses that master page, as well as any information you want to appear in a header
or footer.

• Notes master

Determines the formatting and appearance of the notes in your presentation.

Creating a Slide Master
Impress comes with a collection of preformatted master pages. Eventually, most users
will want to customize their presentations by creating their own slide masters.

1 Start Impress, then create a new empty presentation.

2 Click View >Master > Slide Master.

This opens the current slide master in Master View.

3 Right-click the left-hand panel, then click New Master.

4 Edit the slide master until it has the desired look.

5 Click Close Master View or View > Normal to return to Normal View.

TIP

When you have created all of the slide masters you want to use in your presen-
tations, you can save them in an Impress template. Then, any time you want
to create presentations that use those slide masters, open a new presentation
with your template.

Applying a Slide Master
Slide masters can be applied to selected slides or to all slides in the presentation.
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1 Open your presentation, then click View >Master > Slide Master.

2 (Optional) If you want to apply the slide master to multiple slides, but not to all
slides, select the slides that you want to use that slide master.

To select multiple slides, in the Slides Pane, Control-click on the slides you want
to use that slide master.

3 In the Task Pane, right-click the master page you want to apply.

If you do not see the Task Pane, click View > Task Pane.

4 Apply the slide master by clicking one of the following:.

• Apply to All Slides

Applies the selected slide master to all slides in the presentation.

• Apply to Selected Slides

Applies the selected slide master to the current slide, or to any slides you
select before applying the slide master. For example, if you want to apply a
different slide master to the first slide in a presentation, select that slide, then
change to Master View and apply a slide master to that slide.

3.5 Using Databases with Base
OpenOffice.org includes a database module, Base. Use Base to design a database to
store many different kinds of information, from a simple address book or recipe file to
a sophisticated document management system.

Tables, forms, queries, and reports can be createdmanually or using convenient wizards.
For example, the Table Wizard contains a number of common fields for business and
personal use. Databases created in Base can be used as data sources, such as when
creating form letters.

It is beyond the scope of this document to detail database design with Base. More infor-
mation can be found at the sources listed in Section 3.8, “Finding Help and Information
About OpenOffice.org” (page 180).
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3.5.1 Creating a Database Using Predefined
Options

Base comes with several predefined database fields to help you create a database. The
steps in this section are specific to creating an address book using predefined fields,
but it should be easy to follow them to use the predefined fields for any of the built-in
database options.

The process for creating a database can be broken into several subprocesses:

• Section “Creating the Database” (page 176)

• Section “Setting Up the Database Table” (page 176)

• Section “Creating a Form” (page 178)

• Section “Modifying the Form” (page 178)

• Section “What’s Next?” (page 178)

Creating the Database
First, create the database.

1 Click File > New > Database.

2 Select Create a new database, then click Next.

3 Click Yes, register the database for me to make your database information
available to other OpenOffice.org modules, select both check boxes in the bottom
half of the dialog, then click Finish.

4 Browse to the directory where you want to save the database, specify a name for
the database, then click OK.

Setting Up the Database Table
Next, define the fields you want to use in your database table.
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1 In the Table Wizard, click Personal.

The Sample tables list changes to show the predefined tables for personal use.
If you had clicked Business, the list would contain predefined business tables.

2 In the Sample tables list, click Addresses.

The available fields for the predefined address book appear in the Available
fields menu.

3 In the Available fields menu, click the fields you want to use in your address
book.

You can select one item at a time, or you can shift-click multiple items to select
them.

4 Click the single right-arrow to move the selected items to the Selected fields
menu.

Tomove all available fields to the Selected fieldsmenu, click the double right-
arrow.

5 Use the up-arrow and down-arrow to adjust the order of the selected fields.

The fields appear in the table and forms in the order in which they are listed.

6 Click Next.

7 Make sure each of the fields is defined correctly.

You can change the field name, type, whether the entry is required, and the
maximum length of the field (the number of characters that can be entered in
that field. For this example, leave the settings as they are.

8 Click Next.

9 ClickCreate a primary key, click Automatically add a primary key, click Auto
value, then click Next.

10 Accept the default name for the table, selectCreate a form based on this table,
then click Finish.
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Creating a Form
Next, create the form to use when entering data into your address book.

1 In the Form Wizard, click the double right-arrow to move all available fields to
the Fields in the form list, then click Next twice.

2 Select how you want to arrange your form, then click Next.

3 Select the option to use the form to display all data and leave all of the check
boxes empty, then click Next.

4 Apply a style and field border, then click Next.

For this example, accept the default selections.

5 Name the form, select theModify the form option, then click Finish.

Modifying the Form
After the form has been defined, you can modify the appearance of the form to suit
your preferences.

1 Close the form that opened when you finished the previous step.

2 In the main window for your database, right-click the form you want to modify
(there should be only one option), then click Edit.

3 Arrange the fields on the form by dragging them to their new locations.

For example, move the First Name field so it appears to the right of the Last
Name field, and then adjust the locations of the other fields to suit your preference.

4 When you have finished modifying the form, save it and close it.

What’s Next?
After you have created your database tables and forms, you are ready to enter your data.
You can also design queries and reports to help sort and display the data.
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Refer to OpenOffice.org online help and other sources listed in Section 3.8, “Finding
Help and Information About OpenOffice.org” (page 180) for additional information
about Base.

3.6 Creating Graphics with Draw
Use OpenOffice.org Draw to create graphics and diagrams. You can save your drawings
in today’s most common formats and import them into any application that lets you
import graphics, including the other OpenOffice.org modules. You can also create Flash
versions of your drawings.

The OpenOffice.org documentation contains complete instructions on using Draw. See
Section 3.8, “Finding Help and Information About OpenOffice.org” (page 180) for more
information.

To use a Draw graphic in a document:

1 Open Draw, then create the graphic.

2 Save the graphic.

3 Copy the graphic and paste it into the document, or insert the graphic directly
from the document.

One particularly useful feature of Draw is the ability to open it from other OpenOf-
fice.org modules so you can create a drawing that is automatically imported into your
document.

1 From anOpenOffice.org module (for example, fromWriter), click Insert >Object
> OLE Object > OpenOffice.org 2.3 Drawing > OK.

This opens Draw.

2 Create your drawing.

3 Click in your document, outside the Draw frame.

The drawing is automatically inserted into your document.
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3.7 Creating Mathematical Formulas
with Math

It is usually difficult to include complex mathematical formulas in your documents.
The OpenOffice.org Math equation editor lets you create formulas using operators,
functions, and formatting assistants. You can then save those formulas as objects that
can be imported into other documents. Math functions can be inserted into other
OpenOffice.org documents like any other graphic object.

NOTE

Math is not a calculator. The functions it creates are graphical objects. Even if
they are imported into Calc, these functions cannot be evaluated.

3.8 Finding Help and Information
About OpenOffice.org

OpenOffice.org contains extensive online help. In addition, a large community of users
and developers support it. As a result, it is seldom hard to find help or information about
using the OpenOffice.org. The following table shows some of the places where you
can go for additional information. (Because Web sites often close or their content
changes, the information in the following table might not be current when you read it.)

Table 3.5 Where to Get Information About OpenOffice.org

What You Can FindLocation

Extensive help on performing any task in
OpenOffice.org

OpenOffice.org online help menu

Manuals, tutorials, user and developer
forums, users@openoffice.org mailing
list, FAQs, and much more

Official OpenOffice.org support page
[http://support.openoffice
.org/index.html]
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What You Can FindLocation

Information about migrating to OpenOf-
fice.org from other office suites, including
Microsoft Office

OpenOffice.org Migration Guide
[http://documentation
.openoffice.org/manuals/
oooauthors2/
0600MG-MigrationGuide.pdf]

Books, news, tips and tricksTaming OpenOffice.org [http://www
.taming-openoffice-org.com/
]

Extensive information about creating and
using macros

OpenOffice.org Macros [http://www
.pitonyak.org/oo.php]
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4Evolution: E-Mail and
Calendaring
Evolution™makes the tasks of storing, organizing, and retrieving your personal infor-
mation easy, so you can work and communicate more effectively with others. It’s a
highly evolved groupware program, an integral part of the Internet-connected desktop.

Evolution can help you work in a group by handling e-mail, address, and other contact
information, and one or more calendars. It can do that on one or several computers,
connected directly or over a network, for one person or for large groups.

With Evolution, you can accomplish your most common daily tasks quickly. For exam-
ple, it takes only one or two clicks to enter appointment or contact information sent to
you by e-mail, or to send e-mail to a contact or appointment. People who get lots of e-
mail will appreciate advanced features like search folders, which let you save searches
as though they were ordinary e-mail folders.

This chapter introduces you to Evolution and helps you get started using it. For complete
information, refer to the Evolution documentation.

• Section 4.1, “Starting Evolution for the First Time” (page 184)

• Section 4.2, “Using Evolution: An Overview” (page 195)
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4.1 Starting Evolution for the First
Time

Start the Evolution client by clickingComputer > Evolution, or by typing evolution
in a terminal window.

4.1.1 Using the Setup Assistant
The first time you run Evolution, it creates a directory called .evolution in your
home directory, where it stores all of its local data. Then, it opens a Setup Assistant to
help you set up e-mail accounts and import data from other applications.

Using the Setup Assistant takes two to five minutes.

Later on, if you want to change this account, or if you want to create a new one, click
Edit > Preferences, then clickMail Accounts. Select the account you want to change,
then click Edit. Alternately, add a new account by clicking Add.

The Setup Assistant helps you provide the information Evolution needs to get started.

• Section “Defining Your Identity” (page 184)

• Section “Receiving Mail” (page 185)

• Section “Receiving Mail Options” (page 188)

• Section “Sending Mail” (page 193)

• Section “Account Management” (page 194)

• Section “Time Zone” (page 194)

• Section “Importing Mail (Optional)” (page 195)

Defining Your Identity
The Identity window is the first step in the assistant.
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Here, you enter some basic personal information. You can define multiple identities
later by clicking Edit > Preferences, then clickingMail Accounts.

When the First-Run Assistant starts, the Welcome page is displayed. Click Forward to
proceed to the Identity window.

1 Type your full name in the Full Name field.

2 Type your e-mail address in the E-Mail Address field.

3 (Optional) Select if this account is your default account.

4 (Optional) Type a reply to address in the Reply-To field.

Use this field if you want replies to e-mails sent to a different address.

5 (Optional) Type your organization name in the Organization field.

This is the company where you work, or the organization you represent when
you send e-mail.

6 Click Forward.

Receiving Mail
The Receiving E-mail option lets you determine where you get your e-mail.

You need to specify the type of server you want to receive mail with. If you are unsure
about the type of server to choose, ask your system administrator or ISP.

• Select a server type in the Server Type list.

The following a list of server types that are available:

Novell GroupWise: Select this option if you connect to Novell®GroupWise®.
Novell GroupWise keeps e-mail, calendar, and contact information on the server.

Microsoft Exchange: Available only if you have installed the Connector for
Microsoft* Exchange. It allows you to connect to a Microsoft Exchange 2000
or 2003 server, which stores e-mail, calendar, and contact information on the
server.
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IMAP: Keeps the e-mail on your server so you can access your e-mail from
multiple systems.

IMAP4rev1: Keeps the e-mail on your server so you can access your e-mail
from multiple systems.

POP: Downloads your e-mail to your hard disk for permanent storage, freeing
up space on the e-mail server.

USENETNews: Connects to the news server and downloads a list of available
news digests.

Local Delivery: Choose this option if you want to move e-mail from the spool
(the location where mail waits for delivery) and store it in your home directory.
You need to provide the path to the mail spool you want to use. If you want to
leave e-mail in your system’s spool files, choose the Standard Unix Mbox Spool
option instead.

MH Format Mail Directories: If you download your e-mail using mh or an-
other MH-style program, you should use this option. You need to provide the
path to the mail directory you want to use.

Maildir FormatMail Directories: If you download your e-mail using Qmail
or another maildir-style program, you should use this option. You need to provide
the path to the mail directory you want to use.

Standard Unix Mbox Spool or Directory: If you want to read and store e-
mail in the mail spool on your local system, choose this option. You need to
provide the path to the mail spool you want to use.

None: Select this if you do not plan to check e-mail with this account. If you
select this, there are no configuration options.

Remote Configuration Options

If you selected Novell GroupWise, IMAP, POP, or USENET News as your server, you
need to specify additional information.

1 Type the hostname of your e-mail server in the Hostname field.

If you don’t know the hostname, contact your administrator.
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2 Type your username for the account in the Username field.

3 Select to use a secure (SSL) connection.

If your server supports secure connections, you should enable this security option.
If you are unsure if your server supports a secure connection, contact your system
administrator.

4 Select your authentication type in the Authentication list.

or

Click Check for Supported Types to have Evolution check for supported types.
Some servers do not announce the authentication mechanisms they support, so
clicking this button is not a guarantee that available mechanisms actually work.

If you are unsure what authentication type you need, contact your system admin-
istrator.

5 Select if you want Evolution to remember your password.

6 Click Forward.

7 (Conditional) If you chose Microsoft Exchange, provide your username in the
Username field and your Outlook Web Access (OWA) URL in the OWA Url
field. OWA URL and user names should be entered as in OWA. If the mail box
path is different from the username, OWA path should include mail box path
also. You should see something similar to this: http://<server name>/ex-
change/<mail box path>

When you have finished, continue with Section “Receiving Mail Options” (page 188).

Local Configuration Options

If you selected Local Delivery, MH-Format Mail Directories, Maildir-Format Mail
Directories, or Standard Unix Mbox Spool or Directory, you must specify the path to
the local files in the path field. Continue with Section “Receiving Mail Options”
(page 188).
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Receiving Mail Options
After you have selected a mail delivery mechanism, you can set some preferences for
its behavior.

• Section “Novell GroupWise Receiving Options” (page 188)

• Section “Microsoft Exchange Receiving Options” (page 189)

• Section “IMAP and IMAP4rev1 Receiving Options” (page 190)

• Section “POP Receiving Options” (page 191)

• Section “USENET News Receiving Options” (page 191)

• Section “Local Delivery Receiving Options” (page 192)

• Section “MH-Format Mail Directories Receiving Options” (page 192)

• Section “Maildir-Format Mail Directories Receiving Options” (page 192)

• Section “Standard Unix Mbox Spool or Directory Receiving Options” (page 193)

Novell GroupWise Receiving Options

If you select Novell GroupWise as your receiving server type, you need to specify the
following options:

1 Select if you want Evolution to automatically check for new mail.

If you select this option, you need to specify how often Evolution should check
for new messages.

2 Select if you want to check for new messages in all folders.

3 Select if you want to apply filters to new messages in the Inbox on the server.

4 Select if you want to check new messages for junk content.

5 Select if you want to only check for junk messages in the Inbox folder.
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6 Select if you want to automatically synchronize remote mail locally.

7 Type your Post Office Agent SOAP port in the Post Office Agent SOAP Port
field.

If you are unsure what your Post Office Agent SOAP port is, contact your system
administrator.

8 Click Forward.

When you have finished, continue with Section “Sending Mail” (page 193).

Microsoft Exchange Receiving Options

If you select Microsoft Exchange as your receiving server type, you need to specify the
following options.

1 Select if you want Evolution to automatically check for new mail.

If you select this option, you need to specify how often Evolution should check
for new messages.

2 Specify the Global Catalog server name in theGlobal Catalog Server Name field.

The Global Catalog Server contains the user information for users. If you are
unsure what your Global Catalog server name is, contact your system adminis-
trator.

3 Select if you want to limit the number of Global Address Lists (GAL).

The GAL contains a list of all e-mail addresses. If you select this option, you
need to specify the maximum number of responses.

4 Select if you want the password expire warning period.

If you select this option, you need to specify how often Evolution should send
the password expire message.

5 Select if you want to automatically synchronize remote mail locally.

6 Click Forward.
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When you have finished, continue with Section “Sending Mail” (page 193).

IMAP and IMAP4rev1 Receiving Options

If you select IMAP or IMAP4rev1 as your receiving server type, you need to specify
the following options:

1 Select if you want Evolution to automatically check for new mail.

If you select this option, you need to specify how often Evolution should check
for new messages.

2 Select if you want Evolution to use custom commands to connect to Evolution.

If you select this option, specify the custom command you want Evolution to
use.

3 Select if you want Evolution to show only subscribed folders.

Subscribed folders are folders that you have chosen to receive mail from by
subscribing to them.

4 Select if you want Evolution to override server-supplied folder namespaces.

By choosing this option you can rename the folders that the server provides. If
you select this option, you need to specify the namespace to use.

5 Select if you want to apply filters to new messages in the Inbox.

6 Select if you want to check new messages for junk content.

7 Select if you want to check for junk messages in the Inbox folder.

8 Select if you want to automatically synchronize remote mail locally.

9 Click Forward.

When you have finished, continue with Section “Sending Mail” (page 193).
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POP Receiving Options

If you select POP as your receiving server type, you need to specify the following op-
tions:

1 Select if you want Evolution to automatically check for new mail.If you select
this option, you need to specify how often Evolution should check for new mes-
sages.

2 Select if you want to leave messages on the server.

3 Select if you want to disable support for all POP3 extensions (support for POP3).

4 Click Forward.

When you have finished, continue with Section “Sending Mail” (page 193).

USENET News Receiving Options

If you select USENET News as your receiving server type, you need to specify the
following options:

1 Select if you want Evolution to automatically check for new mail.If you select
this option, you need to specify how often Evolution should check for new mes-
sages.

2 Select if you want to show folders in short notation.

For example, comp.os.linux would appear as c.o.linux.

3 Select if you want to show relative folder names in the subscription dialog box.

If you select to show relative folder names in the subscription page, only the
name of the folder is displayed. For example the folder evolution.mail would
appear as evolution.

4 Click Forward.

When you have finished, continue with Section “Sending Mail” (page 193).
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Local Delivery Receiving Options

If you select Local Delivery as your receiving server type, you need to specify the fol-
lowing options:

1 Select if you want Evolution to automatically check for new mail.If you select
this option, you need to specify how often Evolution should check for new mes-
sages.

2 Click Forward.

When you have finished, continue with Section “Sending Mail” (page 193).

MH-Format Mail Directories Receiving Options

If you select MH-Format Mail Directories as your receiving server type, you need to
specify the following options:

1 Select if you want Evolution to automatically check for new mail.If you select
this option, you need to specify how often Evolution should check for new mes-
sages.

2 Select if you want to user the .folders summary file.

3 Click Forward.

When you have finished, continue with Section “Sending Mail” (page 193).

Maildir-Format Mail Directories Receiving Options

If you select Maildir-Format Mail Directories as your receiving server type, you need
to specify the following options:

1 Select if you want Evolution to automatically check for new mail.If you select
this option, you need to specify how often Evolution should check for new mes-
sages.

2 Select if you want to apply filters to new messages in the Inbox.

3 Click Forward.
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When you have finished, continue with Section “Sending Mail” (page 193).

Standard Unix Mbox Spool or Directory Receiving Options

If you select Standard Unix Mbox Spool or Directory as your receiving server type,
you need to specify the following options:

1 Select if you want Evolution to automatically check for new mail.If you select
this option, you need to specify how often Evolution should check for new mes-
sages.

2 Select if you want to apply filters to new messages in the Inbox.

3 Select if you want to store status headers in Elm, Pine, and Mutt formats.

4 Click Forward.

When you have finished, continue with Section “Sending Mail” (page 193) Section
“Sending Mail” (page 193).

Sending Mail
Now that you have entered information about how you plan to get mail, Evolution needs
to know about how you want to send it.

• Select a server type from the Server Type list.

The following server types are available:

Sendmail: Uses the Sendmail program to send mail from your system. Send-
mail is more flexible, but is not as easy to configure, so you should select this
option only if you know how to set up a Sendmail service.

SMTP: Sends mail using an outbound mail server. This is the most common
choice for sending mail. If you choose SMTP, there are additional configuration
options.

SMTP Configuration

1 Type the host address in the Host field.
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If you are unsure what your host address is, contact your system administrator.

2 Select if your server requires authentication.

If you selected that your server requires authentication, you need to provide the
following information:

2a Select your authentication type in the Authentication list.

or

Click Check for Supported Types to have Evolution check for supported
types. Some servers do not announce the authentication mechanisms they
support, so clicking this button is not a guarantee that available mechanisms
actually work.

2b Type your username in the Username field.

2c Select if you want Evolution to remember your password.

3 Select if you use a secure connection (SSL).

4 Click Forward.

Continue with Section “Account Management” (page 194).

Account Management
Now that you have finished the e-mail configuration process you need to give the account
a name. The name can be any name you prefer. Type your account name on the Name
field, then click Forward.

Continue with Section “Time Zone” (page 194).

Time Zone
In this step, you need to select your time zone either on the map or select from the time
zone drop-down list.
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When you have finished, click Forward, then click Apply. Evolution opens with your
new account created.

If youwant to import e-mail from another e-mail client, continuewith Section “Importing
Mail (Optional)” (page 195). If not, skip to Section 4.2, “Using Evolution: AnOverview”
(page 195).

Importing Mail (Optional)
If Evolution finds e-mail or address files from another application, it offers to import
them.

Microsoft Outlook* and versions of Outlook Express after version 4, use proprietary
formats that Evolution cannot read or import. To import information, you might want
to use the Export tool under Windows*.

Before importing e-mail from Netscape*, make sure you have selected File > Compact
All Folders. If you don’t, Evolution will import and undelete the messages in your Trash
folders.

NOTE

Evolution uses standard file types for e-mail and calendar information, so you
can copy those files from your ~/.evolution directory. The file formats
used are mbox for e-mail and iCal for calendar information.

Contacts files are stored in a database, but can be saved as a standard vCard*.
To export contact data, open your contacts tool and select the contacts you
want to export (press Ctrl+A to select them all). Click File > Save as VCard.

4.2 Using Evolution: An Overview
Now that the first-run configuration has finished, you’re ready to begin using Evolution.
Here’s a quick explanation of what’s happening in your main Evolution window.

Evolution: E-Mail and Calendaring 195



Figure 4.1 Evolution Window

Menu Bar
The menu bar gives you access to nearly all of Evolution features.

Folder List
The folder list gives you a list of the available folders for each account. To see the
contents of a folder, click the folder name and the contents are displayed in the e-mail
list.

Toolbar
The toolbar gives you fast and easy access to the frequently used features in each
component.
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Search Tool
The search tool lets you search your e-mail, contacts, calendar, and tasks to easily find
what you’re looking for.

Message List
The message list displays a list of e-mail that you have received. To view an e-mail in
the preview pane, click the e-mail in the e-mail list.

Shortcut Buttons
The shortcut bar lets you switch between folders and between Evolution tools. At the
bottom of the shortcut bar there are buttons that let you switch tools, and above that is
a list of all the available folders for the current tool. If you have the Evolution Connector
for Microsoft Exchange installed, you have an Exchange button in addition to buttons
for the other tools.

Status Bar
The status bar periodically displays a message, or tells you the progress of a task. This
most often happens when you’re checking or sending e-mail. These progress queues
are shown in the previous figure. The Online/Offline indicator is here, too, in the lower
left of the window.

Preview Pane
The preview pane displays the contents of the e-mail that is selected in the e-mail list.

4.2.1 The Menu Bar
The menu bar’s contents always provide all the possible actions for any given view of
your data. If you’re looking at your Inbox, most of the menu items relate to e-mail.
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Some content relates to other components of Evolution and some, especially those in
the File menu, relates to the application as a whole.

File: Anything related to a file or to the operations of the application usually falls
under this menu, such as creating things, saving them to disk, printing them, and quitting
the program itself.

Edit: Holds useful tools that help you edit text and move it around. Lets you access
the settings and configuration options in the Edit menu.

View: Lets you decide how Evolution should look. Some of the features control the
appearance of Evolution as a whole, and others the way a particular kind of information
appears.

Folder: Holds actions that can be performed on folders. You can find things like
copy, rename, delete, and so on.

Message: Holds actions that can be applied to a message. If there is only one target
for the action, such as replying to a message, you can normally find it in the Message
menu.

Search: Lets you search for messages, or for phrases within a message. You can also
see previous searches you have made. In addition to the Search menu, there is a text
entry box in the toolbar that you can use to search for messages. You can also create a
search folder from a search.

Help: Opens the Evolution Help files.

4.2.2 The Shortcut Bar
Evolution’s most important job is to give you access to your information and help you
use it quickly. One way it does that is through the shortcut bar, which is the column on
the left side of the main window. The buttons, such as Mail and Contacts, are the
shortcuts. Above them is a list of folders for the current Evolution tool.

The folder list organizes your e-mail, calendars, contact lists, and task lists in a tree,
similar to a file tree. Most people find one to four folders at the base of the tree, depend-
ing on the tool and their system configuration. Each Evolution tool has at least one,
called On This Computer, for local information. For example, the folder list for the e-

198 GNOME User Guide



mail tool shows any remote e-mail storage you have set up, plus local folders and search
folders.

If you get large amounts of e-mail, you might want more folders than just your Inbox.
You can create multiple calendar, task, or contacts folders.

To create a new folder:

1 Click Folder > New.

2 Type the name of the folder in the Folder Name field.

3 Select the location of the new folder.

4 Click OK.

Folder Management
Right-click a folder or subfolder to display a menu with the following options:

Copy: Copies the folder to a different location. When you select this item, Evolution
offers a choice of locations to copy the folder to.

Move: Moves the folder to another location.

Mark Messages As Read: Marks all the messages in the folder as read.

New Folder: Creates another folder in the same location.

Delete: Deletes the folder and all its contents.

Rename: Lets you change the name of the folder.

Disable: Disables the account.

Properties: Checks the number of total and unread messages in a folder, and, for
remote folders, lets you select whether to copy the folder to your local system for offline
operation.

You can also rearrange folders and messages by dragging and dropping them.
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Any time new e-mail arrives in a e-mail folder, that folder label is displayed in bold
text, along with the number of new messages in that folder.

4.2.3 E-Mail
Evolution e-mail is like other e-mail programs in several ways:

• It can send and receive e-mail in HTML or as plain text, and makes it easy to send
and receive multiple file attachments.

• It supports multiple e-mail sources, including IMAP, POP3, and local mbox or mh
spools and files created by other e-mail programs.

• It can sort and organize your e-mail in a wide variety of ways with folders,
searches, and filters.

• It lets you guard your privacy with encryption.

However, Evolution has some important differences from other e-mail programs. First,
it’s built to handle very large amounts of e-mail. The junk e-mail, message filtering
and searching functions were built for speed and efficiency. There’s also the search
folder, an advanced organizational feature not found in some e-mail clients. If you get
a lot of e-mail, or if you keep every message you get in case you need to refer to it later,
you’ll find this feature especially useful. Here’s a quick explanation of what’s happening
in your main Evolution e-mail window.

Message List
The message list displays all the e-mails that you have. This includes all your read and
unread messages, and e-mail that is flagged to be deleted.

Preview Pane
This is where your e-mail is displayed.

If you find the preview pane too small, you can resize the pane, enlarge the whole
window, or double-click the message in the message list to have it open in a new win-
dow. To change the size of a pane, drag the divider between the two panes.
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As with folders, you can right-click messages in the message list and get a menu of
possible actions, including moving or deleting them, creating filters or search folders
based on them, and marking them as junk mail.

Most of the e-mail-related actions you want to perform are listed in the Actions menu
in the menu bar. The most frequently used ones, like Reply and Forward, also appear
as buttons in the toolbar. Most of them are also located in the right-click menu and as
keyboard shortcuts.

4.2.4 The Calendar
To begin using the calendar, click Calendar in the shortcut bar. By default, the calendar
shows today’s schedule on a ruled background. At the upper right, there’s a monthly
calendar you can use to switch days. Below that, there’s a Task list, where you can keep
a list of tasks separate from your calendar appointments.

Appointment List
The appointment list displays all your scheduled appointments.

Month Pane
The month pane is a small view of a calendar month. To display additional months,
drag the column border to the left. You can also select a range of days in the month
pane to display a custom range of days in the appointment list.

Task List
Tasks are distinct from appointments because they generally don’t have times associated
with them. You can see a larger view of your task list by clicking Tasks in the shortcut
bar.

4.2.5 The Contacts Tool
The Evolution contacts tool can handle all of the functions of an address book or phone
book. However, it’s easier to update Evolution than it is to change an actual paper book,
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in part because Evolution can synchronize with PalmOS* devices and use LDAP direc-
tories on a network.

Another advantage of the Evolution contacts tool is its integration with the rest of the
application. For example, you can right-click on an e-mail address in Evolution mail
to instantly create a contact entry.

To use the contacts tool, clickContacts in the shortcut bar. By default, the display shows
all your contacts in alphabetical order, in a minicard view. You can select other views
from the Viewmenu, and adjust the width of the columns by clicking and dragging the
gray column dividers.

The largest section of the contacts display shows a list of individual contacts. You can
also search the contacts in the same way that you search e-mail folders, using the search
tool on the right side of the toolbar.
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5Synchronizing Your Handheld
Devices with GNOME Pilot
GNOME Pilot lets you integrate your GNOME desktop with handheld computers. You
can use it to set up and perform synchronization between PDAs and your GNOME
desktop.

Thegnome-pilot package, alongwith the optional conduits inevolution-pilot,
allows you to move information between your handheld device and your GNOME
desktop. You must run the setup tool before synchronizing. The setup tool starts the
GNOME Pilot daemon, gpilotd. If it is not running, you can start the daemon with
the/usr/libexec/gpilotd command. You can also use theGNOMEPilot applet
to start the daemon.

To start the GNOME Pilot applet, click Computer >More Applications > System >
GNOME Pilot.

• Section 5.1, “GNOME Pilot Configuration Tool” (page 203)

• Section 5.2, “The Pilot Applet” (page 209)

5.1 GNOME Pilot Configuration Tool
To start the GNOME Pilot configuration tool, click Computer >More Applications >
System > GNOME Pilot.

There are three tabs in the Pilot Settings tool: Pilots, Devices, and Conduits. The first
time you run the GNOME Pilot tools, you will be guided through the initial setup by
an assistant.
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• Section 5.1.1, “The GNOME Pilot Setup Assistant” (page 204)

• Section 5.1.2, “Adding or Editing a Handheld Entry” (page 206)

• Section 5.1.3, “Adding or Editing an Entry On the Device Settings Tab” (page 207)

• Section 5.1.4, “Conduit Settings” (page 208)

5.1.1 The GNOME Pilot Setup Assistant
The setup assistant guides you through getting your handheld device ready to synchronize
with your desktop system.

1 Click Computer >More Applications > System > GNOME Pilot, then click
Forward to start the GNOME Pilot Setup Assistant

2 In the Device Settings dialog box, describe your handheld's cradle, then click
Forward.

See Section 5.1.3, “Adding or Editing an Entry On the Device Settings Tab”
(page 207) for more information about the information requested by this step.
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3 In the PDA Identification dialog box, identify your device, then click Forward.

If you have previously used synchronization software with this PDA, it will al-
ready have a synchronization ID that your desktop can get from it. If you have
not, you can set the username and ID on the PDA from your desktop.

4 On the Initial Sync dialog box, click Forward to contact your PDA device and
get or set the name and other information.
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5 Choose a name to use when referring to the PDA, and a directory on your desktop
system where you will store backups and other data.

5.1.2 Adding or Editing a Handheld Entry
The Pilots tab lists the handheld devices you have configured. If you have not used the
Pilot Settings tool before, you will not have any items in this list, and the tool will open
a new window to walk you through the process of creating one. To add a new pilot,
click Add. To edit an existing pilot entry, select it and click Edit.

When editing or creating an entry, you will be asked for five pieces of information:

• User Name: This is the name used on your Pilot. If your pilot already has a name
configured, you can get it from the pilot by clicking the Get from Pilot button. You
can also set it on the pilot by clicking the Set On Pilot button.

• ID: This is the user ID number from your pilot. You can get this value from the
handheld by clicking the Get from Pilot button. You can also set it on the handheld
by clicking the Set On Pilot button.

• Pilot Name: This is the name by which your handheld will be identified. For
example, you could call it MyPilot, or Palm5, or Roger.

• Local Basedir: This is the directory where you will store information backed
up from your handheld.
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• Sync Action: This is the action that will be performed when you press the Hot-
Sync button on your cradle. If you set this option to Use conduit settings, then you
can choose different actions depending on the type of data being handled. If you
set it to anything else, all data will be handled the same way. For descriptions of
the synchronization actions, see Section 5.1.4, “Conduit Settings” (page 208).

5.1.3 Adding or Editing an Entry On the
Device Settings Tab

The Device Settings tab controls the way your desktop system looks at your handheld
as hardware. To add an entry to the list, click Add. To edit a device, select it, then click
Edit.

For each entry, you can specify the following options:

• Name: This is the name used to display the device in a list.

• Type: Select the type of connection you have: Serial, USB, IrDA (infrared), or
Network.

• Timeout: Specifies the amount of time to try to connect to the system, in seconds.
If there is no communication between the desktop and the handheld for this many
seconds, the system will stop trying.

• Device: Your handheld is represented to the computer as a special file in the
/dev directory. The name of the file will vary from system to system. In many
cases, however, it will be /dev/pilot. Other possible values are /dev/ttyS0
or /dev/ttyS1 for serial cradles (under Windows, these are referred to as COM
ports), or /dev/usb/, for USB cradles.

You will need to make sure that your user account has read, write, and execute
permissions on this device. To add those permissions, become root with the su
command and enter the command chmod a+wrx /dev/ttyS0. Substitute the
name of the device you are setting.

If you have not chosen the correct device, you will get an error message when you
click OK.
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• Speed: Select a number from the drop-down menu. The higher the number, the
faster you are asking the system to transfer information. Normally, you should not
change this option, because it is set by default for the fastest value that your con-
nection type can provide. If you experience problems at high speeds, reducing the
transfer speed might help.

5.1.4 Conduit Settings
AConduit is a specialized program that channels data between your computer and your
handheld. The gnome-pilot package includes several, and you can also install additional
conduits such as those for Evolution.

Each configured handheld might have its own set of conduits and conduit settings.

If a conduit is disabled, that type of data will be ignored when you HotSync. If a conduit
is enabled, its data will be synchronized according to its settings. To enable or disable
a conduit, select it and click the Enable or Disable button on the right side of the list
of conduits.

To edit the settings, select a conduit and click the Settings button. Each conduit will
have at least two settings: an Action to perform whenever you synchronize, and a One
Time Action, performed only the next time you synchronize.

Not all conduits will have all of these actions. The list of possible actions includes the
following:

• Disabled: Do nothing.

• Synchronize: Ensures that data is the same in both places, copying new data
from the pilot to the desktop, and from the desktop to the computer.

• Copy to pilot: Copies all data from the desktop to the pilot. New data added on
the pilot will not be copied to the desktop.

• Copy from pilot: Copy all data from the pilot to the desktop. New data added
on the desktop will not be copied to the pilot.

Other settings might be available as well, includingConduit Priority, which determines
the order in which conduits will be used, and Sync Private Records, which determines
whether to copy private information as well as public, or just the public data.
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5.2 The Pilot Applet
The GNOME Pilot panel applet sits in your panel until you are ready to synchronize
your handheld device. If the pilot access daemon is running, the applet will appear in
black and white. If it is not running, the applet will appear red and black. If the daemon
is paused, the applet will be yellow and black.

Click the applet button to start the GNOME Pilot configuration tool.

The following actions for the applet are available in the right-click menu:

• Restore: If your PalmOS device has lost all data, select this item to restore it
from a backup you made earlier.

• Pause Daemon: Pauses the GNOME Pilot daemon gpilotd. If the daemon is
paused, this item will read Continue.

• Restart: Stops and restarts the daemon.

• Last Log: Displays the results of the last synchronization performed.

• Preferences: Click this item to select what happens when you click the applet,
and whether to display notices in dialog boxes.
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6Instant Messaging with Pidgin
Use Pidgin (formerly called Gaim) to use all of your instant messaging accounts from
a single instant messaging client. Pidgin supports all of the most popular instant mes-
saging protocols, so you can log in to all of your accounts at once and chat live with
your contacts in one tabbed interface, regardless of which IM system they use.

With Pidgin, you can log in to multiple accounts on multiple IM networks simultane-
ously. Pidgin also supports many features of the various networks, such as file transfer,
away messages, and typing notification.

This chapter explains the Pidgin options you need to know about to set up Pidgin and
communicate with your contacts. It does not explain all of Pidgin features and options.
For more information, open Pidgin, then click Help > Online Help or press F1.

• Section 6.1, “Supported Protocols” (page 211)

• Section 6.2, “Adding an Account” (page 212)

• Section 6.3, “Managing Your Buddy List” (page 213)

• Section 6.4, “Chatting” (page 215)

6.1 Supported Protocols
Pidgin supports the following instant messaging protocols:

• AOL* Instant Messenger (AIM)
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• Bonjour

• Gadu-Gadu

• Google Talk

• GroupWise Messenger

• ICQ

• IRC

• Jabber/XMPP

• MSN Messenger

• QC

• SILC

• SIMPLE

• Yahoo!*

• Zephyr*

6.2 Adding an Account
To use Pidgin, you must already have accounts on the systems you want to use. For
example, to use Pidgin for your AIM account, you must first have an AIM account.
Once you have those accounts, set them up in the Pidgin Add Account dialog.

1 Start Pidgin by clicking Computer >More Applications > Internet > Pidgin.

2 Click Accounts > Add/Edit to open the Accounts dialog box.

The first time you run Pidgin, or any subsequent time you start Pidgin when you
don’t have any accounts set up, the Accounts dialog box opens automatically.

3 Click Add to open the Add Account dialog.
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4 Select the protocol you want to set up.

TheAdd Account dialog differs for each protocol, depending onwhat setup options
are available for that protocol.

5 Enter the setup options for the chosen protocol.

Typical options include your account name and password. Your protocol might
support additional options, such as a buddy icon, alias, login options, or others.

6 Click Save.

7 Repeat Steps 2 to 5 for each additional protocol.

After an account is added, you can log in to that account by entering your password in
the Pidgin login dialog box.

6.3 Managing Your Buddy List
Use the Buddy List to manage your contacts, also known as buddies. You can add and
remove buddies from your Buddy List, and you can organize your buddies in groups
so they are easy to find.
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6.3.1 Displaying Buddies in the Buddy List
After your accounts are set up, all buddies who are online appear in your Buddy List.
If you also want your buddies who are not online to appear in the Buddy List, click
Buddies > Show Offline Buddies.

Figure 6.1 Pidgin Buddy List

6.3.2 Adding a Buddy
To add a buddy to your Buddy List, click Buddies > Add Buddy, then enter the informa-
tion about that buddy.

NOTE

For some protocols, you cannot add a buddy in the Pidgin interface. You must
use the client for those protocols if you want to add to your buddy list. After
you have added a buddy in the protocol’s client, that buddy appears in your
Buddy List.
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6.3.3 Removing a Buddy
To remove a buddy, right-click on that buddy’s name in the Buddy List, then click Re-
move.

6.4 Chatting
To open a chat session, double-click a buddy name in the Buddy List. The Chat screen
opens. Type your message, then press Enter to send it.

Each chat session you open appears as a tab in the Chat screen. Click on a buddy’s tab
to chat with that buddy. Close a chat session by closing the tab for that buddy.

Figure 6.2 Pidgin Chat Session
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7Using Voice over IP with Ekiga
Modern telecommunicationmeans far more than just doing a phone call. It is also about
exchanging text messages and sometimes even video conferencing. Roaming enables
you to be reachable under one phone number all across the world. Ekiga brings these
features to your Linux desktop allowing you to communicate over broadband Internet.

Before you start, make sure the following requirements are met:

• Your sound card is properly configured.

• A headset or a microphone and speakers are attached to your computer.

• For dialing in to regular phone networks you have created a SIP account. SIP
(Signaling protocol for Internet Telephony) is the protocol used to establish sessions
for audio and video conferencing or call forwarding. For a list of providers refer
to http://www.voipproviderslist.com/. Free trials are provided by
http://www.voipbuster.com.

• For video conferencing you have attached a Web cam to your computer.

7.1 Configuring Ekiga
On first start, Ekiga comes up with a configuration assistant that requests you to enter
all data needed to configure your instance of Ekiga. To configure Ekiga, proceed as
follows:
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1 Enter your user name (name and surname).

2 Enter your ekiga.net account data or choose not to sign up to ekiga
.net.

To add other accounts later on, configure them using Edit > Accounts.

3 Determine your connection type.

4 Determine the type of firewall to use to enable you to perform calls with Ekiga.

5 Choose the audio manager to use. Accept the default setting ALSA, as it
guarantees the best sound quality and other sound systems like OSS are not
available on openSUSE.

6 Choose the audio input and output devices and test your settings.

7 Accept the video manager selection, V4L.

8 Choose the video input device and test your settings.

9 Check the summary of your settings and apply them.

10 If registration fails after you made changes to your configuration, just restart
Ekiga.

Ekiga allows you to maintain multiple accounts. To configure an additional account,
proceed as follows:

1 Open Edit > Accounts and select Add.

2 Choose an Account Name.

3 Select an appropriate Protocol depending on what type of account you use.
Normally, you would select SIP here.

4 Enter the Registrar to which you want to register. This is usually an IP address
or a host name that will be given to you by your Internet Telephony Service
Provider. Enter User and Password according to the data provided by your
provider.
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5 Leave the configuration dialog with OK and activate the account.

The status of your account displayed in the Ekiga main window changes to
Registered.

7.2 The Ekiga User Interface
All functions of Ekiga are available via the menu bar. Shortcuts to the most important
functions are provided bymeans of a toolbar to the left and by special key combinations.

Figure 7.1 Ekiga User Interface

The user interface has different modes. To switch between views, use View > View
Mode and View > Control Panel or select the view mode icon on the left side of the
GUI and the different tabs at the bottom. The Full View is shown in Figure 7.1, “Ekiga
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User Interface” (page 219). All icons in the toolbar provide a tool tip that is activated
on hovering over the icon with your mouse pointer.

At the bottom of the user interface, several tabs provide the functionality for Dialpad,
Audio, Video and Statistics. Some settings like the Audio settings may only be changed
during a phone call.

Many of functions of Ekiga are available via keyboard shortcuts. Table 7.1, “Keyboard
Shortcuts for Ekiga” (page 220) summarizes the most important ones.

Table 7.1 Keyboard Shortcuts for Ekiga

DescriptionCtrl Sequence

Initiate a call with the current number.Ctrl + O

Hang up.Ctrl + D

Hold the current call.Ctrl + G

Transfer the current call to another party.Ctrl + T

Save the current picture to hard disk.Ctrl + S

Close the Ekiga user interface.Ctrl +W

Quit Ekiga.Ctrl + Q

Start the Accounts manager.Ctrl + E

Open the Ekiga Preferences overview. This dialog al-
lows you to do some fine-tuning to your Ekiga settings.

Ctrl + P

Zoom in to the picture of the Web cam.Ctrl + +

Zoom out or the picture of the Web cam.Ctrl + -

Return to the normal size of the Web cam display.Ctrl + =

Use full screen for the Web cam.Ctrl + F
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DescriptionCtrl Sequence

Display the history of your calls.Ctrl + H

7.3 Making a Call
Once Ekiga is configured appropriately, making a call is straightforward.

1 Start Ekiga using the menu or the command line.

2 Enter the SIP address of the other party at the SIP address prompt. The address
should look like:

• for direct local calls: sip:username@domainnameor
username@hostname

• for proxied calls or calls using the service of a SIP provider:
username@sipserver or userid@sipserver

If you have a SIP provider who accepts real phone calls, you may just enter the
number like sip:<call number>

3 Click Call or type Ctrl + O and wait for the other party to pick up the phone.

4 Once you are done or wish to end the call, click Hang up or type Ctrl + D.

If you need to tweak the sound parameters during a call, click View > View Mode >
Full View to show four tabs holding more options. The second one holds the Audio
options for Playback level and Recording level. Use the sliders to adjust both volumes
to fit your needs.

7.4 Answering a Call
Ekiga can receive calls in two different ways. First, the user may be called directly with
sip:user@host. Alternatively, make your calls via a SIP provider. Most SIP
providers enable you to get calls from a normal land line to your VoIP account. Depend-
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ing on the mode Ekiga is run, there are several ways in which you would notice an in-
coming call:

Normal Application
Incoming calls can only be received and answered if Ekiga is already running. You
hear the ring sound on your headset or your speakers. If Ekiga is not running, the
call cannot be received.

Panel Applet
Normally, the Ekiga panel applet would run silently without giving any notice of
its existence. This changes as soon as a call comes in. The main window of Ekiga
opens and you hear a ring sound on your headset or speakers.

Once you have noticed an incoming call, just click Accept to pick up the phone and
start talking. If you do not want to accept this call, click Reject. It is also possible to
transfer the call to another SIP address.

7.5 Using the Address Book
Ekiga offers to manage your SIP contacts. Start the address book with Tools > Address
book. An empty list window opens. To add a contact, first select Personal with your
mouse. Then right-click into the address window and selectNewContact. Alternatively,
just press Ctrl > N.

The following entries need to be made for a valid contact:

Name
Enter the name of your contact. This may be a full name, but you can also use a
nickname here.

SIP Address
Enter a valid SIP address for your contact.

Email
Enter the e-mail address of your contact for your own reference.

Speed Dial
With a Speed Dial you may access often used numbers more easily. However,
this is optional as well.
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Categories
Add your own categories if you have many different contacts.

Local Address Book
By default, you have a local address book with the name Personal available. If you
need more address books, create them with File > New Address Book or use the
keyboard shortcut Ctrl + B.

To call any contact from the address book, double-click this contact with the mouse.
The call will be directly initiated.

7.6 For More Information
The official home page of Ekiga is http://www.ekiga.org/. This site offers the
frequently asked questions as well as a more detailed documentation.

For information about the support of the H323 teleconferencing protocol in Linux, see
http://www.voip-info.org/wiki/view/H.323. This is also a good starting
point when searching for projects supporting VoIP.

If you intend to set up your private telephone network, you might be interested in the
PBX software Asterisk http://www.asterisk.org/. Information about this
project can also be found at http://www.voip-info.org/wiki-Asterisk.
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8Accessing Network Resources
From your desktop, you can access files and directories or certain services on remote
hosts or make your own files and directories available to other users in your network.
openSUSE® offers the following ways of accessing and creating network shared re-
sources.

• Network Browsing: Your file manager, Nautilus, lets you browse your network
for shared resources and services. Learn more about this in Section 8.2, “Accessing
Network Shares” (page 226).

• Sharing Folders inMixed Environments: Using Nautilus, configure your files
and folders to share with other members of your network. Make your data readable
or writable for users from any Windows or Linux workstation. Learn more about
this in Section 8.3, “Sharing Folders” (page 227).

• Managing Windows Files: openSUSE can be configured to integrate into an
existing Windows network. Your Linux machine then behaves like a Windows
client. It takes all account information from the Active Directory domain controller,
just as the Windows clients do. Learn more about this in Section 8.4, “Managing
Windows Files” (page 229).

• Configuring and Accessing a Windows Network Printer: You can configure
a Windows network printer through the GNOME Control Center. Learn how to
configure this in Section 8.5, “Configuring and Accessing a Windows Network
Printer” (page 230).
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8.1 General Notes on File Sharing and
Network Browsing

Whether and to which extent you can use file sharing and network browsing on your
machine and in your network highly depends on the network structure and on the con-
figuration of your machine. Before setting up either of them, contact your system ad-
ministrator to make sure that your network structure supports this feature and to check
whether your company's security policies permit it.

Network browsing, be it SMB browsing forWindows shares or SLP browsing for remote
services, relies heavily on the machine's ability to send broadcast messages to all clients
in the network. These messages and the clients' replies to them enable your machine to
detect any available shares or services. For broadcasts to work effectively, your machine
must be part of the same subnet as all other machines it is querying. If network browsing
does not work on your machine or the detected shares and services do not match with
what you expected, contact your system administrator to make sure that you are con-
nected to the appropriate subnet.

To allow network browsing, your machine needs to keep several network ports open
to send and receive network messages that provide details on the network and the
availability of shares and services. The standard openSUSE is configured for tight se-
curity and has a firewall up and running that protects your machine against the Internet.
To adjust the firewall configuration, you would either need to ask your system admin-
istrator to open a certain set of ports to the network or to tear down the firewall entirely
according to your company's security policy. If you try to browse a network with a re-
strictive firewall running on your machine, Nautilus warns you about your security re-
strictions not allowing it to query the network.

8.2 Accessing Network Shares
Networking workstations can be set up to share folders. Typically, files and folders are
marked to let remote users access them. These are called network shares. If your system
is configured to access network shares, you can use your file manager to access these
shares and browse them just as easily as if they were located on your local machine.
Whether you have only read access or also write access to the shared folders depends
on the permissions granted to you by the owner of the shares.
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To access network shares, open Nautilus and click Network Servers. Nautilus displays
the networks that you can access. Click a network, then click the server. You might be
required to authenticate to the server by providing a username and password.

Figure 8.1 Network File Browser

8.3 Sharing Folders
Sharing and exchanging documents is a must-have in corporate environments. Nautilus
offers you file sharing, which makes your files and folders available to both Linux and
Windows users.

8.3.1 Enabling Sharing on the Computer
Before you can share a folder, you must enable sharing on your computer. To enable
sharing:

1 Click Computer >More Applications > System > YaST.

2 Enter the root password.

3 Click Network Services.
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4 ClickWindows Domain Membership.

5 Click Allow Users to Share Their Directories, then click Finish.

8.3.2 Enabling Sharing for a Folder
To configure file sharing for a folder:

1 Open Nautilus.

2 Right-click the window background or a folder, then select Sharing Options from
the context menu.

3 Select Share this folder.

4 (Optional) If you want other people to be able to write to the folder, select Allow
other people to write in this folder.

5 (Conditional) If the folder does not already have the permissions that are required
for sharing, click Add the permissions automatically.

The folder icon changes to indicate that the folder is now shared.

IMPORTANT: Samba Domain Browsing

Samba domain browsing only works if your system's firewall is configured ac-
cordingly. Either disable the firewall entirely or assign the browsing interface
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to the internal firewall zone. Ask your system administrator about how to
proceed.

8.4 Managing Windows Files
With your openSUSEmachine being an Active Directory client, you can browse, view,
and manipulate data located on Windows servers. The following examples are just the
most prominent ones:

Browsing Windows Files with Nautilus
Use Nautilus's network browsing features to browse your Windows data.

Viewing Windows Data with Nautilus
Use Nautilus to display the contents of yourWindows user folder just as you would
for displaying a Linux directory. Create new files and folders on the Windows
server.

Manipulating Windows Data with GNOME Applications
Many GNOME applications allow you to open files on the Windows server, ma-
nipulate them, and save them back to the Windows server.

Single-Sign-On
GNOME applications, including Nautilus, support Single-Sign-On, which means
that to access other Windows resources, such as Web servers, proxy servers, or
groupware servers like MS Exchange, you do not need to reauthenticate. Authenti-
cation against all these is handled silently in the background once you provided
your username and password on login.

To access your Windows data using Nautilus, proceed as follows:

1 Open Nautilus and click Network Servers.

2 ClickWindows Network.

3 Click the icon of the workgroup containing the computer you want to access.

4 Click the computer’s icon (and authenticate, if prompted to do so), then navigate
to the shared folder on that computer.
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To create folders in your Windows user folder using Nautilus, proceed as you would
when creating a Linux folder.

8.5 Configuring and Accessing a
Windows Network Printer

Being part of a corporate network and authenticating against a Windows Active Direc-
tory server, you can access corporate resources, such as printers. GNOME allows you
to configure printing from your Linux client to a Windows network printer.

To configure a Windows network printer for use through your Linux workstation, pro-
ceed as follows:

1 Start the GNOME Control Center from the main menu.

2 Select Hardware > Printers.

3 Select New Printer.

Adding a printer requires root privileges, so you must enter the root password to
continue.

4 Select Network Printer, then selectWindows Printer (SMB) from the drop-down
menu.

5 Enter or select the Windows host, the printer, and the username and password
required to access the Windows computer, then click Forward.

6 Select the driver that most closely matches the printer, then click Forward.

7 Click Apply.

The printer is ready for use.

To print to the Windows network printer configured above, select it from the list of
available printers.
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9Encryption with Passwords
and Encryption Keys
The GNOME Passwords and Encryption Keys program is an important component of
the encryption infrastructure on your system. With the help of this program, you can
create and manage PGP and SSH keys, import and export PGP and SSH keys, share
your keys with others, back up your keys and keyring, cache your passphrase, and en-
crypt and decrypt the clipboard.

Figure 9.1 Password and Encryption Keys Main Window

• Section 9.1, “Signing and Encryption” (page 232)
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• Section 9.2, “Generating a New Key Pair” (page 232)

• Section 9.3, “Modifying Key Properties” (page 235)

• Section 9.4, “Importing Keys” (page 240)

• Section 9.5, “Exporting Keys” (page 241)

• Section 9.6, “Backing Up Keyrings” (page 241)

• Section 9.7, “Signing a Key” (page 242)

• Section 9.8, “File Manager Integration” (page 243)

• Section 9.9, “Encryption Preferences” (page 244)

9.1 Signing and Encryption
Signing means attaching electronic signatures to e-mail messages or even software to
prove its correct derivation. To keep someone else from writing messages using your
name, and to protect both you and the people you send them to, you should sign your
mails. Signatures help you easily check the sender of the messages you receive and
distinguish good-natured messages from malicious messages.

Software developers sign their software so that you can check the integrity. Even if you
get the software from an unofficial server, you can verify the package with the signature.

You might also have sensitive information you want to protect from other parties. En-
cryption helps you transform data and make it unreadable for others. This is important
for companies so they can protect internal information as well as their employees' pri-
vacy.

9.2 Generating a New Key Pair
To exchange encrypted messages with other users, you must first generate your own
key pair. One part of it—the public key—is distributed to your communication partners,
who can than use it to encrypt the files or e-mail messages they send. The other part of
the key pair—the private key—is used to decrypt the encrypted contents.
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IMPORTANT

The public key is intended for the public and should be distributed to all your
communication partners. However, only you should have access to the private
key. Do not grant other users access to this data.

• Section 9.2.1, “Creating OpenPGP Keys” (page 233)

• Section 9.2.2, “Creating Secure Shell Keys” (page 234)

9.2.1 Creating OpenPGP Keys
OpenPGP is a non proprietary protocol for encrypting e-mail with the use of public key
cryptography based on PGP. It defines standard formats for encrypted messages, signa-
tures, private keys and certificates for exchanging public keys.

1 Click Computer >More Applications > Utilities > Passwords and Encryption
Keys.

2 Click Key > Create New Key.

3 Select PGP Key, then click Continue.

4 Specify your full name, e-mail address, and any additional information.

5 (Optional) Click Advanced key options to specify the following advanced options
for the key.

Encryption Type: Specifies the encryption algorithms used to generate your
keys. DSA ElGamal is the recommended choice because it lets you encrypt, de-
crypt, sign, and verify as needed. BothDSA (sign only) and RSA (sign only) allow
only signing.

Key Strength: Specifies the length of the key in bits. The longer the key, the
more secure it is (provided a strong passphrase is used), but keep in mind that
performing any operation with a longer key requires more time than it does with
a shorter key. Acceptable values are between 1024 and 4096 bits. At least 2048
bits is recommended.
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Expiration Date: Specifies the date at which the key will cease to be usable
for performing encryption or signing operations. You will have to either change
the expiration date or generate a new key or subkey after this amount of time
passes. Sign your new key with your old one before it expires to preserve your
trust status.

6 Click Create to create the new key pair.

The Passphrase for New PGP Key dialog box opens.

7 Specify the passphrase twice for your new key, then click OK.

When you specify a passphrase, use the same practices you use when you create
a strong password. The main difference between a password and a passphrase is
that spaces are valid characters in a passphrase.

9.2.2 Creating Secure Shell Keys
Secure Shell (SSH) is a method of logging into a remote computer to execute commands
on that machine. SSH keys are used in key-based authentication system as an alternative
to the default password authentication system. With key-based authentication, there is
no need to manually type a password to authenticate.

1 Click Computer >More Applications > Utilities > Passwords and Encryption
Keys.

2 Click Key > Create New Key.

3 Select Secure Shell Key, then click Continue.

4 Specify a description of what the key is to be used for.

You can use your e-mail address or any other reminder.

5 (Optional) Click Advanced key options to specify the following advanced options
for the key.

Encryption Type: Specifies the encryption algorithms used to generate your
keys. Select RSA to use the Rivest-ShamirAdleman (RSA) algorithm to create
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the SSH key. This is the preferred and more secure choice. SelectDSA to use the
Digital Signature Algorithm (DSA) to create the SSH key.

Key Strength: Specifies the length of the key in bits. The longer the key, the
more secure it is (provided a strong passphrase is used), but keep in mind that
performing any operation with a longer key requires more time than it does with
a shorter key. Acceptable values are between 1024 and 4096 bits. At least 2048
bits is recommended.

6 Click Just Create Key to create the new key, or click Create and Set Up to create
the key and set up another computer to use for authentication.

7 Specify the passphrase for your new key, click OK, then repeat.

When you specify a passphrase, use the same practices you use when you create
a strong password. The main difference between a password and a passphrase is
that spaces are valid characters in a passphrase.

9.3 Modifying Key Properties
• Section 9.3.1, “Editing OpenPGP Key Properties” (page 235)

• Section 9.3.2, “Editing Secure Shell Key Properties” (page 239)

9.3.1 Editing OpenPGP Key Properties
The descriptions in this section apply to all OpenPGP keys.

1 Click Computer >More Applications > Utilities > Passwords and Encryption
Keys.

2 Double-click the PGP key you want to view or edit (or select the key, then click
Key > Properties).

3 Use the options on the Owner tab to add a photo to the key or to change the
passphrase associated with the key.
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Photo IDs allow a key owner to embed one or more pictures of themselves in a
key. These identities can be signed just like normal user IDs. A photo ID must
be in JPEG format and should be no larger than 240x288 pixels.

If the chosen image does not meet the required file type or size, Passwords and
Encryption Keys can resize and convert it on the fly from any image format
supported by the GDK library.

4 Click the Names and Signatures tab to add a user ID to a key.

See Section “Adding a User ID” (page 237) for more information.

5 Click the Details tab, which contains the following properties:

Key ID: The Key ID is similar to the Fingerprint, but the Key ID contains
only the last eight characters of the fingerprint. It is generally possible to identify
a key with only the Key ID, but sometimes two keys might have the same Key
ID.

Type: Specifies the encryption algorithm used to generate a key. DSA keys
can only sign. ElGamal keys are used to encrypt.

Strength: Specifies the length, in bits, of the key. The longer the key, the more
security it provides. However, a long key will not compensate for the use of a
weak passphrase.

Fingerprint: A unique string of characters that exactly identifies a key.

Created: The date the key was created.

Expires: The date the key can no longer be used (a key can no longer be used
to perform key operations after it has expired). Changing a key's expiration date
to a point in the future re-enables it. A good general practice is to have a master
key that never expires and multiple subkeys that do expire and are signed by the
master key.

Location: The location where the private key has been stored.

Subkeys: See Section “Editing OpenPGP Subkey Properties” (page 238) for
more information.
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6 Click Close.

Adding a User ID
User IDs allow multiple identities and e-mail addresses to be used with the same key.
Adding a user ID is useful, for example, when you want to have an identity for your
job and one for your friends. They take the following form:

Name (comment) <e-mail address>

1 Click Computer >More Applications > Utilities > Passwords and Encryption
Keys.

2 Double-click the PGP key you want to view or edit (or select the key, then click
Key > Properties).

3 Click the Names and Signatures tab, then click Add Name.

4 Specify a name in the Full Name field.

You must enter at least five characters in this field.

5 Specify an e-mail address in the Email Address field.

Your e-mail address is how most people will locate your key on a key server or
other key provider. Make sure it is correct before continuing.

6 In the Key Comment field, specify additional information that will display in the
name of your new ID
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This information can be searched for on key servers.

7 Click Close.

Editing OpenPGP Subkey Properties
Each OpenPGP key has a single master key used to sign only. Subkeys are used to en-
crypt and to sign as well. In this way, if your sub key is compromised, you don't need
to revoke your master key.

1 Click Computer >More Applications > Utilities > Passwords and Encryption
Keys.

2 Double-click the PGP key you want to edit (or select the key, then click Key >
Properties).

3 Click the Details tab, then click Subkeys.

4 Use the button to on the left of the dialog box to add, delete, expire, or revoke
subkeys.

Each subkey has the following information:

ID: The identifier of the subkey.
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Type: Specifies the encryption algorithm used to generate a subkey. DSA
keys can only sign, ElGamal keys are used to encrypt, and RSA keys are used
to sign or to encrypt.

Created: Specifies the date the key was created.

Expires: Specifies the date the key can no longer be used.

Status: Specifies the status of the key.

Strength: Specifies the length, in bits, of the key. The longer the key, the more
security it provides. However, a long key will not compensate for the use of a
weak passphrase.

5 Click Close.

9.3.2 Editing Secure Shell Key Properties
The descriptions in this section apply to all SSH keys.

1 Click Computer >More Applications > Utilities > Passwords and Encryption
Keys.

2 Double-click the Secure Shell key you want to view or edit (or select the key,
then click Key > Properties).

3 Use the options on the Key tab to change the name of the key or the passphrase
associated with the key.

4 Click the Details tab, which contains the following properties:

Algorithm: Specifies the encryption algorithm used to generate a key.

Strength: Indicates the length in bits of a key. The longer the key, the more
security it provides. However, a long key does not make up for the use of a weak
passphrase.

Location: The location where the private key has been stored.

Fingerprint: A unique string of characters that exactly identifies a key.
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5 Click Close.

9.4 Importing Keys
To import keys:

1 Click Computer >More Applications > Utilities > Passwords and Encryption
Keys.

2 Click Key > Import.

3 Select a file containing at least one ASCII armored public key.

4 Click Open to import the key.

You can also paste keys inside Passwords and Encryption Keys:

1 Select an ASCII armored public block of text, then copy it to the clipboard.

2 Click Computer >More Applications > Utilities > Passwords and Encryption
Keys.

3 Click Edit > Paste Keys
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9.5 Exporting Keys
To export keys:

1 Click Computer >More Applications > Utilities > Passwords and Encryption
Keys.

2 Select the keys you want to export.

3 Click Key > Export Public Key.

4 Specify a filename and location for the exported key.

5 Click Save to export the key.

You can also export keys to the clipboard in an ASCII armored block of text:

1 Click Computer >More Applications > Utilities > Passwords and Encryption
Keys.

2 Select the keys you want to export.

3 Click Edit > Copy Public Key.

9.6 Backing Up Keyrings
You can back up your public and private keyrings to an archived file.

1 Click Computer >More Applications > Utilities > Passwords and Encryption
Keys.

2 Click Key > Back up Key Rings.

3 Specify a filename with a valid archive extension, then specify the location to
save the archive.

You can choose any of the archive types file-roller supports.
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4 Click Save.

9.7 Signing a Key
Signing another person's key means that you are giving trust to that person. Before
signing a key, carefully check the key's fingerprint to ensure that the key really belongs
to that person.

Trust is an indication of how sure you are of a person's ability to correctly extend the
web of trust. When you are faced with a key you have not signed, the validity of that
person's key will be determined based on the signatures they have collected and how
well or not you trust the people who havemade those signatures. By default, an unknown
key will require three signatures with marginal trust value or one fully trusted signature.

1 Click Computer >More Applications > Utilities > Passwords and Encryption
Keys.

2 Select the key you want to sign from the Trusted Keys or Other Collected Keys
tabs.

3 Click Key > Sign.

4 Select how carefully the key has been checked, then indicate if the signature
should be local to your keyring, and if your signature can be revoked
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5 Click Sign.

9.8 File Manager Integration
Passwords and Encryption Keys integrates with the Nautilus file manager. You can
encrypt, decrypt, sign, and verify files as well as import public keys from the file
manager window without launching Passwords and Encryption Keys.

• Section 9.8.1, “Encrypting Files From Nautilus” (page 243)

• Section 9.8.2, “Signing Files From Nautilus” (page 243)

• Section 9.8.3, “Decrypting Files From Nautilus” (page 244)

• Section 9.8.4, “Verifying Signatures From Nautilus” (page 244)

9.8.1 Encrypting Files From Nautilus
1 In Nautilus, right-click the files you want to encrypt.

2 Select Encrypt.

3 Select the people (recipients) you want to encrypt the file to, then click OK.

9.8.2 Signing Files From Nautilus
1 In Nautilus, right-click the files you want to sign.

2 Select Sign.

3 Select a signer, then click OK.

4 If prompted, specify the passphrase of your private key, then click OK.

Encryption with Passwords and Encryption Keys 243



9.8.3 Decrypting Files From Nautilus
To decrypt an encrypted file in Nautilus, simply double-click the file youwant to decrypt.

If prompted, specify the passphrase of your private key.

9.8.4 Verifying Signatures From Nautilus
To verify files, simply double-click the detached signature file. Detached signature file
names often have a .sig extension.

9.9 Encryption Preferences
• Section 9.9.1, “Encryption Settings” (page 244)

• Section 9.9.2, “Passphrase Cache” (page 245)

• Section 9.9.3, “Key Servers” (page 246)

• Section 9.9.4, “Key Sharing” (page 247)

9.9.1 Encryption Settings
1 Click Computer >More Applications > Utilities > Passwords and Encryption

Keys.

2 Click Edit > Preferences, then click the Encryption Settings tab.
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3 Choose from the following options:

Default Key: Specifies the key you want to use to sign files. Files will be en-
crypted to this key if theWhen encrypting, always include myself as a recipient
option is selected.

When encrypting, always include myself as a recipient: Select this option
to add yourself to the recipients list for all files encrypted by Passwords and En-
cryption Keys. If you do not select this option, and you do not select yourself as
a recipient, you cannot decrypt any files you encrypt.

4 Click Close.

9.9.2 Passphrase Cache
Enabling Passwords and Encryption Keys's passphrase caching ability allows you to
perform many operations that require entering your passphrase without reentering it
every time seahorse-daemon takes the place of gpg-agent. Letting the cached
passphrases expire is usually a good idea. This will then require reentering your
passphrase, but adds security.

1 Click Computer >More Applications > Utilities > Passwords and Encryption
Keys.

2 Click Edit > Preferences, then click the Passphrase Cache tab.
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3 Choose from the following options:

Never remember passphrases: Select this option to not remember any
passphrase.

Remember passphrases for ... minutes: Specifies the amount of time, in
minutes, for storing passphrases.

Always remember passphrases whenever logged in: Select this option to
remember any passphrases whenever you are logged in to the session.

Askme before using a cached passphrase: Select this option to ask you before
a stored passphrase is used.

Automatically load Secure Shell keys: Select this option to automatically
cache any Secure Shell key.

4 Click Close.

9.9.3 Key Servers
You can keep your keys up to date by syncing keys periodically with remote keyservers.
Syncing will make sure that you have the latest signatures made on all of your keys so
that the web of trust will be the most useful.
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1 Click Computer >More Applications > Utilities > Passwords and Encryption
Keys.

2 Click Edit > Preferences, then click the Key Servers tab.

Passwords and Encryption Keys provides support for HKP and LDAP keyservers.

HKP Servers: HKP keyservers are ordinary Web-based keyservers such as
the popular hkp://pgp.mit.edu:11371, also accessible at http://pgp.mit
.edu.

LDAP Keyservers: LDAP keyservers are less common, but use the standard
LDAP protocol to serve keys. ldap://keyserver.pgp.com is a good LDAP server.

3 Click Close.

9.9.4 Key Sharing
Key Sharing is provided by DNS-SD, also known as Bonjour or Rendevous. Enabling
key sharing adds the local Passwords and Encryption Keys users' public key rings to
the remote search dialog box. Using these local key servers is generally faster than ac-
cessing remote servers.

1 Click Computer >More Applications > Utilities > Passwords and Encryption
Keys.
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2 Click Edit > Preferences, then click the Key Sharing tab.

3 Select Share my keys with others on my network.

4 Click Close.
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10Searching with Beagle
Beagle is a search tool that indexes your personal information space (normally your
home directory) to find whatever you're looking for. Using Beagle, you can find docu-
ments, e-mails and attachments, Web history, IM/IRC conversations, address book
contacts, calendar appointments, notes, source code, images, music and video files,
archives and their contents, and applications.

• Section 10.1, “Using Beagle” (page 249)

• Section 10.2, “Search Tips” (page 251)

• Section 10.3, “Performing a Property Search” (page 252)

• Section 10.4, “Setting Search Preferences” (page 254)

• Section 10.5, “Indexing Other Directories” (page 255)

• Section 10.6, “Preventing Files and Directories from Being Indexed” (page 256)

10.1 Using Beagle
To use Beagle, click Computer, enter your search terms in the Search field, then press
Enter. The results are displayed in the Desktop Search dialog box.
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Figure 10.1 Desktop Search Dialog Box

You can use the results lists to open a file, forward it via e-mail, or display it in the file
manager. Simply right-click an item in the results list and select the option you want.
The options available for an item in the results list depend on the type of file it is. Se-
lecting a file in the list displays a preview of the file and information such as the title,
path, and date the file was last modified or accessed.
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Figure 10.2 Desktop Search Dialog Box With a File Selected

Use the Search menu to limit your search to files in a specific location, such as your
address book or Web pages, or to display only a specific type of file in your results list.
The Viewmenu lets you sort the items in your results list according to name, relevance,
or the date the file was last modified.

You can also access Desktop Search by clicking Computer >More Applications >
System > Search.

10.2 Search Tips
• You can use both uppercase and lowercase letters in search terms. Searches are not
case-sensitive by default.

To perform a case-sensitive search, put double quotationmarks (“) around the word
you want to match exactly. For example, if you use “APPLE” in a search, apple
will be ignored.
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• To search for optional terms, use OR (for example, apples OR oranges).

IMPORTANT

The OR is case-sensitive when used to indicate optional search terms.

• To exclude search terms, use a minus sign (-) in front of the term you want to ex-
clude (for example, apples -oranges will find results containing apples but not or-
anges).

• To search for an exact phrase or word, put quotation marks (“) around the phrase
or word.

• Common words such as “a,” “the,” and “is” are ignored.

• The base form of a search term is used when searching (for example, a search for
“driving” will match “drive,” “drives,” and “driven”).

10.3 Performing a Property Search
By default, the Beagle search tool looks for search terms in the text of documents and
in their metadata. To search for a word in a particular property, use property:query.
For example, author:john searches for files that have “john” listed in the Author
property.

Table 10.1 Supported Property Keywords

PropertyApplies toKeyword

Name of albumMusic filesalbum

Name of artistMusic fileartist

Author of the document (same as ??? (page 253))Documentauthor

Creator of the document, mapped to dc:creator
(for example, creator of PDF files)

Documentcreator
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PropertyApplies toKeyword

E-mail addressAddress bookemail

File extension (for example, extension:jpeg or
ext:mp3). Use extension: or ext: to search in
files with no extension.

Fileextension or ext

Genre of musicMusic filegenre

Comments and descriptions found in images
that have an IPTC caption or Exif comment

Image fileimagecomment

Model of camera (for example, EOS2D)JPEG imageimagemodel

F-Spot and Digikam image tags, and IPTC
keywords

Image fileimagetag

Name of senderE-mailmailfrom

E-mail address of senderE-mailmailfromaddr

Id of mailing list (for example, dashboard-
hackers.gnome.org)

E-mailmailinglist

Name of recipientE-mailmailto

E-mail address of recipientE-mailmailtoaddr

SpeakerChatspeakingto

Title of document, mapped to dc:title (for exam-
ple, title tag of HTML files)

Documenttitle

Property searches follow the rules mentioned in Section 10.2, “Search Tips” (page 251).
You can use property searches as an OR query or as an exclusion query, and phrases
can be used as query. For example, the following line will search for all PDF or HTML
documents containing the word “apple” whose author property contains “john” and
whose title does not contain the word “oranges”:
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apple ext:pdf OR ext:html author:john -title:oranges

10.4 Setting Search Preferences
Use the Search Preferences dialog box to set search preferences for Beagle.

1 Click Computer >More Applications > System > Search & Indexing.

You can also click Search > Preferences in the Desktop Search dialog box.

2 Choose from the following options:

Start search & indexing services automatically: Select this option if you
want the search daemon to start automatically when you log in to your session
(this option is selected by default). If you want to use Beagle’s Search function-
ality, the daemon must be running.

Index data while on battery power: Select this option if you want your data
to be indexed when your computer is operating on battery power. This option is
particularly useful if you are using openSUSE on a laptop and you want to stop
indexing when your laptop is running on battery power.
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Automatically start searching after the user has stopped typing: Select
this option if you want Beagle to start searching as soon as you stop entering text
in the Find field in the Desktop Search window. This option has no effect on the
Search field in the main menu.

Display the search window by pressing: Choose the keystrokes that will
display the Desktop Search window by specifying any combination of Ctrl, Alt,
and a function key. F12 is the default keystroke.

3 Click OK.

10.5 Indexing Other Directories
By default, Beagle indexes your home directory only. If you do not want your home
directory to be indexed, uncheck the Index my home directory option on the Indexing
tab of the Search Preferences dialog box. If you want to index additional folders, follow
these steps:

1 Click Computer >More Applications > System > Search & Indexing.

You can also click Search > Preferences in the Desktop Search dialog box.

2 Click the Indexing tab.
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3 Click Add in the General section of the dialog box.

4 Select the directory you want to index, then click Open.

Make sure you have rights to the directories you add.

5 If you want to remove a directory from the list of indexed directories, select it
in the list, then click Remove.

6 Click OK.

10.6 Preventing Files and Directories
from Being Indexed

Use the Search Preferences dialog box to specify resources that you don’t want indexed.
These resources can include directories, patterns, mail folders, or types of objects.

1 Click Computer >More Applications > System > Search & Indexing.

2 Click the Indexing tab.

3 Click Add in the Privacy section.

4 Select a resource to exclude from indexing, then specify the path to the resource.

5 Click OK twice.
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11Taking Notes with Tomboy
Tomboy is a GNOME desktop application for taking notes that gives you the ability to
organize the ideas and information you deal with every day. Among other things, it can
help you collect and sort all kind of data, write down your ideas, make to do lists, and
allocate your contacts.

Tomboy also has some useful editing features to help you customize your notes, includ-
ing:

• Highlighting search text

• Inline spell checking

• Auto-linking Web and e-mail addresses

• Undo/redo support

• Font styling and sizing

• Bulleted lists

Tomboy is located on the GNOME panel ( ), and by default, is started automatically
when you log into GNOME. You can also access Tomboy by clicking Computer >
More Applications > Utilities > Tomboy Notes.

This sections contains the following information

• Section 11.1, “Creating Notes” (page 258)
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• Section 11.2, “Searching All Notes” (page 259)

• Section 11.3, “Linking Notes” (page 260)

• Section 11.4, “Accessing Your Notes” (page 261)

• Section 11.5, “Formatting Text in Notes” (page 261)

• Section 11.6, “Exporting Notes to HTML” (page 264)

• Section 11.7, “Deleting Notes” (page 264)

• Section 11.8, “Printing Notes” (page 265)

• Section 11.9, “Configuring Tomboy Preferences” (page 265)

11.1 Creating Notes
To create a new note, click the Tomboy Notes icon ( ) in your GNOME Panel, then
select Create New Note.

Figure 11.1 A New Tomboy Note

To edit the note, click the content area, then use the keyboard to add and remove content.
The first line of the note holds the title. By default, this is populated with the text New
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Note #. You can change the title by clicking the line and using the keyboard to change
the title. By default, focus is given to the content area upon creation of a new note, so
you can immediately start editing the note without clicking the content area. For more
information on formatting the contents of a note, see Section 11.5, “Formatting Text
in Notes” (page 261).

Your note is saved automatically.

You can then organize the notes you create by linking related notes and ideas together.
Fore more information, see Section 11.3, “Linking Notes” (page 260).

11.2 Searching All Notes
To get an overview of all your notes, click , then select Search All Notes. By default,
the Search All Notes dialog box displays your notes in the order they were last modified.
Click the Note or Last Changed column headings to change the sort order. Click the
column heading a second time to toggle between ascending and descending order.

Figure 11.2 Search All Notes Dialog Box

You can find specific notes by entering text into the Search field. The list of notes au-
tomatically updates to list only the notes that contain matching text.

To open a note listed in the Search All Notes dialog box, do any of the following:

• Double-click a note.
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• Select a note, then click File > Open.

• Right-click a note, then select Open.

• Select a note, then press Ctrl + O.

11.3 Linking Notes
You can link notes in Tomboy by highlighting text in your current note, then clicking
the Link button in the toolbar. This creates a new note and underlines the note's title in
the current note.

For example, if your current note contains the phrase “resume,” you can select this text,
then click Link to create a new note with the title “resume.” A link is also created in
the current note which you can click to open the new “resume” note.

Figure 11.3 Links in Tomboy Notes

If you change the title of a note, the links in other notes to the note whose title you
changed are automatically updated.
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Typing the name of another note in your current note automatically links that note for
you.

To see what other notes link to the current note, click Tools >What links here?

11.4 Accessing Your Notes
To access your notes, click the Tomboy icon ( ) on the GNOME panel, then select
one of the notes you recently viewed or created from the menu, or Search for older
notes (see Section 11.2, “Searching All Notes” (page 259) for more information). The
Table of Contents lists all your notes in the order they were last modified.

To force a note to always appear in the panel menu regardless of when you last accessed
it, click the thumbtack icon to the right of the note to “pin” it to the menu. Notes that
are pinned to the panel menu have a thumbtack icon that look like this: . Notes that
are not pinned to the panel menu have thumbtack icons that look like this: .

11.5 Formatting Text in Notes
You can use the Text button on the Tomboy toolbar to format text within your notes.
The Text button displays a drop-down menu with the following options:

• Undo: Allows you to revert previous changes made to your note during the
current session. To undo your last change using the keyboard, press Ctrl + Z.

• Redo: Allows you to put back changes that were removed using theUndo feature.
To redo your last change using the keyboard, press Shift + Ctrl + Z.

• Bold: To make text within your note bold, select the text you want to modify,
then select the Bold option from the Text drop-down menu. You can also press Ctrl
+ B after selecting text.

• Italic: To make text within your note italic, select the text you want to modify,
then select the Italic option from the Text drop-down menu. You can also press
Ctrl + I after selecting text.first select the text
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• Strikeout: Puts a line through the selected text. To add a strikeout, select the
text you want, then select the Strikeout option from the Text drop-down menu. You
can also press Ctrl + S after selecting text.

• Highlight: Puts a yellow background around the selected text. To add a highlight,
select the text you want, then select the Highlight option from the Text drop-down
menu. You can also press Ctrl + H after selecting text.

• Fixed Width: The fixed width style allows text to use a fixed width font. To
change existing text, select the text you want to modify, then select the FixedWidth
option from the Text drop-down menu. You can also select the Fixed Width option
from the Text drop-down menu before you start typing to have the text you type
be in a fixed width style.

• Font Size: There are four options in this part of the menu: Small,Normal, Large,
and Huge. Each of these options represents a font size you can use for the selected
text in the note. To modify the font size, select the text you want to modify, then
select one of the Font Size options from the Text drop-down menu.

• Bullets: Select the Bullets option from the Text drop-down menu to begin or end
a bulleted list. If your cursor is inside a bulleted list, the Increase Indent and De-
crease Indent options are enabled.

For more information on bullets, see Section 11.5.1, “Using Bulleted Lists”
(page 263).

• Increase Indent: With the cursor on a bulleted list line, select this option to shift
the current line to the right.

• Decrease Indent: With the cursor on a bulleted list line, select this option to
shift the current line to the left.

• Find in This Note: Lets you search for text within the current note. Selecting
this option causes a Find bar to open at the bottom of the note. To open the Find
bar using the keyboard, press Ctrl + F.

Enter the text you want to find. After entering text, any matches are highlighted.
Click Find Next to highlight the next match and place the cursor there. Click Pre-
vious to move to the previous match.
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Use the Case sensitive checkbox to limit the matches to ones that exactly match
the case of the search string.

To close the find bar, click X on the far left or press the Escape key.

11.5.1 Using Bulleted Lists
• Section “Beginning a Bulleted List” (page 263)

• Section “Ending a Bulleted List” (page 263)

• Section “Increasing Indentation” (page 264)

• Section “Decreasing Indentation” (page 264)

Beginning a Bulleted List
To begin a bulleted list, use any of the following methods:

• Select Bullets from the Text drop-down menu.

• Start a line of text with a single dash character (-), type text immediately following
the dash, then press Enter.

Ending a Bulleted List
To end a bulleted list, do any of the following:

• Select Bullets from the Text drop-down menu.

• Press Enter on a blank bulleted line.

• Select Decrease Indent from the Text drop-down menu until the current line is no
longer part of the bulleted list.

• Press Shift + Tab until the current line is no longer part of the bulleted list.
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Increasing Indentation
To increase the line indentation in a bulleted list, select Increase Indent from the Text
drop-down menu, or press the Tab key.

Decreasing Indentation
To decrease the line indentation in a bulleted list, select Decrease Indent from the Text
drop-down menu, or press Shift + Tab.

11.6 Exporting Notes to HTML
You can create an HTML (Hypertext Markup Language) document from one or more
notes.

1 In the note you want to export, select the Export to HTML option from the Tools
drop-down menu.

2 Specify where to save the HTML file.

3 (Optional) Select Export linked notes to export any notes for which a link exists
in the current note.

Select Include all other linked notes to export all notes for which a link exits in
any of the notes linked to your current note.

4 Click Save.

11.7 Deleting Notes
To delete a note, click the Delete button on the Tomboy toolbar. You will see a dialog
box asking if you want to permanently delete the note and its contents. Click Delete to
discard the note permanently, or click Cancel to abort the process.

Links to this note from other notes will still exist, but will re-create the note upon acti-
vation.
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11.8 Printing Notes
Select the Print option on the Tools drop-down menu to print the current note. You will
be presented with the standard GNOME print dialog box.

11.9 Configuring Tomboy Preferences
To modify preferences for Tomboy, right-click the Tomboy icon ( ) on the GNOME
panel, then select Preferences. You can configure the following:

• Section 11.9.1, “Editing Preferences” (page 265)

• Section 11.9.2, “Hotkey Preferences” (page 266)

• Section 11.9.3, “Synchronization Preferences” (page 267)

• Section 11.9.4, “Add-ins Preferences” (page 269)

11.9.1 Editing Preferences
The Editing tabbed page lets you set preferences related to editing notes.
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Figure 11.4 Tomboy Editing Preferences

The Editing preferences include the following:

• Spell check while typing: Underlines misspellings in red, and provides sugges-
tions in the right-click context menu.

• Highlight WikiWords: Creates links for phrases ThatLookLikeThis.
Clicking the link creates a new note with the title corresponding to the link text.

• Use custom font: Sets a custom font to be used in your notes. If this option is
disabled, the default system font will be used.

11.9.2 Hotkey Preferences
The Hotkeys tabbed page lets you set global key combinations to perform different
functions in Tomboy. To set key combinations, the Listen for Hotkeys checkbox must
be selected. Press Alt + H to toggle this option on or off.
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Figure 11.5 Tomboy Hotkey Preferences

The Hotkey preferences include the following:

• Show notes menu: Specify the key combination to open the notes menu.

• Open “Start Here”: Specify the key combination to open the “Start Here” note,
which is preinstalled with Tomboy.

• Create new note: Specify the key combination to create a new note.

• Open “Search All Notes”: Specify the key combination to open the Search All
Notes dialog box.

11.9.3 Synchronization Preferences
The Synchronization tabbed page lets you share notes, announce notes, receive announce-
ments, and get notes from other instances of Tomboy. This can be useful, for example,
if you want to work on a single set of notes in separate instances of Tomboy running
on your desktop and your laptop.
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Figure 11.6 Tomboy Synchronization Preferences

The Synchronization preferences include the following:

• Service: Specify the location of the synchronized files. By default, you can select
a local folder or WebDAV server. To synchronize to a remote location, click the
Add-ins tab, select Synchronization > SSH Sync Service Add-in, then click Enable.
This adds an SSH (sshfs FUSE) option to the Service drop-down list.

Specify the information required for the Service you selected, then click Save.

• Advanced: Specify what happens when a conflict is detected between a local
note and a note on the configured synchronization server. You can choose to be
prompted when a conflict occurs, to rename the local note, or to replace the local
note with the note on the synchronization server.

• Clear: Clears your current synchronization settings. If you choose to clear your
synchronization settings, you might have to synchronize your notes again when
you save new settings.

To synchronize your notes, click Tools > Synchronize Notes in any open note.
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11.9.4 Add-ins Preferences
The Add-ins tabbed page lets you enable and configure Tomboy add-ins (formerly
called plugins). Tomboy comes with several pre-installed add-ins, such as Backlinks,
Bugzilla Links, Evolution Mail Integration, Export to HTML, Fixed Width, Note of
the Day, Printing Support, and Sticky Notes Importer.

The list of installed add-ins is shown on the left of the Add-ins tabbed page. To enable
or disable an add-in, select the plug-in you want, then click Enable or Disable.

Figure 11.7 Tomboy Add-ins Preferences

Additional add-ins can be found in the Tomboy Add-ins [http://live.gnome
.org/Tomboy/PluginList] page. Place new add-ins in the $HOME/.tomboy/
addins folder.
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12Browsing with Firefox
Included with your openSUSE® is the Mozilla Firefox Web browser. With features
like tabs, pop-up window blocking, and download and image management, Firefox
combines the latest Web technologies. You can view more than one Web page in a
single window. You can suppress annoying advertisements and disable images that
only slow you down. Its easy access to different search engines helps you find the in-
formation you need. Start the program from themainmenu or by entering the command
firefox. The main program features are described in the following sections.

12.1 Navigating Web Sites
Firefox has much the same look and feel as other browsers. It is shown in Figure 12.1,
“The BrowserWindow of Firefox” (page 274). The navigation toolbar includesForward
and Back and a location bar for a Web address. Bookmarks are also available for quick
access. For more information about the various Firefox features, use the Help menu.
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Figure 12.1 The Browser Window of Firefox

12.1.1 Tabbed Browsing
If you often use more than oneWeb page at a time, tabbed browsing may make it easier
to switch between them. Load Web sites in separate tabs within one window.

To open a new tab, select File > New Tab. This opens an empty tab in the Firefox
window. Alternatively, right-click a link and select Open link in new tab. Right-click
the tab itself to access more tab options. You can create a new tab, reload one or all
existing tabs, or close them. You can also change the sequence of the tabs by dragging
and dropping them on a requested position.
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12.1.2 Using the Sidebar
Use the left side of your browser window for viewing bookmarks or the browsing his-
tory. Extensions may add new ways to use the sidebar as well. To display the Sidebar,
select View > Sidebar and select the desired contents.

12.2 Finding Information
There are two ways to find information in Firefox: the search bar and the find bar. The
search bar looks for pages while the find bar looks for things on the current page.

12.2.1 Finding Information on the Web
Firefox has a search bar that can access different engines, like Google, Yahoo, or
Amazon. For example, if you want to find information about openSUSE using the
current engine, click in the search bar, type openSUSE, and hit Enter. The results appear
in your window. To choose your search engine, click the icon to the left of the search
bar. A menu opens with a list of available search engines.

12.2.2 Installing a Different Search Engine
If you favorite search engine is not listed, Firefox gives you the possibility to configure
it. Try the following steps:

1 Establish an Internet connection first.

2 Click the icon to the left of the search bar.

3 SelectManage Search Engines from the menu.

4 Click Get more search engines.

5 Firefox displays aWeb page with available search engines. You can choose from
Wikipedia, IMDB, Flickr, and others. Click the desired search plug-in.

6 Install your search plug-in with Add or abort with Cancel.
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12.2.3 Searching in the Current Page
To search inside a Web page, click Edit > Find in This Page or press Ctrl + F. The find
bar opens. Usually, it is displayed at the bottom of a window. Type your query in the
input field. Firefox finds the first occurrence of this phrase. You can find other occur-
rences of the phrase by pressing F3 orNext button in the find bar. You can also highlight
all occurrences by pressing the Highlight all button. Checking theMatch case option
makes the query case sensitive.

12.3 Managing Bookmarks
Bookmarks offer a convenient way of saving links to your favorite Web sites. To add
the currentWeb site to your list of bookmarks, clickBookmarks >Bookmark This Page.
If your browser currently displays multiple Web sites on tabs, only the URL on the
currently selected tab is added to your list of bookmarks.

When adding a bookmark, you can specify an alternative name for the bookmark and
select a folder where Firefox should store it. To bookmark Web sites on multiple tabs,
select Bookmark All Tabs. Firefox creates a new folder that includes bookmarks of each
site displayed on each tab. To remove a Web site from the bookmarks list, click Book-
marks, right-click the bookmark in the list, then click Delete.

12.3.1 Using the Bookmark Manager
The bookmark manager can be used to manage the properties (name and address loca-
tion) for each bookmark and organize the bookmarks into folders and sections. It resem-
bles Figure 12.2, “Using the Firefox Bookmark Manager” (page 277).
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Figure 12.2 Using the Firefox Bookmark Manager

To open the bookmark manager, click Bookmark > Organize Bookmarks. A window
opens and displays your bookmarks. WithNew Folder, create a new folder with a name
and a description. If you need a new bookmark, click New Bookmark. This lets you
insert the name, location, keywords, and also a description. The keyword is a shortcut
to your bookmark. If you need your newly created bookmark in the sidebar, check Load
this bookmark in the sidebar.

12.3.2 Importing Bookmarks from Other
Browsers

If you used a different browser in the past, you probably want to use your old bookmarks
in Firefox, too. Firefox allows to import bookmarks from other browsers installed on
your system such as Netscape or Opera. It also allows to import bookmarks from a file
exported from a browser on different computer.

To import your settings, click File > Import. Select the browser from which to import
settings and click Next or choose a file. Find your imported bookmarks in a newly cre-
ated folder, beginning with From.
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12.3.3 Live Bookmarks
Live bookmarks display headlines in your bookmark menu and keep you up to date
with the latest news. This enables you to save time with one glance at your favorite
sites.

Many sites and blogs support this format. AWeb site indicates this by showing an orange
icon in the right part of the location bar. Click it and choose Subscribe to NAME OF
THE FEED. Click Subscribe now in the page that opens. A dialog box opens in which
to select the name and location of your live bookmark. Confirm with Add.

Some sites do not tell Firefox that they support a news feed, although they actually do.
To add a live bookmark manually, you need the URL of the feed. Do the following:

Procedure 12.1 Adding a Live Bookmark Manually

1 Open the bookmark manager with Bookmarks > Organize Bookmarks. A new
window opens.

2 Select File > New Live Bookmark. A dialog box opens.

3 Insert a name for the live bookmark and add your URL in the Feed Location, for
example,http://www.novell.com/newsfeeds/rss/coolsolutions
.xml. Firefox updates your live bookmarks.

4 Close your bookmark manager.

12.4 Using the Download Manager
With the help of the download manager, keep track of your current and past downloads.
To open the download manager, click Tools > Downloads. Firefox opens a window
with your downloads. While downloading a file, see a progress bar and the current file.
If necessary, pause a download and resume it later. To open a downloaded file, click
Open. With Remove, remove it from the list. If you need information about the file,
right-click the filename and choose Properties.
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If you need further control of the download manager, open the configuration window
from Edit > Preferences and go to theMain tab. Here, determine the download folder
and how the manager behaves.

12.5 Customizing Firefox
Firefox can be customized extensively. You can install extensions, change themes, and
add smart keywords for your online searches.

12.5.1 Extensions
Mozilla Firefox is a multifunctional application, which means that you can download
and install add-ons, known as extensions. For example, add a new download manager
and mouse gestures. This has the advantage that Firefox itself stays small and lean.

To add an extension, click Tools > Add-ons > Extensions. In the bottom-right corner,
click Get Extensions to open the Mozilla extensions update Web page where you can
choose from a variety of available extensions. Click the extension to install then click
the install link to download and install it. When you restart Firefox, the new extension
is functional. You can also look at the various extensions at http://addons
.mozilla.org/.

Figure 12.3 Installing Firefox Extensions
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12.5.2 Changing Themes
If you do not like the standard look and feel of Firefox, install a new theme. Themes
do not change the functionality, only the appearance of the browser. When installing a
theme, Firefox asks for confirmation first. Allow the installation or cancel it. After a
successful installation, you can enable the new theme.

1 Click Tools > Add-ons > Themes.

2 In the new dialog that appears, click Get Themes. If have you already installed
a theme, find it in the list, as in Figure 12.4, “Installing Firefox Themes”
(page 280).

Figure 12.4 Installing Firefox Themes

3 Anewwindow appears with theWeb sitehttps://addons.mozilla.org.

4 Choose a theme and click Install Now.

5 Confirm the download and installation.

6 After downloading the theme, select the theme from the list of themes then click
Use Theme.

7 Close the window and restart Firefox.
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You can always switch between installed themes by clicking Tools > Add-ons > Themes
and thenUse Theme. However, Firefox has to be restarted for the change to take effect.
If you do not use a theme anymore, you can delete it in the same dialog with Uninstall.

12.5.3 Adding Smart Keywords to Your
Online Searches

Searching the Internet is one of the main tasks a browser can perform for you. Firefox
lets you define your own smart keywords: abbreviations to use as a “command” for
searching the Web. For example, if you use Wikipedia often, use a smart keyword to
simplify this task:

1 Go to http://en.wikipedia.org.

2 After Firefox displays the Web page, see the search text field. Right-click it then
choose Add a Keyword for this Search from the menu that opens.

3 The Add Bookmark dialog appears. In Name, name this Web page, for example,
Wikipedia (en).

4 For Keyword, enter your abbreviation of this Web page, for example, wiki.

5 With Create in, choose the location of the entry in your bookmarks section. You
can put it into any folder.

6 Finalize with Add.

You have successfully generated a new keyword. Whenever you need to look into
Wikipedia, you do not have to use the entire URL. Just type wiki Linux to view an
entry about Linux.

12.6 Printing from Firefox
Configure the way Firefox prints the content it displays using the Page Setup dialog.
Click File > Page Setup then go to the Format & Options tab to select the orientation
of your print jobs. You can scale or make it adjust automatically. To print a background,
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select Print Background (colors & images). Click theMargins & Header/Footer tab
to adjust margins and select what to include in the headers and footers.

After you configured your settings, print a Web page with File > Print. Select the
printer or a file in which to save the output. With Properties, set the paper size, specify
the print command, choose grayscale or color, and determine themargins.When satisfied
with your settings, approve with Print.

12.7 For More Information
Get more information about Firefox from the official home page at http://www
.mozilla.com/firefox/. Refer to the integrated help to find out more about
certain options or features.
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13Transferring Data From the
Internet
GNOME FTP (gFTP) is a multithreaded file transfer client with the following features:

• Support for the FTP, FTPS (control connection only), HTTP, HTTPS, SSH, and
FSP protocols.

• FTP and HTTP proxy server support.

• Support for FXP file transfers (that is, transferring files between two remote servers
via FTP).

• Support for UNIX, EPLF, Novell®, MacOS, VMS, MVS and NT (DOS) style di-
rectory listings.

• Bookmarks menu that lets you quickly connect to remote sites.

To start GNOMEFTP, clickComputer >More Applications > Internet >GNOMEFTP.
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Figure 13.1 GNOME FTP

• Section 13.1, “Connecting to a Remote Server” (page 284)

• Section 13.2, “Transferring Files” (page 285)

• Section 13.3, “Setting Up an HTTP Proxy Server” (page 286)

• Section 13.4, “ASCII vs. Binary Transfers” (page 286)

13.1 Connecting to a Remote Server
1 In GNOME FTP, click Remote > Open URL.

2 Specify a URL to connect to, then enter a username and password.

Leave the username blank to log in as anonymous user.

3 Click Connect.
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Upon successful connection, you will see a list of the files on the remote server
on the right of the GNOME FTPwindow (the file list on the left side is your local
computer's directory of files). You can now uploaded and downloaded files.

To bookmark a site you access frequently, click Bookmarks > Add bookmark. Specify
a name for the bookmark, then click Add. The new bookmark is added to your list of
bookmarks.

13.2 Transferring Files
In the following figure, the file list on the right contains the remote server's directory
of files. The file list on the left side contains your local computer's directory of files
(on your hard drive or network).

Figure 13.2 gFTP File Transfer

To download files, select the files you want to download in the remote list of files, then
click the left arrow button. The progress of each download is listed in the field in the
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middle of the window. If the transfer is successful, you will see the files in the directory
listing on the left.

To upload a file, select the files you want to upload in your local directory listing on
the left, then click the right arrow button. The progress of each download is listed in
the field in the middle of the window. If the transfer is successful, you will see the files
in the remote directory listing on the right.

To modify preferences for your downloads, click FTP > Options.

13.3 Setting Up an HTTP Proxy Server
1 In GNOME FTP, click FTP > Options, then click the FTP tab.

2 SelectHTTP proxy from the Proxy server type drop-down list, then specify your
proxy server information on that dialog box.

3 Click the HTTP tab, then enter the same proxy server information on that dialog
box.

4 Click OK.

13.4 ASCII vs. Binary Transfers
There are two common ways to transferring files via FTP: ASCII and binary. ASCII
mode transfers files as text. Examples of ASCII files include .txt, .asp, .html,
and .php files.Binarymode transfers files as raw data. Examples of binary files include
.wav, .jpg, .gif, and mp3 files.

To change the transfer mode, click FTP > Binary or FTP > Ascii.

For FTP transfers, you can also click FTP > Options, click the FTP tab, then select the
Transfer files in ASCII mode option.
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14Reading Newsfeeds with
Liferea
Liferea is a news aggregator for receiving and reading online newsfeeds. It provides
GNOME users a fast, easy-to-use interface for reading Internet newsfeeds and blogs.

This chapter contains the following information:

• Section 14.1, “Starting Liferea” (page 287)

• Section 14.2, “Reading a Newsfeed” (page 288)

• Section 14.3, “Creating a New Subscription” (page 290)

• Section 14.4, “Updating Subscriptions” (page 291)

• Section 14.5, “For More Information” (page 291)

14.1 Starting Liferea
To start Liferea, click Computer >More Applications > Internet > Liferea.
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Figure 14.1 Liferea Main Screen

By default, the Liferea interface is divided into two sections: the Feed List and the Item
List. The Feed List is on the left. It contains a list of your subscriptions. When you click
on a subscription, the headlines for that subscription appear in the Item List, on the
right. When you click on a headline, the contents of that feed appear in the View pane,
beneath the Item List.

Drag the borders between each pane to resize the panes for more comfortable viewing.

14.2 Reading a Newsfeed
Liferea comes preconfigured to receive newsfeeds fromNovell® Cool Solutions™ and
Novell Technical Information. To read one of these example feeds:
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1 Start Liferea as described in Section 14.1, “Starting Liferea” (page 287).

2 In the Feed List, click the subscription you want to read.

For example, click Example Feeds > Novell > Novell Cool Solutions.

3 Click a headline in the Item List.

Unread headlines appear in bold text. When you click a headline, the selected
item opens for reading in the View pane.

Unlike many news aggregators, Liferea lets you read news even if you are offline. After
headlines are fed to Liferea, you can read the items, whether you are online or not. You
must be online, however, to update your newsfeeds with the latest headlines.

Figure 14.2 Reading a Newsfeed with Liferea
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14.3 Creating a New Subscription
You can subscribe to feeds from many locations on the Internet. These include news
and information services, blogs, discussion forums, and more. This section describes
how to add a subscription. The example in the following procedure shows how to sub-
scribe to the CNN* Top Stories newsfeed, but the process is very similar for most feed
providers.

1 Start Liferea as described in Section 14.1, “Starting Liferea” (page 287).

2 Obtain the URL for the desired feed.

For example, to obtain the CNN newsfeed URL:

2a Open your browser and go to http://www.cnn.com.

2b Scroll down near the bottom of the CNN page, then click RSS.

2c Locate the URL for the Top Stories feed in the list provided by CNN and
copy it.

For this example, the URL is http://rss.cnn.com/rss/cnn_topstories.rss.

3 In Liferea, click Feeds > New Subscription.

4 Paste the URL into the Source field.

5 Click OK.

6 Enter a name for the feed and the amount of time you want to pass before the
feed is checked for updates, then click OK.

The newsfeed is added to the Feed List. Any headlines are downloaded and added to
the Item List.
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14.4 Updating Subscriptions
Subscriptions are updated with the latest headlines according to the time interval you
set when you created the subscription. You can also update your subscriptions manually
before the interval has passed. You can update all of your subscriptions at once, update
only the subscriptions in a folder, or update a specific individual subscription.

To update all subscriptions at once: Click Feeds > Update All.

To update all subscriptions within a folder: Select the folder you want to update,
then click Feeds > Update Selected.

To update a specific subscription: To update a specific subscription, select the
subscription and click Feeds > Update Selected.

14.5 For More Information
For more information about using Liferea, click Help or refer to the official Liferea
home page at http://liferea.sourceforge.net/.
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15Manipulating Graphics with
The GIMP
The GIMP (The GNU Image Manipulation Program) is a program for creating and
editing raster graphics. In most aspects, its features are comparable to those of Adobe
Photoshop and other commercial programs. Use it to resize and retouch photographs,
design graphics for Web pages, create covers for your custom CDs, or almost any other
graphics project. It meets the needs of both amateurs and professionals.

Like many other Linux programs, The GIMP is developed as a cooperative effort of
developers worldwide who volunteer their time and code to the project. The program
is under constant development, so the version included in your system may vary
slightly from the version discussed here. The layout of the individual windows and
window sections is especially likely to vary.

The GIMP is an extremely complex program. Only a small range of features, tools, and
menu items are discussed in this chapter. See Section 15.7, “For More Information”
(page 310) for ideas of where to find more information about the program.

15.1 Graphics Formats
There are two main types of graphics—raster and vector. The GIMP is intended for
working with raster graphics, which is the normal format for photographs and scanned
images. Raster graphics consist of pixels—small blocks of color that together create
the entire image. The files can easily become quite large because of this. It is also not
possible to increase the size of a pixel image without losing quality. The GIMP supports
most common formats of raster graphics.
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Unlike raster graphics, vector graphics do not store information for all individual pixels.
Instead, it uses geometrical primitives such as points, lines, curves, and polygons.
Vector images can be scaled very easily. There are many specialized applications for
vector graphics, for example Inkscape. The GIMP has only a very limited support for
vector graphics. For example, the GIMP can open and rasterize vector graphics in SVG
format or work with vector paths.

15.2 Starting The GIMP
Start The GIMP from the main menu. Alternatively, enter gimp & in a command line.

15.2.1 Initial Configuration
When starting The GIMP for the first time, a configuration wizard opens for preparatory
configuration. The default settings are acceptable for most purposes. Press Continue in
each dialog unless you are familiar with the settings and prefer another setup.

15.2.2 The Default Windows
Three windows appear by default. They can be arranged on the screen and, except the
toolbox, closed if no longer needed. Closing the toolbox closes the application. In the
default configuration, The GIMP saves your window layout when you exit. Dialogs
left open reappear when you next start the program.

The Toolbox
Themain window of The GIMP, shown in Figure 15.1, “TheMainWindow” (page 297),
contains the main controls of the application. Closing it exits the application. At the
very top, the menu bar offers access to file functions, extensions, and help. Below that,
find icons for the various tools. Hover the mouse over an icon to display information
about it.
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Figure 15.1 The Main Window

The current foreground and background color are shown in two overlapping boxes. The
default colors are black for the foreground and white for the background. Click the box
to open a color selection dialog. Swap the foreground and background color with the
bent arrow symbol to the upper right of the boxes. Use the black and white symbol to
the lower left to reset the colors to the default.

To the right, the current brush, pattern, and gradient are shown. Click the displayed one
to access the selection dialog. The lower portion of the window allows configuration
of various options for the current tool.

Under the toolbox, a dialog shows options for the currently selected tool. If it is not
visible, open it by double-clicking the tool's icon in the toolbox.

Layers, Channels, Paths, Undo
In the first section, use the drop-down box to select the image to which the tabs refer.
By clicking Auto, control whether the active image is chosen automatically. By default,
Auto is enabled.

Layers shows the different layers in the current images and can be used to manipulate
the layers. Information is available in Section 15.5.6, “Layers” (page 308). Channels
shows and can manipulate the color channels of the image.

Paths are a vector-based method of selecting parts of an image. They can also be used
for drawing. Paths shows the paths available for an image and provides access to path
functions. Undo shows a limited history of modifications made to the current image.
Its use is described in Section 15.5.5, “Undoing Mistakes” (page 307).
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15.3 Getting Started
Although The GIMP can be a bit overwhelming for new users, most quickly find it easy
to use once they work out a few basics. Crucial basic functions are creating, opening,
and saving images.

15.3.1 Creating a New Image
To create a new image, select File >New or press Ctrl +N. This opens a dialog in which
to make settings for the new image. If desired, select a predefined setting called a
Template. To create a custom template, select File > Dialogs > Templates and use the
controls offered by the window that opens.

In the Image Size section, set the size of the image to create in pixels or another unit.
Click the unit to select another unit from the list of available units. The ratio between
pixels and a unit is set inResolution, which appears when theAdvanced Options section
is opened. A resolution of 72 pixels per inch corresponds to common screen display.
It is sufficient for Web page graphics. A higher resolution should be used for images
to print. For most printers, a resolution of 300 pixels per inch results in an acceptable
quality.

In Colorspace, select whether the image should be in color (RGB) or Grayscale. For
detailed information about image types, see Section 15.5.7, “ImageModes” (page 308).
In Fill With select the color the image is filled with. You can choose betweenForeground
Color and Background Color set in the toolbox,White or Transparency for a transparent
image. Transparency is represented by a gray checkerboard pattern. Enter a comment
for the new image in Comment.

When the settings meet your needs, press OK. To restore the default settings, press
Reset. Pressing Cancel aborts creation of a new image.

15.3.2 Opening an Existing Image
To open an existing image, select File >Open or press Ctrl +O. In the dialog that opens,
select the desired file. You can also press Ctrl + L and type directly the path to the desired
image. Then click Open to open the selected image or press Cancel to skip opening an
image.
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15.3.3 Scanning an Image
Instead of opening an existing image or creating a new one, you can scan one. To scan
directly from The GIMP, make sure that the package xsane is installed. To open the
scanning dialog, select File > Acquire > XSane: Device dialog.

Create a preview when the object to scan is smaller than the total scanning area. Press
Acquire preview in the Preview dialog to create a preview. If you want to scan only
part of the area, select the desired rectangular part with the mouse.

In the xsane dialog, select whether to scan a binary (black and white without shades of
gray), grayscale, or color image and the required scan resolution. The higher the reso-
lution you choose, the better is the quality of the scanned image. However, this also
results in a correspondingly larger file and the scanning process can take a very long
time at higher resolutions. The size of the final image (both in pixels and bytes) is shown
in the lower part of the dialog.

In the xsane dialog, use the sliders to set desired gamma, brightness, and contrast values.
These sliders are not available in binary mode. Changes are visible in the preview im-
mediately. Once all settings have been made, click Scan to scan the image.

15.3.4 The Image Window
The new, opened, or scanned image appears in its own window. The menu bar in the
top of the window provides access to all image functions. Alternatively, access the
menu by right-clicking the image or clicking the small arrow button in the left corner
of the rulers.

File offers the standard file options, such as Save and Print. Close closes the current
image. Quit closes the entire application.

With the items in the Viewmenu, control the display of the image and the image window.
New View opens a second display window of the current image. Changes made in one
view are reflected in all other views of that image. Alternate views are useful for mag-
nifying a part of an image for manipulation while seeing the complete image in another
view. Adjust the magnification level of the current window with Zoom. When Shrink
Wrap is selected, the image window is resized to fit the current image display exactly.
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15.4 Saving Images
No image function is as important as File > Save. It is better to save too often than too
rarely. Use File > Save as to save the image with a new filename. It is a good idea to
save image stages under different names or make backups in another directory so you
can easily restore a previous state.

When saving for the first time or using Save as, a dialog opens in which to specify the
filename and type. Enter the filename in the field at the top. For Save in folder, select
the directory in which to save the file from a list of commonly used directories. To use
a different directory or create a new one, open Browse for other folders. It is recom-
mended to leave Select File Type set to By Extension. With that setting, The GIMP de-
termines the file type based on the extension appended to the filename. The following
file types are frequently useful:

XCF
This is the native format of the application. It saves all layer and path information
along with the image itself. Even if you need an image in another format, it is
usually a good idea to save a copy as XCF to simplify future modifications. Infor-
mation about layers is available in Section 15.5.6, “Layers” (page 308).

PAT
This is the format used for The GIMP patterns. Saving an image in this format en-
ables using the image as a fill pattern in The GIMP.

JPEG
JPG or JPEG is a common format for photographs and Web page graphics without
transparency. Its compressionmethod enables reduction of file sizes, but information
is lost when compressing. It may be a good idea to use the preview option when
adjusting the compression level. Levels of 85% to 75% often result in an acceptable
image quality with reasonable compression. Saving a backup in a lossless format,
like XCF, is also recommended. If editing an image, save only the finished image
as JPG. Repeatedly loading a JPG then saving can quickly result in poor image
quality.

GIF
Although very popular in the past for graphics with transparency, GIF is less often
used now because of license issues. GIF is also used for animated images. The
format can only save indexed images. See Section 15.5.7, “ImageModes” (page 308)
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for information about indexed images. The file size can often be quite small if only
a few colors are used.

PNG
With its support for transparency, lossless compression, free availability, and in-
creasing browser support, PNG is replacing GIF as the preferred format for Web
graphics with transparency. An added advantage is that PNG offers partial trans-
parency, which is not offered byGIF. This enables smoother transitions from colored
areas to transparent areas (antialiasing).

To save the image in the chosen format, press Save. To abort, pressCancel. If the image
has features that cannot be saved in the chosen format, a dialog appears with choices
for resolving the situation. Choosing Export, if offered, normally gives the desired re-
sults. A window then opens with the options of the format. Reasonable default values
are provided.

15.5 Editing Images
The GIMP provides a number of tools for making changes to images. The functions
described here are those most interesting for home users.

15.5.1 Changing the Image Size
Once an image is scanned or a digital photograph is loaded from the camera, it is often
necessary to modify the size for display on a Web page or for printing. Images can
easily be made smaller either by scaling them down or by cutting off parts of them.
Making an image larger is much more problematic. Because of the nature of raster
graphics, quality is lost when an image is made larger. It is recommended to keep a
copy of your original image before scaling or cropping.

Cropping an Image
Cropping an image works like cutting the edges off a piece of paper. Select the crop
tool from the toolbox (it resembles a scalpel) or with Tools > Transform Tools > Crop
& Resize. Click a starting corner and drag to outline the area to keep.
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A small window opens with information about the starting point and the size of the se-
lected area. Adjust these values by clicking and dragging a corner of the crop box or
by adjusting the values in the window. From Selection adjusts the crop to fit the current
selection (selections are explained in Section 15.5.2, “Selecting Parts of Images”
(page 303)). Auto Shrink makes the crop smaller based on color changes in the image.

Press Cancel to abort the crop. Press Crop to crop the image. The results of Resize are
identical to those of Change Canvas Size, described in Section “Changing the Canvas
Size” (page 302).

Scaling an Image
Select Image > Scale Image to change the overall size of an image. Select the new size
by entering it inWidth or Height. To change the proportions of the image when scaling
(this distorts the image), click the chain icon to the right of the fields to break the link
between them. When those fields are linked, all values are changed proportionately
when the value in one of the fields is changed. Adjust the resolution with X resolution
and Y resolution.

Interpolation is an expert option that controls the scale method.When finished adjusting
the size, press Scale to scale the image. Reset restores the original values.Cancel aborts
the procedure.

Changing the Canvas Size
Changing the canvas size is like putting a mat around an image. Even if the mat is
smaller, the rest of the image is there, but you can only see part of it. If the mat is larger,
you see the original image with extra space around it. To do this, select Image >Canvas
Size.

In the dialog that opens, enter the new size. By default, the width and height maintain
the same proportions as the current image. To change this, click the chain icon.

After adjusting the size, determine how the existing image should be positioned in
comparison to the new size. Use the offset values or drag the box inside the frame at
the bottom. When satisfied with the changes, click Resize to change the canvas size.
Click Reset to restore the original values or Cancel to cancel the canvas resize.
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15.5.2 Selecting Parts of Images
It is often useful to perform an image operation on only part of an image. To do this,
the part of the image with which to work must be selected. Areas can be selected using
the select tools available in the toolbox, using the quick mask, or combining different
options. Selections can also be modified with the items under Select. The selection is
outlined with a dashed line, called marching ants.

Using the Selection Tools
The main select tools are rather easy to use. The paths tool, which can also be used for
more than selecting, is more complicated so is not described here. In the tool options
for the other select tools, use one of the icons in theMode row to determine whether
the selection should replace, be added to, be subtracted from, or intersect with an existing
selection.

Rect Select
This tool can be used to select rectangular or square areas. In the tool options, select
among Free Select, Fixed Size, and Fixed Aspect Ratio to control the shape and
size of the selection. To make a square selection in the free select mode, hold Shift
while selecting a region.

Ellipse Select
Use this to select elliptical or circular areas. The same options are available as with
rectangular selection. Holding Shift during selection produces a circle.

Free Select (Lasso)
Draw a selection area freehand with this tool by dragging the mouse over the image
with the left mouse button pressed. The end points will be connected with a straight
line when you release the tool. The area inside is then selected.

Fuzzy Select (Magic Wand)
This tools selects a continuous region based on color similarities. Set the maximum
difference between colors in the tool options dialog in Threshold.

By Color Select
With this, select all the pixels in the image with the same or similar color as the
clicked pixel. The maximum difference between colors can be set in the tool options
dialog in Threshold.

Manipulating Graphics with The GIMP 303



Intelligent Scissors
Click a series of points in the image. As you click, the points are connected based
on color differences. Click on the first point to close the area. Convert it to a regular
selection by clicking inside it.

Using the Quick Mask
The quick mask is a way of selecting parts of an image using the paint tools. A good
way to use it is to make a rough selection using the intelligent scissors or the lasso
(freehand selection tool). Then activate the quick mask by pressing the small icon with
the dashed box in the lower left corner.

The quick mask displays the selection using an overlay of red. Areas shaded with red
are not selected. Areas appearing as they did before the mask was activated are selected.
To modify the selection, use the paint tools. Painting with white selects the painted
pixels. Painting with black deselects pixels. Shades of gray (colors are treated as shades
of gray) are a partial selection. Partial selection allows smooth transitions between se-
lected and unselected areas.

To use a different color for displaying the quickmask, right-click the quickmask button
then select Configure Color and Opacity from the menu. Click the colored box in the
dialog that opens to select a new color.

After using the paint tools to adjust the selection as desired, convert from the quick
mask view back to the normal selection view by clicking the icon in the lower left corner
of the image window (currently displaying a red box). The selection is again displayed
with the marching ants.

15.5.3 Applying and Removing Color
Most image editing involves applying or removing color. By selecting a part of the
image, limit where color can be applied or removed. When you select a tool and move
the cursor onto an image, the cursor's appearance changes to reflect the chosen tool.
With many tools, an icon of the current tool is shown along with the arrow. For paint
tools, an outline of the current brush is shown, allowing you to see exactly where you
will be painting in the image and how large an area will be painted.
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Selecting Colors
Paint tools use the foreground color. To select the color, first click the display box of
the foreground color. A dialog with four tabs opens. These tabs provide different color
selection methods. Only the first tab, shown in Figure 15.2, “The Basic Color Selector
Dialog” (page 305), is described here. The new color is shown inCurrent. The previous
color is shown in Old.

Figure 15.2 The Basic Color Selector Dialog

The easiest way to select a color is using the colored areas in the boxes to the left. In
the narrow vertical bar, click a color similar to the desired color. The larger box to the
left then shows available nuances. Click the desired color. It is then shown in Current.
If that color is not what you want, try again.

The arrow button to the right of Current enables saving a number of possible colors.
Click the arrow to copy the current color to the history. A color can then be selected
by clicking it in the history. A color can also be selected by directly entering its hex-
adecimal color code in HTML Notation.

The color selector defaults to selecting a color by hue, which is usually easiest for a
new user. To select by saturation, value, red, green, or blue, select the corresponding
radio button to the right. The sliders and number fields can also be used to modify the
currently selected color. Experiment a bit to find out what works best for you.

When the desired color is shown in Current, click OK. To restore the original values
shown when the dialog was opened, click Reset. To abort changing the color, click
Cancel.
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To select a color that already exists in your image, use the color picker tool, the icon
for which resembles an eye dropper. With the tool options, set whether the foreground
or background color should be selected. Then click a point in the image that shows the
desired color. When the color is right, click Close to close the tool's dialog.

Painting and Erasing
To paint and erase, use the tools from the toolbox. There are a number of options
available to fine-tune each tool. Pressure sensitivity options apply only when a pressure-
sensitive graphics tablet is used.

The pencil, brush, airbrush, and eraser work much like their real-life equivalents. The
ink tool works like a calligraphy pen. Paint by clicking and dragging. The bucket fill
is a method of coloring areas of an image. It fills based on color boundaries in the image.
Adjusting the threshold modifies its sensitivity to color changes.

Adding Text
With the text tool, easily add text to an image. With the tool options, select the desired
font, font size, color, justification, indent, and line spacing. Then click a starting point
in the image. A small dialog opens in which to enter your text. Enter single or multiple
lines of text then press Close.

The text tool creates text on a special layer. To work with the image after adding text,
read Section 15.5.6, “Layers” (page 308). When the text layer is active, it is possible to
modify the text by clicking in the image to reopen the entry dialog. Change the settings
by modifying the tool options.

Retouching Images—The Clone Tool
The clone tool is ideal for retouching images. It enables you to paint in an image using
information from another part of the image. If desired, it can instead take information
from a pattern.

When retouching, it is usually a good idea to use a small brush with soft edges. In this
way, the modifications can blend better with the original image.

To select the source point in the image, press and hold Ctrl while clicking the desired
source point. Then paint with the tool as usual. When you move the cursor while
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painting, the source point, marked by a cross, moves as well. If the Alignment is set to
Non Aligned (the default setting), the source resets to the original when you release the
left mouse button.

15.5.4 Adjusting Color Levels
Images often need a little adjusting to get ideal print or display results. In many programs
designed for inexperienced users, the brightness and contrast levels are modified. This
can work and is also available in The GIMP, but better results can be obtained by ad-
justing the color levels.

To do this, select Layer > Colors > Levels. A dialog opens for controlling the levels in
the image. Good results can usually be obtained by clicking Auto. To make manual
adjustments to all channels, use the dropper tools in All Channels to pick areas in the
image that should be black, neutral gray, and white.

To modify a channel individually, select the desired channel in Channel. Then drag the
black, white, and middle markers in the slider in Input Levels. Alternatively, use the
dropper tools to select points in the image that should serve as the white, black, and
gray points for that channel.

If Preview is checked, the image window shows a preview of how the image would
look with the modifications applied. When the desired result is achieved, press OK to
apply the changes. With Reset, restore the original settings. Cancel aborts level adjust-
ment.

15.5.5 Undoing Mistakes
Most modifications made in The GIMP can be undone. To view a history of modifica-
tions, use the undo dialog included in the default window layout or open one from the
toolbox menu with File > Dialogs > Undo History.

The dialog shows a base image and a series of editing changes that can be undone. Use
the buttons to undo and redo changes. In this way, you can work back to the base image.
If you undo a modification then make a new one, the undone modification cannot be
redone.
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Changes can also be undone and redone with the Edit menu. Alternatively, use the
shortcuts Ctrl + Z and Ctrl + Y.

15.5.6 Layers
Layers are a very important aspect of The GIMP. By drawing parts of your image on
separate layers, change, move, or delete those parts without damaging the rest of the
image. To understand how layers work, imagine an image created from a stack of
transparent sheets. Different parts of the image are drawn on different sheets. The stack
can be rearranged, changing which parts are on top. Individual layers or groups of layers
can shift position, moving sections of the image to other locations. New sheets can be
added and others set aside.

Use the Layers dialog to view the available layers of an image. The text tool automati-
cally creates special text layers when used. The active layer is highlighted. The buttons
at the bottom of the dialog offer a number of functions. More are available in the menu
opened when a layer is right-clicked in the dialog. The two icon spaces before the image
name are used for toggling image visibility (eye icon when visible) and for linking
layers. Linked layers are marked with the chain icon and moved as a group.

Only layers with transparency (an alpha channel) can be placed above other layers in
a stack. To add this to a layer, right-click and select it from the menu.

15.5.7 Image Modes
The GIMP has three image modes—RGB, Grayscale, and Indexed. RGB is a normal
color mode and is the best mode for editing most images. Grayscale is used for black-
and-white images. Indexed limits the colors in the image to a set number. It is mainly
used for GIF images. If you need an indexed image, it is normally best to edit the image
in RGB then convert to indexed right before saving. If you save to a format that requires
an indexed image, The GIMP offers to index the image when saving.

15.5.8 Special Effects
The GIMP includes a wide range of filters and scripts for enhancing images, adding
special effects to them or making artistic manipulations. They are available in Filters
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and Script-fu. Experimenting is the best way to find out what is available. Xtns in the
toolbox includes a number of items for creating buttons, logos, and other things.

15.6 Printing Images
To print an image, selectFile > Print from the imagemenu. If your printer is configured
in the system, it should appear in the list. In some cases, it may be necessary to select
an appropriate driver with Setup Printer. Select the appropriate paper size withMedia
Size and the type inMedia Type. Other settings are available in the Image / Output
Settings tab.

Figure 15.3 The Print Dialog

In the bottom portion of the window, adjust the image size. Press Use Original Image
Size to take these settings from the image itself. This is recommended if you set an ap-
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propriate print size and resolution in the image. Adjust the image's position on the page
with the fields in Position or by dragging the image in Preview.

When satisfied with the settings, press Print. To save the settings for future use, instead
use Print and Save Settings. Cancel aborts printing.

15.7 For More Information
The following resources are useful for users of The GIMP, even if some of them apply
to older versions.

• Help provides access to the internal help system. This documentation is also
available in HTML and PDF formats at http://docs.gimp.org.

• Find many tutorials explaining basic or advanced image manipulation techniques
with The GIMP at http://gimp.org/tutorials/.

• The GIMPUser Group offers an informativeWeb site athttp://gug.sunsite
.dk.

• http://www.gimp.org is the official home page of The GIMP.

• Grokking the GIMP by Carey Bunks is an excellent book based on an older version
of The GIMP. Although some aspects of the program have changed, it can provide
excellent guidance for image manipulation. An online version is available at
http://gug.sunsite.dk/docs/Grokking-the-GIMP-v1.0/.
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16Managing Your Digital Image
Collection
F-Spot is a management tool for your collection of digital images tailored for the
GNOME desktop. It allows you to assign different tags to your images in order to cat-
egorize them and offers various image editing options. For example, you can remove
red-eye, crop, and adjust brightness and colors. F-Spot supports sixteen common file
types, including JPEG, GIF, TIFF, and RAW.

You can import photos from your hard drive, your digital camera, or your iPod*. You
can also use F-Spot to create photo CDs, generate a Website gallery, or export your
photos to your Flickr, 23, Picasa Web, or SmugMug account.

To access F-Spot, click Computer > F-Spot Photo Browser. The first time you run F-
Spot, you can tell it where to find the images you want to import into your collection.
If you already have a collection of images stored on your hard drive, enter the path to
the respective directory and optionally include subfolders. F-Spot imports these images
into its database.
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Figure 16.1 F-Spot Main Window

Thumbnails of your images are displayed in the right part of the window, and detailed
information for a selected image is displayed in a sidebar to the left. By default, your
photos are displayed in reverse-chronological order, so your newest photos are always
at the top. You can sort your photos in chronological order or reverse-alphabetical order
by clicking View > Reverse Order.

A menu bar at the top of the window allows you to access the main menus. A toolbar
below the menu bar offers the following options:

Table 16.1 F-Spot Toolbar

DescriptionIcon

Use this shortcut to change an image's orientation.Rotate (Left or Right)

The Browse mode allows you to view and search your
entire collection or tagged subsets of it. You can also use
the time line to search images by creation date.

Browse

This mode allows you to select one image and do some
basic image processing. Details are available in Sec-
tion 16.7, “Basic Photo Editing” (page 323).

Edit Image
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DescriptionIcon

Switch to fullscreen display mode.Fullscreen

Start a slide show.Slideshow

16.1 Importing Photos
You can import photos from your hard drive or from your digital camera (see Sec-
tion 16.2, “Downloading Pictures fromYour Camera” (page 314) for more information).
F-Spot automatically makes copies of photos imported from your hard drive. If you
don’t want to copy images, uncheckCopy files to the Photos folder on the Import dialog
box, or press Shift when dragging photos into F-Spot.

Figure 16.2 Importing Images into F-Spot

By default, F-Spot copies your photos to the /Photos directory in your home directory.
You can change the directory F-Spot uses by clicking Edit > Preferences.

If all the photos you are importing are from a particular event, or if they have some
other characteristic in common, you can create a tag for them so you can easily find
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them at a later time. During the import, select Attach Tag, then choose the appropriate
tag from the drop-down menu.

To import photos:

1 Click File > Import.

2 Select an import source, then click Open.

3 After the photos are finished loading, click Import.

The photos are added to your catalog.

16.2 Downloading Pictures from Your
Camera

You can import new images from your digital camera by connecting it to the USB port
of your computer. The type of camera is detected automatically. When you import
photos from your camera, F-Spot makes copies of them so that you can clear your
camera's memory.

1 Click File > Import.

2 Select your camera as the import source.

F-Spot launches a preview window displaying all the images that are available
for download from your camera. The files are copied to the target directory
specified viaCopy Files to. If Import files after copy is selected, all images copied
from the camera are automatically imported to F-Spot's database. Tagging can
be done on import, if you select the appropriate tag with Select Tags. If you do
not want to import all images on your camera to your database, just deselect the
unwanted ones in the preview window.
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3 Click Copy.

4 When the photo transfer is complete, click OK.

The photos are added to your catalog.

16.3 Getting Photo Information
When you select an image, some basic statistical information is displayed in the lower-
left part of the window. This includes the filename, its version (copy or original image),
the date of creation, size, and the exposure used in creating this particular photo.

To viewmore detailed information on a photo, including the EXIF data associated with
the file, click View >Metadata Browser.
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Figure 16.3 F-Spot Metadata Browser

16.4 Managing Tags
Use tags to categorize any of your photos to createmanageable subsets of your collection.
F-Spot comes with default tags, but you can change them and add new ones. If, for
example, you want to organize your collection of portrait shots of your loved ones, do
the following:

1 Select the Browse mode of F-Spot.

2 In the left frame of the F-Spot window, right-click the People category, then select
Create New Tag.

2a Create a new tag called Friends.

2b Create a new tag called Family.

The new tags appear as subcategories below the People category.
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3 Attach tags to images or groups of selected images.

Right-click an image, select Attach Tag, then select the appropriate tag for this
image. To attach a tag to a group of images, click the first one, then press Shift
and select the other ones without releasing the Shift key. Right-click for the tag
menu and select the matching category.

You can also use the following methods to tag photos:

• Drag and drop a photo onto a tag.

• Drag and drop a tag onto the photo.

• Use the options on the Tags menu and the Edit menu.

• Select a photo, then press t to display the Tags entry bar.

The first photo you associate with a tag is used for that tag's icon. To edit a tag's name,
parent tag, or icon, right-click the tag, then select Edit Tag.

You can change a tag's parent by dragging and dropping it where you want. You can
also edit the name of a tag by selecting it and pressing F2.

After your photos have been tagged, you can browse your collection by tags. Using our
earlier example, clicking People > Family limits the displayed collection to the photos
tagged Family. Searching your collection by tag is also possible through Find > Find
Selected Tag. The result of your search is displayed in the thumbnail overview window.

Removing tags from single images or groups of images works similarly to attaching
them. The tag editing functions are also accessible on the Tags menu in the top menu
bar.

16.5 Searching and Finding Photos
Asmentioned in Section 16.4, “Managing Tags” (page 316), tags can be used as a means
to find certain images. Another way to find images is to use the Timeline below the
toolbar. By dragging the little frame along this time line, you can limit the images dis-
played in the thumbnail overview to those taken in a selected time frame. F-Spot starts
with a default time line, but you can edit the time span by moving the sliders to the
right and left of the time line.
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You can also start a search by clicking Find > Show Find Bar. With the find bar dis-
played, you can drag tags from the tag view to the find bar.

Figure 16.4 Show Find Bar in F-Spot

To find photos that are tagged with more than one tag, select the first tag in the tag view
(or drag the tag onto the Find bar), then drag the second tag and drop it on top of the
first. You can also right-click the second tag in the tag view, or click Find > Find Se-
lected Tag With, then select the first tag (or group of tags).

You can search for photos that don’t have a particular tag by double-clicking a tag in
the Find bar. Photos that don’t have that tag (or any tag at all) are displayed. You can
also right-click a tag in the Find bar, then select Exclude.

To remove a tag from the search, drag it away from the Find bar, or right-click the tag
and select Remove.

By default, photos tagged Hidden will not be shown. You must explicitly include the
Hidden tag in your search to show such photos.

There is also a type-to-find entry. Press the forward slash (/) to open it. It cannot be
used at the same time as the Find bar. You can type queries such as “TagA and (TagB
or (TagC and TagD))”. At any point, if F-Spot recognizes what you have typed as a
valid query, it will update your search. The not operator is not yet supported.
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Figure 16.5 Type-to-find Search

16.6 Exporting Image Collections
F-Spot offers a range of export functions for your photo collections:

• Section 16.6.1, “Generating a Website Gallery” (page 320)

• Section 16.6.2, “Exporting Photos to CD” (page 321)

• Section 16.6.3, “Exporting Photos to a Folder” (page 321)

• Section 16.6.4, “Posting to a Flickr, PicasaWeb Album, SmugMug, or 23 Account”
(page 322)
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16.6.1 Generating a Website Gallery
If you use the PHP software known as Gallery [http://gallery.sourceforge
.net], you can post your photos to your existing album. Ensure that the Remote
module in your Gallery installation is enabled (Site Admin > Plugins (Get More Plugins)
> Remote).

PennAve [http://pennave.sourceforge.net/] is another dynamic photo
gallery application. It is designed to be used in conjunction with F-Spot to organize and
manage your photos.

1 Select the photos you want to export.

2 Click File > Export > Export to Web Gallery.

3 Select a gallery you want to export your images to, or click Add to add a new
gallery.

F-Spot establishes a connection to theWeb location entered for your web gallery.

4 Select the album you want to export the images to, then specify whether to scale
the images automatically and export titles and comments.

5 Click OK.
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16.6.2 Exporting Photos to CD
1 Select the photos you want to burn to CD.

2 Click File > Export > Export to CD, then click OK.

F-Spot copies the files and opens the Write to Disc dialog box.

3 Assign a name to your image disk, then select the writing speed.

4 ClickWrite to start the CD writing process.

16.6.3 Exporting Photos to a Folder
1 Select the photos you want to export.

2 Click File > Export > Export to Folder.
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3 Choose from the following export methods:

Create standaloneweb gallery: Exports your photos to an interactiveWebsite,
ready for you to upload.

Save the files only: Exports your photos as files within directories, without
putting them into a gallery.

Create gallery using “Original”: Exports your photos ready for use with
Jakub Steiner's Original Photo Gallery [http://jimmac.musichall.cz/
original.php] software.

4 Click OK.

16.6.4 Posting to a Flickr, Picasa Web
Album, SmugMug, or 23 Account

If you use Flickr [http://www.flickr.com/], Picasa Web Album [https://
www.google.com/accounts/ServiceLogin?hl=en_US&continue=http
%3A%2F%2Fpicasaweb.google.com%2F&passive=true&service=lh2],
SmugMug [http://www.smugmug.com/], or 23 [http://www.23hq.com/
], you can post your files directly from F-Spot to your account.

1 Select the photos you want to export.
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2 ClickFile > Export > Export to Flickr, Export to Picasaweb, Export to SmugMug,
or Export to 23hq.

3 Select or unselect the options you want in the Export dialog box.

The options displayed on the Export dialog box depend on the type of account
you are exporting to. For example, Flickr and 23 exports require authorization
in order to upload photos. To do this, click Authorize to open a Web browser,
then log in to your account.

4 Click OK.

16.7 Basic Photo Editing
F-Spot offers several basic image editing functions, such as the ability to remove red-
eye, crop, and adjust colors and brightness.

When you edit a photo, a new copy (called a version) is created, so your original photo
is never altered. After your first edit to a photo, subsequent edits modify the same ver-
sion. If you want to create multiple versions of a photo (for example, with different
cropping or coloring), click File > Create New Version. To access a photo’s original
version, click File > Version > Original.

1 Select the photo you want to edit.

2 To enter edit mode, click the Edit Photo icon in the toolbar, double-click the
image, or press Enter.
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3 Choose from the following edit functions, using the toolbar below the photo or
items on the Edit menu:

DescriptionFunction

To adjust the brightness, contrast, and colors of a
photo, click the Adjust the photo colors icon to

Adjust Colors

open the adjustment dialog box. Change the set-
tings you want, then click OK.

This effect automatically adjusts color levels to
make a color-balanced picture. It works best for

AutoColor

pictures taken with automatic white balance. Click
the Automatically adjust the colors icon to access
this feature.

You can add a description or a comment to a photo
by clicking the text entry box below the photo and
entering text.

Comment

Converts the photo to black and white.Convert to Black and
White
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DescriptionFunction

Converts the photo to sepia tones.
Convert to Sepia

Tones

Cropping an image is a great way to improve the
quality of a photograph by improving how it is

Crop

framed. You crop a photo by selecting the part of
the photo you want to keep. If you want your
photo to be the exact dimensions necessary for a
certain print size, you can constrain the kind of
selection F-Spot will allow you to draw by choos-
ing the appropriate size from the Constraint drop-
down list. See the description of the Remove Red-
Eye function for details on making a selection on
your photo.

After youmake your crop selection, click theCrop
icon beneath the photo to finalize the crop. If you
are working with the original photo, cropping
creates a new version of your photo.

To remove red-eye from a photo, select a zone
containing the eyes. You might want to zoom in

Remove Red-Eye

on the image to accurately select the eyes in the
photo. You should be able to correct both eyes on
the same person at once, or even the eyes from
multiple people at once. If this doesn't work, or if
the selected zone contains some vivid red parts
(such as lips), you will probably have to correct
one red eye at a time.

To make your selection, click one corner of the
rectangle that will be your selection, then drag
your mouse to the diagonal corner and release it.
You can resize your selection by dragging its
edges, and you can move it by clicking in the
middle of it and dragging it to where you want it.
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DescriptionFunction

After you have selected a zone, remove the red by
clicking the Red-eye icon beneath the photo.

Access this function by clicking Edit > Sharpen.
Adjust the values for Amount, Radius, and
Threshold to your needs, then click OK.

Sharpen

Sharpening one region of a picture while blurring
all the rest is a way to emphasize a particular areaSoft Focus
and grab attention. The soft focus effect is a way
to emulate a lens that allows shooting with a short
distance in front of and beyond the subject that
appears to be in focus.

Choose the central point of the area you want to
be in focus, then click the Soft Focus icon beneath
the photo. Adjust the amount of blurring, then click
Apply.

The Straighten effect helps you level a photo and
is useful when editing landscapes taken without aStraighten
tripod (when the imaginary line of horizon is not
at 0°). This tool rotates a photo by a specified angle
and automagically crops the resulted image so that
you always see a perfect rectangle.

4 (Optional) If you want to edit another photo, use the arrow keys at the bottom
right to switch to a new photo.

5 To exit the edit mode, click Browse on the toolbar.

TIP

Professional image editing can also be done with The GIMP. For more informa-
tion, see Chapter 15, Manipulating Graphics with The GIMP (page 295).
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16.8 Sharing Photos
You can use either of the following methods to share your photos using F-Spot. Both
methods share only the photos you have selected when you run them.

• Section 16.8.1, “E-mailing Photos” (page 327)

• Section 16.8.2, “Printing Photos” (page 328)

16.8.1 E-mailing Photos
You can e-mail your photos directly from F-Spot, sending them as-is (original size) or
resizing them.

1 Select the photos you want to e-mail.

2 Click File > Send Mail.

3 Select a size for your photos.

4 Click Create mail.

Your default e-mail program opens, with your photos attached to a new mail
message.
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16.8.2 Printing Photos
1 Select the photos you want to print.

2 Click File > Print.

3 Select the print options you want, such as the printer you want to use or the page
orientation, then click Print to print your photos.
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17Playing and Managing Your
Music with Banshee
Banshee™ is a GNOME music management and playback application that lets you
import CDs, sync your music collection to an iPod* or other digital audio player, play
music directly from an iPod (or other digital audio player), create playlists with songs
from your library, create audio andMP3 CDs from subsets of your library, and subscribe
to, download, and listen to your favorite podcasts. Banshee also supports streaming
audio through its Internet Radio plug-in.

To open Banshee, click Computer > Banshee Music Player.

The first time you open Banshee, you are prompted to import music. Choose an import
source, such as your home directory, a local folder, a local file, a CD, or an alternate
music source (such as a digital audio player), then click Import Music Source.

Figure 17.1 Import Music Library

After successfully importing your music, your library is displayed.
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Figure 17.2 Banshee Library

17.1 Listening to Music
To listen to music, Banshee needs to know what is available to listen to. You can listen
to music in your library, which means that you will need to import music from an ex-
ternal source such as a file, folder, or CD, or you can listen to music directly off a CD.
You can also listen to music on Internet radio stations, podcasts, or your digital audio
player (see Section 17.3, “Using Banshee with Your Digital Audio Player” (page 342)
for more information).

Banshee also comes with MP3 support. If your music collection consists of both MP3
and Ogg Vorbis files, you do not need to convert any files to a different format. Just
open Banshee and start listening.

If the format you are tying to play is not supported by the player's engine, Banshee offers
to search for a suitable codec which you can then install with YaST.

• Section 17.1.1, “Importing Music” (page 331)

• Section 17.1.2, “Playing Your Music” (page 331)
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• Section 17.1.3, “Ripping Your Music” (page 334)

• Section 17.1.4, “Listening to Internet Radio” (page 335)

• Section 17.1.5, “Listening to Podcasts” (page 337)

17.1.1 Importing Music
Banshee can import music from a file, folder, CD, or digital audio player.

1 In Banshee, clickMusic > Import Music.

2 Select an import source.

3 Click Import Music Source.

Banshee can automatically query MusicBrainz [http://musicbrainz.org] for
extra information about tracks that you import and fetch cover art for display when you
play a song. To enable this feature, click Edit > Plugins, then selectMetadata Searcher.

17.1.2 Playing Your Music
To play a song, simply double-click the song in the library.

Use the buttons on the upper-left corner ( ) to pause a song or play the next

or previous song. Use to adjust the volume. You can also use the items on the
Playback menu to repeat or shuffle songs.

Banshee also has an integrated CD player. When you insert a music CD, your CD title
appears in the left panel. Select the title, then click the Play button to play your full CD.

Notification Area Icon
You can keep Banshee hidden in the notification area when you're not interacting with
it by minimizing the Banshee window. You will see a pop-up identifying the current
song when a track changes.
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If you don’t want to see the pop-ups, click Edit > Plugins > Notification Area Icon >
Configuration, then deselect Show notifications when song changes.

Figure 17.3 Banshee Notification Area Pop-up

Mini Mode
You can also use the Mini Mode feature to condense the interface and free up valuable
desktop space. You can switch between your library, playlists, and music devices while
in Mini Mode. To activate Mini Mode, click View >Mini mode.
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Figure 17.4 Banshee in Mini Mode

Music Recommendations
Banshee automatically recommends music that it thinks you might like, based on the
currently playing song. It finds artists and popular songs that others with similar musical
tastes enjoy.

If you don’t want to receive recommendations, click Edit > Plugins, then deselectMusic
Recommendations.
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Figure 17.5 Banshee Music Recommendations

17.1.3 Ripping Your Music
To rip music from a CD and add it to your library:

1 Insert a CD into your CD or DVD drive.

Banshee automatically lists the CD as a source in the left menu.
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2 Select the CD title in the source list on the left, then click Import CD in the upper-
right corner.

17.1.4 Listening to Internet Radio
You can use Banshee to listen to Internet radio stations and streaming audio. The Radio
view in Banshee automatically lists several common Internet radio stations maintained
on banshee-project.org [http://banshee-project.org]. You can also add your
own stations.

Listening to an Internet Radio Station
To listen to Internet radio stations, select Radio in the source list on the left, then double-
click the station you want to listen to.
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Figure 17.6 Internet Radio Stations in Banshee

Adding a New Internet Radio Station
1 Right-click Radio in the source list, then click Add Station.

2 Enter the stream details in the Add new radio station dialog box, then click Save.
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The new station is added to your list.

17.1.5 Listening to Podcasts
Banshee lets you subscribe, download, and listen to your favorite Podcasts. Podcasting
is a form of audio blogging where users subscribe to a feed of shows and the episodes
are downloaded and managed for offline listening.

Subscribing to a Podcast
1 ClickMusic > Subscribe to Podcast.

2 Enter the URL of the podcast you want to subscribe to.

3 (Optional) Click Advanced, then specify what happens when new episodes of
this podcast are available.

You can choose to download only the most recent episode, download all episodes,
or decide which episodes you want to download when new episodes become
available.

4 Click Subscribe.

The new podcast is added to your list.

Listening to a Podcast
To listen to a podcast, select Podcasts in the source list, then double-click the podcast
you want to listen to.

Use the options on the Tools > Podcast menu to update a podcast, subscribe to other
podcasts, or find new podcasts.
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Figure 17.7 Podcasts in Banshee

17.2 Managing Your Music Library
Banshee gives you several ways to organize your music. You can create playlists, which
allow you to put similar songs together, and you can sort and rate songs. You can also
view a variety of information about your music collection, including playback statistics
(when a song was last played and how many times).

• Section 17.2.1, “Organizing Your Music” (page 338)

• Section 17.2.2, “Creating Smart Playlists” (page 340)

17.2.1 Organizing Your Music
To create a new playlist, clickMusic > New Playlist (or press Ctrl+N). A new playlist
is displayed in the left panel. Right-click New Playlist, select Rename Playlist, then
enter the name you want. You can drag and drop songs from one playlist to another, or
use the options on the Edit menu to remove or delete songs and rename or delete
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playlists. You can sort a playlist by clicking the title of the column. Click the column
again to reverse the sort. You can also right-clickMusic Library, then click Sort Playlists.

You can edit the name of the artist, album, and title, as well as the track number and
track count. Simply select a song, then click Edit > Edit Song Metadata. You can also
rate your music, which gives you the ability to play only songs with a certain rating.
To rate a song, select the number of stars you want to assign in the Rating field.

Figure 17.8 Editing Song Dialog Box

If you want to set all fields in a group to the same value, select multiple songs in a
playlist, then click Edit > Edit Song Metadata. Make the changes you want, then click
Apply common field values to all tracks. You can also use the Back and Forward buttons
to cycle through the selected songs.
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Figure 17.9 Editing Multiple Songs Dialog Box

Click the Details tab to view detailed information about the selected song, including
when a song was last played, when the song was imported, how long the song is, and
how many times the song has been played.

Figure 17.10 Details Dialog Box

17.2.2 Creating Smart Playlists
You can create playlists that automatically add and remove songs based on criteria you
specify. For example, a smart playlist can contain songs you rated as five stars but that
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you haven’t listened to for six months. Another smart playlist can contain all songs
published in 2006 that you have labeled with the Classical genre.

Banshee automatically updates all smart playlists when a change is made to your music
library. If you import new songs, Banshee checks to see if they match any of your
available smart playlists. When applicable, Banshee also updates your smart playlists
if you just listened to a song or updated a song’s metadata.

Creating a Smart Playlist
1 In Banshee, clickMusic > New Smart Playlist.

2 Specify a name for the smart playlist, then select the criteria for songs in this
playlist to match.

Use the plus and minus symbols to add or remove criteria. To use an already
defined smart playlist, click Predefined Smart Playlists, then select the playlist
you want.

3 Click Save.

The smart playlist is added to your music library.
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Creating a Smart Playlist from a Search
You can create a smart playlist based on search criteria. For example, if you search for
all songs in your music library by a certain artist, Banshee can create a smart playlist
in which all songs by that artist are selected.

1 In Banshee, clickMusic > New Smart Playlist from Search.

2 Specify a name for the smart playlist, then specify the search criteria you want.

Use the plus and minus symbols to add or remove criteria. To use an already
defined smart playlist, click Predefined Smart Playlists, then select the playlist
you want.

3 Click Save.

The smart playlist is added to your music library.

17.3 Using Banshee with Your Digital
Audio Player

Banshee supports several digital audio players, including Apple* iPods, Creative*
Nomads*, Dell* DJs, and almost any other generic USB Mass Storage player. Instead
of having to use separate applications to get support for your audio devices, Banshee
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gives you easy, integrated support and lets you copy your music to or from your device,
no matter what format the music is in.

• Section 17.3.1, “Playing Music from Your Digital Audio Player” (page 343)

• Section 17.3.2, “Adding Music to Your Digital Audio Player” (page 344)

• Section 17.3.3, “Copying Music on Your Digital Audio Player to Banshee”
(page 345)

• Section 17.3.4, “Synchronizing Your Library” (page 345)

17.3.1 Playing Music from Your Digital
Audio Player

To play music from your digital audio player, simply plug your player into your system.
After your system recognizes your device, an icon is displayed in the left panel in
Banshee.

Select the icon to display the music on your device in the right panel. Double-click the
song you want to listen to.
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Figure 17.11 Banshee MP3 Playback from an iPod Mini

To view or change device properties, right-click your device, then select Source Prop-
erties. From there, you can view various pieces of information. If you have an iPod,
you can update the owner's name.

17.3.2 Adding Music to Your Digital Audio
Player

To add tracks to your player, simply drag the tracks you want from your Music Library
to your device.

Banshee transparently supports transcoding of your songs for any device. You can have
your music library in any number of formats (including, but not limited to, FLAC, Ogg
Vorbis, MP3, and AAC), and it will be transparently transcoded before it is sent to your
digital audio player.

To remove tracks, select your device in the list of sources, right-click the song you want
to delete, then click Remove Song(s).
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17.3.3 Copying Music on Your Digital Audio
Player to Banshee

Banshee supports importing music from your digital audio player to your music library.
Simply drag and drop the songs from your digital audio player to your Music Library
and they are copied automatically. You can also import all of the music on your digital
audio player by right- clicking your player in the source list and selecting Import.

Figure 17.12 Importing Music from Your Digital Audio Player to Banshee

17.3.4 Synchronizing Your Library
To keep your digital audio player up to date with your Banshee Library, select your
player in the source list, then click Synchronize in the upper-right corner.

Banshee also synchronizes your ratings and cover art in your tracks to your iPod.

17.4 Creating Audio and MP3 CDs
1 Insert a blank CD in your CD or DVD drive.

2 Select the songs you want to burn, then click theWrite CD button in the upper-
right side of Banshee.

3 Specify the disk options you want, then clickWrite.

For example, click Eject disk after writing if you want Banshee to eject your CD
when the writing is completed.
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You can track the status of the burn in the bottom-left corner of Banshee. A
message box appears when the burn is complete.

4 Click OK.

17.5 Sharing Your Music
You can automatically update your online Audioscrobbler [http://www.last.fm]
profile with the music you listen to in Banshee. This lets others see what you are listening
to, and gives you access to charts detailing your listening history. If you join groups
such as the Banshee Group [http://www.last.fm/group/Banshee], you can
also see what other people are listening to.

1 In Banshee, click Tools > Audioscrobbler > Configure.
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2 If you have already registered with Last.fm [http://www.last.fm/], click
Enable song reporting, then specify your Last.fm username and password.

If you have not previously registered with Last.fm, clickCreate an account. This
opens the Last.fmWeb site where you can register. Click Enable song reporting,
then specify your Last.fm username and password.

3 Click Close.

Banshee starts reporting with the next song you play.

After Audioscrobbler is configured, use the options on the Tools > Audioscrobbler
menu to enable or disable song reporting, visit your user profile Web page, or
visit the Web site of any Audioscrobbler groups you belong to.

17.6 Configuring Banshee Preferences
1 Click Edit > Preferences.

2 Choose from the following options:
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Music Library: Lets you specify a music folder location. This location is used
when you import music. ClickCopy files to music folder when importing to place
a copy of the files you import in your Banshee music folder.

File System Organization: Lets you determine folder hierarchy in the music
library and how filenames are displayed.

CD Importing: Lets you determine encoding profiles for CD ripping. Select
the output format you want, then click Edit to configure advanced options for
that format.

Use error correction when importing: Error correction. Tries to work around
problem areas on a disk, such as surface scratches, but can substantially slow
down the time it takes to import.

3 Click Close to save your changes.
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18Playing Movie Files
The TotemMovie Player application is a movie player for the GNOME desktop which
provides the following features:

• Support for a variety of video and audio files

• A variety of zoom levels and aspect ratios, and a full screen view

• Seek and volume controls

• Playlists

• Complete keyboard navigation

• Video thumbnailer for GNOME

• Nautilus properties tab

To start the Totem Movie Player, click Computer >More Applications >Multimedia
> Totem Movie Player.

• Section 18.1, “Using the Totem Movie Player” (page 350)

• Section 18.2, “Modifying Totem Movie Player Preferences” (page 355)
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18.1 Using the Totem Movie Player
When you start Totem Movie Player, the following window is displayed.

Figure 18.1 Totem Movie Player Start Up Window

• Section 18.1.1, “Opening a Video or Audio File” (page 351)

• Section 18.1.2, “Opening a Video or Audio File By URI Location” (page 351)

• Section 18.1.3, “Playing a DVD, VCD, or CD” (page 351)

• Section 18.1.4, “Seeking Through Movies or Songs” (page 352)

• Section 18.1.5, “Changing the Zoom Factor” (page 352)

• Section 18.1.6, “Showing or Hiding Controls” (page 353)

• Section 18.1.7, “Managing Playlists” (page 353)

• Section 18.1.8, “Choosing Subtitles” (page 354)
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• Section 18.1.9, “Taking Screenshots” (page 354)

18.1.1 Opening a Video or Audio File
1 ClickMovie > Open.

2 Select the files you want to open, then click Add

You can also drag a file from another application (such as a file manager) to the Totem
Movie Player window. The Totem Movie Player application opens the file and plays
the movie or song. Totem Movie Player displays the title of the movie or song beneath
the display area and in the titlebar of the window.

If you try to open a file format that Totem Movie Player does not recognize, the appli-
cation displays an error message.

You can double-click a video or audio file in the Nautilus file manager to open it on
the Totem Movie Player window.

18.1.2 Opening a Video or Audio File By URI
Location

1 ClickMovie > Open Location.

2 Specify the URI location of the file you want to open, then click Open.

18.1.3 Playing a DVD, VCD, or CD
To play a DVD, VCD, or CD, insert the disc in the optical device of your computer,
then clickMovie > Play Disc.

To eject a DVD, VCD, or CD, clickMovie > Eject.

To pause a movie or song that is playing, click the button, or clickMovie > Play/Pause.
When you pause a movie or song, the statusbar displays Paused and the time elapsed
on the current movie or song stops.
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To resume playing a movie or song, click the button, or clickMovie > Play / Pause.

To view properties of a movie or song, click View > Sidebar to make the sidebar appear,
then click Properties in the drop-down list. The dialog contains the title, artist, year,
and duration of movie or song, video dimensions, codec and framerate, and the audio
bitrate and codec.

18.1.4 Seeking Through Movies or Songs
To seek through movies or songs, use any of the following methods:

To skip forward
To skip forward a movie or song, click Go > Skip Forward.

To skip backward
To skip backward a movie or song, click Go > Skip Backward.

To move to next movie or song
To move to the next movie or song, click Go > Next Chapter/Movie, or click the

button.

To move to previous movie or song
To move to the previous movie or song, click Go > Previous Chapter/Movie, or

click the button.

18.1.5 Changing the Zoom Factor
To change the zoom factor of the display area, use any of the following methods:

To zoom to full screen mode
Click View > Fullscreen. To exit fullscreen mode, click the Leave Fullscreen button
or press Esc.

To zoom to half size (50%) of the original movie or visualization
Click View > Fit Window to Movie > Resize 1:2.
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To zoom to size (100%) of the original movie or visualization
Click View > Fit Window to Movie > Resize 1:1.

To zoom to double size (200%) of the original movie or visualization
Click View > Fit Window to Movie > Resize 2:1.

To switch between different aspect ratios, click View > Aspect Ratio. The supported
aspect ratios include:

• Auto

• Square

• 4:3 (TV)

• 16:9 (Widescreen)

• 2.11:1 (DVB)

The default aspect ratio is Auto.

18.1.6 Showing or Hiding Controls
To hide the Totem Movie Player window controls, click View > Show Controls to des-
elect the Show Controls option. To show the controls on the Totem Movie Player win-
dow, right-click the window, then select Show Controls.If the Show Controls option is
selected, Totem Movie Player shows the menubar, time elapsed slider, seek control
buttons, volume slider, and statusbar on the window. If the Show Controls option is
not selected, the application hides these controls and shows only display area.

18.1.7 Managing Playlists
To show the playlist, click View > Sidebar, then click Playlist at the top of the sidebar.
The Playlist dialog box is displayed.

You can use the Playlist dialog box to do the following:

• To add a track or movie: Click the Add button. Select the file you want to add
to the playlist, then click OK
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• To remove a track or movie: Select the filenames from the filename list box,
then click Remove.

• To save a playlist to file: Click the Save button, then specify a filename

• Tomove a track ormovie up the playlist: Select the filename from the filename
list box, then click the Up button.

• To move a track or movie down the playlist: Select the filename from the
filename list box, then click the Down button

To hide the playlist, click View > Sidebar, or click the Sidebar button.

To enable or disable repeat mode, click Edit > Repeat Mode. To enable or disable
shuffle mode, click Edit > Shuffle Mode.

18.1.8 Choosing Subtitles
To choose the language of the subtitles, click View > Subtitles, then select the subtitles
language you want to display.

To disable the display of subtitles, click View > Subtitles > None.

By default, Totem Movie Player chooses the same language for the subtitles that you
use on your computer.

Totem Movie Player automatically loads and displays subtitles if the file that contains
them has the same name as the video file and has an asc, txt, sub, smi, or ssa file
extension.

18.1.9 Taking Screenshots
To take a screenshot of a movie or a visualization of song that is playing, click Edit >
Take Screenshot. You can save a screenshot to either of the following:

• File: Select Save screenshot to file, then click the Browse button to specify a
filename.

• Desktop: Select Save screenshot to the desktop.
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18.2 Modifying Totem Movie Player
Preferences

To modify Totem Movie Player preferences, click Edit > Preferences. You can modify
the following:

• Section 18.2.1, “General Preferences” (page 355)

• Section 18.2.2, “Display Preferences” (page 356)

• Section 18.2.3, “Audio Preferences” (page 357)

18.2.1 General Preferences
The Totem General Preferences let you select a network connection speed, specify a
TV-out connection type, and change the font and encoding used to display subtitles.

Figure 18.2 Totem General Preferences

General Preferences include the following:
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Networking
Select network connection speed from the Connection speed drop-down list box.

TV-Out
SelectNo TV-out if you have no TV-out connection (this option is selected by default
if you don't have a TV-out interface). Select TV-out in fullscreen by Nvidia (NTSC)
if you want TV-out connection in NTSC, or select TV-out in fullscreen by Nvidia
(PAL) if you want TV-out connection in PAL.

Text Subtitles
Lets you change the font and encoding used to display subtitles.

18.2.2 Display Preferences
The TotemDisplay Preferences let you choose to automatically resize the windowwhen
a new video is loaded, change the color balance, and configure visual effects when an
audio file is played.

Figure 18.3 Totem Display Preferences

Display Preferences include the following:
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Automatically resize the window when a new video is loaded
Select this option if you want Totem Movie Player to automatically resize the
window when a new video is loaded.

Visual Effects
You can choose to show visual effects when an audio file is playing, select the type
of visualization you want to show, and the visualization size.

Color Balance
Specify the level of color brightness, contrast, saturation, and hue.

18.2.3 Audio Preferences
The Totem Audio Preferences dialog box lets you select the audio output type.

Figure 18.4 Totem Audio Preferences
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19Burning CDs and DVDs
The GNOME desktop provides the following applications for writing data and audio
CDs and DVDs:

• Section 19.1, “GNOME CD/DVD Creator ” (page 359)

• Section 19.2, “Brasero” (page 360)

19.1 GNOME CD/DVD Creator
You can use the Nautilus file manager to burn CDs and DVDs. To burn a CD or DVD:

1 ClickComputer >More Applications >Multimedia >GNOMECD/DVDCreator.

You can also insert a blank disc and clickMake Data CD or Make Audio CD.

2 Copy the files you want to put on the CD or DVD into the CD/DVD Creator
window.
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3 ClickWrite to Disc.

4 Modify information in the Write to Disc dialog or accept the defaults, then click
Write.

The files are burned on the disc. This could take a few minutes, depending on
the amount of data being burned and the speed of your burner.

You can use the Banshee music player to burn audio and MP3 CDs, as explained in
Section 17.4, “Creating Audio and MP3 CDs” (page 345).

19.2 Brasero
Brasero is a application for the GNOME desktop that lets you burn CDs and DVDs.

360 GNOME User Guide



Figure 19.1 Brasero Disc Burning Application

Brasero includes the following features:

• Ability to edit disc contents (remove, move, or rename files inside directories)

• Ability to burn or copy data or audio CDs or DVDs on the fly

• Automatic filtering for unwanted files (for example, hidden files, broken/recursive
symlinks, and files not conforming to joliet standard)

• Multisession support

• Joliet extension support

• Ability to write or copy a CD/DVD image to the hard drive

• Ability to check disc file integrity

• Ability to edit CD-TEXT information

• Ability to search for audio files inside dropped folders

• Support for single-session data DVDs
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• Support for any kind of CD

• Ability to erase CDs and DVDs

• Ability to save/load projects

• Ability to burn CD/DVD images and cue files

• Song, image, and video previewer

• Nautilus integrations (drag and drop/cut and paste)

• Ability to use files on a network

• Ability to search for files based on keywords or file type

• Ability to display a playlist and its contents (playlists are automatically searched
through Beagle)

• All disc IO is done asynchronously to prevent the application from blocking

To start Brasero, click Computer >More Applications >Multimedia > Brasero Disc
Burning Application.

The following sections give you a brief overview on using Brasero:

• Section 19.2.1, “Creating a Data CD or DVD” (page 362)

• Section 19.2.2, “Creating an Audio CD or DVD” (page 364)

• Section 19.2.3, “Copying a CD or DVD” (page 366)

• Section 19.2.4, “Burning an Existing CD/DVD Image to Disc” (page 367)

• Section 19.2.5, “Erasing a CD or DVD” (page 368)

19.2.1 Creating a Data CD or DVD
1 In the main Brasero window, click Data project

The New data disc project dialog box opens.

362 GNOME User Guide



2 To add files to the project, do any of the following:

• Select the files you want to add in the selection pane on the right, then click
the Add button.

• Drag files to the area on the left from the selection pane or from your file
manager.

• Double-click the files you want to add in the selection pane.

• Copy the files you want to add (for example, from your file manager), then
paste the files in the area on the left.

3 To remove files from the project, do any of the following:

• Select the files you want to remove, then click the Remove button (or press
the Delete key).

• Drag files from the area on the left.

4 Click Burn to open the Disc burning setup dialog box.
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5 Specify a drive to write to.

Click Properties to select the burning speed and other preferences (such as
whether or not the disc is ejected after burning is complete).

6 (Optional) To create a multisession CD or DVD, select Leave the disc open to
add other files later.

Multisession discs can be used to write data in more than one burning session.
This is useful, for example, for writing backups that are smaller than the media.
In each session, you can add another file. As long as the disc contains enough
space, you can append as many sessions as you like. You can even add audio
files to data discs.

7 (Optional) Select Check data integrity to verify the integrity of the written data
by comparing the MD5 sums of the original data and the burned data.

8 Click Burn.

19.2.2 Creating an Audio CD or DVD
1 In the main Brasero window, click Audio project

The New audio disc project dialog box opens.
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2 To add files to the project, do any of the following:

• Select the files you want to add in the selection pane on the right, then click
the Add button.

• Drag files to the area on the left from the selection pane or from your file
manager.

• Double-click the files you want to add in the selection pane.

• Copy the files you want to add (for example, from your file manager), then
paste the files in the area on the left.

3 To remove files from the project, do any of the following:

• Select the files you want to remove, then click the Remove button (or press
the Delete key).

• Drag files from the area on the left.

4 Click Burn to open the Disc burning setup dialog box.
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5 Specify a drive to write to.

Click Properties to select the burning speed and other preferences (such as
whether or not the disc is ejected after burning is complete).

6 (Optional) To create a multisession CD or DVD, select Leave the disc open to
add other files later.

Multisession discs can be used to add files in more than one burning session. As
long as the disc contains enough space, you can append as many sessions as you
like.

7 Click Burn.

19.2.3 Copying a CD or DVD
1 In the main Brasero window, click Disc copy.

The CD/DVD copy options dialog box opens.

2 Specify the source drive you want to copy.

3 Specify a drive to write to.
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To copy the disc to the file system, select File image from the Select a drive to
write to drop-down list, then click Properties to specify a location and image
type.

4 Click Copy.

19.2.4 Burning an Existing CD/DVD Image
to Disc

1 In the main Brasero window, click Burn image.

The Image burning setup dialog box opens.

2 Specify a drive to write to.

Click Properties to select the burning speed and other preferences (such as
whether or not the disc is ejected after burning is complete).

3 Specify the location of the image you want to burn, and the image type.

4 Click Burn.
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19.2.5 Erasing a CD or DVD
1 In the main Brasero window, click Disc > Erase.

The Disc blanking dialog box opens.

2 Specify the drive containing the disc you want to erase.

3 Select any other options you want.

4 Click Blank.
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AMoving from Windows to
Linux
If you are coming from Microsoft Windows, take a look at how familiar elements of
Windows translate to openSUSE®. After logging in, you will notice that the desktop
has a familiar layout and recognizable icons, many of them similar to theWindows and
Macintosh desktops.

Figure A.1 GNOME Desktop



A.1 Starting Applications from the
Main Menu

Similar to the Start menu on Windows, you can access all the programs installed on
your system from the main menu. To open the menu click Computer in the left corner
of the panel. The function-oriented menu structure makes it easy to find the right appli-
cation for your purpose even if you do not know the application names yet. Find more
information about the main menu in Section 1.4, “Using the Main Menu” (page 14).

Figure A.2 Main Menu in GNOME

Alternatively, you can also start programs from the command line. Click Computer >
More Applications > System > Gnome Terminal to open a dialog where you can enter
a command to start the application. The name of the command is often (but not always)
the application name written in lowercase.

A.2 Managing Files
To start the File Manager, click your home folder icon on the desktop.
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Figure A.3 File Manager

For more information about the File Manager, see Section 1.5, “Managing Folders and
Files with Nautilus” (page 18).

A.3 Using the Command Line
To run commands in a command line environment, similar to a command prompt on
Windows, click Computer >More Applications > System > Gnome Terminal.

Figure A.4 Windows Command Prompt and Terminal
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A.4 Customizing Your Desktop
To change to the way your GNOME desktops looks and behaves, click Computer >
Control Center. Some of the settings you might want to change include the desktop
background, screen saver, keyboard and mouse configuration, sounds, and file associa-
tions.

Figure A.5 GNOME Control Center

For more information, see Chapter 2, Customizing Your Settings (page 59).

A.5 Switching between Applications
Similar to the taskbar onWindows, the bottom panel in GNOME lets you easily switch
between open windows. Unlike Windows, GNOME lets you set up multiple desktops
where each one can run different programs. Switch between them with a single click.
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A.6 Accessing Network Resources
From your desktop, you can access files and directories or certain services on remote
hosts or make your own files and directories available to other users in your network.
openSUSE offers various different ways of accessing and creating network-shared re-
sources. Given that the network structure and the configuration of your computer allow
for it, you can easily browse your network for shared resources and services with the
file manager.

Figure A.6 GNOME Network Browsing

To learn more about the various possibilities of accessing network resources, refer to
Section 1.6, “Accessing Network Resources” (page 23).
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BGNU Licenses
This appendix contains the GNUGeneral Public License and the GNU Free Documen-
tation License.

GNU General Public License
Version 2, June 1991

Copyright (C) 1989, 1991 Free Software Foundation, Inc. 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA

Everyone is permitted to copy and distribute verbatim copies of this license document, but changing it is not allowed.

Preamble
The licenses for most software are designed to take away your freedom to share and change it. By contrast, the GNU General Public License is intended
to guarantee your freedom to share and change free software--to make sure the software is free for all its users. This General Public License applies to
most of the Free Software Foundation’s software and to any other program whose authors commit to using it. (Some other Free Software Foundation
software is covered by the GNU Library General Public License instead.) You can apply it to your programs, too.

Whenwe speak of free software, we are referring to freedom, not price. Our General Public Licenses are designed to make sure that you have the freedom
to distribute copies of free software (and charge for this service if you wish), that you receive source code or can get it if you want it, that you can change
the software or use pieces of it in new free programs; and that you know you can do these things.

To protect your rights, we need to make restrictions that forbid anyone to deny you these rights or to ask you to surrender the rights. These restrictions
translate to certain responsibilities for you if you distribute copies of the software, or if you modify it.

For example, if you distribute copies of such a program, whether gratis or for a fee, you must give the recipients all the rights that you have. You must
make sure that they, too, receive or can get the source code. And you must show them these terms so they know their rights.

We protect your rights with two steps: (1) copyright the software, and (2) offer you this license which gives you legal permission to copy, distribute
and/or modify the software.

Also, for each author’s protection and ours, we want to make certain that everyone understands that there is no warranty for this free software. If the
software is modified by someone else and passed on, we want its recipients to know that what they have is not the original, so that any problems introduced
by others will not reflect on the original authors’ reputations.

Finally, any free program is threatened constantly by software patents. We wish to avoid the danger that redistributors of a free program will individu-
ally obtain patent licenses, in effect making the program proprietary. To prevent this, we have made it clear that any patent must be licensed for everyone’s
free use or not licensed at all.

The precise terms and conditions for copying, distribution and modification follow.



GNUGENERAL PUBLIC LICENSE TERMS AND CONDITIONS FOR COPYING, DISTRIBUTIONANDMODIFICATION
0. This License applies to any program or other work which contains a notice placed by the copyright holder saying it may be distributed under the
terms of this General Public License. The “Program”, below, refers to any such program or work, and a “work based on the Program” means either the
Program or any derivative work under copyright law: that is to say, a work containing the Program or a portion of it, either verbatim or with modifications
and/or translated into another language. (Hereinafter, translation is included without limitation in the term “modification”.) Each licensee is addressed
as “you”.

Activities other than copying, distribution and modification are not covered by this License; they are outside its scope. The act of running the Program
is not restricted, and the output from the Program is covered only if its contents constitute a work based on the Program (independent of having been
made by running the Program). Whether that is true depends on what the Program does.

1. You may copy and distribute verbatim copies of the Program’s source code as you receive it, in any medium, provided that you conspicuously
and appropriately publish on each copy an appropriate copyright notice and disclaimer of warranty; keep intact all the notices that refer to this License
and to the absence of any warranty; and give any other recipients of the Program a copy of this License along with the Program.

You may charge a fee for the physical act of transferring a copy, and you may at your option offer warranty protection in exchange for a fee.

2. You may modify your copy or copies of the Program or any portion of it, thus forming a work based on the Program, and copy and distribute such
modifications or work under the terms of Section 1 above, provided that you also meet all of these conditions:

a) You must cause the modified files to carry prominent notices stating that you changed the files and the date of any change.

b) You must cause any work that you distribute or publish, that in whole or in part contains or is derived from the Program or any part thereof, to
be licensed as a whole at no charge to all third parties under the terms of this License.

c) If the modified program normally reads commands interactively when run, you must cause it, when started running for such interactive use in the
most ordinary way, to print or display an announcement including an appropriate copyright notice and a notice that there is no warranty (or else, saying
that you provide a warranty) and that users may redistribute the program under these conditions, and telling the user how to view a copy of this License.
(Exception: if the Program itself is interactive but does not normally print such an announcement, your work based on the Program is not required to
print an announcement.)

These requirements apply to the modified work as a whole. If identifiable sections of that work are not derived from the Program, and can be reasonably
considered independent and separate works in themselves, then this License, and its terms, do not apply to those sections when you distribute them as
separate works. But when you distribute the same sections as part of a whole which is a work based on the Program, the distribution of the whole must
be on the terms of this License, whose permissions for other licensees extend to the entire whole, and thus to each and every part regardless of who
wrote it.

Thus, it is not the intent of this section to claim rights or contest your rights to work written entirely by you; rather, the intent is to exercise the right to
control the distribution of derivative or collective works based on the Program.

In addition, mere aggregation of another work not based on the Program with the Program (or with a work based on the Program) on a volume of a
storage or distribution medium does not bring the other work under the scope of this License.

3. You may copy and distribute the Program (or a work based on it, under Section 2) in object code or executable form under the terms of Sections
1 and 2 above provided that you also do one of the following:

a) Accompany it with the complete corresponding machine-readable source code, which must be distributed under the terms of Sections 1 and 2
above on a medium customarily used for software interchange; or,

b) Accompany it with a written offer, valid for at least three years, to give any third party, for a charge no more than your cost of physically performing
source distribution, a complete machine-readable copy of the corresponding source code, to be distributed under the terms of Sections 1 and 2 above
on a medium customarily used for software interchange; or,

c) Accompany it with the information you received as to the offer to distribute corresponding source code. (This alternative is allowed only for
noncommercial distribution and only if you received the program in object code or executable form with such an offer, in accord with Subsection b
above.)

The source code for a work means the preferred form of the work for making modifications to it. For an executable work, complete source code means
all the source code for all modules it contains, plus any associated interface definition files, plus the scripts used to control compilation and installation
of the executable. However, as a special exception, the source code distributed need not include anything that is normally distributed (in either source
or binary form) with the major components (compiler, kernel, and so on) of the operating system on which the executable runs, unless that component
itself accompanies the executable.

If distribution of executable or object code is made by offering access to copy from a designated place, then offering equivalent access to copy the
source code from the same place counts as distribution of the source code, even though third parties are not compelled to copy the source along with
the object code.

4. You may not copy, modify, sublicense, or distribute the Program except as expressly provided under this License. Any attempt otherwise to copy,
modify, sublicense or distribute the Program is void, and will automatically terminate your rights under this License. However, parties who have received
copies, or rights, from you under this License will not have their licenses terminated so long as such parties remain in full compliance.
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5. You are not required to accept this License, since you have not signed it. However, nothing else grants you permission to modify or distribute the
Program or its derivative works. These actions are prohibited by law if you do not accept this License. Therefore, by modifying or distributing the
Program (or any work based on the Program), you indicate your acceptance of this License to do so, and all its terms and conditions for copying, dis-
tributing or modifying the Program or works based on it.

6. Each time you redistribute the Program (or any work based on the Program), the recipient automatically receives a license from the original licensor
to copy, distribute or modify the Program subject to these terms and conditions. You may not impose any further restrictions on the recipients’ exercise
of the rights granted herein. You are not responsible for enforcing compliance by third parties to this License.

7. If, as a consequence of a court judgment or allegation of patent infringement or for any other reason (not limited to patent issues), conditions are
imposed on you (whether by court order, agreement or otherwise) that contradict the conditions of this License, they do not excuse you from the conditions
of this License. If you cannot distribute so as to satisfy simultaneously your obligations under this License and any other pertinent obligations, then as
a consequence you may not distribute the Program at all. For example, if a patent license would not permit royalty-free redistribution of the Program
by all those who receive copies directly or indirectly through you, then the only way you could satisfy both it and this License would be to refrain en-
tirely from distribution of the Program.

If any portion of this section is held invalid or unenforceable under any particular circumstance, the balance of the section is intended to apply and the
section as a whole is intended to apply in other circumstances.

It is not the purpose of this section to induce you to infringe any patents or other property right claims or to contest validity of any such claims; this
section has the sole purpose of protecting the integrity of the free software distribution system, which is implemented by public license practices. Many
people have made generous contributions to the wide range of software distributed through that system in reliance on consistent application of that
system; it is up to the author/donor to decide if he or she is willing to distribute software through any other system and a licensee cannot impose that
choice.

This section is intended to make thoroughly clear what is believed to be a consequence of the rest of this License.

8. If the distribution and/or use of the Program is restricted in certain countries either by patents or by copyrighted interfaces, the original copyright
holder who places the Program under this License may add an explicit geographical distribution limitation excluding those countries, so that distribution
is permitted only in or among countries not thus excluded. In such case, this License incorporates the limitation as if written in the body of this License.

9. The Free Software Foundation may publish revised and/or new versions of the General Public License from time to time. Such new versions will
be similar in spirit to the present version, but may differ in detail to address new problems or concerns.

Each version is given a distinguishing version number. If the Program specifies a version number of this License which applies to it and “any later
version”, you have the option of following the terms and conditions either of that version or of any later version published by the Free Software Foun-
dation. If the Program does not specify a version number of this License, you may choose any version ever published by the Free Software Foundation.

10. If you wish to incorporate parts of the Program into other free programs whose distribution conditions are different, write to the author to ask
for permission. For software which is copyrighted by the Free Software Foundation, write to the Free Software Foundation; we sometimesmake exceptions
for this. Our decision will be guided by the two goals of preserving the free status of all derivatives of our free software and of promoting the sharing
and reuse of software generally.

NO WARRANTY

11. BECAUSE THE PROGRAM IS LICENSED FREE OF CHARGE, THERE IS NO WARRANTY FOR THE PROGRAM, TO THE EXTENT
PERMITTED BY APPLICABLE LAW. EXCEPT WHEN OTHERWISE STATED IN WRITING THE COPYRIGHT HOLDERS AND/OR OTHER
PARTIES PROVIDE THE PROGRAM “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING,
BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE
ENTIRERISKASTOTHEQUALITYANDPERFORMANCEOFTHEPROGRAMISWITHYOU.SHOULDTHEPROGRAMPROVEDEFECTIVE,
YOU ASSUME THE COST OF ALL NECESSARY SERVICING, REPAIR OR CORRECTION.

12. IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRITING WILL ANY COPYRIGHT HOLDER, OR
ANY OTHER PARTY WHOMAYMODIFY AND/OR REDISTRIBUTE THE PROGRAM AS PERMITTED ABOVE, BE LIABLE TO YOU FOR
DAMAGES, INCLUDING ANY GENERAL, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OR
INABILITY TO USE THE PROGRAM (INCLUDING BUT NOT LIMITED TO LOSS OF DATA OR DATA BEING RENDERED INACCURATE
ORLOSSES SUSTAINEDBYYOUORTHIRDPARTIESORAFAILUREOFTHEPROGRAMTOOPERATEWITHANYOTHERPROGRAMS),
EVEN IF SUCH HOLDER OR OTHER PARTY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

END OF TERMS AND CONDITIONS

How to Apply These Terms to Your New Programs
If you develop a new program, and you want it to be of the greatest possible use to the public, the best way to achieve this is to make it free software
which everyone can redistribute and change under these terms.

To do so, attach the following notices to the program. It is safest to attach them to the start of each source file to most effectively convey the exclusion
of warranty; and each file should have at least the “copyright” line and a pointer to where the full notice is found.

one line to give the program’s name and an idea of what it does. Copyright (C) yyyy name of author
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   This program is free software; you can redistribute it and/or
   modify it under the terms of the GNU General Public License
   as published by the Free Software Foundation; either version 2
   of the License, or (at your option) any later version.

   This program is distributed in the hope that it will be useful,
   but WITHOUT ANY WARRANTY; without even the implied warranty of
   MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
   GNU General Public License for more details.

   You should have received a copy of the GNU General Public License
   along with this program; if not, write to the Free Software
   Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.

Also add information on how to contact you by electronic and paper mail.

If the program is interactive, make it output a short notice like this when it starts in an interactive mode:

   Gnomovision version 69, Copyright (C) year name of author
   Gnomovision comes with ABSOLUTELY NO WARRANTY; for details
   type `show w’. This is free software, and you are welcome
   to redistribute it under certain conditions; type `show c’ 
   for details.

The hypothetical commands `show w’ and `show c’ should show the appropriate parts of the General Public License. Of course, the commands you use
may be called something other than `show w’ and `show c’; they could even be mouse-clicks or menu items--whatever suits your program.

You should also get your employer (if you work as a programmer) or your school, if any, to sign a “copyright disclaimer” for the program, if necessary.
Here is a sample; alter the names:

   Yoyodyne, Inc., hereby disclaims all copyright
   interest in the program `Gnomovision’
   (which makes passes at compilers) written 
   by James Hacker.

   signature of Ty Coon, 1 April 1989
   Ty Coon, President of Vice

This General Public License does not permit incorporating your program into proprietary programs. If your program is a subroutine library, you may
consider it more useful to permit linking proprietary applications with the library. If this is what you want to do, use the GNU Lesser General Public
License [http://www.fsf.org/licenses/lgpl.html] instead of this License.

GNU Free Documentation License
Version 1.2, November 2002

Copyright (C) 2000,2001,2002 Free Software Foundation, Inc. 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA

Everyone is permitted to copy and distribute verbatim copies of this license document, but changing it is not allowed.

PREAMBLE
The purpose of this License is to make a manual, textbook, or other functional and useful document “free” in the sense of freedom: to assure everyone
the effective freedom to copy and redistribute it, with or without modifying it, either commercially or noncommercially. Secondarily, this License preserves
for the author and publisher a way to get credit for their work, while not being considered responsible for modifications made by others.

This License is a kind of “copyleft”, which means that derivative works of the document must themselves be free in the same sense. It complements
the GNU General Public License, which is a copyleft license designed for free software.
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We have designed this License in order to use it for manuals for free software, because free software needs free documentation: a free program should
come with manuals providing the same freedoms that the software does. But this License is not limited to software manuals; it can be used for any
textual work, regardless of subject matter or whether it is published as a printed book. We recommend this License principally for works whose purpose
is instruction or reference.

APPLICABILITY AND DEFINITIONS
This License applies to any manual or other work, in any medium, that contains a notice placed by the copyright holder saying it can be distributed under
the terms of this License. Such a notice grants a world-wide, royalty-free license, unlimited in duration, to use that work under the conditions stated
herein. The “Document”, below, refers to any such manual or work. Any member of the public is a licensee, and is addressed as “you”. You accept the
license if you copy, modify or distribute the work in a way requiring permission under copyright law.

A “Modified Version” of the Document means any work containing the Document or a portion of it, either copied verbatim, or with modifications
and/or translated into another language.

A “Secondary Section” is a named appendix or a front-matter section of the Document that deals exclusively with the relationship of the publishers or
authors of the Document to the Document’s overall subject (or to related matters) and contains nothing that could fall directly within that overall subject.
(Thus, if the Document is in part a textbook of mathematics, a Secondary Section may not explain any mathematics.) The relationship could be a matter
of historical connection with the subject or with related matters, or of legal, commercial, philosophical, ethical or political position regarding them.

The “Invariant Sections” are certain Secondary Sections whose titles are designated, as being those of Invariant Sections, in the notice that says that the
Document is released under this License. If a section does not fit the above definition of Secondary then it is not allowed to be designated as Invariant.
The Document may contain zero Invariant Sections. If the Document does not identify any Invariant Sections then there are none.

The “Cover Texts” are certain short passages of text that are listed, as Front-Cover Texts or Back-Cover Texts, in the notice that says that the Document
is released under this License. A Front-Cover Text may be at most 5 words, and a Back-Cover Text may be at most 25 words.

A “Transparent” copy of the Document means a machine-readable copy, represented in a format whose specification is available to the general public,
that is suitable for revising the document straightforwardly with generic text editors or (for images composed of pixels) generic paint programs or (for
drawings) some widely available drawing editor, and that is suitable for input to text formatters or for automatic translation to a variety of formats
suitable for input to text formatters. A copy made in an otherwise Transparent file format whose markup, or absence of markup, has been arranged to
thwart or discourage subsequent modification by readers is not Transparent. An image format is not Transparent if used for any substantial amount of
text. A copy that is not “Transparent” is called “Opaque”.

Examples of suitable formats for Transparent copies include plain ASCII without markup, Texinfo input format, LaTeX input format, SGML or XML
using a publicly available DTD, and standard-conforming simple HTML, PostScript or PDF designed for human modification. Examples of transparent
image formats include PNG, XCF and JPG. Opaque formats include proprietary formats that can be read and edited only by proprietary word processors,
SGML or XML for which the DTD and/or processing tools are not generally available, and the machine-generated HTML, PostScript or PDF produced
by some word processors for output purposes only.

The “Title Page” means, for a printed book, the title page itself, plus such following pages as are needed to hold, legibly, the material this License requires
to appear in the title page. For works in formats which do not have any title page as such, “Title Page” means the text near the most prominent appearance
of the work’s title, preceding the beginning of the body of the text.

A section “Entitled XYZ” means a named subunit of the Document whose title either is precisely XYZ or contains XYZ in parentheses following text
that translates XYZ in another language. (Here XYZ stands for a specific section name mentioned below, such as “Acknowledgements”, “Dedications”,
“Endorsements”, or “History”.) To “Preserve the Title” of such a section when you modify the Document means that it remains a section “Entitled
XYZ” according to this definition.

The Document may includeWarranty Disclaimers next to the notice which states that this License applies to the Document. TheseWarranty Disclaimers
are considered to be included by reference in this License, but only as regards disclaimingwarranties: any other implication that theseWarranty Disclaimers
may have is void and has no effect on the meaning of this License.

VERBATIM COPYING
You may copy and distribute the Document in any medium, either commercially or noncommercially, provided that this License, the copyright notices,
and the license notice saying this License applies to the Document are reproduced in all copies, and that you add no other conditions whatsoever to
those of this License. You may not use technical measures to obstruct or control the reading or further copying of the copies you make or distribute.
However, you may accept compensation in exchange for copies. If you distribute a large enough number of copies you must also follow the conditions
in section 3.

You may also lend copies, under the same conditions stated above, and you may publicly display copies.

COPYING IN QUANTITY
If you publish printed copies (or copies in media that commonly have printed covers) of the Document, numbering more than 100, and the Document’s
license notice requires Cover Texts, you must enclose the copies in covers that carry, clearly and legibly, all these Cover Texts: Front-Cover Texts on
the front cover, and Back-Cover Texts on the back cover. Both covers must also clearly and legibly identify you as the publisher of these copies. The
front cover must present the full title with all words of the title equally prominent and visible. You may add other material on the covers in addition.
Copying with changes limited to the covers, as long as they preserve the title of the Document and satisfy these conditions, can be treated as verbatim
copying in other respects.
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If the required texts for either cover are too voluminous to fit legibly, you should put the first ones listed (as many as fit reasonably) on the actual cover,
and continue the rest onto adjacent pages.

If you publish or distribute Opaque copies of the Document numbering more than 100, you must either include a machine-readable Transparent copy
along with each Opaque copy, or state in or with each Opaque copy a computer-network location fromwhich the general network-using public has access
to download using public-standard network protocols a complete Transparent copy of the Document, free of added material. If you use the latter option,
you must take reasonably prudent steps, when you begin distribution of Opaque copies in quantity, to ensure that this Transparent copy will remain thus
accessible at the stated location until at least one year after the last time you distribute an Opaque copy (directly or through your agents or retailers) of
that edition to the public.

It is requested, but not required, that you contact the authors of the Document well before redistributing any large number of copies, to give them a
chance to provide you with an updated version of the Document.

MODIFICATIONS
You may copy and distribute a Modified Version of the Document under the conditions of sections 2 and 3 above, provided that you release the Modified
Version under precisely this License, with the Modified Version filling the role of the Document, thus licensing distribution and modification of the
Modified Version to whoever possesses a copy of it. In addition, you must do these things in the Modified Version:

A. Use in the Title Page (and on the covers, if any) a title distinct from that of the Document, and from those of previous versions (which should, if
there were any, be listed in the History section of the Document). You may use the same title as a previous version if the original publisher of that version
gives permission.

B. List on the Title Page, as authors, one or more persons or entities responsible for authorship of the modifications in the Modified Version, together
with at least five of the principal authors of the Document (all of its principal authors, if it has fewer than five), unless they release you from this require-
ment.

C. State on the Title page the name of the publisher of the Modified Version, as the publisher.

D. Preserve all the copyright notices of the Document.

E. Add an appropriate copyright notice for your modifications adjacent to the other copyright notices.

F. Include, immediately after the copyright notices, a license notice giving the public permission to use the Modified Version under the terms of this
License, in the form shown in the Addendum below.

G. Preserve in that license notice the full lists of Invariant Sections and required Cover Texts given in the Document’s license notice.

H. Include an unaltered copy of this License.

I. Preserve the section Entitled “History”, Preserve its Title, and add to it an item stating at least the title, year, new authors, and publisher of the
Modified Version as given on the Title Page. If there is no section Entitled “History” in the Document, create one stating the title, year, authors, and
publisher of the Document as given on its Title Page, then add an item describing the Modified Version as stated in the previous sentence.

J. Preserve the network location, if any, given in the Document for public access to a Transparent copy of the Document, and likewise the network
locations given in the Document for previous versions it was based on. These may be placed in the “History” section. You may omit a network location
for a work that was published at least four years before the Document itself, or if the original publisher of the version it refers to gives permission.

K. For any section Entitled “Acknowledgements” or “Dedications”, Preserve the Title of the section, and preserve in the section all the substance
and tone of each of the contributor acknowledgements and/or dedications given therein.

L. Preserve all the Invariant Sections of the Document, unaltered in their text and in their titles. Section numbers or the equivalent are not considered
part of the section titles.

M. Delete any section Entitled “Endorsements”. Such a section may not be included in the Modified Version.

N. Do not retitle any existing section to be Entitled “Endorsements” or to conflict in title with any Invariant Section.

O. Preserve any Warranty Disclaimers.

If the Modified Version includes new front-matter sections or appendices that qualify as Secondary Sections and contain no material copied from the
Document, you may at your option designate some or all of these sections as invariant. To do this, add their titles to the list of Invariant Sections in the
Modified Version’s license notice. These titles must be distinct from any other section titles.

Youmay add a section Entitled “Endorsements”, provided it contains nothing but endorsements of yourModified Version by various parties--for example,
statements of peer review or that the text has been approved by an organization as the authoritative definition of a standard.

You may add a passage of up to five words as a Front-Cover Text, and a passage of up to 25 words as a Back-Cover Text, to the end of the list of
Cover Texts in the Modified Version. Only one passage of Front-Cover Text and one of Back-Cover Text may be added by (or through arrangements
made by) any one entity. If the Document already includes a cover text for the same cover, previously added by you or by arrangement made by the
same entity you are acting on behalf of, you may not add another; but you may replace the old one, on explicit permission from the previous publisher
that added the old one.
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The author(s) and publisher(s) of the Document do not by this License give permission to use their names for publicity for or to assert or imply endorsement
of any Modified Version.

COMBINING DOCUMENTS
You may combine the Document with other documents released under this License, under the terms defined in section 4 above for modified versions,
provided that you include in the combination all of the Invariant Sections of all of the original documents, unmodified, and list them all as Invariant
Sections of your combined work in its license notice, and that you preserve all their Warranty Disclaimers.

The combined work need only contain one copy of this License, and multiple identical Invariant Sections may be replaced with a single copy. If there
are multiple Invariant Sections with the same name but different contents, make the title of each such section unique by adding at the end of it, in
parentheses, the name of the original author or publisher of that section if known, or else a unique number. Make the same adjustment to the section titles
in the list of Invariant Sections in the license notice of the combined work.

In the combination, you must combine any sections Entitled “History” in the various original documents, forming one section Entitled “History”; likewise
combine any sections Entitled “Acknowledgements”, and any sections Entitled “Dedications”. You must delete all sections Entitled “Endorsements”.

COLLECTIONS OF DOCUMENTS
Youmaymake a collection consisting of the Document and other documents released under this License, and replace the individual copies of this License
in the various documents with a single copy that is included in the collection, provided that you follow the rules of this License for verbatim copying
of each of the documents in all other respects.

You may extract a single document from such a collection, and distribute it individually under this License, provided you insert a copy of this License
into the extracted document, and follow this License in all other respects regarding verbatim copying of that document.

AGGREGATION WITH INDEPENDENT WORKS
A compilation of the Document or its derivatives with other separate and independent documents or works, in or on a volume of a storage or distribution
medium, is called an “aggregate” if the copyright resulting from the compilation is not used to limit the legal rights of the compilation’s users beyond
what the individual works permit. When the Document is included in an aggregate, this License does not apply to the other works in the aggregate which
are not themselves derivative works of the Document.

If the Cover Text requirement of section 3 is applicable to these copies of the Document, then if the Document is less than one half of the entire aggregate,
the Document’s Cover Texts may be placed on covers that bracket the Document within the aggregate, or the electronic equivalent of covers if the
Document is in electronic form. Otherwise they must appear on printed covers that bracket the whole aggregate.

TRANSLATION
Translation is considered a kind of modification, so you may distribute translations of the Document under the terms of section 4. Replacing Invariant
Sections with translations requires special permission from their copyright holders, but you may include translations of some or all Invariant Sections
in addition to the original versions of these Invariant Sections. You may include a translation of this License, and all the license notices in the Document,
and any Warranty Disclaimers, provided that you also include the original English version of this License and the original versions of those notices and
disclaimers. In case of a disagreement between the translation and the original version of this License or a notice or disclaimer, the original version will
prevail.

If a section in the Document is Entitled “Acknowledgements”, “Dedications”, or “History”, the requirement (section 4) to Preserve its Title (section 1)
will typically require changing the actual title.

TERMINATION
You may not copy, modify, sublicense, or distribute the Document except as expressly provided for under this License. Any other attempt to copy,
modify, sublicense or distribute the Document is void, and will automatically terminate your rights under this License. However, parties who have received
copies, or rights, from you under this License will not have their licenses terminated so long as such parties remain in full compliance.

FUTURE REVISIONS OF THIS LICENSE
The Free Software Foundation may publish new, revised versions of the GNU Free Documentation License from time to time. Such new versions will
be similar in spirit to the present version, but may differ in detail to address new problems or concerns. See http://www.gnu.org/copyleft/.

Each version of the License is given a distinguishing version number. If the Document specifies that a particular numbered version of this License “or
any later version” applies to it, you have the option of following the terms and conditions either of that specified version or of any later version that has
been published (not as a draft) by the Free Software Foundation. If the Document does not specify a version number of this License, you may choose
any version ever published (not as a draft) by the Free Software Foundation.

ADDENDUM: How to use this License for your documents
To use this License in a document you have written, include a copy of the License in the document and put the following copyright and license notices
just after the title page:

   Copyright (c) YEAR YOUR NAME.
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   Permission is granted to copy, distribute and/or modify this document
   under the terms of the GNU Free Documentation License, Version 1.2
   only as published by the Free Software Foundation;
   with the Invariant Section being this copyright notice and license.
   A copy of the license is included in the section entitled “GNU
   Free Documentation License”.

If you have Invariant Sections, Front-Cover Texts and Back-Cover Texts, replace the “with...Texts.” line with this:

   with the Invariant Sections being LIST THEIR TITLES, with the
   Front-Cover Texts being LIST, and with the Back-Cover Texts being LIST.

If you have Invariant Sections without Cover Texts, or some other combination of the three, merge those two alternatives to suit the situation.

If your document contains nontrivial examples of program code, we recommend releasing these examples in parallel under your choice of free software
license, such as the GNU General Public License, to permit their use in free software.
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